SQL Server 2008 R2 性能计数器详细列表(四)
原文:SQL Server 2008 R2 性能计数器详细列表(四)
SQL Server Latches 对象:
| SQL Server Latches 计数器 | 说明 |
|---|---|
|
Average Latch Wait Time (ms) |
必须等待授予的闩锁请求的平均等待时间(毫秒)。 |
|
Latch Waits/sec |
未能立即授予的闩锁请求数。 |
|
Number of SuperLatches |
目前是 SuperLatch 的闩锁数。 |
|
SuperLatch Demotions/sec |
在上一秒钟内已降级为常规闩锁的 SuperLatch 数。 |
|
SuperLatch Promotions/sec |
在上一秒钟内已提升为 SuperLatch 的闩锁数。 |
|
Total Latch Wait Time (ms) |
上一秒钟内的闩锁请求的总等待时间(毫秒)。 |
SQL Server Memory Manager 对象:
监视总体的服务器内存使用情况的计数器。监视总体的服务器内存使用情况,以估计用户活动和资源使用,有助于查明性能瓶颈。监视 SQL Server 的实例使用的内存有助于确定:
- 瓶颈的存在是否是因为物理内存不足以存储缓存中被频繁访问的数据。如果内存不足,SQL Server 必须从磁盘检索数据。
- 是否可以通过添加更多内存或使更多内存可用于数据缓存或 SQL Server 内部结构来改善查询性能。
| SQL Server Memory Manager 计数器 | 说明 | ||
|---|---|---|---|
|
Connection Memory (KB) |
服务器正在用来维护连接的动态内存总量。 |
||
|
Granted Workspace Memory (KB) |
当前给予执行哈希、排序、大容量复制和索引创建操作等进程的内存总量。 |
||
|
Lock Blocks |
服务器正在使用的锁块的当前数目(定期进行刷新)。一个锁块代表一个单独的锁定资源,如表、页或行。 |
||
|
Lock Blocks Allocated |
当前分配的锁块数。服务器启动时,分配的锁块数加上分配的锁拥有者块数依赖于 SQL Server Locks 配置选项。若需要更多的锁块,此值会增加。 |
||
|
Lock Memory (KB) |
服务器用于锁的动态内存总量。 |
||
|
Lock Owner Blocks |
当前正在服务器上使用的锁拥有者块的数目(定期进行刷新)。一个锁拥有者块代表一个独立线程对某一对象上的一个锁的拥有权。因此,若三个线程在一个页上各有一个共享 (S) 锁,就会有三个锁拥有者块。 |
||
|
Lock Owner Blocks Allocated |
分配的锁拥有者块的当前块数。服务器启动时,分配的锁拥有者块数和分配的锁块数依赖于 SQL Server Locks 配置选项。若需要更多的锁拥有者块,此数值会动态增加。 |
||
|
Maximum Workspace Memory (KB) |
用于执行哈希、排序、大容量复制和索引创建操作等进程的最大可用内存数。 |
||
|
Memory Grants Outstanding |
成功获得工作空间内存授权的进程总数。 |
||
|
Memory Grants Pending |
等待工作空间内存授权的进程总数。 |
||
|
Optimizer Memory (KB) |
服务器正在用于查询优化的动态内存总数。 |
||
|
SQL Cache Memory (KB) |
服务器正在用于动态 SQL 高速缓存的动态内存总数。 |
||
|
Target Server Memory (KB) |
服务器能够使用的动态内存总量。 |
||
|
Total Server Memory (KB) |
从缓冲池提交的内存 (KB)。
|
SQL Server Plan Cache 对象:
Plan Cache 对象的多个实例,每个实例代表一个要监视的不同类型的计划
| SQL Server Plan Cache 计数器 | 说明 |
|---|---|
|
Cache Hit Ratio |
高速缓存命中次数和查找次数的比率。 |
|
Cache Object Counts |
高速缓存中高速缓存的对象数。 |
|
Cache Pages |
高速缓存对象所使用的 8 (KB) 页的数目。 |
|
Cache Objects in use |
正在使用的缓存对象数。 |
对象中的每个计数器均包含以下实例:
| Plan Cache 实例 | 说明 |
|---|---|
|
_Total |
所有类型的缓存实例的信息。 |
|
Sql 计划 |
由一个临时的 Transact-SQL 查询(包括自动参数化查询)生成的查询计划,或使用 sp_prepare 或 |
|
对象计划 |
通过创建存储过程、函数或触发器而生成的查询计划。 |
|
绑定树 |
视图、规则、计算列和检查约束的规范化树。 |
|
扩展存储过程 |
扩展存储过程的目录信息。 |
|
临时表和表变量 |
与临时表和表变量相关的缓存信息。 |
SQL Server,Resource Pool Stats 对象:
| 计数器名称 | 说明 |
|---|---|
|
CPU usage % |
属于此池的所有工作负荷组中所有请求的 CPU 带宽使用量。此值是相对于计算机度量的,并针对系统中的所有 CPU 进行规范化。此值将随着可用于 SQL Server 进程的 CPU 量的变化而变化。它不会针对 SQL Server 进程接收的信息进行规范化。 |
|
CPU usage target % |
资源池基于资源池配置设置和系统负荷的目标 CPU 使用率 (%)。 |
|
CPU control effect % |
资源调控器对资源池的控制效果。计算公式为:(CPU 使用率 %)/(无资源调控器情况下的 CPU 使用率 %)。 |
|
Compile memory target (KB) |
查询编译的当前内存代理目标值,以千字节 (KB) 为单位。 |
|
Cache memory target (KB) |
缓存的当前内存代理目标值,以千字节 (KB) 为单位。 |
|
Query exec memory target (KB) |
查询执行内存授予的当前内存代理目标值,以千字节 (KB) 为单位。此信息还可在 sys.dm_exec_query_memory_grants 中获得。 |
|
Memory grants/sec |
每秒此资源池中发生的内存授予数。 |
|
Active memory grants count |
当前内存授予总数。此信息还可在 sys.dm_exec_query_memory_grants 中获得。 |
|
Memory grant timeouts/sec |
每秒内存授予超时数。 |
|
Active memory grant amount (KB) |
当前授予的内存总量,以千字节 (KB) 为单位。此信息还可在 sys.dm_exec_query_resource_semaphores 中获得。 |
|
Pending memory grant count |
队列中挂起的内存授予请求数。此信息还可在 sys.dm_exec_query_resource_semaphores 中获得。 |
|
Max memory (KB) |
资源池基于资源池设置和服务器状态可获得的最大内存量,以千字节 (KB) 为单位。 |
|
Used memory (KB) |
用于资源池的内存量,以千字节 (KB) 为单位。 |
|
Target memory (KB) |
资源池基于资源池设置和服务器状态尝试获得的目标内存量,以千字节 (KB) 为单位。 |
SQL Server SQL Errors 对象:
| SQL Server SQL Errors 计数器 | 说明 |
|---|---|
|
Errors/sec |
每秒的错误数。 |
对象中的每个计数器均包含以下实例:
| 项目 | 定义 |
|---|---|
|
_Total |
有关所有错误的信息。 |
|
DB 离线错误 |
跟踪导致 SQL Server 将当前数据库离线的错误。 |
|
信息错误 |
与错误消息相关的信息,错误消息可向用户提供信息但不会导致错误。 |
|
断开连接错误 |
跟踪导致 SQL Server 断开当前连接的错误。 |
|
用户错误 |
有关用户错误的信息。 |
SQL Server 2008 R2 性能计数器详细列表(四)的更多相关文章
- SQL Server 2008 R2 性能计数器详细列表(五)
原文:SQL Server 2008 R2 性能计数器详细列表(五) SQL Server:SQL Statistics 对象: 监视编译和发送到 SQL Server 实例的请求类型 SQL Ser ...
- SQL Server 2008 R2 性能计数器详细列表(三)
原文:SQL Server 2008 R2 性能计数器详细列表(三) SQL Server,Deprecated Features 对象: 监视指定为不推荐使用的功能: SQL Server Depr ...
- SQL Server 2008 R2 性能计数器详细列表(二)
原文:SQL Server 2008 R2 性能计数器详细列表(二) SQL Server Buffer Partition 对象: 提供计数器来监视 SQL Server 如何使用可用页 SQL S ...
- SQL Server 2008 R2 性能计数器详细列表(一)
原文:SQL Server 2008 R2 性能计数器详细列表(一) SQL Server Backup Device 计数器: 可监视用于备份和还原操作的 Microsoft SQL Server ...
- SQL Server 2008 R2 超详细安装图文教程
一.下载SQL Server 2008 R2安装文件 ed2k://|file|cn_sql_server_2008_r2_enterprise_x86_x64_ia64_dvd_522233.iso ...
- SQL Server 2008 R2 超详细安装图文教程及问题解决(锐姿公司安装)
问题点: 1.为了sqlserver与mysql 的安全,建议数据库低权限运行.禁止远程访问 1433与 3306端口等. 2.安装提示.net 3.5没有安装 ,在server2012的添加 3. ...
- 四、利用SQL Server 2008 R2创建自动备份计划
(转) 本文主要利用SQL Server 2008 R2自带的"维护计划"创建一个自动备份数据的任务. 首先,启动 Sql Management studio,确保"SQ ...
- SQL Server 2008 R2——学习/练习/错误/总结/搜集
==================================声明================================== 本文原创,转载在正文中显要的注明作者和出处,并保证文章的完 ...
- 安装 SQL Server 2008 R2 的硬件和软件要求(转)
以下各部分列出了安装和运行 SQL Server 2008 R2 的最低硬件和软件要求.有关 SharePoint 集成模式下的 Analysis Services 的要求的详细信息,请参阅硬件和软件 ...
随机推荐
- 使用SharePoint管理中心管理服务
使用SharePoint管理中心管理服务 为了管理服务应用程序.场管理员要么使用管理中心,要么使用PowerShell. 管理服务应用程序页面列出了场上执行的服务.你能够管理他们. 很多服务都有自己的 ...
- crm2011js子网格导航栏字段事件操作
- Android:What is ART?
背景:Android4.2之前,安卓手机系统的应用程序均在Dalvik Java的虚拟机上执行,这样的执行模式还要依靠一个编译器来实现与应用程序的沟通.应用程序每次执行时,都须要将程序内的代码转变为机 ...
- ViewPager空指针错误,android.support.v4.view.ViewPager.onSaveInstanceState
support.v4 包为我们提供了一个非常实用的滑动控件ViewPager,在使用ViewPager时有一个需要注意的地方: 即: android.support.v4.view.ViewPager ...
- 【Android 应用开发】 FastJson 使用具体解释
博客地址 :http://blog.csdn.net/shulianghan/article/details/41011605 fastjson 源代码地址 : -- GitHub : https:/ ...
- MySQL中数据表的增操作
今天学习到表的增操作,写个博客总结一下,PS:以下所有的凝视都是我在电脑上所有操作完毕后,再拷贝到记事本上加入的.至于在运行的时候可不能够那样加入凝视,就有待考证了. 选择库 mysql> sh ...
- android 4.0 中出错 java.lang.UnsupportedOperationException
在android4.0中 画图的时候使用: canvas.clipPath(path, Region.Op.XOR); 报错 java.lang.UnsupportedOperationExcept ...
- T-SQL基础(4) - 子查询
简单子查询select * from (select custid, companyname from Sales.Customers where country = N'USA') as USACu ...
- MIPS台OpenWrt在系统内的路由器Rust应用程序开发
笔者:Liigo(庄小莉) 迄今:2014年9一个月17日本 (9一个月29日更新,11一个月19日本再次更新.在最后可用更新) 原文链接:http://blog.csdn.net/liigo/art ...
- style.display table-row与block
<tr id="js_rowShow" style=" display:none"> </tr> 问题: display:设置成bloc ...