一般做完矢量图绘制工作后,生成的.mxd文件只能在ArcMap中查看,为了方便用户进行浏览,我们需要发布地图服务。

目前为止最常用的就是在ArcGIS中发布地图服务。

今天也算是在做“发布地图服务”的小结时,顺便学习下其他几种发布地图服务的方法及完善“发布地图服务”的文档。

地图服务是一种利用 ArcGIS 使地图可通过 Web 进行访问的方法。适合在多种 Web 和 intranet 情景下使用。对于同一地图服务,可由多个用户分别在 ArcMap、Web 应用程序、ArcGIS Online 和移动应用程序中同时使用。首先在 ArcMap 中制作地图,然后将地图作为服务发布到 ArcGIS Server 站点上。之后,Internet 或 Intranet 用户便可在 Web 应用程序、ArcGIS for Desktop、ArcGIS Online 以及其他客户端应用程序中使用此地图服务。

ArcGIS Server发布地图的方式有三种:

  • 第一中式通过ArcMap进行地图发布;
  • 第二种是通过ArcGIS Server Manager进行地图发布;
  • 另一种是通过ArcCatalog进行发布。

1. ArcMap上传地图

1)开启 ArcMap ->新建一个空白地图的工程 ->打开包含要发布的地图的工程;

2)上一步单击“确定”后,即可看到D:\SGDownload下存在的已经下载好的地图包,如下图:

3)。。。

未完。。。。待补充

2.  使用ArcGIS Manager发布

1)点击【开始】->【程序】->【ArcGIS】->【ArcGIS Server for the Java paltform】->【ArcGIS Server Manager】

图1

打开ARCGIS Server Manager登录界面。输入用户名和密码,点击“登录”即可ASM的进入主界面

图2

2)在ASM主界面面中,点击“发布GIS资源”,进入发布地图信息界面,点击“浏览...”,找到相应的.mxd文件,一路Next下去即可完成发布地图服务。

3.  使用ArcCatalog发布

1)点击【开始】->【程序】->【ArcGIS】->【ArcCatalog】

打开ArcCatalog-ArcInfo-GIS Services 界面:

双击“GIS Servers”目录下的“Add ArcGIS Server”,弹出Add ArcGIS Server界面,选择“Manage GIS Services”发布地图(只能是本地的.mxd文件)

2)点击“下一步”,进入General 界面: 
在Server URL中输入地址,Host Name 中输入名称localhost,点击“Finish”。   
3)找到test.mxd文件,右键单击,选择“Publish to ArcGIS Server”,进入如下界面:     
4)点击下一步,进入如下界面:     
5)点击“下一步”,进入如下界面:   
6)点击“Finish”,右键单击“localhost(admin)”,点击“refresh”。就可以看到发布后的地图了。

ArcGIS发布地图服务的更多相关文章

  1. ArcGIS发布地图服务时报错Error: ArcGIS Server site is currently being configured by another administrative operation. Please try again later.

    2017-06-06试图发布ArcGIS Server站点托管的服务时,返回以下错误消息: ERROR: Service 'test'.'MapServer' in folder '/' is cur ...

  2. ArcGIS发布地图服务后直接调用查看方法

    做项目配置了一个地理底图,不知道有没有问题,如何给到客户查看并确认呢? 首先在ArcGIS上发布该地图: 打开地图后->文件->共享为->服务…… 发布成功后,得到可以访问的地图服务 ...

  3. arcgis 发布地图服务

    arcgis中,地图文档需要发布,才能为WEB所用. 咋发布呢? 1.在arcmap里面,点击 文件 - 共享为 - 服务 2.在弹出的对话框里选"发布服务",然后 3.这里面有点 ...

  4. JavaWeb和WebGIS学习笔记(六)——使用ArcGIS for Server发布地图服务

    系列链接: Java web与web gis学习笔记(一)--Tomcat环境搭建 Java web与web gis学习笔记(二)--百度地图API调用 JavaWeb和WebGIS学习笔记(三)-- ...

  5. arcgis server10.2发布地图服务报错

    发布地图服务时,读取了本机电脑中的切片方案.发布服务,报打包成功,但发布失败错误. 解决办法:给arcgis账户,赋予读写权限即可.重复发布服务,成功发布.

  6. 从零开始发布一个ArcGIS Server地图服务

    @ 目录 一.软件环境搭建 1.数据库安装 1.1.Oracle(可选) 1.1.1.安装Oracle服务端 1.1.2.安装Oracle客户端 1.2.PostgreSQL(可选) 1.2.1.安装 ...

  7. ArcGIS Server 10.1安装、配置、发布地图服务

    先跟大家分享一个esri的学习资料,http://pan.baidu.com/s/1nBzxB,<ArcGIS10.1 for Server 入门教程>.教程讲述的很清楚,下面说说我这次发 ...

  8. 天地图应用ArcGIS发布的服务

    本文包含三个部分:利用ArcMap将Excel的数据转化为ArcGIS MXD文件.利用ArcMap发布服务.天地图添加ArcGIS发布的服务. 一 MXD文件的生成 假设在Excel中存有两个点的坐 ...

  9. 利用 PortableBasemapServer 发布地图服务

    前段时间需要给自己的C/S系统加一个地图,但是没有数据,于是就想到了使用网上的切片地图,但是C/S系统又不能联网,于是就想本地发布切片服务来使用. 本来想用ArcGIS Server来发布从网上下载的 ...

随机推荐

  1. HDU 5615 Jam's math problem

    Jam's math problem Problem Description Jam has a math problem. He just learned factorization.He is t ...

  2. linux下导入、导出mysql数据库命令

    一.导出数据库用mysqldump命令(注意mysql的安装路径,即此命令的路径): 1.导出数据和表结构: mysqldump -u用户名 -p密码 数据库名 > 数据库名.sql #/usr ...

  3. [HDOJ1232]畅通工程

    畅通工程 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submis ...

  4. LINUX RPM卸载

    1. which httpd /usr/bin/httpd 2.rpm -q -f /usr/bin/httpd name 3.rpm -e name 如果有依赖: rpm -e --allmatch ...

  5. kvc kvo(摘录)

    概述 由于ObjC主要基于Smalltalk进行设计,因此它有很多类似于Ruby.Python的动态特性,例如动态类型.动态加载.动态绑定等.今天我们着重介绍ObjC中的键值编码(KVC).键值监听( ...

  6. C# WinForm程序添加引用后调用静态方法时报“Interfaces_Helper.Global”的类型初始值设定项引发异常。---> System.NullReferenceException: 未将对象引用设置到对象的实例。

    出现原因: 因为Global类初始化某个静态变量时没有成功则会抛 System.NullReferenceException 异常,具体代码: public static string connstr ...

  7. 你不知道的css中的expression

    expression是在IE5版本之后支持使用的,用来把CSS属性和Javascript脚本关联起来,[这里的CSS属性可以是元素固有的属性,也可以是自定义属性.]是动态设置CSS属性的强大方法,但也 ...

  8. 个人作业Week 2 ----------代码的规范和代码复审

    1.是否需要有代码规范 从个人理解的角度出发,我认为代码规范还可以细分为代码的风格还有代码的结构设计(就好比排版一类的) 以前在上C语言课程的时候就看到过,老师会在打“{”的时候进行一个换行,但是有些 ...

  9. S3C2440的GPIO编程

    一.初步认识S3C2440A [S3C2440A简介] S3C2440A是三星公司推出的基于ARM920t内核的32/16位RISC微处理器.主要用于手持设备和中高端电子产品中.它内部集成16k数据c ...

  10. RTMP命令亲自测试记录

    手动和自动录像模块: recorder rec1 { record all manual; record_unique on; record_notify on; record_max_size 51 ...