docker 报错Failed to start Docker Storage Setup. 的处理基本都是容器满了
:: localhost docker-storage-setup: Volume group "centos" has insufficient free space ( extents): required.
Apr :: localhost systemd: docker-storage-setup.service: main process exited, code=exited, status=/NOTINSTALLED
Apr :: localhost systemd: Failed to start Docker Storage Setup.
Apr :: localhost systemd: Unit docker-storage-setup.service entered failed state.
Apr :: localhost systemd: docker-storage-setup.service failed.
Apr :: localhost systemd: Starting Docker Application Container Engine...
Apr :: localhost journal: Forwarding stdin to journald using Priority Informational and tag docker
Apr :: localhost kernel: loop: module loaded
Apr :: localhost journal: time="2016-04-27T15:15:38.376521502+08:00" level=warning msg="Usage of loopback devices is strongly discouraged for production use. Please use `--storage-opt dm.thinpooldev` or use `man docker` to refer to dm.thinpooldev section."
Apr :: localhost systemd: Device dev-disk-by\x2duuid-81caf5ff\x2dd883\x2d45a2\x2db20c\x2d31a41d07ad2c.device appeared twice with different sysfs paths /sys/devices/virtual/block/loop0 and /sys/devices/virtual/block/dm-
Apr :: localhost journal: time="2016-04-27T15:15:38.571170482+08:00" level=info msg="[graphdriver] using prior storage driver \"devicemapper\""
Apr :: localhost journal: time="2016-04-27T15:15:38.572029145+08:00" level=warning msg="Docker could not enable SELinux on the host system"
Apr :: localhost kernel: Bridge firewalling registered
Apr :: localhost journal: time="2016-04-27T15:15:46.069579911+08:00" level=warning msg="Running modprobe bridge br_netfilter failed with message: modprobe: WARNING: Module br_netfilter not found.\ninsmod /lib/modules/3.10.0-229.4.2.el7.x86_64/kernel/net/llc/llc.ko \ninsmod /lib/modules/3.10.0-229.4.2.el7.x86_64/kernel/net/802/stp.ko \ninsmod /lib/modules/3.10.0-229.4.2.el7.x86_64/kernel/net/bridge/bridge.ko \n, error: exit status 1"
Apr :: localhost kernel: nf_conntrack version 0.5. ( buckets, max)
Apr :: localhost journal: time="2016-04-27T15:15:46.118260335+08:00" level=info msg="Firewalld running: false"
Apr :: localhost journal: time="2016-04-27T15:15:46.366809062+08:00" level=fatal msg="Error starting daemon: Error initializing network controller: could not delete the default bridge network: network bridge has active endpoints"
Apr :: localhost systemd: Started Docker Application Container Engine.
Apr :: localhost systemd: Started Session of user root.
Apr :: localhost systemd: Starting Session of user root.
Apr :: localhost systemd: Started Session of user root.
Apr :: localhost systemd: Starting Session of user root.
Apr :: localhost systemd: Started Session of user root.
Apr :: localhost systemd: Starting Session of user root.
Apr :: localhost systemd: Started Session of user root.
Apr :: localhost systemd: Starting Session of user root.
Apr :: localhost systemd: Started Session of user root.
Apr :: localhost systemd: Starting Session of user root.
Apr :: localhost systemd: Starting Docker Storage Setup...
Apr :: localhost docker-storage-setup: Rounding up size to full physical extent 264.00 MiB
Apr :: localhost docker-storage-setup: Volume group "centos" has insufficient free space ( extents): required.
Apr :: localhost systemd: docker-storage-setup.service: main process exited, code=exited, status=/NOTINSTALLED
Apr :: localhost systemd: Failed to start Docker Storage Setup.
Apr :: localhost systemd: Unit docker-storage-setup.service entered failed state.
Apr :: localhost systemd: docker-storage-setup.service failed.
OPTIONS='--selinux-enabled=false --graph=/home/lib/docker' 解决,但是没有以前的镜像文件了
------------------------------------------------------------------------------
cd /var/lib
sudo cp -rf docker docker.bak
sudo cp -rf docker /<my_new_location>/
sudo ln -s /<my_new_location>/docker docker
sudo /etc/init.d/docker start
5、docker无法启动,原因有可能磁盘不够,或者没有解析到。
Nov 19 20:29:36 centos7 systemd: Starting Docker Storage Setup...
Nov 19 20:29:36 centos7 docker-storage-setup: Rounding up size to full physical extent 32.00 MiB
Nov 19 20:29:36 centos7 docker-storage-setup: Volume group "centos_centos7" has insufficient free space (0 extents): 8 required.
Nov 19 20:29:36 centos7 systemd: docker-storage-setup.service: main process exited, code=exited, status=5/NOTINSSTALLED
Nov 19 20:29:36 centos7 systemd: Failed to start Docker Storage Setup.
Nov 19 20:29:36 centos7 systemd: Unit docker-storage-setup.service entered failed state.
Nov 19 20:29:36 centos7 systemd: Starting Docker Application Container Engine...
Nov 19 20:29:36 centos7 docker: time="2015-11-19T20:29:36.538243264+08:00" level=info msg="Listening for HTTP on unix (/var/run/docker.sock)"
Nov 19 20:29:36 centos7 docker: time="2015-11-19T20:29:36.540394247+08:00" level=error msg="WARNING: No --storage-opt dm.thinpooldev specified, using loopback; this configuration is strongly discouraged for production use"
解决办法:
增加vg容量,重启机器试试
不行就删除 /usr/lib/systemd/system/docker.service 里的DOCKER_STORAGE_OPTIONS
systemctl daemon-reload
systemctl restart docker.service
6、还是无法启动docker,原因可能为docker没有识别到正常的thinpooldev,需要手动指定
Error starting daemon: error initializing graphdriver: EOF
/usr/bin/docker daemon --selinux-enabled --storage-driver devicemapper --storage-opt dm.fs=xfs --storage-opt dm.thinpooldev=/dev/mapper/centos_centos7-docker--pool-tpool
解决办法:
https://gist.github.com/joshix/ec1673f2791bf5cb352f#file-thin-pool-md
dmsetup status
找到tpool结尾的那行,比如centos_centos7-docker--pool-tpool
修改文件
vim /etc/sysconfig/docker-storage
DOCKER_STORAGE_OPTIONS=--storage-driver devicemapper --storage-opt dm.fs=xfs --storage-opt dm.thinpooldev=/dev/mapper/centos_centos7-docker--pool-tpool
重启
systemctl daemon-reload
systemctl restart docker.service
docker 报错Failed to start Docker Storage Setup. 的处理基本都是容器满了的更多相关文章
- docker 报错: Job for docker.service failed because the control process exited with error code. See "systemctl status docker.service" and "journalctl -xe" for details.
centos 启动docker服务报错: Job for docker.service failed because the control process exited with error cod ...
- 启动docker报错Failed to listen on Docker Socket for the API.
1.启动时报错查看日志发现 # journalctl -xe Failed to listen on Docker Socket for the API. 查找socket这个配置文件,修改如下 # ...
- 安装docker报错:https://download.docker.com/linux/centos/7/i386/stable/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
如题,执行docker安装命令报错: [root@centos ~]# yum install docker-ce Loaded plugins: fastestmirror, security Se ...
- Centos7 系统启动docker报错 inotify add watch failed
环境说明: 最近新装的系统启动docker报错,之前没有遇到过.(之前都是系统直接启动,新装机器无报错的情况) 当时排查了很久没找到问题在哪,观察报错信息如下: 提示表文件失败,没有这个文件或者目录. ...
- centos6 启动docker报错
1.启动docker报错: # service docker stop Stopping docker: [ OK ] [root@RSING data2]# service docker start ...
- docker报错处理集合
前言 本篇博客将把docker错误都进行整合,方便大家进行查看,如果各位同学有遇到docker使用中遇到的报错,也可以把报错信息截图和处理办法微信发我. docker报错 1. 拉取镜像显示被拒绝 2 ...
- Docker 报错 error during connect: Get pipe/docker_engine: The system cannot find the file specified. - 摘要: 本文讲的是Docker 报错 error during connect: Get pipe/dock
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.37/version: open //./pipe/docker_ ...
- docker报错Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
docker报错Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon run ...
- Vue.js报错Failed to resolve filter问题原因
Vue.js报错Failed to resolve filter问题原因 金刚 vue Vue.js js javascript 之前使用vue.js写分页功能时,写了一个过滤器,发现一个比较奇怪的错 ...
随机推荐
- 关于socket——SO_SNDBUF and SO_RECVBUF
转自:http://blog.csdn.net/wf1982/article/details/38871521 参见 http://stackoverflow.com/questions/425741 ...
- 介绍n款计算机视觉库/人脸识别开源库/软件
计算机视觉库 OpenCV OpenCV是Intel®开源计算机视觉库.它由一系列 C 函数和少量 C++ 类构成,实现了图像处理和计算机视觉方面的很多通用算法. OpenCV 拥有包括 300 多个 ...
- ASP.NET 4.0 取消表单危险字符验证
/// <summary> /// ASP.NET4.0 表单验证类 /// </summary> public class FormRequestValidation : R ...
- java大数取模
题目链接:http://lightoj.com/volume_showproblem.php?problem=1214 用java写大数果然是方便多了! import java.math.BigInt ...
- UIPopoverController 的使用
#import "ViewController.h" #import "RYColorSelectController.h" #import "RYM ...
- XCL-Charts图表库简要教程及常见问题
这个Andriod图表库项目从开始至现在,热情消耗几近殆尽.还好已基本实现我想做的那些东西.趁还剩下点兴趣,把一些点非常简单的归纳一下. 所支持的图表类型: 基类 ...
- Almost Sorted Array
http://acm.hdu.edu.cn/contests/contest_showproblem.php?cid=646&pid=1006 #include<iostream> ...
- 【转载】C++中public,protected,private访问
第一:private, public, protected 访问标号的访问范围. 假如我们约定: 类内部-----指的是当前类类型的定义中,以及其成员函数的声明和定义中: 类外部-----指的是不在当 ...
- RTTI (Run-Time Type Identification,通过运行时类型识别) 转
参考一: RTTI(Run-Time Type Identification,通过运行时类型识别)程序能够使用基类的指针或引用来检查这些指针或引用所指的对象的实际派生类型. RTTI提供了以下两个 ...
- Wireshark工具创建过滤器的方式
Wireshark工具创建过滤器的方式 [实例1-3]现在要抓取目的或来源地址为192.168.5.9的封包.在图1.5中添加如下所示的条件: tcp dst port 3128 添加后单击Star ...