之前在x86架构的服务器部署redis集群,未遇到题中问题;然而在ARM架构的服务器部署redis集群,第一次遇到如此问题。虽然问题已经解决,但不清楚问题的具体原因,在此做个记录。


性能测试过程中,通过pinpoint捕捉到如下报错:

MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk. Commands that may modify the data set are disabled, because this instance is configured to report errors during writes if RDB snapshotting fails (stop-write...(618)

这个错误通常表示Redis配置了保存RDB快照,但当前无法将快照持久化到磁盘上。


解决办法如下:

方法一:通过命令行修改

redis-cli登入redis,输入命令:config set stop-writes-on-bgsave-error no

127.0.0.1:6379> config set stop-writes-on-bgsave-error no

方法二:通过配置文件修改

修改redis.conf配置文件,将stop-writes-on-bgsave-error 的参数yes改为no。随后重启redis服务。

 230 # However if you have setup your proper monitoring of the Redis server
231 # and persistence, you may want to disable this feature so that Redis will
232 # continue to work as usual even if there are problems with disk,
233 # permissions, and so forth.
234 stop-writes-on-bgsave-error yes

问题原因分析:

① 就上述【方法二】中的redis配置文件信息,咨询chatGPT,给出如下回复:

230号行:然而,如果你已经正确设置了对Redis服务器的监控和持久化,你可能希望禁用这个特性,以便即使出现磁盘、权限等问题,Redis仍然可以正常工作。

231号行:该行是一个注释,提醒用户可以禁用Redis报告错误的功能,因为在正确设置了监控和持久化的情况下,Redis可以继续正常工作,即使磁盘或权限等存在问题。

232号行:注释说明了禁用此功能后的效果,即Redis将继续以往的工作方式运行,即使在磁盘、权限等方面存在问题。

233号行:该行是一个注释,提醒用户可能还有其他类似的问题。

234号行:stop-writes-on-bgsave-error yes表示当RDB快照失败时,停止写入命令。这意味着如果RDB快照操作失败,Redis会禁止执行可能修改数据集的命令。

② 进一步咨询chatGPT,什么情况下会出现redis RDB快照失败的情况?继续给出如下回复:

Redis RDB快照可能会失败的几种情况包括:

磁盘空间不足:当Redis尝试将RDB快照写入磁盘时,如果磁盘空间不足以容纳快照文件,就会导致快照失败。

权限问题:如果Redis进程没有足够的权限将RDB快照文件写入指定的目录,就会导致快照失败。确保Redis进程具有正确的权限来访问和写入目标目录。

磁盘故障:如果磁盘发生错误或损坏,可能会导致RDB快照无法成功写入磁盘,从而导致快照失败。

系统错误或中断:在执行RDB快照过程中,如果发生了系统错误或中断(如服务器崩溃、断电等),可能会导致快照失败。

内存不足:如果Redis实例的内存使用达到上限,可能会导致RDB快照失败。在执行快照之前,确保Redis实例有足够的可用内存来完成快照操作。

其他配置问题:一些配置问题,如错误的保存频率、目录配置错误等,也可能导致RDB快照失败。

需要注意的是,RDB快照失败不会导致数据丢失,因为Redis仍然可以继续运行并将数据保存在内存中。但是,如果持久化是关键需求,建议及时解决RDB快照失败的问题以确保数据的持久性和可靠性。

就此推测,应该是由于上述的某原因导致redis RDB快照失败,然后必须得将stop-writes-on-bgsave-error 的参数值配置为no才行。进一步推理:如果解决了上述导致redis RDB快照失败的问题,即使将参数修改回默认的yes,重启redis服务,问题也将不复存在。

redis集群报错:MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk.的更多相关文章

  1. Redis常见报错之 Redis::CommandError (MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk)

    在Redis运行过程中,报错信息如下: Redis::CommandError (MISCONF Redis is configured to save RDB snapshots, but it i ...

  2. MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk. Commands that may modify the data set are disabled, because this instance is configured to report e

    早上来到公司,线上的项目报错: Error in execution; nested exception is io.lettuce.core.RedisCommandExecutionExcepti ...

  3. redis异常信息:MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk.。。。。

    redis.exceptions.ResponseError: MISCONF Redis is configured to save RDB snapshots, but it is current ...

  4. 解决MISCONF Redis is configured to save RDB snapshots, but it is currently not able to persist on disk.问题

    突然发现昨天刚搭建的websocket不能连接了,提示: MISCONF Redis is configured to save RDB snapshots, but it is currently ...

  5. redis集群报错

    写入redis集群报错:(error) MOVED 6918 解决方法:redis-cli -c -p 7001 -h 10.0.0.104

  6. redis集群报错:(error) CLUSTERDOWN Hash slot not served

    百度上坑太多,如果你遇到搭建redis集群的时候出现这个错误在百度上找到解决办法基本上都是坑. 首先集群搭建完成后,你肯定去登陆redis进行测试 1.redis01/redis-cli -h &qu ...

  7. redis集群报错:(error) CLUSTERDOWN The cluster is down

    更换了电脑,把原来的电脑上的虚拟机复制到了新电脑上,启动虚拟机上的centos系统,然后启动redis集群(redis5版本),发现集群可以启动,redis进程也有,但是连接集群中的任意节点就报错,如 ...

  8. maven项目中使用redis集群报错: java.lang.NumberFormatException: For input string: "7001@17001"

    解决:由于redis集群的采用的版本是2.7的,在maven的pom.xml中将jedis的版本改成2.9的就可以了

  9. maven项目中使用redis集群报错: java.lang.NumberFormatException: For input string: "7006@17006"

    Caused by: org.springframework.beans.BeanInstantiationException: Failed to instantiate [redis.client ...

  10. redis集群报错:(error) MOVED 11469 192.168.163.249:7002

    应该是你没有启动集群模式(即缺少了那个"-c"): redis-cli -c -h yourhost -p yourpost

随机推荐

  1. mapper接口中常见的增删改查

    前言 相信大家在使用mybatis写mapper接口的时候,最常用且简单的方法就是增删改查了.我也是刚开始做项目,在本篇文章中,我将根据自己在vhr微人力项目中的mapper接口方法为实例,记录一下接 ...

  2. 五月八号java基础知识点

    1.对于容器中元素进行访问时,经常需要按照某种次序对容器中的每个元素访问且仅访问 一次,这就是遍历,也称为迭代.2.遍历是指从容器中获得当前元素的后续元素.对元素的遍历有很多种:第一种就是foreac ...

  3. js开发规范

    ####################### 1.缩进 [强制] 使用 4 个空格做为一个缩进层级,不允许使用 2 个空格 或 tab 字符. [强制] switch中缩进2个空格 [强制] 要求分 ...

  4. React+Antd在使用form表单提交DatePicker日期框的时候会出现少八小时的情况

    在使用antd做form表单提交的时候,突然发现了一个很有意思的bug.就是在使用datepicker组件日期框的时候会出现提交后少一天的问题 我在网上搜索了许多解决办法,也是困扰了我一天的时间,下面 ...

  5. FormData收集表单信息&并且转化为Json格式进行提交验证

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...

  6. Windows 本地安装mysql8.0

    前言 看了网上许多关于Windows 本地安装mysql的很多教程,基本上大同小异.但是安装软件有时就可能因为一个细节安装失败.我也是综合了很多个教程才安装好的,所以本教程可能也不是普遍适合的.现我将 ...

  7. MySQL(六)存储引擎

    存储引擎 ​ 连接管理.查询缓存.解析器和执行器被归为MySQL service,而把真实存储数据的功能划分为存储引擎的功能.所以MySQL service经过查询优化后,只需按照生成的执行计划调用存 ...

  8. 非关系型数据库---Redis安装与基本使用

    一.数据库类型 关系数据库管理系统(RDBMS) 非关系数据库管理系统(NoSQL) 按照预先设置的组织机构,将数据存储在物理介质上(即:硬盘上) 数据之间可以做无关联操作 (例如: 多表查询,嵌套查 ...

  9. 一个可用于生产项目 基于 .NET 6 自研ORM

    Fast Framework 作者 Mr-zhong 代码改变世界.... 一.前言 Fast Framework 基于NET6.0 封装的轻量级 ORM 框架 支持多种数据库 SqlServer O ...

  10. 区块链——Lab2

    区块链的典型数据结构 比特币:UTXO模型,以交易后找零为中心 ETH:Account 模型,以账户余额为中心(就是账户的形式) 区块链交易 用户发起交易 矿工验证交易(能够得到 区块奖励) 验证成功 ...