tomcat 启动服务器日志小结
1、tomcat 启动服务配置:
目前主要有 ①把编译好war或者项目直接扔到webapps 目录下, 启动bin目录下的startup.bat 即可 ② 在conf目录下
修改 server.xml的<Host></Host>中添加一行<Context />,启动bin目录下的startup.bat 即可,其实eclipse->add添加项目工程后,也是自动添加了这行数据:
<Context docBase="Chart" path="/Chart" reloadable="true" source="org.eclipse.jst.jee.server:Chart"/>
③ 可以删除server.xml的那个<Context ...>的内容,在conf->cataline->lacalhost 目录下添加一个 .xml的文件,启动bin目录下的startup.bat 即可,里面的内容就是一行
<Context path="/启动项目名" docBase="E:/项目地址" reloadable="true"/> ,与server.xml一致,这里说明一下,tomcat会先找server.xml的context,其次才找lacalhost目录下面的<Context />内容,这就是我要求先删除server.xml里面的context的原因

可能会用的或者修改问题:
1、启动需要修改tamcat 端口: 只需要在server.xml 修改 port参数就好了
<Connector connectionTimeout="20000" port="81" protocol="HTTP/1.1" redirectPort="8443"/>
---------------------------------------------------------------------------------------------------------
2、启动tomcat报错:Error parsing HTTP request header
Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level. java.lang.IllegalArgumentException: Invalid character found in the request target. The valid characters are defined in RFC 7230 and RFC 3986……
原因分析:Tomcat在 7.0.73, 8.0.39, 8.5.7 版本后,添加了对于http头的验证,具体来说,就是添加了些规则去限制HTTP头的规范性
解决方法:在tomcat目录下:conf/catalina.properties 中添加 tomcat.util.http.parser.HttpParser.requestTargetAllow=|{} 即可解决问题
----------------------------------------------------------------------------------------------------
3、启动tomcat报错:
- OutOfMemoryError: Java heap space
- OutOfMemoryError: PermGen space
- OutOfMemoryError: unable to create new native thread.
原因分析: 内存溢出
解决方法:
Linux服务器:
在/usr/local/apache-tomcat-5.5.23/bin 目录下的catalina.sh
添加:JAVA_OPTS='-Xms512m -Xmx1024m'
或者 JAVA_OPTS="-server -Xms800m -Xmx800m -XX:MaxNewSize=256m"
或者 CATALINA_OPTS="-server -Xms256m -Xmx300m"
Windows服务器:
在catalina.bat最前面加入
set JAVA_OPTS=-Xms128m -Xmx350m
或者set CATALINA_OPTS=-Xmx300M -Xms256M
------------------------------------------------------------------------------------------------------------
4.Post请求体过大 ,设置tomcat server.xml中属性 maxPostSize="5120000"
<Connector executor="tomcatThreadPool"
port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" maxPostSize="5120000" />
-----------------------------------------------------------------------------------------------------------
5.导入git 项目报错:An internal error occurred during: "Computing Git status for repository ...”
linux:
rm -r .metadata/.plugins/org.eclipse.core.resources/.projects/*/org.eclipse.egit.core
rm -r .metadata/.plugins/org.eclipse.core.resources/.projects/*/.indexes/properties.index
windows:
可以直接到eclipse的workspace目录下,找到上面的目录,剪切
org.eclipse.egit.core和properties.index到其他目录
然后重启eclipse, process视图中,不再显示“Computing Git Status for reposritory Application”
上述操作会导致项目与Git断开,在项目上右键->team,不显示commit等git操作选项。
解决方法: Eclipse->Project Explorer->项目->team->Share Project,自动识别出git中关联的项目
----------------------------------------------------------------------------------------------------------
属作者原创,如有转载,请表明出处:https://www.cnblogs.com/mobeisanghai/p/10755625.html
tomcat 启动服务器日志小结的更多相关文章
- 如何查看tomcat启动异常日志详情
我的电脑同时使用两个jdk版本,默认1.7,eclipse使用的是1.8,,由于项目启动时有加载类需要jdk1.8的包,1.7不支持.所以导致项目在eclipse直接能够跑,而在外面的tomcat跑是 ...
- linux下tomcat启动没有日志,没有进程,没有报错,没有监听端口
可以试试运行catalina.sh run,这个命令会让tomcat在终端打印日志.
- Tomcat学习笔记 - 错误日志 - NetBeans配置tomcat出错情况总结 -- 尚未授予访问 Tomcat 服务器的权限。请在服务器管理器的 Tomcat 定制器中设置 "manager-script" 角色的正确用户名和口令。 有关详细信息, 请查看服务器日志。
错误描述: 发布时控制台出现: 部署错误: 尚未授予访问 Tomcat 服务器的权限.请在服务器管理器的 Tomcat 定制器中设置 "manager-script" 角色的正确用 ...
- myeclipse启动服务器时,tomcat出错问题
启动服务器,错误提示: Launching web on myeclipse tomcat has encountered a problem An internal error occurred d ...
- Linux服务器tomcat启动很慢
Linux服务器tomcat启动很慢 步骤: 一:找到 java 位置 whereis java 输出内容(部分):/usr/lib/java ...... 二:进入到 lib 目录 cd /usr ...
- Linux下启动Tomcat启动并显示控制台日志信息
Linux下如何启动Tomcat像Windows启动并显示控制台日志信息一样? Windows下启动tomcat,一般直接运行startup.bat,启动后如下图所示: Linux下直接启动./sta ...
- 原!tomcat启动超时(打印了几行日志,后面没了。也不报错,处于启动状态,直到超时)
项目框架:spring+struts2+mybatis 今天优化代码,改了一堆mybatis dao和xml文件,启动项目时,就出现如标题描述的状况:打印了几行日志,后面就不打印了,也不报错,处于启动 ...
- 基于Saltstatck实现页面实时显示tomcat启动日志(17)
一.相关文件 master端: /srv/salt/tomcat/start.sls #tomcat启动服务state.sls,须要自己创建 /srv/salt/tomca ...
- Linux下如何查看tomcat是否启动、查看tomcat启动日志
在Linux系统下,重启Tomcat使用命令的操作! 1.首先,进入Tomcat下的bin目录 cd /usr/local/tomcat/bin 使用Tomcat关闭命令 ./shutdown.sh ...
随机推荐
- win8使用教程
win8如何关机 http://product.pconline.com.cn/itbk/software/win8/1305/3301394.html shutdown.exe -s -t 00 W ...
- window phone 8 开发准备工作(一)
一.下载安装Window phone SDK 1.Windows Phone SDK 8.0下载 http://www.microsoft.com/ZH-CN/download/details.asp ...
- ssl_protocols和ssl_ciphers应该怎么配置
http://wiki.nginx.org/HttpSslModule#ssl_ciphers 推荐配置: A) 在Apache 的 SSL 配置中禁用 SSLv3 和 SSLv3SSLProtoco ...
- js 习题
<!DOCTYPE html> <html> <head> <meta http-equiv="Content-Type" content ...
- C# 增加 删除 更新 方法
/// <summary> /// 增加一条数据 /// </summary> public int Add(string 表名,string 参数,string 参数值) { ...
- APICloud上啦加载下拉刷新模块
apicloud有自带的上啦加载下拉刷新,当让也可以用第三方或者在模块库里面找一个使用 一.下拉刷新,一下代码写在 apiready = function (){} 里面 apiready = fun ...
- javaee字符文件的复制
package Zy; import java.io.FileNotFoundException; import java.io.FileReader; import java.io.FileWrit ...
- python 生成HTmL报告页面
计划做一个html页面 py3.4 代码: # -*- coding=utf-8 -*- # import time,os class Template_mixin(object): "&q ...
- Python之CSV模块
1. CSV简介 CSV(Comma Separated Values)是逗号分隔符文本格式,常用于Excel和数据库的导入和导出,Python标准库的CSV模块提供了读取和写入CSV格式文件的对象. ...
- SBC37x交叉编译平台QT+OPENCV【2】虚拟机Vbox下Ubuntu的磁盘扩容
虚拟机Vbox下Ubuntu,当初为了学习,仅仅分配了8g,结果qt,opencv等一上,就说room空间不够了.于是开始折腾磁盘扩容. 网上一大堆,也不知道有多少是自己动手走过,正是不但浪费别人时间 ...