1 tomcat 6600启动报错
[root@localhost webapps]#     sh /usr/local/apache-tomcat-6.0.37_6600/bin/startup.sh 
Using CATALINA_BASE:   /usr/local/apache-tomcat-6.0.37_6600
Using CATALINA_HOME:   /usr/local/apache-tomcat-6.0.37_6600
Using CATALINA_TMPDIR: /usr/local/apache-tomcat-6.0.37_6600/temp
Using JRE_HOME:        /usr/java/jdk1.6.0_45
Using CLASSPATH:       /usr/local/apache-tomcat-6.0.37_6600/bin/bootstrap.jar
Using CATALINA_PID:    /var/tomcat/6600.pid
Existing PID file found during start.
Removing/clearing stale PID file.
看到/var/tomcat/6600.pid已经存在了,所以载入失败。

停止tomcat,然后检查tomcat进程

2 删除已经存在的6600.pid文件
[root@localhost webapps]# ps -eaf|grep 6600
root     10446  4972  0 15:09 pts/2    00:00:00 grep 6600
[root@localhost webapps]# more /var/tomcat/6600.pid
10180
[root@localhost webapps]# 
[root@localhost webapps]# ll /var/tomcat/6600.pid
-rw-r--r-- 1 root root 6 05-03 15:07 /var/tomcat/6600.pid

[root@localhost webapps]# rm -rf /var/tomcat/6600.pid
[root@localhost webapps]#

3 再重新启动,还是报错,查看错误日志例如以下:
tail -n 1000 /usr/local/apache-tomcat-6.0.37_6600/logs/catalina.out
2014-5-3 15:18:29 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
严重: The web application [/grouponAdminWeb] appears to have started a thread named [Thread-197] but has failed to stop it. This is very likely to create a memory leak.
2014-5-3 15:18:29 org.apache.catalina.loader.WebappClassLoader clearReferencesThreads
严重: The web application [/grouponAdminWeb] appears to have started a thread named [Thread-198] but has failed to stop it. This is very likely to create a memory leak.
......
2014-5-3 15:15:41 org.apache.catalina.startup.HostConfig deployWAR
信息: Deploying web application archive grouponAdminWeb.war
SLF4J: This version of SLF4J requires log4j version 1.2.12 or later. See also http://www.slf4j.org/codes.html#log4j_version
2014-5-3 15:15:44 org.apache.catalina.core.StandardContext start
严重: Error listenerStart
2014-5-3 15:15:44 org.apache.catalina.core.StandardContext start
严重: Context [/grouponAdminWeb] startup failed due to previous errors

从这里能够看出grouponAdminWeb这个web应用在tomcat容器上面deploy失败,为什么失败?

4 分析为什么会deploy应用失败?
找这个应用的设计人员。经过同事提醒。去看同一文件夹的localhost.2014-05-03.log文件
tail -n 1000 /usr/local/apache-tomcat-6.0.37_6600/logs/localhost.2014-05-03.log
有例如以下错误提示:
2014-5-3 15:15:41 org.apache.catalina.core.StandardContext listenerStart
严重: Exception sending context initialized event to listener instance of class org.springframework.web.util.Log4jConfigListener
java.lang.IllegalStateException: Web app root system property already set to different value: 'GrouponWeb.root' = [/usr/local/apache-tomcat-6.0.37_6600/webapps/grouponWeb/] instead of [/usr/local/apache-tomcat-6.0.37_6600/webapps/grouponAdminWeb/] - Choose unique values for the 'webAppRootKey' context-param in your web.xml files!
at org.springframework.web.util.WebUtils.setWebAppRootSystemProperty(WebUtils.java:148)
at org.springframework.web.util.Log4jWebConfigurer.initLogging(Log4jWebConfigurer.java:117)
at org.springframework.web.util.Log4jConfigListener.contextInitialized(Log4jConfigListener.java:45)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4206)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4705)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:943)
at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:778)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:504)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
at org.apache.catalina.core.StandardService.start(StandardService.java:525)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
2014-5-3 15:15:41 org.apache.catalina.core.ApplicationContext log
信息: Initializing Spring root WebApplicationContext

5  看到错误信息,是配置文件有误,去改动WEB-INF下的web.xml
vim  /usr/local/apache-tomcat-6.0.37_6600/webapps/grouponAdminWeb/WEB-INF/web.xml
将 GrouponWeb.root 的key值由GrouponWeb改动成GrouponAdminWeb,例如以下所看到的:

......
<context-param>
<param-name>webAppRootKey</param-name>
<param-value>GrouponAdminWeb.root</param-value>
</context-param>
......

之后重新启动tomcat或者,又一次载入GrouponAdminWeb应用,就OK了。

6 查看最新tomcat启动日志例如以下
[root@localhost WEB-INF]# tail -n 200 /usr/local/apache-tomcat-6.0.37_6600/logs/catalina.out
信息: Initializing Coyote HTTP/1.1 on http-6600
2014-5-3 15:18:53 org.apache.catalina.startup.Catalina load
信息: Initialization processed in 472 ms
2014-5-3 15:18:53 org.apache.catalina.core.StandardService start
信息: Starting service Catalina
2014-5-3 15:18:53 org.apache.catalina.core.StandardEngine start
信息: Starting Servlet Engine: Apache Tomcat/6.0.37
2014-5-3 15:18:53 org.apache.catalina.startup.HostConfig deployDescriptor
信息: Deploying configuration descriptor manager.xml
2014-5-3 15:18:53 org.apache.catalina.startup.HostConfig deployWAR
信息: Deploying web application archive grouponWeb.war
SLF4J: This version of SLF4J requires log4j version 1.2.12 or later. See also http://www.slf4j.org/codes.html#log4j_version
============
2014-5-3 15:18:58 org.apache.catalina.startup.HostConfig deployWAR
信息: Deploying web application archive grouponAdminWeb.war
SLF4J: This version of SLF4J requires log4j version 1.2.12 or later. See also http://www.slf4j.org/codes.html#log4j_version
============
2014-5-3 15:19:02 org.apache.catalina.startup.HostConfig deployWAR
信息: Deploying web application archive grouponService.war
2014-5-3 15:19:04 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory ROOT
2014-5-3 15:19:04 org.apache.coyote.http11.Http11Protocol start
信息: Starting Coyote HTTP/1.1 on http-6600
2014-5-3 15:19:04 org.apache.jk.common.ChannelSocket init
信息: JK: ajp13 listening on /0.0.0.0:6609
2014-5-3 15:19:04 org.apache.jk.server.JkMain start
信息: Jk running ID=0 time=0/13  config=null
2014-5-3 15:19:04 org.apache.catalina.startup.Catalina start
信息: Server startup in 10955 ms

总结:tomcat容器的web应用载入报错,除了要去看catalina.log日志之外,还要去看localhost.2014-05-03.log日志信息。

【Tomcat】严重: Context [/grouponAdminWeb] startup failed due to previous errors的更多相关文章

  1. Tomcat启动报Error listenerStart错误 Context [] startup failed due to previous errors

    本文转载自xpenxpen 今天启动Tomcat启动不了,报以下错: org.apache.catalina.core.StandardContext startInternal SEVERE: Er ...

  2. 关于Context []startup failed due to previous errors

    文章转自:http://blog.sina.com.cn/s/blog_49b4a1f10100q93e.html 框架搭建好后,启动服务器出现如下的信息: log4j:WARN No appende ...

  3. 报错信息 Context []startup failed due to previous errors

    文章转自:http://blog.sina.com.cn/s/blog_49b4a1f10100q93e.html 框架搭建好后,启动服务器出现如下的信息: log4j:WARN No appende ...

  4. tomcat bug之部署应用的时候经常会发上startup failed due to previous errors

    在tomcat上部署应用的时候经常会发上startup failed due to previous errors错误.这个错误产生以后经常会让人摸不到头脑.以下是几点查找经验: 1.web.xml文 ...

  5. 【Error listenerStart】 Error listenerStart Context [] startup failed due to previous errors

    发给 报错信息 八月 12, 2015 11:58:19 上午 org.apache.coyote.AbstractProtocol start 信息: Starting ProtocolHandle ...

  6. 关于Context []startup failed due to previous errors有效解决方式

    http://blog.csdn.net/mcpang/article/details/5468386

  7. org.apache.catalina.core.StandardContext.startInternal Context [/test] startup failed due to previou

    解决方法: WEB-INF/classes目录下新建一个文件叫logging.properties,截图如下: 代码如下: handlers=org.apache.juli.FileHandler,j ...

  8. tar: This does not look like a tar archive tar: Skipping to next header tar: Exiting with failure status due to previous errors

    解压一个.tar.zip文件时报错 tar -zxvf bcl2fastq2-v2---linux-x86-.zip tar: This does not look like a tar archiv ...

  9. 解决“tar:Exiting with failure status due to previous errors”【转】

    问题: 当我想试着用tar命令来创建一个压缩文件时,总在执行过程中失败,并且抛出一个错误说明"tar:由于前一个错误导致于失败状态中退出"("Exiting with f ...

随机推荐

  1. Gym - 100637A Nano alarm-clocks 模拟

    题意:有n个时钟,只能顺时针拨,问使所有时间相同的最小代价是多少 思路:将时间排序,枚举拨动到每一个点的时间就好了,容易证明最终时间一定是其中之一 #include <iostream> ...

  2. HDU 5375 Gray Code 动归

    题意:给你一串不确定的二进制码,其对应的格雷码的每一位有对应的权值,问转换成的格雷码的能取到的最大权值是多少. 思路:没有思路,乱搞也AC #pragma comment(linker, " ...

  3. Codeforces 344D Alternating Current 简单使用栈

    Description Mad scientist Mike has just finished constructing a new device to search for extraterres ...

  4. OPENCV(6) —— 角点检测

    图像特征的类型通常指边界.角点(兴趣点).斑点(兴趣区域).角点就是图像的一个局部特征,应用广泛.harris角点检测是一种直接基于灰度图像的角点提取算法,稳定性高,尤其对L型角点检测精度高,但由于采 ...

  5. visual studio 添加库文件

    我在visual studio中使用OpenGL时需要添加额外的库 一 首先下载库文件,里面将会有一些.h文件和.lib文件,打开visual studio安装目录下打开: D:\program\VS ...

  6. Swift学习笔记(5)--数组

    数组的下标从0开始计数,相关方法属性涉及到下标时也从0开始计数 1.定义: //1.可变数组 var cityArray = ["Portland","San Franc ...

  7. 浏览器加载渲染HTML、DOM、CSS、 JAVASCRIPT、IMAGE、FLASH、IFRAME、SRC属性等资源的顺序总结

    页面响应加载的顺序:   1.域名解析->加载html->加载js和css->加载图片等其他信息 DOM详细的步骤如下: 解析HTML结构. 加载外部脚本和样式表文件. 解析并执行脚 ...

  8. Oracel 格式化日期 to_char()

    select empno,ename,job,mgr,to_char(HIREDATE,'yyyy-mm-dd') as 入职日期,sal,comm,deptno from emp order by ...

  9. AIX 适配器

    1. 查看所有适配卡 lsdev -CHc adapter     2. 物理网卡适配卡 查看到物理网卡的个数与类型 lsdev -Cc adapter|grep ent   查看物理网卡具体插槽位( ...

  10. ES6第二节:新的声明方式

    通过上一节的环境搭建完成,接下来我们就可以愉快的探索ES6的新世界了!下面我们从新的声明方式开始: 在ES6里新加了两种声明方式:let 和 const,以前我们都是用var去作声明,接下来我们一一比 ...