配置telnet     

通过配置文件,我们可以设置telnet的连接时间、连接数、连接ip等,实现更加安全的连接

1、设置连接时间,参数“access_times”

[root@localhost wj]# gedit /etc/xinetd.d/telnet

service telnet

{

    flags      = REUSE

    socket_type   = stream        

    wait       = no

    user       = root

    server     = /usr/sbin/in.telnetd

    log_on_failure    += USERID

    disable       = no

    access_times = 08:00-09:00 13:00-15:00           //规定允许连接的时间段8~9点,13~15点

}

 

[root@localhost wj]# service xinetd restart         //重启服务

停止xinetd:                                             [确定]

正在启动xinetd:                                          [确定]

 

[root@localhost wj]# telnet 192.168.0.119           //尝试连接

Trying 192.168.0.119...

Connected to 192.168.0.119.

Escape character is '^]'.

Connection closed by foreign host.                  //连接失败

2、设置连接数,通过参数“instances”可以设置允许的连接数,超过之后就无法再连接了

[root@localhost wj]# gedit /etc/xinetd.d/telnet

service telnet

{

    flags      = REUSE

    socket_type   = stream        

    wait       = no

    user       = root

    server     = /usr/sbin/in.telnetd

    log_on_failure    += USERID

    disable       = no

    instances      = 1                                   //这里设置只允许一个连接,第二个就无法连接了

}

 

[root@localhost wj]# service xinetd restart         //重启服务

停止xinetd:                                             [确定]

正在启动xinetd:                                          [确定]

 

[root@localhost wj]# telnet 192.168.0.119          //第一个连接

Connected to 192.168.0.119.

login: david       

Password:

Last login: Thu Aug 16 09:10:22 from 192.168.0.119

already login                                          //成功

 

[root@localhost wj]# telnet 192.168.0.119        //第二个连接

Connected to 192.168.0.119.

Connection closed by foreign host.                //失败

3、允许/禁止特定的ip或者网段登录,参数“only-from”“no_access”

[root@localhost wj]# gedit /etc/xinetd.d/telnet 

service telnet

{

    flags      = REUSE

    socket_type   = stream        

    wait       = no

    user       = root

    server     = /usr/sbin/in.telnetd

    log_on_failure    += USERID

    disable       = no

    only_from  = 192.168.0.113                     //只允许113连接

#   only_from  = 192.168.0.0/24                    //允许1~254连接

#   only_from  = 192.168.0.100-192.168.0.200    //允许100~200连接

#   only_from  = 192.168.0.                        //允许113和114连接

#   no_access  = 192.168.0.113                    //禁止113连接,其他写法同上

} 

4、允许root连接。只要将文件“/etc/securetty”删除,那么系统读不到这个文件,自然就会永续root登录

[root@localhost wj]# mv /etc/securetty /etc/securetty.bak     //重命名该文件

[root@localhost wj]# service xinetd restart                     //重启服务

停止 xinetd:                                              [确定]

正在启动 xinetd:                                          [确定]

[root@localhost wj]# telnet 192.168.0.119                       //连接

Trying 192.168.0.119...

Connected to 192.168.0.119.

login: root                                                          //使用root用户连接

Password:                                                              

Last login: Thu Aug 16 07:51:45 from 192.168.0.119

already login                                                        //连接成功

Linux服务器配置---配置telnet的更多相关文章

  1. Linux服务器配置---安装telnet

    安装telnet      telnet是标准的远程登录协议,历史悠久.但是telnet的对话数据没有加密,甚至用户名和密码都是明文显示,这样的服务风险极大.目前大多数系统多已经不会再安装这个服务了, ...

  2. Linux学习之七-配置Telnet连接Linux服务器

    配置Telnet连接Linux服务器 通过telnet可以从windows平台访问linux 服务器 ,实现和ssh 客户端一样的效果,区别在于通过ssh连接更安全. 检查Linux系统中是否安装了t ...

  3. Linux服务器配置之加载硬盘

    Linux服务器配置之加载硬盘 1.修改密码 passwd 2.测试密码是否成功 3.查看硬盘信息 fdisk –l 4.格式化分区 fdisk /dev/vdb 5.查看分区 6.快速格式化/dev ...

  4. 在 Linux 上配置一个 syslog 服务器

    syslog服务器可以用作一个网络中的日志监控中心,所有能够通过网络来发送日志的设施(包含了Linux或Windows服务器,路由器,交换机以及其他主机)都可以把日志发送给它. 通过设置一个syslo ...

  5. Linux服务器配置(一)

    Linux服务器配置(一) jdk,tomcat,nginx记录 最近公司买了三台服务器System x3650 M5用来跑公司的项目.现,记录一下真机部署与后期维护历程~ 因为系统是服务器买来就装好 ...

  6. Linux centos7. 配置安装Oracle

    oralcle 11g r2 配置一下前期的网络环境 一 修改linux核心配置 1.修改用户的SHELL限制vi /etc/security/limits.conf oracle soft npro ...

  7. Linux 服务器配置、运行、不用敲命令(新手必备!) - 宝塔全攻略建站一条龙

    Linux 服务器配置.运行.不用敲命令 WordPress 建站攻略 本文提供全流程,中文翻译. Chinar 坚持将简单的生活方式,带给世人!(拥有更好的阅读体验 -- 高分辨率用户请根据需求调整 ...

  8. Gradle在Windows环境与Linux上配置有哪些不同?

    我的开发环境:Windows + Android Studio + Gradle 2.8 all + Jenkins 公司CI 服务器环境: Linux + Gradle 2.10 bin + Jen ...

  9. Linux 网桥配置命令:brctl

    Linux网关模式下将有线LAN和无线LAN共享网段实现局域网内互联: 思路其实很简单:就是将虚拟出一个bridge口,将对应的有线LAN和无线LAN都绑定在这个虚拟bridge口上,并给这个brid ...

随机推荐

  1. Android ScrollView嵌套ScrollView滚动的问题解决办法

    引用:http://mengsina.iteye.com/blog/1707464 http://fenglog.com/article.asp?id=449 Android ScrollView嵌套 ...

  2. 服务器群秒级别文件同步(ssh+SHELL)

    1.介绍 \ 2.业务服务器远程更新浏览服务器文件的脚本 #!/bin/bash operate=$ ip=$ conf_file="/var/www/html/test/ip_list&q ...

  3. Spark ML包,数据挖掘示例数据Affairs

    1.数据字段解释 affairs:一年来婚外情的频率   gender:性别   age:年龄   yearsmarried:婚龄   children:是否有小孩   religiousness:宗 ...

  4. 04 用户个人信息和二次开发django的文件存储系统

    用户的个人信息的前端页面如下: 业务逻辑分析 从上图中可以看出,需要后端传送的数据有,用户的名字和练习的地址,和最近的浏览记录. 用户的名字和联系的地址可以通过地址表(adress)中获得,地址表可以 ...

  5. tomcat启动报错“Error: Exception thrown by the agent : java.net.MalformedURLException: Local host name unknown: java.net.UnknownHostException: iZ25fsk1ifk: iZ25fsk1ifk”

    在启动了Tomcat的时候出现下面的错误,导致启动不了,卡在读日志的状态 Error: Exception thrown by the agent : java.net.MalformedURLExc ...

  6. js 的基础知识

    一.弱类型意识 js变量是没有类型的 var  a = 1;  //a 就是一个变量 不要提什么类型 变量可以赋任何类型的值 类型仅仅是值的性质 与变量无关 Js的基本类型 变量未赋值时,其值为und ...

  7. EasyUI常用控件禁用方法

    EasyUI常用控件禁用方法: 1.validatebox可以用的用法:前两种适用于单个的validatebox; 第三种应用于整个form里面的输入框; <1>.$("#id& ...

  8. OC中分类(Category)和扩展(Extension)

    1.分类的定义 category是Objective-C 2.0之后添加的语言特性,中文也有人称之为分类.类别.Category的主要作用是为已经存在的类添加方法.这个大家可能用过很多,如自己给UIC ...

  9. 服务器端FIN的条件

    服务器端FIN的条件_域名/网络_常见问题_对象存储 OSS-阿里云 https://help.aliyun.com/knowledge_detail/65427.html 服务器端FIN的条件 KB ...

  10. arcgis server multipoint 服务 applyedit功能

    首先打开arcmap,在catalog中新建 File GDB 在File GDB 中新建 Feature Class 类型选择 Multipoint 选择坐标 此时图层列表中有了新建的要素,点击Ed ...