通过jenkins构建服务,并发布服务,修改Jenkins以Root用户运行
通过jenkins构建服务,并发布服务,修改Jenkins以Root用户运行
其他博文:从0到1体验Jenkins+Docker+Git+Registry实现CI自动化发布
从0到1体验Jenkins+Docker+Git+Registry实现CI自动化发布
Jenkins注册中心
每次构建服务时,丢弃旧的构建,策略为Log Rotation;
源码管理选择无;
新建一个Jenkins注册服务中心,添加如下可执行shell的构建信息:
pid=$(docker ps -a | grep "service-register" | awk '{print $1}')
if [ -n "$pid" ]; then
docker rm -f $pid
fi
docker run -d -p 8762:8762 -m 2g -v /logs:/logs -v /etc/localtime:/etc/localtime xxx/service-register:1.0.0
一、新建任务

二、配置jenkins



三、通过后台启动服务
之前需后台启动,是因为通过docker拉取的jdk镜像为openjdk,导致项目上传附件的一个功能不好使,后来进行修改,将openjdk改为oracle的jdk,则解决,直接可通过Jenkins持续集成项目,并启动docker服务。
#!/bin/bash
jps | grep jar| awk '{print $1}'|xargs -I {} kill -9 {}
# jps查看当前运行的进行
# grep jar :查询以jar方式运行的相关jar进程
# awk 抽取查询出的数据
# kill -9 干掉该进程
cd /root/.jenkins/workspace/$1/xx-xx-$1/target
# cd 进入到项目打包后的路径
pwd
#后台挂起执行
nohup java -jar xx-xx-1.0-SNAPSHOT.jar --spring.profiles.active=$1 > /logs/xx-xx-$1/xx.log 2>&1 &
tail -f /logs/xx-xx-$1/xx.log
四、CentOS7 修改Jenkins以root用户运行
CSDN:jeikerxiao:CentOS7 修改Jenkins以root用户运行
4.1修改Jenkins配置文件
修改$JENKINS_USER
打开jenkins配置文件:
➜ vim /etc/sysconfig/jenkins
找到如下行:
将原来的jenkins用户修改为 root用户。
$JENKINS_USER="root"
修改Jenkins相关文件夹用户权限
更改jenkins三个文件夹的用户所有都和用户组:
➜ chown -R root:root /var/lib/jenkins
➜ chown -R root:root /var/cache/jenkins
➜ chown -R root:root /var/log/jenkins
重启Jenkins
重启Jenkins服务并检查运行Jenkins的用户是否已经切换为root。
➜ systemctl restart jenkins
查看Jenkins进程所属用户
➜ ps -ef | grep jenkins
若显示为root用户,则表示修改完成。
通过jenkins构建服务,并发布服务,修改Jenkins以Root用户运行的更多相关文章
- 修改ES使用root用户运行
默认ES不允许使用root用户运行,如果使用root会报如下图的错误: ,通常建议创建elsearch用户并使用该用户运行ES.但如果必须使用root用户时,按如下设置即可: 1.启动是使用如下命令 ...
- 使用thrift实现订阅服务和发布服务
使用thrift实现订阅服务和发布服务 服务:订阅服务 market_subscriber 和 发布服务 market_publisher功能:market_subscriber 能够向 market ...
- CentOS7 修改Jenkins以root用户运行
修改Jenkins以root用户运行,这在正式环境中是不可取的,但在自己的测试环境中就无所谓了啦,怎么方便怎么来. 1. 修改Jenkins配置文件1.1 修改$JENKINS_USER打开jenki ...
- Jenkins以root用户运行的方法
以centOS系统为例,记录下修改Jenkins以root用户运行的方法. 修改Jenkins配置文件 # 打开配置文件 vim /etc/sysconfig/jenkins # 修改$JENKINS ...
- 以root用户运行jenkins中shell命令 重要
以centOS系统为例,记录下修改Jenkins以root用户运行的方法. 修改Jenkins配置文件 # 打开配置文件vim /etc/sysconfig/jenkins# 修改$JENKINS_U ...
- 使用ROOT用户运行Jenkins
!本教程仅适用于以YUM.APT等包管理器安装的Jenkins. 使用ROOT用户运行Jenkins,以保证Jenkins以最高权限执行任务. 注:会存在安全风险! 1.找到Jenkins启动脚本 通 ...
- 解决jenkins构建job报错“NoClassDefFoundError” in jenkins/scm/RunWithSCM问题
现象 使用Jenkins 2.8,当我运行一个简单的Jenkins工作时,构建一个job获取源代码,出现下面的错误 FATAL: jenkins/scm/RunWithSCM java.lang.No ...
- ubuntu 下修改MySQL 的root用户密码
环境:Ubuntu 16.04 : Mysql 5.7问题:mysql root登录密码 忘记了..忘记了..忘..了 1.登录MySQL $ mysql -u root -p 输入密码,如果登录 ...
- 修改RedHat7的root用户密码
前言 前段时间由于长时间没有使用虚拟机里面的一个操作系统,导致密码记得不是太清,登录不进去.今天想起还是做个小记录,以便以后参考. 再一个是,当时网上也搜了很多解决问题的博客,但大部分都是同一个博客内 ...
随机推荐
- java线程与内核线程的关系,及怎么定义ThreadPoolExecutor相关参数
p.p1 { margin: 0; font: 12px Menlo } p.p1 { margin: 0; font: 12px Menlo } p.p2 { margin: 0; font: 12 ...
- TurtleBot 3 & 2i ROS开源实验平台
TurtleBot 3 & 2i ROS开源实验平台,全球更受欢迎的ROS平台. TurtleBot是ROS标准平台机器人,在全球开发人员和学生中深受欢迎.其有3个版本: TurtleBot1 ...
- nrm : 无法加载文件 C:\Users......因为在此系统上禁止运行脚本。
1.以管理员身份运行powershell 2.使用set-ExecutionPolicy RemoteSigned命令将计算机上的执行策略更改为 RemoteSigned,输入Y确定 3.查看计算机执 ...
- Element UI组件说明
-<el-card>-查询及展示列表页面-[v-show]属性控制显示隐藏-<el-card class="box-card" >-多标签页面-<el ...
- java集合并发操作异常解决方法:CopyOnWriteArrayList
一.我们知道ArrayList是线程不安全的,请编写一个不安全的案例并给出解决方案 HashSet与ArrayList一致 HashMap HashSet底层是一个HashMap,存储的值放在Hash ...
- 关于 RNN 循环神经网络的反向传播求导
关于 RNN 循环神经网络的反向传播求导 本文是对 RNN 循环神经网络中的每一个神经元进行反向传播求导的数学推导过程,下面还使用 PyTorch 对导数公式进行编程求证. RNN 神经网络架构 一个 ...
- 【Java基础】Eclipse 和数组
Eclipse 和数组 Eclipse 安装和使用 ... 数组的概述 数组(Array):是多个相同类型数据按一定顺序排列的集合,并使用一个名字命名,并通过编号的方式对这些数据进行统一管理. 数组相 ...
- 【SpringMVC】SpringMVC 实现文件上传
SpringMVC 实现文件上传 文章源码 文件上传回顾 查看 JavaWeb 阶段的文件上传下载 实现步骤: 客户端: 发送 post 请求,告诉服务器要上传什么文件 服务器: 要有一个 form ...
- springboot 和 mongdb连接问题 Exception in thread "main" com.mongodb.MongoSecurityException:
1 Exception in thread "main" com.mongodb.MongoSecurityException: Exception authenticating ...
- ctfshow—web—web5
打开靶机,代码审计 附上代码 <?php error_reporting(0); ?> <html lang="zh-CN"> <head> & ...