Tomcat启动失败,提示Server Tomcat v7.0 Server at localhost failed to start

在一次查看自己以前写过的项目中,运行tomcat失败,出现如图提示

然而自己之前的项目运行时候都很正常,没有出现这样的错误,再次运行时候就出现这样的错误,百思不得其解,上网百度、请教别人最终将这个问题解决,总结了六点,分享给大家,希望可以帮助到那些和我一样,遇见同样问题而苦恼的人。

1、把你工作空间按照如下的文件路径打开:

<workspace>\.metadata\.plugins\org.eclipse.wst.server.core

删除里面的temp文件夹,删除后重启eclipse,tomcat就可以用了。

2、把你工作空间按照如下的文件路径打开:

<workspace>\.metadata\.plugins\org.eclipse.core.resources

删除 .snap 文件,(我在使用eclipse下有这个.snap文件)。

3、在server视图窗口中,把tomcat删除。然后再重新添加tomcat 再添加你的Web项目并启动。

4、打开任务管理器,找到javax.exe,右键结束进程,重启eclipse。

5、检查web.xml中的servlet映射里面的<url-pattern>,看<url-pattern></url-pattern>中配置的内容是否缺少“/” ,"/"表示当前web应用。这个问题也可能是由过滤器引起的。

6、不同的servlet使用了相同的@WebServlet标注。在Servlet上设置@WebServlet标注,容器就会自动读取当中的信息。

举个例子:

@WebServlet("/DownLoadDemo2")
public class DownLoadDemo2 extends HttpServlet{

当用户请求的URL是"/DownLoadDemo2",则由DownLoadDemo2的实例提供服务。

注:@WebServlet("/DownLoadDemo2")这种方式称为注解,省去在web.xml中进行配置。

例如:

<servlet>
  <!-- 声明Servlet对象 -->
  <servlet-name>RequestDemo1</servlet-name>
  <!-- 上面一句指定Servlet对象的名称 -->
  <servlet-class>com.jd.request.RequestDemo1</servlet-class>
  <!-- 上面一句指定Servlet对象的完整位置,包含包名和类名 -->
</servlet>
<servlet-mapping>
  <!-- 映射Servlet -->
  <servlet-name>RequestDemo1</servlet-name>
  <!--<servlet-name>与上面<Servlet>标签的<servlet-name>元素相对应,不可以随便起名 -->
  <url-pattern>/RequestDemo1</url-pattern>
  <!-- 上面一句话用于映射访问URL -->
</servlet-mapping>

Tomcat启动失败 提示Server Tomcat v7.0 Server at localhost failed to start.六种解决方法的更多相关文章

  1. Tomcat启动失败原因: More than one fragment with the name [spring_web] was found. 解决

    将一个eclipse上搭建好的项目移到idea开发时遇到的问题,tomcat启动时报了3个错误 -Nov- :: ms -Nov- ::)-127.0.0.1] org.apache.tomcat.u ...

  2. Tomcat启动失败Unrecognized Windows Sockets error: 0: JVM_Bind

    问题:Tomcat一直无法运行,或者是运行了报上面图片的哪些错误. 解决:关闭myeclipse,打开任务管理器(Ctrl+Alt+Delete)关闭javaw.exe这个进程,另外说一下,Tomca ...

  3. Server Tomcat v8.0 Server at localhost failed to start.的解决方法

    1.可能是web.xml中的filter-mapping中url-pattern没加/* 2.可能是servlet和servlet-mapping中的servlet-name不匹配

  4. msfconsole启动失败并报错`not_after=': bignum too big to convert into `long'的解决方法

    1.启动msfconsole失败并报如下错误: /usr/share/metasploit-framework/lib/msf/core/payload/android.rb:86:in `not_a ...

  5. ArcGis安装失败提示“需要Microsoft .NET Framework 3.5 sp1或等效环境”的解决方法

    这个问题一般出现在Win8或者Win10系统上,因为系统默认没有启用该.Net Framework. 下载Microsoft .NET Framework 3.5 sp1安装后再开始安装ArcGis. ...

  6. Tomcat启动失败原因

    Tomcat启动失败原因 一.Tomcat启动时,要求被加载的项目必须拥有独立路径名称 发布的两个工程具有相同路径名称,这是不允许. 二.8080端口号已经被占用了 启动失败原因,就是8085端口上, ...

  7. myeclipse2015不能启动tomcat,提示: Several ports (8005, 8080, 8009) required by Tomcat v7.0 Server at local

    myeclipse2015不能启动tomcat,提示: Several ports (8005, 8080, 8009) required by Tomcat v7.0 Server at local ...

  8. tomcat启动失败问题排除及解决办法 Server Tomcat v7.0 Server at localhost failed to start.

    tomcat启动失败问题排除及解决办法 Server Tomcat v7.0 Server at localhost failed to start. 导致上面问题的原因可能有很多种,每种的解决办法都 ...

  9. Tomcat v7.0 Server at localhost are already in use,tomcat提示端口被占用,tomcat端口已经被使用,tomcat端口占用

    Tomcat v7.0 Server at localhost are already in use, tomcat提示端口被占用,tomcat端口已经被使用 >>>>> ...

随机推荐

  1. HIVE 数据分析

    题目要求: 具体操作: ①hive路径下建表:sale create table sale (day_id String, sale_nbr String, buy_nbr String, cnt S ...

  2. redis-server.exe双击闪退

    转自 https://blog.csdn.net/qq_40361770/article/details/80454248 解决方法: 1-win+R 打开命令行 2-cd至redis目录,例如 D: ...

  3. Dubbo本地存根是什么,Dubbo本地伪装又是什么?

    真正的大师永远怀着一颗学徒的心 哈喽!大家好,我是小奇,一位程序员界的学徒 小奇打算以轻松幽默的对话方式来分享一些技术,如果你觉得通过小奇的文章学到了东西,那就给小奇一个赞吧 前言 书接上回,昨天打了 ...

  4. C++ 获取指定的重载函数地址

    刚刚看到一篇博客,说 std::bind 无法绑定正确的重载函数.这里的问题并不是 std::bind 能力不足,而是将函数名传递给 std::bind 时编译器无法取到这个函数的地址(也就是符号,编 ...

  5. 借助SpotBugs将程序错误扼杀在摇篮中

    背景 最近一年多在一家toB业务的公司,部门主要做的是建筑行业的招投标业务信息化,希望借助软件来达到"阳光.降本.提效"的目的,我刚入职时大概30多家客户,截止现在已经超过100家 ...

  6. ESXI系列问题整理以及记录——使用Windows PowerShell中的SSH功能连接ESXI控制台

    首先进入ESXI管理页面,开启ESXI的SSH功能 接下来到位于同一局域网的Win主机上开启Powershell,如果ESXI主机的IP地址为192.168.1.77,则在Powershell中输入: ...

  7. WPF开发随笔收录-本地日志LogUtil类

    一.前言 生活中的日志是记录你生活的点点滴滴,让它把你内心的世界表露出来,更好的诠释自己的内心世界.而在开发者眼中的日志是我们排除问题的第一手资料,项目中的程序上线之后,一旦发生异常,第一件事就是先去 ...

  8. sql-DCL用户及权限管理及其他常用命令-oracle

    DCL 用户管理 创建用户 create user 用户名 identified by 密码; 在oracle中要创建一个新的用户使用create user语句,一般是具有dba(数据库管理员)的权限 ...

  9. docker-compose: 未找到命令,安装docker-compose

    1.安装扩展源 sudo yum -y install epel-release 2.安装python-pip模块 sudo yum install python-pip 3.通过命令进行安装 cd ...

  10. Halcon 条形码识别

    read_image (Image, 'C:/Users/HJ/Desktop/test_image/image.png') create_bar_code_model([], [], BarCode ...