gin-k8s 运行的问题
1,k8s admin dashboard
项目地址:
https://github.com/kubernetes/dashboard
项目使用的是golang 作为后端,然后使用angular 作为前段框架的。
项目依赖kubernetes 的api服务,不能单独跑起来。
参考之前写的 centos 安装 kubernetes 1.5 :
Centos7 安装 kubernetes 1.5 版本
详情:新智云(www.enncloud.cn)
2,启动项目
beego 是个好东西,可将任何main 函数入口的都带起来并且可以实时的检查变化。
然后自动重启。我在使用beego 开发的时候手动启动的次数就很少。
非常的方便。
项目main函数在:
$GOPATH/src/github.com/kubernetes/dashboard/src/app/backend
doc 下面有很多的文档,讲如何将dashboard 启动起来。
启动的时候需要增加环境变量:
export KUBERNETES_SERVICE_HOST=127.0.0.1
export KUBERNETES_SERVICE_PORT=8080
go run dashboard.go
报错:
open /var/run/secrets/kubernetes.io/serviceaccount/token: no such file or directory
需要配置 ssl 调用kubernetes ,要有个密钥,同时需要token。
想想算了。还是使用http链接得了,反正也是个测试环境。
启用测试没有找到直接使用 http 链接:
func InClusterConfig() (*Config, error) {
host, port := os.Getenv("KUBERNETES_SERVICE_HOST"), os.Getenv("KUBERNETES_SERVICE_PORT")
if len(host) == 0 || len(port) == 0 {
return nil, fmt.Errorf("unable to load in-cluster configuration, KUBERNETES_SERVICE_HOST and KUBERNETES_SERVICE_PORT must be defined")
}
token, err := ioutil.ReadFile("/var/run/secrets/kubernetes.io/serviceaccount/" + api.ServiceAccountTokenKey)
if err != nil {
return nil, err
}
tlsClientConfig := TLSClientConfig{}
rootCAFile := "/var/run/secrets/kubernetes.io/serviceaccount/" + api.ServiceAccountRootCAKey
if _, err := certutil.NewPool(rootCAFile); err != nil {
glog.Errorf("Expected to load root CA config from %s, but got err: %v", rootCAFile, err)
} else {
tlsClientConfig.CAFile = rootCAFile
}
return &Config{
// TODO: switch to using cluster DNS.
Host: "https://" + net.JoinHostPort(host, port),
BearerToken: string(token),
TLSClientConfig: tlsClientConfig,
}, nil
}
修改成:
func InClusterConfig() (*Config, error) {
host, port := os.Getenv("KUBERNETES_SERVICE_HOST"), os.Getenv("KUBERNETES_SERVICE_PORT")
if len(host) == 0 || len(port) == 0 {
return nil, fmt.Errorf("unable to load in-cluster configuration, KUBERNETES_SERVICE_HOST and KUBERNETES_SERVICE_PORT must be defined")
}
_, err := ioutil.ReadFile("/var/run/secrets/kubernetes.io/serviceaccount/" + api.ServiceAccountTokenKey)
if err != nil {
fmt.Println("read file err: ", err)
}
tlsClientConfig := TLSClientConfig{}
rootCAFile := "/var/run/secrets/kubernetes.io/serviceaccount/" + api.ServiceAccountRootCAKey
if _, err := certutil.NewPool(rootCAFile); err != nil {
glog.Errorf("Expected to load root CA config from %s, but got err: %v", rootCAFile, err, tlsClientConfig)
}
return &Config{
// TODO: switch to using cluster DNS.
Host: "http://" + net.JoinHostPort(host, port),
}, nil
}
修改成http 即可。然后就可以启动了。
方式二:
设置KUBECONFIG=/etc/kubernetes/admin.conf的环境变量
config源自$HOME/.kube/config
cd $GOPATH/src/github.com/kubernetes/dashboard/src/app/backend
go run dashboard.go
Using HTTP port: 9090
Creating API server client for http://127.0.0.1:8080
Successful initial request to the apiserver, version: v1.5.2
Creating in-cluster Heapster client
Using service account token for csrf signing
查看 namespace :
curl 127.0.0.1:9090/api/v1/namespace
{
"listMeta": {
"totalItems": 2
},
"namespaces": [
{
"objectMeta": {
"name": "default",
"creationTimestamp": "2017-04-14T00:07:27Z"
},
"typeMeta": {
"kind": "namespace"
},
"phase": "Active"
},
{
"objectMeta": {
"name": "kube-system",
"creationTimestamp": "2017-04-14T00:07:27Z"
},
"typeMeta": {
"kind": "namespace"
},
"phase": "Active"
}
]
}
这个只是后端的部分,没有前端,前段是nodejs,不会。
3,项目的意义
admin dashboard 是一个非常好的demo。讲述如何调用kubernetes的 api。
如果一个企业需要使用 kubernetes 需要自己定制开发的话。
直接使用 kubernetes 的api 就行了。其实最重要的就是 直接调研 API。
都是做应用的底层的东西度没有时间经历去修改。
只能在外围做些定制化的开发。
但是看了代码才发现项目拆分的非常细。模块拆分的非常多。
而且前后端拆分的非常洗。
4,代码分析
入口就是 dashboard.Go
首先查看环境变量,或者是配置文件,查找 kubernetes api 地址。然后:
apiserverClient, config, err := client.CreateApiserverClient(*argApiserverHost, *argKubeConfigFile)
只有全部启动正确之后才行,否则会报错。
handler/apihandler.go
是主要的函数,路由配置。讲请求转换成 kubernetes client 接口调用。
剩下的就是最重要的各种资源:
cluster
common
config
configmap
container
daemonset
dataselect
deployment
discovery
event
horizontalpodautoscaler
ingress
job
limitrange
logs
metric
namespace
node
owner
persistentvolume
persistentvolumeclaim
pod
rbacrolebindings
rbacroles
replicaset
replicationcontroller
resourcequota
secret
service
statefulset
storageclass
thirdpartyresource
workload
这些资源都是使用 kubernetes 客户端进行调用的。同时都汇总到 apihandler.go 这个类当中。
返回给前端页面进行展示。
前端的入口是 index.html,然后加载资源,也是一堆的资源,每一个一个文件夹。
基本上和后端的资源都对齐了。前端使用 Angular module 将模块拆分成一个一个的。
按照模块化进行开发了。
真的是非常的细致。可惜看不到全局,整体的东西了。
BrowserSync (9090) —> Dashboard backend (9091) —> Kubernetes API server (8080)
前端的技术比较复杂,使用的SASS,ES6,Angular,最后都编译成一个单页面的ajax 应用。
作为我一个后端hold 不住了。只会点jQuery。
4,总结
kubernetes 真的是一个非常好的项目。
kubernetes自带的dashboard 使用的前后端拆分。后端有简单的业务逻辑。
前端使用nodejs 开发,用gulp 编译。使用ES6,+angular 开发。
要搭建一个简单的paas 平台的话,需要研究 kubernetes api。
底层的东西修改的很少主要是做应用写自己的业务逻辑。
gin-k8s 运行的问题的更多相关文章
- k8s运行容器之Job(四)--技术流ken
Job 容器按照持续运行的时间可分为两类:服务类容器和工作类容器. 服务类容器通常持续提供服务,需要一直运行,比如 http server,daemon 等.工作类容器则是一次性任务,比如批处理程序, ...
- k8s运行容器之deployment(三)--技术流ken
deployment 我们已经知道k8s是通过各种controller来管理pod的生命周期.为了满足不同业务场景,k8s开发了Deployment.ReplicaSet.DaemonSet.Stat ...
- K8s运行dashboard命令启动报错:"no endpoints available for service \"kubernetes-dashboard\""
今天启动k8s dashboard的时候报错:"no endpoints available for service \"kubernetes-dashboard\"&q ...
- k8s运行容器之Job(四)
Job 容器按照持续运行的时间可分为两类:服务类容器和工作类容器. 服务类容器通常持续提供服务,需要一直运行,比如 http server,daemon 等.工作类容器则是一次性任务,比如批处理程序, ...
- k8s运行容器之deployment(三)
deployment 我们已经知道k8s是通过各种controller来管理pod的生命周期.为了满足不同业务场景,k8s开发了Deployment.ReplicaSet.DaemonSet.Stat ...
- k8s运行容器之Job应用(6)
容器按照持续运行的时间可分为两类:服务类容器和工作类容器. 服务类容器通常持续提供服务,需要一直运行,比如 http server,daemon 等.工作类容器则是一次性任务,比如批处理程序,完成后容 ...
- Dapr + .NET Core实战(十-终篇)K8S运行Dapr
工作原理 为了实现在k8s上安装Dapr,Dapr需要部署dapr-sidecar-injector.dapr-operator.dapr-placement和dapr-sentry服务. dapr- ...
- gin中运行多个服务
运行服务的返回类型为 :http.Handler .gin.New(),gin.Default() 返回的就是此类型.使用&http.Server{....} 设置服务参数使用g.Go(fun ...
- 用 k8s 运行一次性任务 - 每天5分钟玩转 Docker 容器技术(132)
容器按照持续运行的时间可分为两类:服务类容器和工作类容器. 服务类容器通常持续提供服务,需要一直运行,比如 http server,daemon 等.工作类容器则是一次性任务,比如批处理程序,完成后容 ...
- k8s 运行应用
一.deployment 创建过程 kubect创建deployment —> deployment 创建ReplicaSet—>根据ReplicaSet 创建Pod 命名方式 relic ...
随机推荐
- c语言_二叉树的建立以及3种递归
二叉树c语言的实现 二叉树的建立 二叉树的数据结构 typedef struct node{ int data; struct node* left; struct node* ri ...
- 手写tomcat——概述
1. 使用java 编写一个echo http服务器 使用java 编写一个echo http服务器 https://github.com/ZhongJinHacker/diy-tomcat/tree ...
- 以软件定义物联网芯片,以技术融合推动LPWAN2.0泛在物联
作为数字化产业重要的基础设施之一,物联网迎来了黄金发展期.物联网通信技术通过数据的采集.分析.输出,从浅层次的互联工具和产品深化,到成为重塑生产组织方式的基础设施和关键要素,正深刻地改变着传统产业形态 ...
- Typora Markdown 安装包
下载地址: 链接:https://pan.baidu.com/s/1wy0Ik95AjM5WjSC3nzOzqA 提取码:f26j 复制这段内容后打开百度网盘手机App,操作更方便哦 已更新至最新版0 ...
- CI/CD集成
文章转载自:https://kuboard.cn/guide/cicd/ 下图展示了当前比较典型的持续构建集成的一种做法. 在是否自动将最新版本部署到 Kubernetes 环境这个问题上,可能会有多 ...
- 使用Elasticsearch的processors来对csv格式数据进行解析
来源数据是一个csv文件,具体内容如下图所示: 导入数据到es中 有两种办法,第一种是在kibana界面直接上传文件导入 第二种方法是使用filebeat读取文件导入 这里采用第二种办法 配置文件名: ...
- Prometheus监控Nginx
转载自:https://www.cnblogs.com/you-men/p/13173245.html CentOS7.3 prometheus-2.2.1.linux-amd64.tar.gz ng ...
- CentOS系统一键部署jdk,maven,tomcat,mysql
#!/bin/bash ####使用方法############### # chmod a+x JdTomK-Auto.sh # source JdTomK-Auto.sh ############# ...
- 安装jumpserver 2.1.2版本遇到的坑
官方文档地址:https://docs.jumpserver.org/zh/master/install/step_by_step/ Jumpserver 对外需要开放 80 和 2222 端口,如果 ...
- cf1082 A. Vasya and Book
中文题意: 思路:我们先看看能不能直接从x翻到y,abs(y-x)%d==0,可以就直接输出abs(y-x)/d咯,不行的话之后有2种操作 1.先翻回到第一页,从第一页看看能不能范到y,不能的话翻到最 ...