Icehouse resize No valid host was found

Hi all!!

We're currently experimenting an error that's it's pretty weird, the reason
it's that with another user same base image and same flavor we can resize
the instance but with another user with the same base image we cannot with
this error on the logs:

2015-04-21 22:03:37.700 4047516 WARNING nova.scheduler.utils
[req-19a28c0f-ac5e-488b-8722-59135496f8e4 70886ff6b1434e0db5ddefa6180916f8
361f01feb5564973bcffe0a1d75ec795] Failed to compute_task_migrate_server: No
valid host was found.
Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/server.py",
line 139, in inner
return func(*args, **kwargs)

File "/usr/lib/python2.7/dist-packages/nova/scheduler/manager.py", line
298, in select_destinations
filter_properties)

File
"/usr/lib/python2.7/dist-packages/nova/scheduler/filter_scheduler.py", line
140, in select_destinations
raise exception.NoValidHost(reason='')

NoValidHost: No valid host was found.

In case that someone ask this options are already on all the nodes and the
controller:

allow_resize_to_same_host=True
allow_migrate_to_same_host=True

Boths are in the default section, as I said before the resize can be done
with other instances and with and instances with the same specs.

On the other hand we tried with both cli and dashboard and both user with
enought quota to do the resize and with all the nodes with ram and cpu for
the instance, as a said we already did it with an instance with the same
flavor, can anyone point us on how to do a more deep debug or any advice
about how to handle the error to do a the resize?

Thanks in advance

jonathan.abdiel at gmail

Apr 21, 2015, 7:54 PM

Post #2 of 2
(464 views)

Permalink

Re: Icehouse resize No valid host was found
[In reply to]


Hi George,

We already did that we try the resize with an instance on the same node and
did the resize succesfully without troubles but with the instance with the
problem it didn't work, we're already working with debug=True and
verbose=True and nothings shows up.

We're now trying modifying the .xml file by hand but doesn't look like a
good solutions

On Tue, Apr 21, 2015 at 11:46 PM George Mihaiescu <lmihaiescu [at] gmail>
wrote:

> Hi Jonathan,
>
> The compute node where the instance that fails to resize is hosted must
> have a different config than the others.
> To confirm this theory, find another instance that runs on that host and
> initiate a resize as the user who owns that instance and it will probably
> fail as well.
>
> Enabling debug and verbose in nova.conf and restarting the services on
> that host before trying should give enough info in the nova-compute.log
> about the cause of the failure.
>
> George
>
> On Tue, Apr 21, 2015 at 10:23 PM, Jonathan Abdiel Gonzalez Valdebenito <
> jonathan.abdiel [at] gmail> wrote:
>
>> Hi all!!
>>
>> We're currently experimenting an error that's it's pretty weird, the
>> reason it's that with another user same base image and same flavor we can
>> resize the instance but with another user with the same base image we
>> cannot with this error on the logs:
>>
>> 2015-04-21 22:03:37.700 4047516 WARNING nova.scheduler.utils
>> [req-19a28c0f-ac5e-488b-8722-59135496f8e4 70886ff6b1434e0db5ddefa6180916f8
>> 361f01feb5564973bcffe0a1d75ec795] Failed to compute_task_migrate_server: No
>> valid host was found.
>> Traceback (most recent call last):
>>
>> File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/server.py",
>> line 139, in inner
>> return func(*args, **kwargs)
>>
>> File "/usr/lib/python2.7/dist-packages/nova/scheduler/manager.py", line
>> 298, in select_destinations
>> filter_properties)
>>
>> File
>> "/usr/lib/python2.7/dist-packages/nova/scheduler/filter_scheduler.py", line
>> 140, in select_destinations
>> raise exception.NoValidHost(reason='')
>>
>> NoValidHost: No valid host was found.
>>
>>
>> In case that someone ask this options are already on all the nodes and
>> the controller:
>>
>> allow_resize_to_same_host=True
>> allow_migrate_to_same_host=True
>>
>> Boths are in the default section, as I said before the resize can be done
>> with other instances and with and instances with the same specs.
>>
>> On the other hand we tried with both cli and dashboard and both user with
>> enought quota to do the resize and with all the nodes with ram and cpu for
>> the instance, as a said we already did it with an instance with the same
>> flavor, can anyone point us on how to do a more deep debug or any advice
>> about how to handle the error to do a the resize?
>>
>>
>> Thanks in advance
>>
>>
>> _______________________________________________
>> Mailing list:
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
>> Post to : openstack [at] lists
>> Unsubscribe :
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
>>
>>
>

openstack instance resize to的更多相关文章

  1. openstack instance resize Resize error: Unable to resize disk down

  2. openstack instance resize

    Error: No valid host was found. No valid host found for resize

  3. openstack instance resize to rebuild

  4. OpenStack的Resize和冷迁移代码解析及改进

    原文:http://www.hengtianyun.com/download-show-id-79.html OpenStack的Resize(升级)功能,我们可以改变虚拟机的CPU核数.内存及磁盘大 ...

  5. openStack 重新resize时会进行重新调度,可能在本机Resize 扩展资源,也可能存在的情况时 ,新扩展的资源在当前节点不足分配,整个虚拟机将进行迁移调度,进行异机迁移时需要迁移 的两台主机间能使用nova系统用户经passless登录

    openStack 重新resize时会进行重新调度,可能在本机Resize 扩展资源,也可能存在的情况时 ,新扩展的资源在当前节点不足分配,整个虚拟机将进行迁移调度,进行异机迁移时需要迁移 的两台主 ...

  6. openstack instance snapshort

    从下面的截图 高手应该能够看到openstack基于snapshort的 实例的 备份策略了!!!! 从下面某张截图你也能看到用openstack snapshort备份 也是 不太理想的,首先从“磁 ...

  7. openStack instance error 恢复

    cli command下加载openstack超级管理员权限 重设openStack 虚拟机error实例状态即可 nova reset-state instance-id --active

  8. openstack instance change storage dir

    在云计算openstack中以为新建的虚拟机都存放在/var/lib/nova/instances中,在新建虚拟机时内存当然不够用,所以可以将nova转移到新的存储位置 以下操作只在计算节点上进行 一 ...

  9. openstack instance bootmgr is missing 问题 修复

随机推荐

  1. 面向对象程序设计--Java语言第三周编程题:查找里程

    查找里程 题目内容: 下图为国内主要城市之间的公路里程: 你的程序要读入这样的一张表,然后,根据输入的两个城市的名称,给出这两个城市之间的里程. 注意:任何两个城市之间的里程都已经给出,不需要计算经第 ...

  2. 话说Form标签的target属性-----无刷新表单提交

    国庆前(2013)无聊,就在铁道部的12306上“逛”了下下. PS:原来之所以叫12306,是因为其客服号码是12306,好吧,我很无知…… 首先是被“逛”的页面:票价查询. 之所以去逛,是因为一直 ...

  3. [USACO06JAN] 冗余路径 Redundant Paths

    题目描述 In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1. ...

  4. sql常用的命令

    SELECT NAME, database_id,create_date 创建时间,is_auto_shrink_on 自动收缩,state_desc 状态,recovery_model_desc 恢 ...

  5. Libreswan软件的密钥协商协议IKEv1主模式实现分析

    Libreswan软件的密钥协商协议IKEv1主模式实现分析 1 协商过程 IKEv1(互联网密钥交换协议第一版)是IPsec VPN隧道协商使用的标准密钥协商协议,其协商过程如下图所示. 总共来回交 ...

  6. [bzoj1042][HAOI2008][硬币购物] (容斥原理+递推)

    Description 硬币购物一共有4种硬币.面值分别为c1,c2,c3,c4.某人去商店买东西,去了tot次.每次带di枚ci硬币,买si的价值的东西.请问每次有多少种付款方法. Input 第一 ...

  7. [bzoj1966][Ahoi2005][VIRUS 病毒检测] (字符串dp)

    Description 科学家们在Samuel星球上的探险仍在继续.非常幸运的,在Samuel星球的南极附近,探险机器人发现了一个巨大的冰湖!机器人在这个冰湖中搜集到了许多RNA片段运回了实验基地.科 ...

  8. redis学习——数据类型

    一.内容简介 Redis不仅仅是简单的key-value 存储器,同时也是一种data structures server.传统的key-value是指支持使用一个key字符串来索引value字符串的 ...

  9. Shiro_DelegatingFilterProxy

    1.DelegatingFilterProxy实际上是Filter的一个代理对象.默认情况下,Spring会到IOC容器中查找与<filter-name>对应的filter bean.也可 ...

  10. 强连通图 HDU - 1269

    为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以 ...