升级步骤:

(1)    备份数据库

(2)    运行patchset,升级oracle 软件

(3)    准备新的ORACLE_HOME

(4)    运行dbua 或者脚本升级实例

(5)    检查升级后的版本信息和无效对象

备份数据库

升级数据库是一个十分危险的事情,在生产库上,升级之前最好做一个全库的备份,以便在升级失败时可以还原数据库。

停掉所有与这个数据库相关的业务系统,如中间件。确定没有业务在运行。在数据库正常关闭后,还需要备份Oracle主目录,目的还是为了升级失败时,能够还原出数据库软件到升级前的版本。备份如下:tar -xcvf oracle11201_bak.tar.gz $ORACLE_BASE。

我这里是测试环境,就不进行备份,如果是生产环境,切记要先备份,后操作。

如果是In-Place Upgrade,同时备份一下整个ORACLE_HOME目录。 如果升级有问题,还可以还原回来。

重点是如下目录:

ORACLE_HOME/dbs

ORACLE_HOME/network/admin

ORACLE_HOME/hostname_dbname

ORACLE_HOME/oc4j/j2ee/OC4J_DBConsole_hostname_dbname

授权:

chmod 777 p13390677_112040_Linux-x86-64_* p20996923_112040_Linux-x86-64.zip p6880880_112000_Linux-x86-64.zip

一、原始状态

(点小图查看大图)

SQL>set linesize 150

SQL>set pagesize 9999

SQL> col comp_name format a40

SQL> SELECT COMP_NAME, VERSION, STATUS FROM SYS.DBA_REGISTRY;

(点小图查看大图)

关闭监听、关闭数据实例

二、把所有补丁软件都拷贝到/tmp,补丁包一共7个,只需要前2个就成

解压:unzip p13390677_112040_Linux-x86-64_1of7.zip -d /tmp && unzip p13390677_112040_Linux-x86-64_2of7.zip -d /tmp

cd /tmp/database

运行Patchset 的runInstaller

(点小图查看大图)

(点小图查看大图)

注意这里,我们选择第三个选项,skip software update,因为我们的patchset已经下载过了,如果选择第二个选项,会遇到如下错误,

INS-20704 Thelocation provided is not in the expected directory structure

Oracle 给的解决方式是用如下命令来执行:

./runInstaller –downloadUpdates

但是这个命令需要收费的Metalink帐号。 MOS 的相关文档:

How To Download The Latest Updates AndPatches Using 11.2.0.2 OUI [ID 1295074.1]

Error: INS-20704 While Installing 11.2.0.2with "Use pre-downloaded software updates" Option [ID 1265270.1]

(点小图查看大图)

这里要注意,我们之前讲过11gR2的Patchset 可以直接用来安装。在这个界面就可以选择操作类型,这个功能比较方便,从而也导致patchset 越来越大,我们这里选择upgrade an existing database。

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

注意这里的安装位置,我之前的安装目录是11.2.0,我新目录是11.2.0.4 即将oracle 安装到其他位置,这样可以减少宕机时间,也是oracle 推荐的方法。

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

执行到76%的时候弹出如下窗口:

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

下面就是一个配置监听的过程

(点小图查看大图)

随后就是 会自动调用DBUA 来升级我们的实例(1---7步)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

(点小图查看大图)

三、然后,再修改oracle用户的.bash_profile

ORACLE_HOME=$ORACLE_BASE/product/11.2.0.4/db_1

然后source ~/.bash_profile

四、查看 cat /etc/oratab   【内容应该是新目录】

五、登录查看,升级后版本

[oracle@DB200 ~]$ sqlplus / as sysdba

SQL*Plus: Release 11.2.0.1.0 Production on Mon May 25 22:00:21 2015

Copyright (c) 1982, 2009, Oracle.  All rights reserved.

Connected to:

Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production

With the Partitioning, OLAP, Data Mining and Real Application Testing options

六、11.2.0.4.0升级到11.2.0.4.7(打patch,关闭实例与监听)

1、解压安装包
自定义存放路径为/home/oracle/psu
cd /home/oracle/psu
mv p6880880_112000_04-SEP-2015_Linux-x86-64.zip p20760997_112030_15_Linux-x86-64.zip /home/oracle/psu
unzip p6880880_112000_04-SEP-2015_Linux-x86-64.zip
unzip p20760997_112030_15_Linux-x86-64.zip -d 112047

2、检查psu补丁是否有冲突
/home/oracle/psu/OPatch/opatch prereq CheckConflictAgainstOHWithDetail -phBaseDir /home/oracle/psu/112047/20996923

3、信息收集
--查看组件信息
set linesize 500 pagesize 600
col COMP_NAME for a30
select COMP_ID,COMP_NAME,VERSION,STATUS from DBA_REGISTRY;
--查看补丁情况
set linesize 500 pagesize 600
col ACTION_TIME for a30
col COMMENTS for a30
select ACTION_TIME, ACTION, COMMENTS from sys.DBA_REGISTRY_HISTORY;
--查看无效对象
select count(*) from dba_objects where status<>'VALID';

4、停止数据库
--停止数据库外部进程
ps -ef|grep -v grep |grep LOCAL=NO|awk '{print $2}'|xargs kill -9
--停库
alter system checkpoint
shutdown immediate
--停监听
lsnrctl stop

--查看启停日志
/home/oracle/diag/rdbms/sccp/sccp/trace/alert*.log

5、备份
使用root用户备份oracle_home (将#ORACLE_HOME上级目录整个备份)
tar -zcvpf db_20151103.tar.gz db_1

6、打PSU
su - oracle
cd /home/oracle/psu/112047/20996923/20760982 ---20760982为压缩包解压出的二级目录(不进入该目录apply会报错)
/home/oracle/psu/OPatch/opatch apply

----如果补丁过程中出现以下错误
OPatch报错 Prerequisite check "CheckActiveFilesAndExecutables" failed
Following executables are active :
/opt/oracle/product/10.2.0/bin/oracle
ApplySession failed during prerequisite checks: Prerequisite check "CheckActiveFilesAndExecutables" failed.

通过以下命令找到正在占用文件的进程,然后kill进程
fuser /opt/oracle/product/10.2.0/bin/oracle

7、检查数据库
su – oracle
$ORACLE_HOME/OPatch/opatch lsinv

8、更新数据字典、编译失效对象
su - oracle
cd $ORACLE_HOME/rdbms/admin
SQL> CONNECT / AS SYSDBA
SQL> STARTUP
SQL> @catbundle.sql psu apply
SQL> @utlrp.sql

9、重启数据库
shutdown immediate
startup

10、检查数据库状态
--查看组件信息
set linesize 500 pagesize 600
col COMP_NAME for a30
select COMP_ID,COMP_NAME,VERSION,STATUS from DBA_REGISTRY;
--查看补丁情况
set linesize 500 pagesize 600
col ACTION_TIME for a30
col COMMENTS for a30
select ACTION_TIME, ACTION, COMMENTS from sys.DBA_REGISTRY_HISTORY;
--查看无效对象
select count(*) from dba_objects where status<>'VALID';

11、启动监听
lsnrctl start
ps -ef|grep -v grep |grep LOCAL=NO|wc -l
SQL> CONNECT / AS SYSDBA
SQL>alter system register;

若监听启动失败
cd $ORACLE_HOME/network/admin
mv sqlnet.ora sqlnet.orabak
lsnrctl start
ps -ef|grep -v grep |grep LOCAL=NO|wc -l
SQL> CONNECT / AS SYSDBA
SQL>alter system regiter
SQL>exit
mv sqlnet.orabak sqlnet.ora

七、实验中遇到的报错

1、----如果补丁过程中出现以下错误
OPatch报错 Prerequisite check "CheckActiveFilesAndExecutables" failed
Following executables are active :
/opt/oracle/product/10.2.0.4/bin/oracle
ApplySession failed during prerequisite checks: Prerequisite check "CheckActiveFilesAndExecutables" failed.

通过以下命令找到正在占用文件的进程,然后kill进程
fuser /opt/oracle/product/10.2.0.4/bin/oracle

2、INS-32025报错
the chosen installation conflicted with software already installed in the given Oracle home.
所选安装与指定 Oracle 主目录中已安装的软件冲突

解决方法:
vi /home/oracle/oraInventory/ContentsXML/inventory.xml

[root@db 桌面]# more /home/oracle/oraInventory/ContentsXML/inventory.xml
<?xml version="1.0" standalone="yes" ?>
<!-- Copyright (c) 1999, 2013, Oracle and/or its affiliates.
All rights reserved. -->
<!-- Do not modify the contents of this file by hand. -->
<INVENTORY>
<VERSION_INFO>
<SAVED_WITH>11.2.0.4.0</SAVED_WITH>
<MINIMUM_VER>2.1.0.6.0</MINIMUM_VER>
</VERSION_INFO>
<HOME_LIST>
<HOME NAME="OraDb11g_home1" LOC="/home/oracle/app/oracle/product/11.2.0/dbhome_1
" TYPE="O" IDX="1"/>
</HOME_LIST>
<COMPOSITEHOME_LIST>
</COMPOSITEHOME_LIST>
</INVENTORY>
[root@db 桌面]#

删除其中的HOME_NAME信息
<HOME NAME="OraDb11g_home1" LOC="/home/oracle/app/oracle/product/11.2.0/dbhome_1
" TYPE="O" IDX="1"/>

三、ORA-00845: MEMORY_TARGET not supported on this system报错解决
在oracle 11g中新增的内存自动管理的参数MEMORY_TARGET,它能自动调整SGA和PGA,这个特性需要用到/dev/shm共享文件系统,而且要求/dev/shm必须大于MEMORY_TARGET,如果/dev/shm比MEMORY_TARGET小就会报错
解决方案

1.初始化参数MEMORY_TARGET或MEMORY_MAX_TARGET不能大于共享内存(/dev/shm),为了解决这个问题,可以增大/dev/shm

如:

# mount -t tmpfs shmfs -o size=7g /dev/shm

2.为了确保操作系统重启之后能生效,需要修改/etc/fstab文件

shmfs /dev/shm tmpfs size=7g 0

3.如果/dev/shm没有挂载也会报上面的错,所认需要确保已经挂载

oracle@aaaprod-db ~]$ df -h

……

tmpfs 16G 8.9G 7.2G 56% /dev/shm

……

oracle 11.2.0.1.0 升级 11.2.0.4.0 并 patch 到11.2.0.4.7的更多相关文章

  1. CENTOS 6.4 安装oracle 10g,手工建库及升级到10.2.0.5

    一. 数据库软件安装 参照官方手册 1.安装rpm包 注这里的yum直接用163的yum yum -y install binutils compat-libstdc++-33 compat-libs ...

  2. oracle数据库psu升级(本实验是将10.2.0.3.12升级到10.2.0.3.15)

    psu升级(本实验是将10.2.0.3.12升级到10.2.0.3.15) 一.解压安装包自定义存放路径为/home/oracle/yjb/psu/10.2.0.3.15cd /home/oracle ...

  3. Nginx1.8.0版本平滑升级新版本1.9.7

    原文:http://www.jb51.net/article/79878.htm 首先查看现在环境nginx的版本为1.8.0 编译的参数只指定了安装路径: 复制代码代码如下: [root@local ...

  4. 07 oracle 归档模式 inactive/current redo log损坏修复--以及错误ORA-00600: internal error code, arguments: [2663], [0], [9710724], [0], [9711142], [], [], [], [], [], [], []

    07 oracle 归档模式 inactive/current redo log损坏修复--以及错误ORA-00600: internal error code, arguments: [2663], ...

  5. 关于把.net 2.0的项目升级到.net4.0遇到的一些问题

    进入公司实习的的第一个项目又是是一个升级项目.这次升级的是一个c/s架构的项目. 大致介绍一下这个项目的结构客户端采用winform+devexpress商业控件开发的,数据库是用的oracle数据库 ...

  6. CMS .NET 程序框架 从2.0/3.5升级到4.0 版本后 需要调整的地方

    问题一: document.forms1.action 不可使用 需要修改程 document.forms[0] .NET 程序框架 从2.0/3.5升级到4.0 版本后,document.forms ...

  7. Android7.0 应用内升级

    Android7.0应用内升级 最近线上项目在7.0机器上出现应用内升级失败,原来是由于Android7.0权限问题导致. 如果项目的 targetSdkVersion>=24 在处理应用内升级 ...

  8. [Oracle维护工程师手记]一次升级后运行变慢的分析

    客户报告,当他从 Oracle 11.1.0.7 ,迁移到云环境,并且升级到12.1.0.2.运行客户的应用程序测试,发现比以前更慢了. 从AWR report 的"Top 10 Foreg ...

  9. 所使用的“EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”版本高于所引用的程序集“EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089”的版本

    错误信息:所使用的"EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089&qu ...

随机推荐

  1. 效率神器-uTools推荐和使用

    提高办公开发效率...非常好用  功能很多很全,官网:https://u.tools/ 文档:https://u.tools/docs/guide/about-uTools.html

  2. Llbp2p是什么?

    这是个很好的问题.用一句话来概况就是libp2p是一个模块化的协议系统,它的规范和程序库可以用来开发p2p网络应用程序. 对等节点基础 对于我们对libp2p在上面的概要描述有很多内容需要进一步解释, ...

  3. vue functional函数式组件

    第1种写法 test.vue <template functional> <div class="test"> {{props.test.name}} &l ...

  4. 如何实现OSM地图本地发布并自定义配图

    目录 1.缘起 2.准备环境 2.1.安装linux系统 2.2.安装docker 2.3.安装Docker Compose 2.4.安装git 3.发布地图 3.1.拉取代码 3.2.测试网络 3. ...

  5. AcWing 326. XOR和路径

    大型补档计划 题目链接 如果整体来做,发现既有加法,也有整体异或,这样不容易搞. 考虑异或,各个位置互不干扰,按位考虑一下. 枚举每一位 \(k\) 发现如果设 \(f[u]\) 为这一位的期望结果还 ...

  6. Java并发编程的艺术(九)——闭锁、同步屏障和信号量

    闭锁:CountDownLatch 使用场景 当前线程需要等待若干条线程执行完毕后,才能继续执行的情况. 也可以是若干个步骤执行完毕后的情况. 使用方法 初始化闭锁的时候,填入计数值,然后等待其他线程 ...

  7. Emlog整站搬家教程

    之前使用的服务器空间到期,不想再续费,所以就打算更换服务器,购买新的服务器之后不知道怎么把EM程序转移到新的服务器上面,所以东查查西查查,终于找到了一个既简单又方便的搬家方法,分享给大家.步骤开始:1 ...

  8. Qingcloud_MySQL Plus(Xenon) 高可用搭建实验

    实验:Xenon on 5.7.30 Xenon (MySQL Plus) 是青云Qingcloud的一个开源项目,号称金融级别强一致性的高可用解决方案,项目地址为 https://github.co ...

  9. 四、Jmeter安装插件

    Jmeter安装插件方法和使用 1-下载Jmeter管理jar包 下载地址:https://jmeter-plugins.org/install/Install/ 2-点击下载 plugins-man ...

  10. JavaSE17-File&递归&字节流

    1.File类 1.1 File类概述和构造方法 File类介绍 它是文件和目录路径名的抽象表示 文件和目录是可以通过File封装成对象的 对于File而言,其封装的并不是一个真正存在的文件,仅仅是一 ...