手贱的回忆录 --- L版openrc密码修改(OS_PASSWORD)
---恢复内容开始---
刚刚部署完L版,发现默认登录的管理员账号在41、42、43的openrc文件中,登录名是admin,登录密码却是一串随机码,于是想修改一个简单易记的密码,手贱的把OS_PASSWORD修改为了Abcd1234,三个API节点都这么搞了一下,然后就杯具了,从此无法登录页面,且没有admin权限做任何补救操作,后经成坤操作,问题被瞬秒,以下为操作过程,供参考:
登录到41节点,打开openrc文件,注销掉Rescue model之上的所有内容,仅留下以下内容:
export OS_SERVICE_TOKEN="6f3d8875d6efcf42a159bd67"
export OS_SERVICE_ENDPOINT=http://lb.151.zxzx.uopenstack.in:35357/v3
这是针对忘记密码等的抢救模式,但是对于L版,这个还不OK,因为这个是对应的keystone V2版本的配置,目前我们的L版已经是V3版本了,所以要修改成如下的样子:
export OS_TOKEN="6f3d8875d6efcf42a159bd67"
export OS_URL=http://lb.151.zxzx.uopenstack.in:35357/v3
export OS_IDENTITY_API_VERSION=3
改完之后,保存退出。
继续在41节点上操作:
env | grep OS
可以看到以下两个之前的环境变量:
OS_SERVICE_TOKEN="6f3d8875d6efcf42a159bd67"
OS_SERVICE_ENDPOINT=http://lb.151.zxzx.uopenstack.in:35357/v3
然后执行以下命令把他们unset了:
unset OS_SERVICE_TOKEN
unset OS_SERVICE_ENDPOINT
然后依次执行以下命令,开始重置admin登录密码之旅:
#初始化环境变量
source openrc
#看看admin用户在没
openstack user list
#重置密码,其中Abcd1234是我的新密码,admin是上一步看到的要改密码的用户名
openstack user set --password Abcd1234 admin
行了,到这儿,可以用admin和Abcd1234登录openstack的面板了,但是这只能临时变更,过段时间仍会变回之前的密码,如果之前的密码找不到了,首先可以到41、42、43任何一个节点上的openrc文件中去找,另外,也可以到部署运维节点上的/etc/puppet/hieradata/151.zxzx.uopenstack.in/common/目录下,找到api.yaml文件,找到里面的api.yaml:keystone::roles::admin::password:位置,这里就是原来的密码了,不要尝试修改,建议新建一个用户,赋予admin权限即可,因为需要修改的地方过多,容易出错。
api.yaml:keystone::roles::admin::password: '6f3d8875d6efcf42a159bd67'
api.yaml:glance::api::keystone_password: '6f3d8875d6efcf42a159bd67'
api.yaml:glance::registry::keystone_password: '6f3d8875d6efcf42a159bd67'
api.yaml:glance::keystone::auth::password: '6f3d8875d6efcf42a159bd67'
api.yaml:cinder::api::keystone_password: '6f3d8875d6efcf42a159bd67'
api.yaml:cinder::keystone::auth::password: '6f3d8875d6efcf42a159bd67'
api.yaml:nova::keystone::auth::password: '6f3d8875d6efcf42a159bd67'
api.yaml:nova::api::admin_password: '6f3d8875d6efcf42a159bd67'
api.yaml:nova::api::neutron_metadata_proxy_shared_secret: '6f3d8875d6efcf42a159bd67'
api.yaml: value: '6f3d8875d6efcf42a159bd67'
api.yaml:nova::network::neutron::neutron_admin_password: '6f3d8875d6efcf42a159bd67'
api.yaml:sunfire::compute::neutron_metadata_proxy_shared_secret: '6f3d8875d6efcf42a159bd67'
api.yaml: value: '6f3d8875d6efcf42a159bd67'
api.yaml:neutron::keystone::auth::password: '6f3d8875d6efcf42a159bd67'
api.yaml:neutron::server::auth_password: '6f3d8875d6efcf42a159bd67'
api.yaml:neutron::server::notifications::nova_admin_password: '6f3d8875d6efcf42a159bd67'
api.yaml:neutron::agents::metadata::auth_password: '6f3d8875d6efcf42a159bd67'
api.yaml:neutron::agents::metadata::shared_secret: '6f3d8875d6efcf42a159bd67'
api.yaml:horizon::secret_key: '6f3d8875d6efcf42a159bd67'
api.yaml:heat::keystone_password: '6f3d8875d6efcf42a159bd67'
api.yaml:heat::keystone::auth::password: '6f3d8875d6efcf42a159bd67'
api.yaml:heat::keystone::auth_cfn::password: '6f3d8875d6efcf42a159bd67'
api.yaml:heat::keystone::domain::domain_password: '6f3d8875d6efcf42a159bd67'
---恢复内容结束---
手贱的回忆录 --- L版openrc密码修改(OS_PASSWORD)的更多相关文章
- 手贱随手在Linux敲了 as 命令,出不来了
手贱随手在Linux敲了 as 命令,出不了命令,问问度娘吧,得到下列资料 as命令 GNU组织推出的一款汇编语言编译器,它支持多种不同类型的处理器.语法as(选项)(参数)选项-ac:忽略失败条 ...
- 脑残手贱:被NFS祸害的调度系统
建议:任何时候,都要三思而后行!!! 事请的缘由 系统中采用slurm调度系统来进行并行计算.但是在GPU节点上,无论如何都无法启动slurmd,报插件初始化错误的故障. 因此需要编译新的munge和 ...
- mySQL 5.7版 解决密码登录失败Access denied for user 'root'@'localhost' (us
mySQL 5.7版 解决密码登录失败Access denied for user 'root'@'localhost' (us 2016-03-05 ...
- 手写一套迷你版HTTP服务器
本文主要介绍如何通过netty来手写一套简单版的HTTP服务器,同时将关于netty的许多细小知识点进行了串联,用于巩固和提升对于netty框架的掌握程度. 服务器运行效果 服务器支持对静态文件css ...
- zencart1.5.x版管理员密码90天到期后台进入不了的解决办法
zencart1.5.x版管理员密码90天到期后如果不想更改密码,可以直接在数据库运行以下sql语句. 将pwd_last_change_date(密码最后变换日期)2014-11-11 11:11: ...
- MNIST手写数字分类simple版(03-2)
simple版本nn模型 训练手写数字处理 MNIST_data数据 百度网盘链接:https://pan.baidu.com/s/19lhmrts-vz0-w5wv2A97gg 提取码:cgnx ...
- Git操作文件的时候手贱了,怎么恢复?
我们在使用git的过程当中很难避免的一点就是手贱,因为人嘛总有犯错疏忽的时候,有时候一不小心就操作错了.我也经常遇到这种情况,所以这时候对git的了解和掌握就非常重要,即使操作错了,我们也可以通过gi ...
- 最新Ceph L版与openstack Pike对接
安装Ceph luminous 实验环境 三台服务器,每台服务器都有4块硬盘,每台服务器都将自己的第一块硬盘作为系统盘,剩下的做ceph 一.在所有服务器上操作 #使用阿里源 yum inst ...
- SharePoint中修改密码的WEB Part之终极版:即可以修改AD,又可以修改本机用户密码的Web Part!!
转:http://www.cnblogs.com/dosboy/archive/2007/08/01/838859.html 在网上查了那么多SharePoint密码修改的第三方开发,都有问题.总结下 ...
随机推荐
- shell在一个大文件找出想要的一段字符串操作技巧
昨天端午,晚上的时候接了一个电话,我朋友的公司,数据库被两个工作没多久的phper给弄坏了,具体就是把一个字段值,给全表弄成一个了名字了,当然这个是可以配置了禁止全表更新数据库,这下可急坏了,找到我, ...
- CentOS上安装man手册
我的CentOS采用的是minimal方式安装的,学会遇到命令找不到的问题.今天我遇到的是,查找命令相关的man手册时,显示:通过查看CentOS iso, 我发现了man-pages这个rpm包.装 ...
- convert与int.parse int
1,convert :适合将object 转换 int:简单数据转换 int.parse:将string类型转换为int 2,convert:对于空值返回0 不会报异常 int.parse:将会抛出异 ...
- POMDP
本文转自:http://www.pomdp.org/ 一.Background on POMDPs We assume that the reader is familiar with the val ...
- 安卓中級教程(7):annotation中的 public @interface的用法
package com.example.ele_me.util; import java.lang.annotation.Retention; import java.lang.annotation. ...
- Google Gson 使用简介
http://www.cnblogs.com/haippy/archive/2012/05/20/2509329.html
- SQL SERVER 查询表或字段在哪里使用过
select b.name from dbo.syscomments a, dbo.sysobjects b where a.id=b.id and b.xtype='p' and a.text li ...
- 分享一个oraclehelper
分享一个拿即用的oraclehelper 首先要引用本机中的oralce access,如果是64位的话,也必须是64位运行,不然会报连接为空connection 等于null. using Orac ...
- Elasticsearch 运维实战之1 -- 集群规划
规划一个可用于生产环境的elasticsearch集群. 集群节点划分 整个集群的节点分为以下三种主要类型 Master nodes -- 负责维护集群状态,不保存index数据, 硬件要求: 一般性 ...
- Ubuntu ./configure 半途终止 导致没有生成makefile文件 解决方法
在安装thrift的时候,解压包进入目录,执行命令: ./configure 之后,发现某些包没有安装,导致configure到一半的时候退出,接着make发现没有makefile文件.估计是我系统安 ...