Linux iptables配置错误导致ORA-12535 & ORA-12170
实验环境:
操作系统 : Red Hat Enterprise Linux Server release 5.7 (Tikanga)
数据库版本: Oracle Database 12c Release 12.1.0.1.0 - 64bit Production
前两天在服务器上安装了ORACLE 12c后,从客户端连接到数据库的时候,出现ORA-12170错误,由于以前在博客的ORA-12170:TNS:连接超时总结过这个问题,所以很快定位到是防火墙问题,于是编辑iptables,开放1521端口,然后重新启动防火墙
-A RH-Firewall-1-INPUT -p tcp -m state --state NEW -m tcp --dport 1521 -j ACCEPT
但是依然没有解决问题,于是有重新检查各项:ping、listener.ora、 tnsnames.ora等配置都OK,tnsping报ORA-12535错误,于是我再次确认防火墙是否开启了1521端口,如下所示,
[root@getoraclelnx01 sysconfig]# iptables -L -n Chain INPUT (policy ACCEPT) target prot opt source destination RH-Firewall--INPUT all -- 0.0.0.0/ 0.0.0.0/ Chain FORWARD (policy ACCEPT) target prot opt source destination RH-Firewall--INPUT all -- 0.0.0.0/ 0.0.0.0/ Chain OUTPUT (policy ACCEPT) target prot opt source destination Chain RH-Firewall--INPUT ( references) target prot opt source destination ACCEPT all -- 0.0.0.0/ 0.0.0.0/ ACCEPT icmp -- 0.0.0.0/ 0.0.0.0/ icmp type ACCEPT esp -- 0.0.0.0/ 0.0.0.0/ ACCEPT ah -- 0.0.0.0/ 0.0.0.0/ ACCEPT udp -- 0.0.0.0/ 224.0.0.251 udp dpt: ACCEPT udp -- 0.0.0.0/ 0.0.0.0/ udp dpt: ACCEPT tcp -- 0.0.0.0/ 0.0.0.0/ tcp dpt: ACCEPT all -- 0.0.0.0/ 0.0.0.0/ state RELATED,ESTABLISHED ACCEPT tcp -- 0.0.0.0/ 0.0.0.0/ state NEW tcp dpt: REJECT all -- 0.0.0.0/ 0.0.0.0/ reject-with icmp-host-prohibited ACCEPT tcp -- 0.0.0.0/ 0.0.0.0/ state NEW tcp dpt: ACCEPT tcp -- 0.0.0.0/ 0.0.0.0/ state NEW tcp dpt: [root@getoraclelnx01 sysconfig]#
从上面可以看出,防火墙开放了1521端口,于是我尝试关闭防火墙,发现居然可以从客户端连接到服务器了,那么肯定是防火墙配置问题,重启防火墙,用telnet xxx.xxx.xxx.xxx 1521 测试是否
最后发现居然是配置开放1521端口的时候,将配置选项放在-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited下面导致的,
于是调整顺序保存后,重启iptables服务,问题解决了。看来根本原因还是对iptables不熟悉导致,需要花点时间去研究下Linux下防火墙的配置。
-A RH-Firewall-1-INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m state --state NEW -m tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m state --state NEW -m tcp --dport 5901 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m state --state NEW -m tcp --dport 1521 -j ACCEPT
-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
Linux iptables配置错误导致ORA-12535 & ORA-12170的更多相关文章
- linux异常处理:selinux配置错误导致无法重启
点击返回自学Linux集锦 linux异常处理:selinux配置错误导致无法重启 一次linux无法重启异常记录: 当时第一反应就是梳理最近的配置变更,特别是能预知相关的就是selinux配置变更. ...
- Linux在fstab中因配置错误导致服务器主机无法重启的问题应该如何解决
fstab中配置错误导致系统无法启动的恢复方案 1制造错误的案例发生,在/etc/fstab中配置如下内容 结尾的倒数第一个为1表示进行磁盘检查,为0表示不进行磁盘检查,倒数第二个为0表示不备份,为1 ...
- 两个由于php.ini配置错误导致的报错:ajax图片上传报错和exec报错
遇到了两个由于php.ini配置错误导致的报错:ajax图片上传报错和exec报错 首先第一个: 在做一个用ajax图片上传的功能中,php报了这样一个错误:File upload error - u ...
- Linux iptables 配置规则
Linux iptables 防火墙配置规则 前言:把网上我感觉不错iptables的访问规则都统一在这里,以后做参考. modprobe ipt_MASQUERADE modprobe ip_con ...
- HWADDR配置错误导致network重启失败处理
如果因为/etc/sysconfig/network-scripts/下的ifcfg-eth0(此处以eth0网卡名为例),其中的HWADDR配置错误,不知道到哪里找到原来的HWADDR时,可以尝试一 ...
- Linux实例/etc/fstab文件配置错误导致系统启动异常
Centos 7.3系统 问题现象: 阿里云ECS升级配置后重启,SSH连接不上.登录控制台远程连接ECS,出现以下界面. 提交工单阿里云反馈:https://help.aliyun.com/kno ...
- linux 中环境变量配置错误导致部分命令不能使用包括vi
1,使用 /bin/vi /etc/profile 可以打开环境变量 2,修改正确后,重启
- Linux下环境变量配置错误 导致大部分命令不可以使用的解决办法
直接解决方法:在命令行中输入:export PATH=/usr/bin:/usr/sbin:/bin:/sbin:/usr/X11R6/bin 后 Enter
- linux iptables 配置
1.查看已有配置 iptables -L -n 2.清除原有规则. iptables -F 清除预设表filter中的所有规则链的规则 iptables -X 清除预设表f ...
随机推荐
- aud$定位错误用户密码登陆数据库的具体信息
环境:Oracle 11.2.0.3 客户端使用错误的用户密码登陆数据库 查询最近1天由于密码错误登陆失败的信息 查询当前审计中有哪些returncode值 1. 客户端使用错误的用户密码登陆数据库 ...
- 1Z0-053 争议题目解析577
1Z0-053 争议题目解析577 考试科目:1Z0-053 题库版本:V13.02 题库中原题为: 577.What methods are available to recover lost co ...
- 将DataTable转换成CSV文件
DataTable用于在.net项目中,用于缓存数据,DataTable表示内存中数据的一个表.CSV文件最早用在简单的数据库里,由于其格式简单,并具备很强的开放性,所以起初被扫图家用作自己图集的标记 ...
- MVC学习系列9--控制器接收从视图传递过来的参数
前面学习了,从控制器向视图传递数据,现在学习怎么从视图向控制器传递数据. 通常,我们有两种方式,来处理浏览器的请求,一个是GET方式,一个是POST方式.一般来说,直接通过在浏览器中输入URL话,请求 ...
- C#冒泡排序法
基本原理 比较两个相邻的数的大小,每次比较完后把最大的数放到本轮的末尾.假设有数组: 258,445,131,97,22,36,17,38,28,28,第一轮:258和445比较,位置不用交换.第二轮 ...
- C#使用Graphics画圆写字
画填充圆: Graphics gra = this.pictureBox1.CreateGraphics(); gra.SmoothingMode = System.Drawing.Drawing2D ...
- 各种类型转换为字符串类型(ToString())
更详细请参考:http://blog.csdn.net/wanzhuan2010/article/details/8478904 // C 货币 2.5.ToString("C") ...
- 背水一战 Windows 10 (16) - 动画: ThemeAnimation(主题动画)
[源码下载] 背水一战 Windows 10 (16) - 动画: ThemeAnimation(主题动画) 作者:webabcd 介绍背水一战 Windows 10 之 动画 PopInThemeA ...
- .net开发过程中Bin目录下面几种文件格式的解释
在.NET开发中,我们经常会在bin目录下面看到这些类型的文件: .pdb..xsd..vshost.exe..exe..exe.config..vshost.exe.config 项目发布的时候,往 ...
- (原)3.4 Zookeeper应用 - 分布式锁
本文为原创文章,转载请注明出处,谢谢 分布式锁 1.原理 建立表示锁的父节点(图中locker节点) 每个争抢锁的服务器在locker节点下创建有序的临时节点 判断自己是否抢到锁:获取locker下所 ...


