如果使用Oracle 12C 作为Ignite 的Repository的话,在Repository Createion Wizard的配置过程中,会出现ORA-28040:No matching authentication protocol错误,出现这个错误是因为Ignite使用的JDBC版本过低原因造成。需要升级JDBC的版本

步骤1:先查看本地Java版本并去官方网站下载Oracle JDBC Drive

[root@getlnx05 ignite_8_3_407]# java -version

java version "1.7.0_25"

Java(TM) SE Runtime Environment (build 1.7.0_25-b15)

Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

[root@getlnx05 ignite_8_3_407]#

http://www.oracle.com/technetwork/database/features/jdbc/index-091264.html

步骤2: 关闭Ignite服务,进入 /usr/local/ignite8/ignite_8_3_407目录后,执行shutdown.sh脚本

[root@getlnx05 ignite_8_3_407]# ./shutdown.sh

**************************************************************************

*

* If this script fails you can manually stop the program by

* doing the following steps:

*

* 1) Set the JAVA_HOME environment variable to your Java installation.

* 2) Add <JAVA_HOME>/bin to your PATH environment variable.

* 3) Go to the <Ignite Home>/tomcat/bin directory.

* 4) Run ./shutdown.sh

*

*

***************************************************************************

Catalog exists...

Found java 1.4 or higher

JAVA HOME IS SET TO /usr

PATH IS SET TO /usr/bin:/usr/java/jdk1.7.0_25/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

IBM Jvm Is Set To NO

Setting the -server option for JVM

JAVA_OPTS is -server -Xms128m -Xmx512m -XX:MaxPermSize=128m -Dcom.sun.management.jmxremote -Djava.net.preferIPv4Stack=true

Using CATALINA_BASE: /usr/local/ignite8/ignite_8_3_407/iwc/tomcat

Using CATALINA_HOME: /usr/local/ignite8/ignite_8_3_407/iwc/tomcat

Using CATALINA_TMPDIR: /usr/local/ignite8/ignite_8_3_407/iwc/tomcat/temp

Using JRE_HOME: /usr

Using CLASSPATH: /usr/local/ignite8/ignite_8_3_407/iwc/tomcat/bin/bootstrap.jar:/usr/local/ignite8/ignite_8_3_407/iwc/tomcat/ignite_config

Feb 25, 2014 9:06:52 AM org.apache.catalina.startup.Catalina stopServer

SEVERE: Catalina.stop:

java.net.ConnectException: Connection refused

        at java.net.PlainSocketImpl.socketConnect(Native Method)

        at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)

        at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)

        at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)

        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)

        at java.net.Socket.connect(Socket.java:579)

        at java.net.Socket.connect(Socket.java:528)

        at java.net.Socket.<init>(Socket.java:425)

        at java.net.Socket.<init>(Socket.java:208)

        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:422)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

        at java.lang.reflect.Method.invoke(Method.java:606)

        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:338)

        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:416)

**************************************************************************

*

* IWC is shutting down.

*

***************************************************************************

Exiting script after webserver stopped.

步骤3:进入<IgniteHome>/iwc/tomcat/webapps/iwc/WEB_INF/lib 目录,将 ojdbc14.jar改名为ojdbc14.jar_10g,然后将下载的ojdbc7.jar

上传到该目录

[root@getlnx05 lib]# cd  /usr/local/ignite8/ignite_8_3_407/iwc/tomcat/webapps/iwc/WEB-INF/lib

[root@getlnx05 lib]# pwd

/usr/local/ignite8/ignite_8_3_407/iwc/tomcat/webapps/iwc/WEB-INF/lib

[root@getlnx05 lib]# mv ojdbc14.jar ojdbc14.jar_10g

步骤4:重启Ignite服务

[root@getlnx05 ignite_8_3_407]# ./startup.sh

**************************************************************************

*

* If this script fails you can manually start the program by

* doing the following steps:

*

* 1) Set the JAVA_HOME environment variable to your Java installation.

* 2) Add <JAVA_HOME>/bin to your PATH environment variable.

* 3) Go to the <Ignite Home>/tomcat/bin directory.

* 4) Run ./startup.sh

* 5) Bring up the link (http://machine Name:8123

* or http://machine IP:8123) in your browser.

*

*

***************************************************************************

Catalog exists...

Found java 1.5 or higher

JAVA HOME IS SET TO /usr

PATH IS SET TO /usr/bin:/usr/java/jdk1.7.0_25/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

The server port is 8127

The port is 8123

IWC is not running.

The port 8123 is open

The port 8127 is open

Starting Ignite

IBM Jvm Is Set To NO

Setting the -server option for JVM

JAVA_OPTS is -server -Xms128m -Xmx512m -Xss256k -XX:MaxPermSize=128m -Dcom.sun.management.jmxremote -Djava.net.preferIPv4Stack=true

Waiting on initialization...please be patient

**************************************************************************

*

* Ignite has been launched, wait one minute then bring up

* this link in your browser:

*

* http://<Machine Name>:8123 or http://<Machine IP>:8123

*

* If the link does not work, check <iwc_dir>/tomcat/logs

* and make sure a firewall is not running on this machine.

*

***************************************************************************

Exiting script after webserver launched.

然后使用http://<Machine Name>:8123 or http://<Machine IP>:8123 发现Ignite无法打开。

进入tomcat的日志目录,发现catalina.out下有如下错误信息。

[root@getlnx05 logs]# cd /usr/local/ignite8/ignite_8_3_407/iwc/tomcat/logs

[root@getlnx05 logs]# more catalina.out

The stack size specified is too small, Specify at least 160k

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

The stack size specified is too small, Specify at least 160k

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

The stack size specified is too small, Specify at least 160k

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

在官网搜索了一下资料发现了问题和解决方案:

Some Operations Systems, the 64-bit JRE requires a larger stack size than the default of 128K.  If this is the case, Ignite will not start and will report an error like the following

http://support.confio.com/kb/article/stack-size-error-using-ignite-with-java-17/1685/

Step 1:找到<ignite install dir>/iwc/tomcat/bin/catalina.sh 

Step 2:找到JAVA_OPTS="$JAVA_OPTS -Xss128k" 将其改为 JAVA_OPTS="$JAVA_OPTS -Xss256k"

    if [ $SOLARIS64 ] && [ $SOLARIS64 = "Y" ]

then

        JAVA_OPTS="$JAVA_OPTS -Xss256k -d64"

else

        if [ "$1" != "stop" ] ; then

                JAVA_OPTS="$JAVA_OPTS -Xss128k"

        fi

fi

将其修改为如下

    if [ $SOLARIS64 ] && [ $SOLARIS64 = "Y" ]

then

        JAVA_OPTS="$JAVA_OPTS -Xss256k -d64"

else

        if [ "$1" != "stop" ] ; then

                JAVA_OPTS="$JAVA_OPTS -Xss256k"

        fi

fi

Step 3: 重启启动Ignite服务。问题解决!

参考资料:

     http://support.confio.com/kb/article/monitoring-an-oracle-12c-database/1678/

    http://support.confio.com/kb/article/upgrade-oracle-jdbc-driver/1677/

 

Ignite 配置更新Oracle JDBC Drive的更多相关文章

  1. 错误处理Cannot load JDBC driver class 'oracle.jdbc.drive

    org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnec是由于<Resource name=&qu ...

  2. springboot ——oracle.jdbc.driver.OracleDriver

    网上很多案例讲是oracle的驱动包没有导入进去,我之前尝试下图示方式导入解决该问题: 但是在后期调试的时候,发现会影响后续oracle数据源连接驱动的问题,导致不能查询,因此想,另辟途径,解决这个问 ...

  3. Oracle JDBC连接服务名、SID和tnsnames.ora配置的多种方式

    昨天,领导安排去新服务器上部署项目,给了我数据库地址,服务名称,端口,用户名和密码.结果数据库一直连接不上,日志中的错误提示是监听未找到SID,我才明白原来我jdbc.properties中需要的是S ...

  4. Oracle JDBC配置

    Oracle数据库是收费的,Oracle的JDBC驱动在Maven仓库中虽有其名,却无法下载到jar包. 这就需要手动下载Oracle JDBC驱动并将其安装到本地Maven仓库中. 如果从官网下载, ...

  5. spring配置hibernate在使用oracle驱动时报错Cannot load JDBC driver class 'oracle.jdbc.driver.OracleDriver '

    在看到这个错误的时候就感觉有点不对劲了,在错误的结尾和引号之间还有空间,如果敏锐的点应该察觉到可能是空格问题.由于本人的粗心导致这个问题一直困扰了我接近一个上午. 在排查这个问题的时候首先想到的就是关 ...

  6. 皕杰报表:连接数据库失败,请检查数据源配置(oracle.jdbc.driver.OracleDriver)

    皕杰报表:连接数据库失败,请检查数据源配置(oracle.jdbc.driver.OracleDriver)问题解决: 缺少了classes12.jar 在窗口--首选项--报表运行时配置--添加-- ...

  7. maven打包oracle jdbc驱动

    背景 由于版权问题,maven中央仓库缺少oracle jdbc的驱动,这个给开发带来了很多不便利性.也出现各种各样的解决方案,基本就两种思路: 将oracle驱动安装到本地仓库,这个需要大家统一好名 ...

  8. 高性能 Oracle JDBC 编程

    了解如何利用连接和语句池特性来提高 Oracle 驱动的 JDBC 程序的性能.作者:Yuli Vasiliev2009 年 4 月发布使用诸如连接池和语句池等池技术可以显著提高数据库密集型应用程序的 ...

  9. Eclipse中启用Oracle jdbc logging

    根据自己用的JRE版本, jre1.5选择ojdbc5_g.jar, jre6选择ojdbc6_g.jar, 只有带_g的dirver才输出debug信息. maven 的配置信息: <depe ...

随机推荐

  1. swift 新特性

    switch支持任意类型的数据以及各种比较操作——不仅仅是整数以及测试相等. 运行switch中匹配到的子句之后,程序会退出switch语句,并不会继续向下运行,所以不需要在每个子句结尾写break. ...

  2. PHP类的原理

    一.类的实现 类的内部存储结构: struct _zend_class_entry { char type; // 类型:ZEND_INTERNAL_CLASS / ZEND_USER_CLASS c ...

  3. 1Z0-053 争议题目解析304

    1Z0-053 争议题目解析304 考试科目:1Z0-053 题库版本:V13.02 题库中原题为: 304.What privileges must be granted to allow an a ...

  4. Cesium原理篇:6 Render模块(3: Shader)

    在介绍Renderer的第一篇,我就提到WebGL1.0对应的是OpenGL ES2.0,也就是可编程渲染管线.之所以单独强调这一点,算是为本篇埋下一个伏笔.通过前两篇,我们介绍了VBO和Textur ...

  5. JS Div滚动,下拉框添加属性,年月日下拉条

    创建某一下拉菜单的项: str = str+"<option value='"+i+"'>"+i+"</option>&quo ...

  6. Compute Resource Consolidation Pattern 计算资源整合模式

    Consolidate multiple tasks or operations into a single computational unit. This pattern can increase ...

  7. MVC学习系列——Filter扩展

    在MVC中,Filter也是可以扩展的.在此,本人对Filter的理解就是AOP,不知道各位大侠,有什么高的见解,呵呵... 首先MVC四大过滤神器IAuthorizationFilter,IActi ...

  8. 使用AOP+Annotation实现操作日志记录

    先创建注解 OperInfo @Target({ElementType.TYPE, ElementType.METHOD}) @Retention(RetentionPolicy.RUNTIME) @ ...

  9. UVALive 6908---Electric Bike(DP或记录型深搜)

    题目链接 https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_ ...

  10. 12、ASP.NET MVC入门到精通——HtmlHelper

    本系列目录:ASP.NET MVC4入门到精通系列目录汇总 HtmlHelper:是为了方便View的开发而产生 HtmlHelper的演变 普通首页超级链接为:<a href="/h ...