问题1:

上图是我已经解决了的截图。在百度查询的资料中,说是把zabbix_agentd.conf文件中server监听的主机127.0.0.1去掉,但是我去掉之后问题仍然没有解决,最后在这篇博客上发现:是我防火墙启动了的原因,至于防火墙启动大概是我安装bt的时候脚本中启动了,将防火墙stop之后,问题解决。

查看agentd日志:

[root@VM_0_10_centos src]# tail -f /tmp/zabbix_agentd.log
32170:20191204:164250.030 **************************
32170:20191204:164250.030 using configuration file: /usr/local/etc/zabbix_agentd.conf
32170:20191204:164250.030 agent #0 started [main process]
32171:20191204:164250.031 agent #1 started [collector]
32172:20191204:164250.031 agent #2 started [listener #1]
32173:20191204:164250.032 agent #3 started [listener #2]
32174:20191204:164250.032 agent #4 started [listener #3]
32175:20191204:164250.032 agent #5 started [active checks #1]
32176:20191204:164250.032 agent #6 started [active checks #2]
32176:20191204:164250.035 active check configuration update from [106.53.73.200:10051] started to fail (cannot connect to [
[106.53.73.200]:10051]: [113] No route to host)
# 出现报错
32176:20191204:164950.123 active check configuration update from [106.53.73.200:10051] is working again # 解决之后输出的信息

问题2:Lack of free swap space on tanbaobao

原因:

  部分云主机没有设置交换分区/虚拟内存,使用free -m命令将会显示 SWAP 三项都为0
free -m 显示系统无交换空间

解决:

  配置==》模板==》选择Template OS Linux==》触发器

打开Lack of free swap space on {HOST.NAME}项目,在新打开的触发器编辑页面中修改Expression(表达式)的内容,将原来的

{Template OS Linux:system.swap.size[,pfree].last(0)}<50

改为:

{Template OS Linux:system.swap.size[,pfree].last(0)}<50 and {Template OS Linux:system.swap.size[,free].last(0)}<>0

  此处修改增加了“ and {Template OS Linux:system.swap.size[,free].last(0)}<>0”判断系统有交换空间,当系统无交换空间
即{Template OS Linux:system.swap.size[,free].last(0)}的值为0时将不会时表达式不成立就不会触发错误提示。
  保存之后在下一个更新周期内Zabbix之前报告的“Lack of free swap space”问题就会被自动标记为Resolved(已解决)

问题3:日志报错cannot send list of active checks to "主机ip": host [主机名] not found

  在确保防火墙,selinux设置好之后,网络、端口也是通的情况下,一般是主机解析问题,在zabbix_server服务端和zabbix_agentd被监控端添加主机解析,之后查看日志应该是正常的,我这里后面虽然没有设置,自己也自动恢复了,不过保险起见,设置一下比较好

# 监控端(服务端)
[root@tanbaobao ~]# vi /etc/hosts
10.0.0.1 主机名.localdomain 主机名
10.0.0.2 主机名 # 被监控端
[root@VM_0_16_centos ~]# vi /etc/hosts
10.0.0.2 主机名.localdomain 主机名
10.0.0.1 主机名

问题4:Zabbix对tomcat监控总是出现预警:gzip compression is off for connector http-8080 on XXXXXX

问题解决:

# 编辑tomcat的server.xml文件
# 从上面节点的属性可以看出,要使用gzip压缩功能,你需要在Connector节点中加上如下属性
# compression=“on” 打开压缩功能
# compressionMinSize=“50” 启用压缩的输出内容大小,默认为2KB
# noCompressionUserAgents=“gozilla, traviata” 对于以下的浏览器,不启用压缩
# compressableMimeType=“text/html,text/xml,text/javascript,text/css,text/plain” 哪些资源类型需要压缩
[root@VM_0_10_centos ~]# vi /usr/local/tomcat9.0.29/conf/server.xml
<Connector port="" protocol="HTTP/1.1"
connectionTimeout=""
redirectPort=""
compression="on"
compressionMinSize=""
noCompressionUserAgents="gozilla, traviata"
compressableMimeType="text/html,text/xml,text/javascript,text/css,text/plain" /> # 重启服务
[root@VM_0_10_centos ~]# /usr/local/tomcat9.0.29/bin/shutdown.sh
[root@VM_0_10_centos ~]# /usr/local/tomcat9.0.29/bin/startup.sh

问题解决:

待更新中......

参考博客:

https://blog.csdn.net/qq_37961660/article/details/79923963

https://blog.csdn.net/weixin_42867972/article/details/88581342

【zabbix监控问题】记录zabbix控制面板报错及日志报错的解决方法的更多相关文章

  1. linux下svn客户端报错Cannot negotiate authentication mechanism的解决方法

    svn客户端报错Cannot negotiate authentication mechanism的解决方法: 问题出现的原因之一: 因为SVN服务器配置了saslauthd服务用来实现与ldap的对 ...

  2. 安装PHP过程中,make步骤报错:(集合网络上各种解决方法)

    安装PHP过程中,make步骤报错:(集合网络上各种解决方法) (1)-liconv -o sapi/fpm/php-fpm /usr/bin/ld: cannot find -liconv coll ...

  3. 关于163发邮件报错535 Error:authentication failed解决方法

    关于发邮件报错535 Error:authentication failed解决方法 调用163邮箱服务器来发送邮件,我们需要开启POP3/SMTP服务,这时163邮件会让我们设置客户端授权码,这个授 ...

  4. shell报错:-bash: [: ==: 期待一元表达式 解决方法 ([: ==: unary operator expected)

    shell报错:-bash: [: ==: 期待一元表达式 解决方法 ([: ==: unary operator expected) blogdaren 2015-02-26  抢沙发 14916人 ...

  5. python3中用HTMLTestRunner.py报ImportError: No module named 'StringIO'的解决方法:

    全文转载至:http://www.cnblogs.com/testyao/p/5658200.html python3中用HTMLTestRunner.py报ImportError: No modul ...

  6. 宝塔控制面板创建ftp后链接不上的解决方法

    很多的新手在安装宝塔面板并且创建完ftp管理后链接ftp居然链接不上?有许多朋友都不知道本站q302博客也是基于宝塔控制面板管理的,本站在安装网站完成后也和你们一样ftp链接不上,后面经过多次测试之后 ...

  7. jquery报.live() is not a function的解决方法

    jquery报.live() is not a function的解决方法: jquery中的live()方法在jquery1.9及以上的版本中已被废弃了,如果使用,会抛出TypeError: $(. ...

  8. AndroidStudio中利用git下载github或者git.oschina的代码时报错:repository test has failed解决方法

    作者:程序员小冰,CSDN博客:http://blog.csdn.net/qq_21376985 QQ986945193 微博:http://weibo.com/mcxiaobing AndroidS ...

  9. zabbix启动报错:Connection to database 'xxx' failed解决方法

    Zabbix 分布式系统监视系统 zabbix是一个基于WEB界面的提供分布式系统监视以及网络监视功能的企业级的开源解决方案. zabbix能监视各种网络参数,保证服务器系统的安全运营:并提供灵活的通 ...

随机推荐

  1. VLAN实验3(Hybrid接口的应用)

    本实验基于<HCNA网络技术实验指南> 本实验使用eNSP软件 原理概述: Hybrid接口既可以连接普通终端的接入链路又可以连接交换机间的干道链路,它允 许多个VLAN的帧通过,并可以在 ...

  2. 前端js,如何在结构化与性能中做取舍。

    js发展中的问题 随着前端web技术的发展,js要解决的问题也变得越来越多,越来越复杂. 解决更复杂的问题,需要更好的结构. 解决更复杂的问题,也需要更好的性能. 结构的优化在一定程度上会牺牲性能,同 ...

  3. RestTemplate常用的get和post带参数请求

    在RestTemplate提供的方法中,有一个参数就是目标URL,参数是跟在后面的一个数量可变参数,但是在这里就有个问题,这个方法怎么知道我传的参数值是对应在目标接口的哪个参数的呢: public & ...

  4. .Net core_Excel 导出二维码(以导出箱单为例)

    [AccessLogAttribute(Note = "导出条形码箱单 — 条形码")]public ActionResult ExportContract(string INNE ...

  5. luogu P2824 [HEOI2016/TJOI2016]排序

    题目描述 在2016年,佳媛姐姐喜欢上了数字序列.因而他经常研究关于序列的一些奇奇怪怪的问题,现在他在研究一个难题,需要你来帮助他.这个难题是这样子的:给出一个1到n的全排列,现在对这个全排列序列进行 ...

  6. Java修炼——继承_super父类对象的引用

    Super是指直接父类对象的引用,可以通过super来访问父类中被子类覆盖的方法和属性. 当你调用子类的构造方法时,系统会默认给你先调用父类的构造方法,然后才会调用子类的构造方法. package c ...

  7. MyBatis三个查询方法_selectList_selectOne_selectMap

    mybatis-cfg.xml的配置: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE co ...

  8. 小M的魔术表演

    Description 小M听说会变魔术的男生最能吸引女生注意啦~所以小M费了九牛二虎之力终于学会了一个魔术:首先在桌面上放N张纸片,每张纸片上都写有一个数字.小M每次请女生给出一个数字x,然后划定任 ...

  9. linux-history、find、

    1.history:查看历史记录 -c:清除历史命令记录 -d:删除某一条使用过的命令,-d后跟命令的序列号 2.find:在目录结构中搜索文件 -type:后面跟文件的类型,d表示目录,f表示文件 ...

  10. .NET Core RSA 指南与增强扩展 RSAExtensions

    一. 前言 RSA 作为最常用的非对称加密算法,在我们的实际使用中还是比较常见的,特别是对接支付十有八九都会遇到,或者是其他需要数据安全的业务场景.在 .NET Framework 以及 .NET C ...