如何解决Apache无法启动的问题
今天重装xampp后,一直无法启动Apache,提示以下错误:
22:36:54 [Apache] Attempting to start Apache app...
22:36:54 [Apache] Status change detected: running
22:36:55 [Apache] Status change detected: stopped
22:36:55 [Apache] Error: Apache shutdown unexpectedly.
22:36:55 [Apache] This may be due to a blocked port, missing dependencies,
22:36:55 [Apache] improper privileges, a crash, or a shutdown by another method.
22:36:55 [Apache] Press the Logs button to view error logs and check
22:36:55 [Apache] the Windows Event Viewer for more clues
22:36:55 [Apache] If you need more help, copy and post this
22:36:55 [Apache] entire log window on the forums
大概意思是端口被占用,查看xampp/apache/conf/httpd.conf文件,里面运用的是80端口,也是浏览器默认的80端口。
首先,可以cmd,用netstat -ano来查看端口的占用情况
1. netstat -ano|findstr "80" 查看指定端口80的占用情况
C:\Users\acer>netstat -ano|findstr "80"
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 4
TCP 0.0.0.0:1026 0.0.0.0:0 LISTENING 800
TCP 192.168.0.102:2113 183.136.138.140:80 TIME_WAIT 0
TCP 192.168.0.102:2114 183.136.138.140:80 ESTABLISHED 732
TCP [::]:80 [::]:0 LISTENING 4
TCP [::]:1026 [::]:0 LISTENING 800
UDP [fe80::ce5:bd05:f942:83da%18]:1900 *:* 1744
UDP [fe80::d8c:1ba:16b4:2a29%17]:1900 *:* 1744
UDP [fe80::7469:be65:7b61:a13b%14]:1900 *:* 1744
依次表示 协议 本地地址 外部地址 状态 PID
2. 用tasklist命令查看PID对应的进程
C:\Users\acer>tasklist|findstr "732"
TaobaoProtect.exe 732 Console 1 7,956 K
依次表示 映像名称 PID 会话名 会话# 内存使用
3. 用taskkill命令可以关闭找到的进程,解除端口占用情况
C:\Users\acer>taskkill /f /t /im TaobaoProtect.exe
成功: 已终止 PID 732 (属于 PID 1880 子进程)的进程。
但是有些情况下,我们有些进程是无法关闭的,或者对应进程较多的时候,关闭也很麻烦。退一步来讲,我们可以选择修改Apache对应的端口,岂不是两全其美?
我们继续打开xampp/apache/conf/httpd.conf文件,找到Listen80,将80改为81或者82and so on,保证该端口没有被占用即可,可以用上面的方法进行检验。
我第一次是把所有的80都改为81的,后来发现,只改listen后面这个也可以的~~具体可以去看看Apache的http.conf的详细解释,暂时觉得应该都改掉吧。
啊哈,接下来可以重启Apache了,运气好的话,发现,还是端口被占用哦。
23:10:29 [Apache] Attempting to start Apache app...
23:10:29 [Apache] Status change detected: running
23:10:30 [Apache] Status change detected: stopped
23:10:30 [Apache] Error: Apache shutdown unexpectedly.
23:10:30 [Apache] This may be due to a blocked port, missing dependencies,
23:10:30 [Apache] improper privileges, a crash, or a shutdown by another method.
23:10:30 [Apache] Press the Logs button to view error logs and check
23:10:30 [Apache] the Windows Event Viewer for more clues
23:10:30 [Apache] If you need more help, copy and post this
23:10:30 [Apache] entire log window on the forums
Google了一下,发现,APACHE 还需要 443 端口,具体可以查看xampp/apache/conf/extra/httpd-ssl.conf文件,里面有个listen443,检查一下443端口的占用情况,又被占用了,一样的,将443改为444.
如何找到上面两个文件,可以采取这样的方式。如下图,点击config,出现的前两个,便是了~

重启Apache,OK,搞定,perfect!
23:20:40 [Apache] Attempting to start Apache app...
23:20:41 [Apache] Status change detected: running
点击admin,或者在浏览器输入localhost或者127.0.0.1,啊哦,
Not Found
HTTP Error 404. The requested resource is not found.
not found?因为浏览器的默认端口号为80,而我们不是把端口改为81了吗?此时可以在localhost后面加上端口号:localhost:81,再回车,就OK了~
如何解决Apache无法启动的问题的更多相关文章
- wamp下开启SSL,解决APACHE启动问题
wamp开启SSL解决wamp5_1.7.4中APACHE启动问题 1.#修改httpd.conf文件LoadModule ssl_module modules/mod_ssl.soInclude c ...
- 解决Apache/PHP无法启动的问题
最近经常被问到Apache无法启动的情况,所以写一篇文章,总结一下Windows下经常遇到的 Apache/PHP 无法启动的情况的解决方法. Apache/PHP 无法启动分两种情况: 1..Apa ...
- 80端口未占用,apache无法启动解决办法
网上很多关于apache无法启动的原因,新手遇到最多的是80端口被占用. 今天为了解决apache和tomcat端口共存问题,修改了httpd.conf的配置,由于增加位置没有做明显标识,重启apac ...
- xampp的Apache无法启动解决方法
XAMPP Apache 无法启动原因1(缺少VC运行库): 这个就是我遇到的问题原因,下载安装的XAMPP版本是xampp-win32-1.7.7-VC9,而现有的Windows XP系统又没有安装 ...
- 安装Wamp后 Apache无法启动的解决方法
安装Wamp后 Apache无法启动的解决方法,网上的解决方案可以说是五花八门,有些说了一大推,一点作用都起不到. 其实解决方法只需两步: 1.安装路径不能包含有中文,这个我不知道为什么,总之如果安装 ...
- Apache无法启动解决 the requested operation has failed
Apache不能启动解决办法 原因一:80端口占用例如IIS,另外就是迅雷. 原因二:软件冲突装了某些软件会使apache无法启动如Dr.com 你打开网络连接->TcpIp属性->高级- ...
- Apache不能启动解决办法
这是我这两天频繁遇到的问题.Apache服务器还真是问题少年!任何点改动都可能导致它无法使用. 原因一:80端口占用例如IIS,另外就是迅雷.我的apache服务器就是被迅雷害得无法启用! 原因二:软 ...
- 安装Wamp后 Apache无法启动的解决方法
安装Wamp后 Apache无法启动的解决方法,网上的解决方案可以说是五花八门,有些说了一大推,一点作用都起不到. 其实解决方法只需两步: 1.安装路径不能包含有中文,这个我不知道为什么,总之如果安装 ...
- wamp apache无法启动的解决方法
作者 grunmin 2014.03.12 14:44* 字数 535 阅读 22167评论 9喜欢 5 如题,近日在安装wamp的时候出现了apache无法启动的情况.wamp图标一直显示橙色.网上 ...
随机推荐
- js-百度地图多个标注点
以成都华誉口腔3个门诊部为例,锦江区-青羊区-高新区 html: <div class = "demo_main"> <fieldset class = &quo ...
- ELK之收集Java日志、通过TCP收集日志
1.Java日志收集 使用codec的multiline插件实现多行匹配,这是一个可以将多行进行合并的插件,而且可以使用what指定将匹配到的行与前面的行合并还是和后面的行合并. 语法示例: inpu ...
- Codeforces Round #317 [AimFund Thanks-Round] (Div. 2) Minimization dp
原题链接:http://codeforces.com/contest/572/problem/D 题意 给你个数组A和n,k,问你排列A后,下面的最小值是多少. 题解 先排个序,要填充像1,1+k,1 ...
- Loj #2036. 「SHOI2015」自动刷题机
link : https://loj.ac/problem/2036 这个显然具有单调性,N小的话更容易A题,不仅因为A一次题减少的代码,并且A题的下限也低. 所以直接上二分就行了,注意上限一定不要设 ...
- Excel文件处理Demo
1.BLL业务逻辑代码 /// <summary> /// 处理“店铺竞品销售数据”导入文件 /// </summary> /// <param name="f ...
- Linux 端口防火墙
举例: 开放10000端口的解决步骤如下: 1.修改/etc/sysconfig/iptables文件,增加如下一行: -A RH-Firewall-1-INPUT -m state --state ...
- SilverLight:基础控件使用(3)-DataGrid控件
ylbtech-SilverLight-Basic-Control:基础控件使用(3)-DataGrid控件 DataGrid控件-后台绑定 自动生成表列 不自动生成表列 1.A,返回顶部Person ...
- Java Unsafe类
参考了这篇文章:http://blog.csdn.net/aesop_wubo/article/details/7537278 <JAVA并发编程学习笔记之Unsafe类> Unsafe开 ...
- Redis绑定多个ip地址
Redis绑定多个ip地址 学习了:https://www.zhihu.com/question/20346112/answer/17157379 注意,用空格进行分隔 bind 127.0.0.1 ...
- yarn 基本用法
1.初始化一个新的项目 yarn init 2.添加一个依赖包 yarn add [package] yarn add [package]@[version] yarn add [package]@[ ...