Oracle数据库启动出现ORA-27101错误之ORA-19815处理方式及数据备份
ORA-27101: sharedmemory realm does not exist之ORA-19815处理
重启数据库(数据库:muphy),登陆是越到错误:
ORA-27101: shared memory realm does notexist
首先越到错误查看警告日志alert_muphy.log
Wed Dec 12 22:19:36 2018
Errors in file D:\APP\ORCL\diag\rdbms\muphy\muphy\trace\muphy_m000_5020.trc:
ORA-19815: WARNING:db_recovery_file_dest_size of 2147483648 bytes is 100.00% used, and has 0remaining bytes available.Wed Dec 12 22:19:36 2018
************************************************************************
You have following choices to free up spacefrom recovery area:
1. Consider changing RMAN RETENTION POLICY.If you are using Data Guard,
then consider changing RMAN ARCHIVELOG DELETION POLICY.
2. Back up files to tertiary device such astape using RMAN
BACKUP RECOVERY AREA command.
3. Add disk space and increasedb_recovery_file_dest_size parameter to
reflect the new space.
4. Delete unnecessary files using RMANDELETE command. If an operating
system command was used to delete files, then use RMAN CROSSCHECK and
DELETE EXPIRED commands.
从这段话看出来错误的原因是归档日志文件分配的空间已经使用完成
解决办法1
备份和数据库并整理归档日志文件,顺便学习一下rman的使用
rman全库备份
backupdatabase;(未压缩),或者 backup as compressed backupsetdatabase; (压缩)
命令查看备份信息
listbackupset;
如果需要压缩备份全库及归档日志可以执行如下命令:
backupas compressed backupset database plus archivelog;
rman增量备份
1. 零级备份
backupincremental level 0 database;或者 backup incremental level =0 database;
增量备份都需要一个0级备份为基础,0级备份与全备份的区别在于0级可以用来增量恢复,而全备份则不可以
2. 一级差异增量
backupincremental level 1 database;
差异增量(Differential):是备份低级别或者相同级别备份以来变化的所有数据块,顾名思议,也就是要备前期备份以来的差异数据块
若前面的备份同时存在低级别和相同级别,则优先选择备份从最近的低级别(n-1)以来变化的数据块,
若没有n-1级别备份,则选择备份同级别备份以来变化的数据块,
若没有同级别的备份,则备份更低级别以来(n-x)变化的数据
若前面同时有n-1级别和相同级别,则备份相同级别以来变化的数据
3. 一级累计增量
backupincremental level 1 cumulative database;
累积增量(Cumulative):是备份n-1级别(上级)或更低级别以来变化的所有数据块
若前面的备份同时存在低级别和n-1级别,则优先选择备份从n-1级别以来变化的数据块
若没有n-1级别,则备更低级别的(n-x)
删除归档日志
--->校验日志的可用性
crosscheckarchivelog all;
--->列出所有失效的归档日志
listexpired archivelog all;
--->删除log sequence为16及16之前的所有归档日志
deletearchivelog until sequence 16;
--->删除系统时间7天以前的归档日志,不会删除闪回区有效的归档日志
deletearchivelog all completed before 'sysdate-7';
--->同上,1天以前的
deletearchivelog all completed before 'sysdate - 1';
--->注意这个命令,删除系统时间1天以内到现在的归档日志
deletearchivelog from time 'sysdate-1';
--->该命令清除所有的归档日志
deletenoprompt archivelog all completed before 'sysdate';
--->同上一命令
deletenoprompt archivelog all;
重启数据库
SYS@muphy>startup
ORACLE例程已经启动。
Total System Global Area 411041792 bytes
Fixed Size 3046272 bytes
Variable Size 322962560 bytes
Database Buffers 79691776 bytes
Redo Buffers 5341184 bytes
数据库装载完毕。
数据库已经打开。
检查空间使用情况
selece* from v$flash_recovery_area_usage;
解决办法2
还可以通过扩大个缓冲区大小来暂时缓解,但这种方法应属于指标不治本。
1. 数据库没法启动的情况
重命名SPFILEMUPHY.ORA为SPFILEMUPHY_bak.ORA
修改参数文件INITmuphy.ORA
将*.db_recovery_file_dest_size=6420m的参数6420m改为8192m
重启数据库Startup命令
重新创建spfile文件
Createspfile from pfile
2. 数据库可以启动的情况
altersystem set db_recovery_file_dest_size=4G scope=both;
Oracle数据库启动出现ORA-27101错误之ORA-19815处理方式及数据备份的更多相关文章
- Oracle 数据库启动与关闭 各种方式详解整理
概述 只有具备sysdba和sysoper系统特权的用户才能启动和关闭数据库. 在启动数据库之前应该启动监听程序,否则就不能利用命令方式来管理数据库,包括启动和关闭数据库. 虽然数据库正常运行,但如果 ...
- Oracle 数据库启动与关闭
只有具备sysdba和sysoper系统特权的用户才能启动和关闭数据库. 在启动数据库之前应该启动监听程序,否则就不能利用命令方式来管理数据库,包括启动和关闭数据库. 虽然数据库正常运行,但如果没有启 ...
- Oracle数据库启动和关闭
在介绍oracle数据库的启动和关闭前,先看一下Oracle的参数文件. oracle参数文件 1.初始化参数文件 oracle的初始化参数文件分为spfilesid.ora.spfile.ora.i ...
- 一次vm 虚拟机时间倒流而导致的oracle 数据库启动故障
一次vm 虚拟机时间倒流而导致的oracle 数据库启动故障 本文是原创文章.若转载请注明出处: http://blog.csdn.net/msdnchina/article/details/3878 ...
- Oracle数据库启动时:ORA-00119: invalid specification for system parameter LOCAL_LISTENER; ORA-00132错误解决
问题描述: 1. em打开中提示 https://localhost:1158/em/console/database/instance/repDown?target=orclweng&typ ...
- 关于oracle数据库启动报ORA-01122,ORA-01110,ORA-01203错误的解决方法
ORACLE 数据库空间裸设备出问题了,启动oracle失败,解决方法问题现象: 启动ORACLE的时候报如下的错误: Database mounted. ORA-01 ...
- oracle数据库--启动和关闭
oracle--启动 oracle数据库的启动过程包含3个步骤:启动实例->加载数据库->打开数据库 分步骤启动过程可以对数据库进行不同的维护操作,对应我们不同的需求. 启动模式: 1.s ...
- oracle数据库启动报错,不能启动ASM实例
数据库rac启动时报错,日志例如以下,后来使用 Sat Jun 7 06:02:11 2014 GATHER_STATS_JOB encountered errors. Check the tra ...
- Linux环境下Oracle数据库启动停止命令
切换root至oracle数据库账号 su – oracle 查看数据库服务状态: ps -ef |grep oracle netstat –an|grep 1521 查看数据库监听状态: [orac ...
随机推荐
- [TCP/IP] 传输层-TCP和UDP的使用场景
传输层-TCP和UDP应用场景 TCP(传输控制协议) 需要将要传输的文件分段传输,建立会话,可靠传输,流量控制 UDP(用户报文协议) 一个数据包就能完成数据通信,不需要建立会话,不分段,不用流量控 ...
- Java 创建、填充PDF表单域
表单域,可以按用途分为多种不同的类型,常见的有文本框.多行文本框.密码框.隐藏域.复选框.单选框和下拉选择框等,目的是用于采集用户的输入或选择的数据.下面的示例中,将分享通过Java编程在PDF中添加 ...
- 用python写一个北京市的个税计算器
#应纳税的钱:税前收入-5000元(起征点)-专项扣除(五险一金等) #工资个税的计算公式为: #个人所得税=应纳税的钱×适用税率-速算扣除数 ''' 1.全月应纳税所得额不超过3000元: 税率:3 ...
- MyBatis入门简述
MyBatis前身是iBatis,为Apache的一个开源项目.2010年迁移到了Google Code,改名为MyBatis.2013年迁移到Github. MyBatis是一个优秀的持久层框架,它 ...
- Spring MVC的文件上传和下载
简介: Spring MVC为文件上传提供了直接的支持,这种支持使用即插即用的MultipartResolver实现的.Spring MVC 使用Apache Commons FileUpload技术 ...
- Linux硬盘文件分析取证(SSH过的IP)
在线靶场: https://www.mozhe.cn 背景介绍 某运维人员发现服务器最近被一个IP连接过SSH,请找到连接服务器SSH的IP. 实训目标 1.了解Linux备份方式: 2.了解Acce ...
- 关于Android中ION的libion
在高通的OpenCL SDK中,其Android.mk文件中,有判断当前kernel的版本,如果大于4.12,那么就使用libion.so,否则则使用ion kernle uapi: # Tries ...
- 高通MSM8998 ABL的调试
高通在MSM8998上引入了UEFI,用来代替LK(Little Kernel).高通UEFI由XBL和ABL两部分组成.XBL负责芯片驱动及充电等核心应用功能.ABL包括芯片无关的应用如fastbo ...
- 【English】六、am,is,are 分别用在什么地方
is:第三人称单数am:第一人称单数are:第二人称单数,第一.二.三人称的复数 用于第一人称, I am ......(我是.......)用于第三人称, He is ......(他是...... ...
- cvc-elt.1: Cannot find the declaration of element 'beans'Failed to read schema document 'http://www.springframework.org/schema/beans/spring- beans-3.0.xsd'
Multiple annotations found at this line: - cvc-elt.1: Cannot find the declaration of element 'beans' ...