Hadoop服务启动失败
Hadoop服务启动失败
今天启动Hadoop时,终端报了一个新的错误
```bash
Starting namenodes on [192.168.19.128]
192.168.19.128: ssh: connect to host 192.168.19.128 port 22: Network is unreachable
Starting datanodes
Starting secondary namenodes [zc-virtual-machine]
```
我使用**ifconfig**命令查看了虚拟机IP,惊奇地发现IP居然发生了变化,如下图:
```bash
hadoop@zc-virtual-machine:~$ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (本地环回)
RX packets 14229 bytes 1056774 (1.0 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 14229 bytes 1056774 (1.0 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
```
IP变为了127.0.0.1,难怪会报错,此时我的core-site.xml配置的还是之前的IP地址。
查询了下资料,找到了修改方法
使用**dhclient**命令([dhclient命令传送门](https://www.linuxcool.com/dhclient)),注意要使用sudo命令,以免权限不够。。如下图:
```bash
hadoop@zc-virtual-machine:~$ sudo dhclient -v
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Listening on LPF/ens33/00:0c:29:38:05:a8
Sending on LPF/ens33/00:0c:29:38:05:a8
Sending on Socket/fallback
DHCPDISCOVER on ens33 to 255.255.255.255 port 67 interval 3 (xid=0x13399c1d)
DHCPOFFER of 192.168.19.128 from 192.168.19.254
DHCPREQUEST for 192.168.19.128 on ens33 to 255.255.255.255 port 67 (xid=0x1d9c3913)
DHCPACK of 192.168.19.128 from 192.168.19.254 (xid=0x13399c1d)
bound to 192.168.19.128 -- renewal in 701 seconds.
```
再次查看虚拟机IP,
```bash
hadoop@zc-virtual-machine:~$ ifconfig
ens33: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.19.128 netmask 255.255.255.0 broadcast 192.168.19.255
inet6 fe80::20c:29ff:fe38:5a8 prefixlen 64 scopeid 0x20<link>
ether 00:0c:29:38:05:a8 txqueuelen 1000 (以太网)
RX packets 13 bytes 1708 (1.7 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 41 bytes 6076 (6.0 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
```
操作成功
之后启动Hadoop,没有报错误,使用**jps**命令查看进程,如下图:
```bash
hadoop@zc-virtual-machine:~$ /usr/local/hadoop/hadoop-3.2.2/sbin/start-dfs.sh
Starting namenodes on [192.168.19.128]
Starting datanodes
Starting secondary namenodes [zc-virtual-machine]
hadoop@zc-virtual-machine:~$ jps
4897 DataNode
5218 Jps
5109 SecondaryNameNode
4766 NameNode
```
服务启动成功!
Hadoop服务启动失败的更多相关文章
- 玩转Windows服务系列——无COM接口Windows服务启动失败原因及解决方案
将VS创建的Windows服务项目编译生成的程序,通过命令行 “服务.exe -Service”注册为Windows服务后,就可以通过服务管理器进行管理了. 问题 通过服务管理器进行启动的时候,发现服 ...
- CentOS 7下MySQL服务启动失败的解决思路
今天,启动MySQL服务器失败,如下所示: [root@spark01 ~]# /etc/init.d/mysqld start Starting mysqld (via systemctl): Jo ...
- paip.花生壳 服务启动失败 以及不能安装服务,权限失败的解决
paip.花生壳 服务启动失败 以及不能安装服务,权限失败的解决 系统win7 NewPhDDNS_1.0.0.30166.exe 作者Attilax 艾龙, EMAIL:1466519819@ ...
- Sonatype Nexus 服务启动失败问题解决
Sonatype Nexus 服务启动失败问题解决 问题前述: 近日在开发机本机安装了 Oracle 数据库快捷版 11g2 之后,重启电脑后发现本机的maven代理服务无法访问. 现象 通过 Win ...
- oracleDBconsole服务启动失败
问题出现的故障: 在一次正常使用企业管理器后,重新启动计算机,再次启动OracleDBConsoleORCL服务时,报:Windows 不能在 本地计算机 启动 OracleDBConsoleo ...
- “由于下列错误,Parallel port driver 服务启动失败”,注意了
最近在“事件查看器”中发现这么一个错误:“由于下列错误,Parallel port driver 服务启动失败”, 我到网上搜索了一下,发现很多网页上都说解决办法: 把HKEY_LOCAL_MACHI ...
- ipv6禁用导致rpcbind服务启动失败实例
ipv6禁用导致rpcbind服务启动失败实例 昨天在做服务器磁盘分区扩容的时候出现过一个服务启动的问题,在此记录.情景再现:前天晚上申请做磁盘扩容,得到批准后,昨天早上5点开始做停机调整维护 ...
- win2003 HookPort 服务启动失败的解决办法!
Win2003系统每次开机启动时都弹出个对话框报HookPort 服务启动失败,很多网友都遇到同类问题,问题根源是360安全卫士引起的,官方一直没有给出解决方案 问题描述:Win2003系统每次开机启 ...
- SQL SERVER 服务启动失败
好久没用SQL SERVER了.今天启动SQL,发现服务启动失败.报错例如以下:--错误发生 1069-(因为登录失败而无法启动服务.) .百度一下,解决方式例如以下: 请按下列步骤操作: 1.右键单 ...
- CentOS下,mysql服务启动失败
mysql服务启动失败,可以使用排除法查找原因: 如果修改了my.cnf后重启mysql服务失败,大多数情况下都是配置文件有错误, 可以通过备份原来的配置文件,然后将配置文件清空,只剩下[mysqld ...
随机推荐
- 空间数据格式(地理数据格式):GeoJSON(FeatureCollection)与EsriJSON(FeatureSet/ArcGIS格式)
一.FeatureCollection(GeoJSON)格式介绍 https://learn.microsoft.com/en-us/javascript/api/azure-maps-control ...
- fastapi loguru
使用loguru记录日志 安装 pip install loguru 基本使用 那么这个库怎么来用呢?我们先用一个实例感受下: In [1]: from loguru import logger .. ...
- 实践:基于腾讯云播放器SDK,带您体验播放多场景下的 COS 视频文件
一. 实践步骤 1. 准备您的 腾讯云COS 视频文件链接,您需要: 1.1 创建一个存储桶: 1.2 上传对象: 1.3 在对象信息详情里复制对象地址: 注意: 目前腾讯云有COS特惠活动,新人1元 ...
- 代码and截图
1.babassl ZUC算法代码: #include <stdio.h> #include <string.h> #include <openssl/crypto.h& ...
- Rsync已过时?替代文件同步软件了解一下
随着企业结构分散化的不断扩大,企业内部和企业间的信息互动更加频繁.越来越多的企业要求内部各种业务数据在服务器.数据中心甚至云上能够有实时的同步留存.所以,企业需要文件同步软件,通过在两个或更多设备之间 ...
- js 时间 日期
date.getYear(); // 获取当前年份(2 位) date.getFullYear(); // 获取完整的年份(4 位, 1970-????) date.getMonth(); // 获取 ...
- 【SQL Server】列名首字母大写
使用UPPER 和 LOWWER函数组合首字母大写.例如: 1 SELECT user_id,(UPPER(LEFT(name,1) ) + RIGHT(name , LEN(name) -1) )A ...
- 058_Component Bundles
- git reset 加不加 --hard的区别
通常我们提交代码一般都是 git add ,git commit -m, git push的这么个流程.添加到暂存区,提交到git库生成版本号,push到远程仓库以供他人可以使用.这是一个完整的且 ...
- pg_freespacemap查看表膨胀
pg_freespacemap模块提供一种检查自由空间映射(FSM)的手段.它提供一个名为pg_freespace的函数,或精确的说是两个重载函数.该函数在一个给定的页面或关系中的所有页面的自由空间映 ...