java部署:CentOS 7下Tomcat安装与配置教程(Tomcat开机启动)
一、前言
1、本教程主要内容
- Tomcat安装与基础配置
- Tomcat开机启动配置
2、本教程适用范围与环境信息
- 适用范围
| 软件/工具 | 版本说明 |
|---|---|
| CentOS | CentOS 7 |
| Tomcat | Tomcat 7 + |
- 本教程环境信息
| 软件/工具 | 版本说明 |
|---|---|
| CentOS | CentOS 7 |
| Tomcat | Tomcat 8.5 |
| JDK | 1.8 |
3、准备工作?
二、Tomcat部署过程
1、Tomcat下载与目录配置
- 下载Tomcat
#打开下载目录
cd /home/download
#下载tar包
wget http://mirrors.hust.edu.cn/apache/tomcat/tomcat-8/v8.5.24/bin/apache-tomcat-8.5.24.tar.gz
Tomcat7官网下载地址:https://tomcat.apache.org/download-70.cgi
Tomcat8官网下载地址:https://tomcat.apache.org/download-80.cgi
- 配置tomcat目录
# 创建tomcat目录
sudo mkdir /usr/tomcat
#解压到指定目录
sudo tar -zvxf apache-tomcat-8.5.24.tar.gz -C /usr/tomcat
#改名目录名为tomcat8
mv /usr/tomcat/apache-tomcat-8.5.24 /usr/tomcat/tomcat8
2、Tomcat指定JDK配置
如果系统默认的JDK版本是JDK 1.8.x,那么可以省略此步骤
如果系统中需要部署多Tomcat,例如:Tomcat 7+JDK 7,Tomcat 8 + JDK 8共存那么则需要进行以下配置:
本机默认Java版本可以通过命令 java -version 查看
- 修改catalina.sh文件
#修改catalina.sh
vi /usr/tomcat/tomcat8/bin/catalina.sh
#增加如下配置:
export JAVA_HOME=/usr/java/jdk1.8.0_151
- 修改setclasspath.sh文件
#修改setclasspath.sh
vi /usr/tomcat/tomcat8/bin/setclasspath.sh
#增加如下配置:
export JAVA_HOME=/usr/java/jdk1.8.0_151
其中/usr/java/jdk1.8.0_151,是因为ken.io测试的服务器JDK8在这个目录
,实际部署时替换成所在服务器jdk目录即可
3、Tomcat端口修改与防火墙配置
- 修改端口
非必要操作,如果需要部署多Tomcat,则需要修改端口
#修改server.xml
vi /usr/tomcat/tomcat8/conf/server.xml
找到如下行,Tomcat默认端口为8080,按照自己需求修改即可
<Connector port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"
redirectPort="8443" />
- 开放端口
#开放8080端口
firewall-cmd --add-port=8080/tcp --permanent && firewall-cmd --reload
#重新加载防火墙规则
firewall-cmd --reload
4、Tomcat启动与关闭
- 启动/停用
#启动
cd /usr/tomcat/tomcat8/bin && sh startup.sh
#停用
cd /usr/tomcat/tomcat8/bin && sh shutdown.sh
通过浏览器访问 ip:8080
三、配置Tomcat开机启动
配置Tomcat开机启动很简单,将Tomcat配置为系统服务并配置为开机启动即可。
1、将Tomcat配置为系统服务
#创建Tomcat8服务文件
vi /usr/lib/systemd/system/tomcat8.service
#tomcat8.service文件内容:
[Unit]
Description=Tomcat8
After=syslog.target network.target remote-fs.target nss-lookup.target
[Service]
Type=forking
ExecStart=/usr/tomcat/tomcat8/bin/startup.sh
ExecReload=/usr/tomcat/tomcat8/bin/startup.sh
ExecStop=/usr/tomcat/tomcat8/bin/shutdown.sh
[Install]
WantedBy=multi-user.target
2、将Tomcat服务配置开机启动
#设置Tomcat8开机启动
systemctl enable tomcat8
#启动tomcat8服务
systemctl start tomcat8
原文地址:https://ken.io/note/centos7-tomcat-setup
java部署:CentOS 7下Tomcat安装与配置教程(Tomcat开机启动)的更多相关文章
- Linux/CentOS环境下如何安装和配置PhantomJS工作环境
PhantomJS 是一个基于WebKit的服务器端 JavaScript API.它全面支持web而不需浏览器支持,其快速,原生支持各种Web标准: DOM 处理, CSS 选择器, JSON, C ...
- windows系统下同时启动三台Tomcat服务的配置&并设置开机启动服务
1.tomcat 7.0.82下载地址:链接:https://pan.baidu.com/s/1i51pAgl 密码:mxol 2.解压apache-tomcat-7.0.82-windows-x64 ...
- Linux CentOS 7下Memcached 安装与配置
前言 本篇文章记录一下Linux CentOS 7中关于Memcached的安装与配置. 安装 安装memcached之前首先需要安装libevent,我这里用的版本是: •libevent-2.0. ...
- Apache Tomcat 安装与配置教程
JDK的安装与配置 1. 从官网下载JDK https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-213315 ...
- CentOS下nginx+php的配置及nginx开机启动配置
关闭防火墙 (不然外链接是访问不了 apache) service iptables stop 关闭安全系统 SELinux( 不然报403 访问页面错误 ) 1.Nginx安装主要在于配置文件的修改 ...
- 转:CentOS7 下 Redis4 安装与配置教程(Redis开机启动)
转 https://ken.io/note/centos7-redis4-setup 一.前言 1.本教程主要内容 Redis安装与测试 Redis远程访问配置 Redis开机启动配置 2.本教程环境 ...
- CentOS 7下JumpServer安装及配置
环境 系统 # cat /etc/redhat-release CentOS Linux release 7.4.1708 (Core) # uname -r 3.10.0-693.21.1.el7. ...
- Linux CentOS 7 下 JDK 安装与配置
前言 简单记录一下在CentOS 7中安装配置JDK 1.7的全过程~ ( 安装别的版本或者jre一样) 下载 首先是jdk 1.7 64bit & 32bit的下载地址: jdk-7u79 ...
- Rust第一次---centos 7下的安装,配置,测试
现在安装都依赖于网络,命令比较简单. 一,运行脚本,安装runstup 1,运行如下脚本: curl https://sh.rustup.rs -sSf | sh 2,输入默认项1,完成余下的安装 二 ...
随机推荐
- apache基础,apache环境搭建,apache的3种使用方式(IP、端口、域名)
一台服务器上多个网站同时运行,基于域名访问,IP访问,端口访问. http服务使用的端口是80 HTTPS使用的是443 协议名称://机器地址:端口号/路径名/文件名 协议名称—— 所使用的访问协议 ...
- 实验报告(五)&第七周学习总结
实验目的 理解抽象类与接口的使用: 了解包的作用,掌握包的设计方法. 实验要求 掌握使用抽象类的方法. 掌握使用系统接口的技术和创建自定义接口的方法. 了解 Java 系统包的结构. 掌握创建自定义包 ...
- Linux shell 常用命令大全 每日一更
大一上学期学习了Linux的基本操作,已经很久没使用了,虚拟机也近半年没开(作为一个计算机类专业的少年真的不应该).为了补回这些知识和为将来的学习打下基础,现在每天更新一条shell命令及其子命令,欢 ...
- Action.c(28): Error -27796: Failed to connect to server "xxxx": [10060] Connection timed out
Error -27796: Failed to connect to server "125.93.51.230:8080": [10061] Connection refused ...
- Python for Eclipse插件Pydev安装后eclipse里面看不到
反复安装几次在eclipse里面都找不到,崩溃了,有的说是pydev版本不对,应该和python版本一致,都是扯淡,去pydev官网看了下requirement原来是需要Java1.7+以上,安装1. ...
- 在Linux上搭建私有git仓库
最近在学Linux,顺便将自己的服务器用起来,不然又得废弃一年.这次是跟着网上的教程做一个简单的git私有仓库,复杂完整的git系统还需使用gitlib系统. 首先在linux上安装git yum i ...
- web storage 简单的网页留言版
html <!DOCTYPE html> <html> <head> <meta charset="utf-8" /> <ti ...
- 【串线篇】面向切面编程AOP
面向切面编程AOP 描述:将某段代码“动态”的切入到“指定方法”的“指定位置”进行运行的一种编程方式 (其底层就是Java的动态代理)spring对其做了简化书写 场景: 1).AOP加日志保存到数据 ...
- jsp获取url路径的方法
如果你请求的URL是 http://localhost:8080/demo/Index.jsp request.getScheme() //输出:http request.getServerName ...
- fiddler 抓取手机http/https包
测试需求: 安装有 fiddler 的电脑台 博主fiddler 4: 手机系统不限制智能手机就行,能连接wifi即可: 首先在fiddler这边配置一下(请不要问我为什么没有汉化毕竟free) ...