Eclipse启动和手动启动tomcat访问localhost:8080显示404问题总结
建议对tomcat的文件结构和相关属性有较多了解。本文以eclipse的DynamicWebProject为讲解对象。
- eclipse添加tomcat关联注意点
- tomcat404问题归总(按可能性由大到小排序)
- 我的404:web.xml配置与文件路径--新手常遇
- 第一个helloworld!
- windows-preferences-server-RuntimeEnvironment,点add添加。注意JRE不要在默认的workbench default jre上,换成你的jre版本。忘记了的话可以再次打开点Edit进行修改。
- 配置Tomcat的serverlocation。双击Servers的Tomcat进入Overview,ServerLocation里选UseTomcatinstallation(……)。注意Deploypath,这是配置目录。
- Tomcat的serverlocation中的选项不能改。简单,删掉Tomcat下的所有项目,再右键它,点“clean…”。
- 怎么用:菜单Run as,正常选择,next,要运行的项目放进Configured。如果在右键里选Rnu As,会运行右键时选中的文件,如果这个文件路径不小心弄的有问题,就会出现404 错误,找不出路径问题就会卡到想砸电脑。
- Web.xml配置问题。文件路径问题。
- Server.xml的配置问题。
- tomcat设置问题。
- Webapps-ROOT里没东西。
- 端口8080占用。
- 环境变量问题。
- 防火墙问题。(罕见,金色稀有(*^__^*) )
- eclipse启动tomcat会修改conf-web.xml内容,以及其他文件,想手动启动tomcat进行localhost:8080访问的请先copy原来的web.xml到相应目录。所改文件即eclipse里server目录的文件,如下图:

- Eclipse里DynamicWebProject项目部署会在tomcat创建一个文件夹,这个文件夹就是在添加tomcat时的Deploypath配置目录,默认为wtpwebapps,与webapps同级,在其中会有一个默认的ROOT默认目录和创建的项目文件。项目文件名是eclipse中的项目名,但是其中的文件是项目的WebContent(或WebRoot)内的文件,jsp文件就在其中,这与webapps里的项目一样。
(说是动态页面有些牵强)
eclipse,WebContent下新建jsp文件,在body标签中写入
1 <%out.println("Hello World!");%>
Eclipse启动和手动启动tomcat访问localhost:8080显示404问题总结的更多相关文章
- eclipse启动tomcat访问localhost:8080报404
直接双击tomcat\bin目录下面的startup.bat启动 是没问题 的 但是eclipse启动tomcat访问localhost:8080报404 解决方案如下: 双击红色圈里面的tomcat ...
- Tomcat服务器启动后访问localhost:8080显示404的原因
原因:在eclipse中关联了Tomcat服务器 重点来了,如果你是在eclipse中点击启动按钮启动的Tomcat 那么Tomcat不会默认部署它自己的测试项目(也就是大猫localhost:808 ...
- tomcat 输入localhost:8080显示404 (找不到tomcat主页)
最近使用tomcat时常出现一个问题,tomcat开启后浏览器输入localhost:8080时显示404,但是输入项目的路径是可以看到效果的,因为没啥大碍,所以没有在意 [ 在这里顺便介绍几种访问 ...
- tomcat正常启动输入localhost:8080显示404错误
找了半天才解决. 看这个贴子: https://www.cnblogs.com/lovelanglangyou/p/7410937.html 简而言之: 需要修改eclipse中的server配置,e ...
- eclipse启动tomcat 访问http://localhost:8080 报404错误
eclipse启动tomcat 访问http://localhost:8080 报404错误 Server Locations修改后会变灰,如果需要更改设置,则需要移除与Tomcat服务器关联的项目, ...
- eclipse启动Tomcat服务输入http://localhost:8080/报404解决方法
其实如果Tomcat能够正常启动,而就算输入http://localhost:8080时出现404错误,也不会影响Tomcat作为服务器运行.通过eclipse来启动tomcat会碰到“访问http: ...
- eclipse配置tomcat,访问http://localhost:8080出现404错误
问题:通过eclipse来启动tomcat会碰到“访问http://localhost:8080出现404错误”这样的问题,需要在eclipse中进行一系列的设置才行. 解决:打开eclipse的s ...
- 关于sql server 2008过期导致 MSSQLSERVER服务就无法启动,手动启动就报告错误代码17051。
1.基本现象:MSSQLSERVER服务就无法启动,手动启动就报告17051错误. 2.解决办法: 第一步:进入SQL2008配置工具中的安装中心, 第二步:再进入维护界面,选择版本升级, 第三步:进 ...
- windows下启动mysql服务的命令行启动和手动启动方法
1.图形界面下启动mysql服务. 在图形界面下启动mysql服务的步骤如下: (1)打开控制面板->管理工具->服务,如下图所示: 可以看到Mysql服务目前的状态是未启动(未写已启动的 ...
随机推荐
- at java.net.InetAddress.getLocalHost(InetAddress.java:1475)
今天在centos 安装hadoop安装完成后执行wordcount的时候报如下错误: at java.net.InetAddress.getLocalHost(InetAddress.java:14 ...
- DevExpress VCL 已死-----关于13.1.4的发布。
随着DevExpress VCL 13.1.4 的发布,已基本上宣布了devexpress vcl 已经死亡了. 除了一些bug 修正,没有什么新的东西,每年的订阅费又那么贵,而且delphi 现在已 ...
- python编码(四)
一.预备知识 字符集 1, 常用字符集分类 ASCII及其扩展字符集作用:表语英语及西欧语言.位数:ASCII是用7位表示的,能表示128个字符:其扩展使用8位表示,表示256个字符.范围:ASCII ...
- 使用百度webuploader实现大文件上传
版权所有 2009-2018荆门泽优软件有限公司 保留所有权利 官方网站:http://www.ncmem.com/ 产品首页:http://www.ncmem.com/webapp/up6.2/in ...
- MemCahced 使用及常见问题说明
前言 本文档是针对Memcached使用及常见问题的说明. 一.获取 1. MemCached 官网:http://www.memcached.org 下载:http://memcached.org/ ...
- oracle创建新的用户 创建序列 并生成自动自增
1.用有dba权限的用户登录:sys用户 system 口令:manager 2.创建一个新用户:create user abc identified by 123456; 3.授予DBA权限: gr ...
- Java 容器 LinkedHashMap源码分析1
同 HashMap 一样,LinkedHashMap 也是对 Map 接口的一种基于链表和哈希表的实现.实际上, LinkedHashMap 是 HashMap 的子类,其扩展了 HashMap 增加 ...
- n&&m and n||m 的区别
今天写一道题老是WA最后才发现问题出在了这个地方, 题目说的是当输入的n和m 都为0的时候,结束输入. 于是乎,条件我就写成了while(n&&m),其实这句话的意思是:只有m和n都不 ...
- Android-Xml,PullParser,解析
在上一篇博客,Android-XML格式描述,介绍来XML在Android中的格式: 解析persons.xml文件内容: <?xml version="1.0" encod ...
- TCP/IP协议族分层
协议族的分层抽象,一定意义上来说,每层敬职敬责的做自己的工作,同时也共同完成通讯协议的共同目标. 这是一个垂直划分的抽象层次,挺有意义. 1.链路层/数据链路层/网络接口层 操作系统中的设备驱动程序和 ...