基于在Centos7服务器上使用 yum 安装MySQL5.7到默认路径

在修改文件存储位置的时候,折腾了一番没有将成功将datadir修改为我想要的位置

我决定再尝试一下通过编译源码来自定义安装:

首先下载MySQL5.7的源码文件

https://dev.mysql.com/downloads/mysql/5.7.html#downloads

下载源码文件并上传到服务器

上图中我已经解压完毕

tar zxvf mysql-5.7.24.tar.gz

然后在我的home路径下新建一个mysql文件夹,再在里面新建一个data文件夹

mkdir -p /home/mysql/data

编译源码的基础要有gcc

而且要确保cmake可以使用,如果不可以那就安装

yum -y install make gcc-c++ cmake bison-devel ncurses-devel libaio

现在进入mysql-5.7.24路径下,进行操作

首先进行编译

执行

cmake -DCMAKE_INSTALL_PREFIX=/home/mysql -DMYSQL_DATADIR=/home/mysql/data -DSYSCONFDIR=/etc -DWITH_MYISAM_STORAGE_ENGINE=1 -DWITH_INNOBASE_STORAGE_ENGINE=1 -DWITH_MEMORY_STORAGE_ENGINE=1 -DWITH_READLINE=1 -DMYSQL_UNIX_ADDR=/var/lib/mysql/mysql.sock -DMYSQL_TCP_PORT=3306 -DENABLED_LOCAL_INFILE=1 -DWITH_PARTITION_STORAGE_ENGINE=1 -DEXTRA_CHARSETS=all -DDEFAULT_CHARSET=utf8 -DDEFAULT_COLLATION=utf8_general_ci -DDOWNLOAD_BOOST=1 -DWITH_BOOST=/home/mysql

注意最后面的BOOST,MySQL的安装需要boost,则在编译时指定下载boost,并执行下载下来的路径为mysql

如果没指定则会报错

等待编译成功,然后执行make和make install来安装

make && make install

经过漫长的等待,终于安装成功啦

现在来看看mysql的路径

****************************************************************

由于Centos7默认安装了MariaDB,我已经将其拆卸,但是mysql的用户组以及用户还在,这样我就不需要再创建了

还需要将 /home/mysql赋予给mysql

chown -R mysql:mysql /home/mysql

接下来,进入mysql的bin路径执行命令初始化数据库

./mysql_install_db --basedir=/home/mysql --datadir=/home/mysql/data --user=mysql

拷贝/bin路径下的mysql.server到/etc/init.d路径下

cp /home/mysql/bin/mysql.server /etc/init.d/mysql

配置mysql到环境变量,便于使用命令

vim /root/.bash_profile

添加mysql路径

PATH=$PATH:$HOME/bin:/home/mysql/bin

使用source使其生效

现在可以启动mysql试一下了

systemctl start mysql

报错:没有 /var/lib/mysql(安装的时候忘记截图了)

那就自己建一个

mkdir /var/lib/mysql

权限

chown -R mysql:mysql /var/lib/mysql

再次启动,成功了

设置开机启动(由于不是本机native服务无法使用systemctl)

/sbin/chkconfig mysql on

然后我就遇到了一个大问题:

登陆使用root用户,但是密码是啥呢?在默认安装的时候(使用yum安装)会在/var/log/下有日志文件,里面会有个临时密码用于登陆

但是在这里,启动的日志文件怎么也找不到(log文件在哪呢  /etc下都没有my.cnf,?看到网上其他内容有说需要在初始化前自己创建/var/mysql/log还有需要修改/etc/my.cnf 我这竟然找不到)

他还提示我要我输入随机密码

可我根本就找不到随机密码在哪?

无奈我想到了一个办法,假设我忘记了root的密码,那肯定是有解决办法的,找了相关资料

首先停到mysql服务

systemctl stop mysql

然后切换到mysql的bin路径下

cd /home/mysql/bin 

执行

./mysqld_safe --skip-grant-tables &

然后使用

mysql -p

进入mysql,这时还是会提醒输入password,只要回车就好,终于进到mysql了

然后在里面执行

update mysql.user set authentication_string=password('临时密码') where user='root' and Host = 'localhost';

刷新

flush privileges;

exit退出,使用命令来登陆,输入的密码当然是刚才设置的临时密码

mysql -uroot -p

但是现在还不可以使用sql语句来操作数据库,这相当于我们刚使用临时密码登陆到数据库,最先要做的就是修改密码

ALTER USER 'root'@'localhost' IDENTIFIED BY '你的密码';

现在终于可以操作mysql了,后续的授权远程登陆等等就和前面默认安装的mysql完全相同了

[root@Server-002 bin]# mysql -uroot -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 5
Server version: 5.7.24 Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved. Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners. Type 'help;' or '\h' for help. Type '\c' to clear the current input statement. mysql>


完......

Centos7服务器中通过编译源码安装MySQL的更多相关文章

  1. Linux服务器中OpenSSH的源码编译与升级

                      Linux服务器中OpenSSH的源码编译与升级 https://www.oschina.net/question/12_7383    

  2. Centos7源码安装mysql及读写分离,互为主从

       Linux服务器 -源码安装mysql 及读写分离,互为主从   一.环境介绍: Linux版本: CentOS 7 64位 mysq版本: mysql-5.6.26 这是我安装时所使用的版本, ...

  3. Ubuntu下Ruby的下载和编译源码安装

    1.Ruby的下载 Ruby可以在Ruby 官网上下载,如果想获取更多的Ruby版本,可以到淘宝镜像网站下载. 2.Ruby的编译源码安装 解压 首先把下载下来的源码压缩包解压到自己指定的目录 编译安 ...

  4. centos 6x系统下源码安装mysql操作记录

    在运维工作中经常部署各种运维环境,涉及mysql数据库的安装也是时常需要的.mysql数据库安装可以选择yum在线安装,但是这种安装的mysql一般是系统自带的,版本方面可能跟需求不太匹配.可以通过源 ...

  5. CentOS 7下源码安装MySQL 5.7

    网上说linux安装mysql服务分两种安装方法: ①源码安装,优点是安装包比较小,只有几十M左右,缺点是安装依赖的库多,安装编译时间长,安装步骤复杂容易出错: ②使用官方编译好的二进制文件安装,优点 ...

  6. CentOS 6.4 源码安装MySQL 5.6

    1.安装前准备工作 1.1 必备的包 gcc/g++ :MySQL 5.6开始,需要使用g++进行编译.cmake :MySQL 5.5开始,使用cmake进行工程管理,cmake需要2.8以上版本. ...

  7. 源码安装mysql,及主从同步

    源码安装mysql [可选] 如果用源码安装cmake软件: cd /home/oldboy/tools/ tar xf cmake-.tar.gz cd cmake- ./configure #CM ...

  8. lnux下源码安装MySQL 5.6

    nux下源码安装MySQL 5.6 说明:本文是我自己测试的MySQL5.6源码安装,经本人亲自实践,完全可用,另在5.6之前的版本也是可以按照本文源码安装的.我是在两台linux下一台安装5.5,另 ...

  9. Linux平台下源码安装mysql多实例数据库

    Linux平台下源码安装mysql多实例数据库[root@linux-node1 ~]# netstat -tlunp | grep 330tcp6 0 0 :::3306 :::* LISTEN 6 ...

随机推荐

  1. java虚拟机内存不足,“Could not create the Java Virtual Machine”问题解决方案

    java虚拟机内存不足,"Could not create the Java Virtual Machine"问题解决方案 在运行java程序时,遇到问题"Could n ...

  2. Confluence 6 重构索引缓慢

    你的索引构建是否需要很长时间?索引构建需要的时间是由下面的一些因素确定的: 你 Confluence 安装实例中的页面数量. 附件的数量,类型和大小. Confluence 安装实例可用的内存大小. ...

  3. Flask框架(一)

    Flask框架 Flask本身想当于一个内核,其自身几乎所有功能都依靠扩展(邮件扩展Flask-Mail.用户认证Flask-Login),都需要用第三方的扩展来实现.其WSGI工具箱采用Werkze ...

  4. iis配置问题

    最近调试程序时发现一直用的是vs自带的服务器 当我切换成iis时,发现虽然能显示界面,却连不上数据库 (程序数据库的一系列操作是通过wcf ria完成的) 以前在winserver2012上也遇到过这 ...

  5. ionic在ios侧滑页面空白 禁用视图滑动后退

    本人在ios10左右滑动的时候,经常出现左滑页面后退,然后整个页面空白现象,只能强行退出,并重新登录,最简单的方法就是禁用侧滑后退这个功能: 在app.js上config增加如下: $ionicCon ...

  6. 三.NFS存储服务

    01. 课程回顾 备份服务概念介绍(rsync备份服务利用相应算法,实现增量数据同步) 备份服务工作方式说明: 1. 本地数据备份同步方式(类似cp命令) 2. 远程数据备份同步方式(类似scp命令) ...

  7. linux三剑客

    grep grep       "oldboy"     test.txt   过滤掉文件中oldboy的字符串 -v                               ...

  8. 页面初始化的js函数要放在最最最最最最最前边!否则没效果

    简单说一下这个情况,html的页面的各部分都是动态渲染的,所以头部的某些个样式调用函数需要在页面初始化的时候被加载,这个我也是知道的,结果后边代码敲着敲着,就把这个事儿给忘了,然后启动项目的时候,页面 ...

  9. eclipse maven .jar中没有主清单属性

    报错环境: windows系统eclipse maven 打包jar包后, 运行 java -jar 报错 E:\My_java\mysql\target>java -jar original- ...

  10. 课外知识----ini

    ini    初始化英文单词的缩写,用来初始化参数 ini文件配置 [小节] 键=值 [小节] 键=值