liunx 安装 mysql 5.6
第一步 解压文件
目录切换到/usr/local/
cd /usr/local/
解压 tar zxvf mysql-5.6.33-linux-glibc2.5-x86_64.tar.gz
重命名为 mysql
第二步 添加用户组和用户添加用户组
groupadd mysql
添加mysql用户useradd -g mysql mysql
修改目录为拥有者为mysql用户
cd mysql
chown -R mysql:mysql ./
第三步 安装mysql
./scripts/mysql_install_db --user=mysql --datadir=/usr/local/mysql/data
不开心的是报错了

解决办法
安装autoconf库
yum install -y perl-Data-Dumper
也有可能报这个错截图如下(该错误是另外一次安装是遇见的)

解决办法 安装 libaio库文件
yum install libaio* -y
第四步 修改当前用户为root用户
chown -R root:root ./
修改data目录拥有者为mysql用户
chown -R mysql:mysql data
第五步 把mysql客户端放到默认目录下
ln -s /usr/local/mysql/bin/mysql /usr/bin
第六步 登录mysql
mysql -uroot -p
第一次不用输入密码 直接按enter进入下一步
这里有报错 socket路径有问题

打开/etc/my.cnf 文件
vi /etc/my.cnf 可以看到socket=/var/lib/mysql/mysql.sock 和/tmp/mysql.sock目录不一致
解决办法 创建软连接
ln -s /var/lib/mysql/mysql.sock /tmp/mysql.sock
启动mysql
service mysqld start 或者 systemctl start mariadb.service
这里有报错
Starting MySQL.The server quit without updating PID file (/[FAILED]l/mysql/data/iZuf6gjb9m90kycy585scnZ.pid).
修改 /etc/my.cnf 文件
[mysqld]中 将datadir = /usr/local/mysql/data
log-error = /usr/local/mysql/data/error.log
pid-file = /usr/local/mysql/data/mysql.pid
user = mysql
tmpdir = /tmp
开启bin_log日志
log-bin=/usr/local/mysql/data/mysql-bin
退出 重新初始化数据库 全部指明文件的位置
./mysql_install_db --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --pid-file=/usr/local/mysql/data/mysql.pid --tmpdir=/tmp
修改权限为root
[root@localhost mysql]# chown -R root:root .
[root@localhost mysql]# chown -R mysql:mysql data
添加启动服务
[root@localhost mysql]# cp support-files/mysql.server /etc/init.d/mysql
# 添加服务
chkconfig --add mysql
[root@localhost mysql]# service mysql start
查看开启的服务(chkconfig --list)
再次启动myslq service mysqld start (CentOS7.0 以上启动命令: /bin/systemctl start mysqld.service)
启动成功
Starting MySQL. [ OK ]
登陆mysql
mysql -uroop -p
初次进去mysql 没有密码 直接按enter进入msyql
查看数据库
show databases;

CentOS 7 以上版本 将mysql 全部改为mariadb ,mariadb就是mysql创始人女儿的名字 。所以也有可能一下这种情况。
(查看liunx Centos版本 命令:cat /etc/redhat-release)

第七步 修改root 用户密码
use mysql;
select user,password , host from user;

mysql> update user set password='xxx' where user='root';(这样是不行的)
刷新权限表使之有效
flush privileges;
退出 quit;
测试一下修改的密码 重新进入mysql
这次发现密码不正确
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
原因是上一步更新密码时候语句不正确
不输入密码直接按enter是可以进入mysql
但是这时候发现什么都干不了

解决办法 修改/etc/my.cnf文件
在[mysqld]下面添加 skip-grant-tables 启动mysql是不启动授权表
重新进入mysql 这个时候是可以操作了
在查一下刚刚设置的密码,为什么不对
mysql> select user,password , host from user;
+------+-----------+-------------------------+
| user | password | host |
+------+-----------+-------------------------+
| root | xxx | localhost |
| root | xxx | izuf6gjb9m90kycy585scnz |
| root | xxx | 127.0.0.1 |
| root | xxx | ::1 |
| | | localhost |
| | | izuf6gjb9m90kycy585scnz |
+------+-----------+-------------------------+
第八步 重新更新密码
update user set password =password('xxx') where user='root';
刷新flush privileges;退出quit;
再将/etc/my.cnf中添加的skip-grant-tables 去掉。
重新进入mysql 这时候密码是正确的
给远程用户授权
在本服务器中是可以登录的,但是用客户端是没法登录的,提示没有登录权限,需要给远程用户授权
grant all privileges on *.* to 'root'@'%' identified by 'xxx' with grant option;
刷新权限表 flush privileges;
再等录成功!
liunx 安装 mysql 5.6的更多相关文章
- liunx 安装mysql数据库
yum 安装rz/sz yum install -y lrzsz 卸载Mariadb数据库 查询所安装的MariaDB组件: [root@localhost logs]# rpm -qa | gr ...
- Liunx 安装 Mysql 5.7
#[安装 Mysql 5.7] # 00.系统目录说明# 安装文件下载目录:/data/software# Mysql目录安装位置:/usr/local/mysql# 数据库保存位置:/data/my ...
- 分享知识-快乐自己:Liunx 安装MySQL
第一步: 1):下载mysql安装包:这里选择下载版本 5.6.33,通用版,linux下64位 http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql- ...
- MySQL++:liunx 安装 MySQL
第一步: 1):下载mysql安装包:这里选择下载版本 5.6.33,通用版,linux下64位 http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql- ...
- linux django 知识点 安装mysql数据库 和 pycharm
django 命令及相关知识点 1. 启动 pycharm 命令:sh pycharm.sh 2. 创建 django 项目 : django-admin.py startproject Hello ...
- liunx下mysql数据库使用之三范式,关系模型设计注意项,安装目录结构
数据库的三范式第一范式===>每行记录的属性,是原子的,拆到不可拆为止.===>例如:一个人的籍贯,可以拆分为,省,市,县,乡,村 第二范式===>每行记录的非主属性(非主键属性), ...
- liunx环境下安装mysql数据库
一:如果你的机器上之前安装有mysql数据库,先进行卸载 (1)需要先将它的文件删除 (2)同时注意删除老板本的etc/my.cnf文件和/etc/mysql目录,这两个文件控制的是mysql的一些配 ...
- liunx下安装mysql没有初始密码的解决方法
#/etc/init.d/mysql stop #cd /usr/local/mysql #mysqld_safe --user=mysql --skip-grant-tables --skip-ne ...
- liunx系统下安装mysql数据库5.7.13版本
一:在/usr/local目录下解压安装包
随机推荐
- ffmpeg安装
使用 yum 安装nux-dextop 源. 下载:wget http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0- ...
- 使用select正确处理EOF的str_cli函数
void str_cli(FILE *fp, int sockfd) { int maxfdp1, stdineof; fd_set rset; char buf[MAXLINE]; int n; s ...
- matplotlib的安装和允许中文及几种字体
安装 python -m pip install matplotlib 允许中文: 使用matplotlib的字体管理器指定字体文件 plt.rcParams['font.sans-serif'] ...
- TensorFlow从入门到理解
一.<莫烦Python>学习笔记: TensorFlow从入门到理解(一):搭建开发环境[基于Ubuntu18.04] TensorFlow从入门到理解(二):你的第一个神经网络 Tens ...
- 第20月第29天 cocoa抽象工厂 cocoapods组件化 cocoapods升级
1. 在 Cocoa Touch 框架中,类簇是抽象工厂模式在 iOS 下的一种实现,以 NSArray 举例,将原有的 alloc+init 拆开写: id obj1 = [NSArray allo ...
- python后端将svc文件数据读入数据库具体实现
如何用python将svc文件的数据读入到MySQL数据库里,在此直接上代码了,感兴趣的朋友可以贴代码测试: import pandas as pd import os from sqlalchemy ...
- LinkedHashMap实现LRU缓存算法
LinkedHashMap的get()方法除了返回元素之外还可以把被访问的元素放到链表的底端,这样一来每次顶端的元素就是remove的元素. 构造函数如下: public LinkedHashMap ...
- jq的load
1.用于监听加载是否完成 当指定的元素(及子元素)已加载时,会发生 load() 事件. 该事件适用于任何带有 URL 的元素(比如图像.脚本.框架.内联框架). 根据不同的浏览器(Firefox 和 ...
- cookie——创建、获取、删除
<!DOCTYPE html> <html> <head> <meta charset="UTF-8"> <title> ...
- AOP 横行切面编程和 纵向编程 介绍
1 aop:面向切面(方面)编程,扩展功能不修改源代码实现 2 AOP采取横向抽取机制,取代了传统纵向继承体系重复性代码3 aop底层使用动态代理实现(1)第一种情况,有接口情况,使用动态代理创建接口 ...