下载

访问 https://dev.mysql.com/downloads/mysql/

  • 选择 Red Hat Enterprise Linux / Oracle Linux
  • 选择 Red Hat Enterprise Linux 8 / Oracle Linux (x86, 64-bit)
  • 下载 RPM Bundle (mysql-8.0.26-1.el8.x86_64.rpm-bundle.tar) 这是多个rpm打包的文件

也可以直接在服务器上用wget

wget https://cdn.mysql.com//Downloads/MySQL-8.0/mysql-8.0.26-1.el8.x86_64.rpm-bundle.tar

安装

安装手册 https://dev.mysql.com/doc/refman/8.0/en/linux-installation-rpm.html

yum update
tar xvf mysql-8.0.26-1.el8.x86_64.rpm-bundle.tar
# 按顺序执行
rpm -ivh mysql-community-common-8.0.26-1.el8.x86_64.rpm
rpm -ivh mysql-community-client-plugins-8.0.26-1.el8.x86_64.rpm
rpm -ivh mysql-community-libs-8.0.26-1.el8.x86_64.rpm
rpm -ivh mysql-community-client-8.0.26-1.el8.x86_64.rpm
rpm -ivh mysql-community-server-8.0.26-1.el8.x86_64.rpm

安装server时会要求perl和libaio, 如果没有安装, 需要先用yum install perl libaio安装一下.

上面的安装结束后会提示

[root@db backup]# rpm -ivh mysql-community-server-8.0.26-1.el8.x86_64.rpm
warning: mysql-community-server-8.0.26-1.el8.x86_64.rpm: Header V3 DSA/SHA256 Signature, key ID 5072e1f5: NOKEY
Verifying... ################################# [100%]
Preparing... ################################# [100%]
Updating / installing...
1:mysql-community-server-8.0.26-1.e################################# [100%]
[/usr/lib/tmpfiles.d/mysql.conf:23] Line references path below legacy directory /var/run/, updating /var/run/mysqld → /run/mysqld; please update the tmpfiles.d/ drop-in file accordingly.

参考

  • https://access.redhat.com/solutions/4154291, Due to the systemd change, any package using /var/run will need to be updated to attempt to remove the logs., 根据Systemd的修改, 任何使用 /var/run 这个目录的软件都需要更新路径来避免出现这个提示.
  • https://bugs.gentoo.org/768051 A workaround of this case is to edit /usr/lib/tmpfiles.d/mysql.conf, Do not edit /usr/lib/tmpfiles.d/mysql.conf. Copy that file to /etc/tmpfiles.d and edit it there if you need to.

需要复制 /usr/lib/tmpfiles.d/mysql.conf 到 /etc/tmpfiles.d/,

cp /usr/lib/tmpfiles.d/mysql.conf /etc/tmpfiles.d/
vi /etc/tmpfiles.d/mysql.conf

将最后一行

d /var/run/mysqld 0755 mysql mysql  -

改为

d /run/mysqld 0755 mysql mysql  -

安装的过程中除了安装MySQL自身, 会对系统做以下修改

  • 添加group:mysql, user:mysql

    可以通过more /etc/passwd, more /etc/group查看
  • 添加服务mysqld, 并被设为enabled

    可以通过more /usr/lib/systemd/system/mysqld.service查看
  • 安装过程中如果产生错误, 会被记录到 /var/log/mysqld.log

文件打开数量限制

如果使用Centos8官方的CloudImage镜像, 默认的打开文件数为1024, 可以修改 /etc/security/limits.conf , 增加两行

*                soft    nofile          10240
* hard nofile 10240

然后重启

运行

启动服务前, 修改数据目录

编辑 /etc/my.cnf , 修改

datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

修改为

datadir=/data/mysql
socket=/var/lib/mysql/mysql.sock log-error=/var/log/mysqld.log
pid-file=/run/mysqld/mysqld.pid

注意: 如果修改了socket=/var/lib/mysql/mysql.sock, 那么需要增加client配置, 否则本地执行mysql -uroot -p会提示无法连接socket

SELinux错误

如果出现这样的错误

SELinux is preventing /usr/sbin/mysqld from write access on the directory mysql

检查对比一下原目录和新目录的selinux权限

ls -Zl /var/lib/mysql
...
-rw-r-----. 1 mysql mysql system_u:object_r:mysqld_db_t:s0 16777216 Oct 18 16:09 undo_002
ls -Zl /data/mysql/
...
-rw-r-----. 1 mysql mysql system_u:object_r:default_t:s0 16777216 Oct 18 16:14 undo_002

可以看到差一个mysqld_db_t, 用下面的命令将原目录的selinux权限赋给新的目录

semanage fcontext -a -e /var/lib/mysql /data/mysql

用chcon -R -t mysqld_db_t /data/mysql/命令不行, 启动还会报错mysql Activating service name='org.fedoraproject.Setroubleshootd'这样的错误, 参考这篇关于selinux和mysql的详细解释

之后重启就没问题了

初次启动时, 会产生的修改

第一次启动MySQL服务时, 如果发现data目录是空的, 会进行如下操作

  • 初始化服务器
  • 在data目录下创建 SSL certificate 和 key
  • 安装并启用 validate_password
  • 创建用户 'root'@'localhost', 随机口令写入到 error log 文件, 通过以下命令查看
# RHEL, Oracle Linux, CentOS, and Fedora systems:
sudo grep 'temporary password' /var/log/mysqld.log
# SLES systems:
sudo grep 'temporary password' /var/log/mysql/mysqld.log

注意

如果你初始化完改完密码, 又换了个新的数据目录, 那么mysqld会又进行一次初始化工作, 之前设置的密码是无效的, 要重新去日志里查一下.

初次登录

用安装程序产生的随机口令登录后, 创建新口令

$ mysql -uroot -p
mysql> ALTER USER 'root'@'localhost' IDENTIFIED BY 'MyNewPass4!';

注意 因为默认安装并启用了validate_password, 所以口令必须满足以下全部条件: 至少一个大写字母+至少一个小写字母+至少一个数字+至少一个符号+总长度不低于8.

开启远程访问

如果要从远程访问, 或者用mysql-shell管理, 需要开放用户的远程访问

方法一

创建另一个 root 用户 (因为存在的是 'root@localhost')

CREATE USER 'root'@'%' IDENTIFIED BY '123';

Give the privileges:

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%';

从 MySQL 8 开始, 不能在创建用户时带 GRANT 参数, 要分开执行:

mysql> CREATE USER 'admin'@'192.168.0.0/255.255.0.0' IDENTIFIED BY 'PASSWORD';
mysql> GRANT ALL PRIVILEGES ON *.* TO 'admin'@'192.168.0.0/255.255.0.0' WITH GRANT OPTION;
-- or
CREATE USER 'admin'@'192.168.12.0/24' IDENTIFIED BY 'PASSWORD';
mysql> GRANT ALL PRIVILEGES ON *.* TO 'admin'@'192.168.12.0/24' WITH GRANT OPTION;
-- or
mysql> CREATE USER 'root'@'%' IDENTIFIED BY 'PASSWORD';
mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION;

最后

mysql> FLUSH PRIVILEGES;

方法二

修改原 root 用户

UPDATE mysql.user SET host='%' WHERE user='root';
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%';
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION;

配置优化和调整

sql_mode

MySQL8默认的服务器模式 The default SQL mode in MySQL 8.0 includes these modes:

ONLY_FULL_GROUP_BY, STRICT_TRANS_TABLES, NO_ZERO_IN_DATE, NO_ZERO_DATE, ERROR_FOR_DIVISION_BY_ZERO, NO_ENGINE_SUBSTITUTION

NO_AUTO_CREATE_USER在MySQL8中已经被移除.

模式的说明

  • ONLY_FULL_GROUP_BY

    没有在Group By中的字段, 将被禁止出现在select中, 对于有些项目, 这个选项需要关闭. Reject queries for which the select list, HAVING condition, or ORDER BY list refer to nonaggregated columns that are neither named in the GROUP BY clause nor are functionally dependent on (uniquely determined by) GROUP BY columns. A MySQL extension to standard SQL permits references in the HAVING clause to aliased expressions in the select list. The HAVING clause can refer to aliases regardless of whether ONLY_FULL_GROUP_BY is enabled.
  • STRICT_TRANS_TABLES

    对事务型存储引擎, 启用严格SQL模式, 对非事务型则能启用就启用, 这个选项是一定要开的. Enable strict SQL mode for transactional storage engines, and when possible for nontransactional storage engines. For details, see Strict SQL Mode.
  • NO_ZERO_IN_DATE,

    这个选项是要开的, 这个选项已经是deprecated了, 在将来的版本这个选项会被合并到严格SQL模式中默认开启.

    NO_ZERO_IN_DATE: 是否允许时间数据出现年份非0但是月份或天为0的记录. 像'2010-00-01'和'2010-01-00'是不允许的, 但是'0000-00-00'不受这个选项影响. NO_ZERO_IN_DATE也受是否启用严格SQL模式影响:

    • 如果未设置 NO_ZERO_IN_DATE, 那么为0的字段都是可以写入的也不会报warning
    • 如果设置了 NO_ZERO_IN_DATE, 那么带0的字段的日期, 会被记为'0000-00-00'同时报一个warning.
    • 如果设置了 NO_ZERO_IN_DATE, 同时还开启了严格SQL模式, 带0字段的日期就不能写入了, 会报错(除非带IGNORE). 对于 INSERT IGNORE 和 UPDATE IGNORE, 带0字段的日期会被记为'0000-00-00'并产生一个warning.
  • NO_ZERO_DATE

    这个选项也要开, NO_ZERO_DATE 这个选项是用来禁止'0000-00-00'的, 这个选项也deprecated了, 在将来的版本这个选项会被合并到严格SQL模式中默认开启.
  • ERROR_FOR_DIVISION_BY_ZERO

    就是字面的意思, 是否允许0除, 也要开. 这个选项也deprecated了, 在将来的版本这个选项会被合并到严格SQL模式中默认开启.
  • NO_ENGINE_SUBSTITUTION

    是否自动用默认的存储引起代替, 如果CREATE TABLE 或 ALTER TABLE 指定的存储引擎不存在(未编译)或被禁用了. 默认启用.

在项目中可以关闭的只有ONLY_FULL_GROUP_BY, 用于兼容一些GROUP BY语句.

sql_mode=STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_
ZERO,NO_ENGINE_SUBSTITUTION

其它变量

根据服务器内存大小自行调整

join_buffer_size = 128M
sort_buffer_size = 8M
read_rnd_buffer_size = 8M
key_buffer_size=32M
max_allowed_packet=16M
read_buffer_size = 4M
tmp_table_size = 128M
max_connections = 256
max_heap_table_size = 256M

对应Java项目的修改

依赖修改为

<dependency>
<groupId>mysql</groupId>
<artifactId>mysql-connector-java</artifactId>
<scope>runtime</scope>
<version>8.0.13</version>
</dependency>

spring boot连接参数变为

spring:
...
datasource:
driver-class-name: com.mysql.cj.jdbc.Driver

参考

Centos8 安装 MySQL8.0.26的更多相关文章

  1. CentOS8 安装MySQL8.0

    2019/11/25, CentOS 8,MySQL 8.0 摘要: CentOS 8 安装MySQL 8.0 并配置远程登录 安装MySQL8.0 使用最新的包管理器安装MySQL sudo dnf ...

  2. CentOS8 安装 MySQL8.0(yum)

    1.Mysql 官网下载 RPM 包wget https://dev.mysql.com/get/mysql80-community-release-el8-1.noarch.rpm2.检查是否已安装 ...

  3. CentOS8安装mysql8.0具体步骤

    操作系统:CentOS Linux release 8.0及以上 Mysql版本:Mysql 8.0.22 x86_64 (MySQL Community Server - GPL) Mysql8下载 ...

  4. centos8安装mysql8.0

    官网下载rpm地址 https://dev.mysql.com/downloads/repo/yum/ wget下载 wget https://repo.mysql.com//mysql80-comm ...

  5. CentOS8.1操作系下使用通用二进制包安装MySQL8.0(实践整理自MySQL官方)

    写在前的的话: 在IT技术日新月异的今天,老司机也可能在看似熟悉的道路上翻车,甚至是大型翻车现场!自己一个人开车过去翻个车不可怕,可怕的是带着整个团队甚至是整个公司一起翻车山崖下,解决办法就是:新出现 ...

  6. Linux(CentOS-8)安装MySQL8.0.11

    CentOS安装MySQL8.0.11 总的思路就是:安装MySQL,编写配置文件,配置环境变量,成功开启服务,登陆并修改ROOT密码 开启远程访问的思路就是:授权用户所有IP都可以访问,系统的数据库 ...

  7. Centos7安装MySQL8.0

    请到这个地址看:https://www.cnblogs.com/kevingrace/p/10482469.html Centos7安装MySQL8.0 - 操作手册 一.yum安装方式: 卸载之前版 ...

  8. CentOS7安装MySQL8.0小计

    之前讲配置文件和权限的时候有很多MySQL8的知识,有同志说安装不太一样,希望发个文,我这边简单演示一下 1.环境安装 下载MySQL提供的CentOS7的yum源 官方文档:<https:// ...

  9. CentOS7.4 源码安装MySQL8.0

    MySQL 8 正式版 8.0.11 已发布,官方表示 MySQL 8 要比 MySQL 5.7 快 2 倍,还带来了大量的改进和更快的性能! 以下为本人2018.4.23日安装过程的记录.整个过程大 ...

  10. centos 7下安装mysql-8.0

    本篇文章主要介绍在centos7 环境下安装mysql8.0并设置为开机自启. 安装步骤 1.配置yum源 首先在 https://dev.mysql.com/downloads/repo/yum/  ...

随机推荐

  1. 26-IP调用 - PLL

    1.PLL IP核简介 PLL(Phaze Locked Loop)锁相环是最常用的IP核之一,其性能强大,可以对输入到FPGA的时钟信号进行任意的分频.倍频.相位调整.占空比调整,从而输出一个期望时 ...

  2. TCP连接状态的多种判断方法

    ​ 前言 在TCP网络编程模型中,无论是客户端还是服务端,在网络编程的过程中都需要判断连接的对方网络状态是否正常.在linux系统中,有很多种方式可以判断连接的对方网络是否已经断开. 通过错误码和信号 ...

  3. 幻兽帕鲁 Palworld 私有服务器一键部署教程

    <幻兽帕鲁>(日语:パルワールド,英语:Palworld) 是由日本开发商 Pocket Pair 推出的一款动作冒险生存游戏.游戏设定在一个由类似动物的生物 "帕鲁" ...

  4. [转帖]mysql 里 CST 时区的坑

    mysql 里 CST 时区的坑 一.问题简述 mysql 里 CST 时区是个非常坑的概念,因为在 mysql 里CST既表示中国也表示美国的时区.但是在Jdk代码里,CST 这个字符串被理解为Ce ...

  5. [转帖]SQL Server 2008~2022版本序列号/密钥/激活码 汇总

    https://www.cnblogs.com/cqpanda/p/16148822.html SQL Server 2022# Enterprise: J4V48-P8MM4-9N3J9-HD97X ...

  6. Oracle Preinstall 调优参数的学习

    Oracle Preinstall 调优参数的学习 背景 学习是一个痛苦并快乐的过程. 之前自己手工安装过很多套Oracle数据库,也总结过很多 但是很多都是比较皮毛的. 最近遇到了一些问题. 才发现 ...

  7. [转帖]MySQL Decimal 的实现方法

    码: 背景 数字运算在数据库中是很常见的需求, 例如计算数量.重量.价格等, 为了满足各种需求, 数据库系统通常支持精准的数字类型和近似的数字类型. 精准的数字类型包含 int, decimal 等, ...

  8. [转帖]harbor-db restarting问题

    现象: 在安装harbor后,启动时发现harbor-db 一直是restarting,/harbor-jobservice,/harbor-core 这两是starting 状态,如下图 解决: 1 ...

  9. [转帖]Kafka生产者——重要参数配置

    https://www.cnblogs.com/luckyhui28/p/12001798.html 目录 acks max.request.size retries和retry.backoff.ms ...

  10. [转帖]Kafka 核心技术与实战学习笔记(七)kafka集群参数配置(上)

    一.Broker 端参数 Broke存储信息配置 log.dirs:非常重要,指定Broker需要使用的若干文件目录路径,没有默认值必须亲自指定. log.dir:他只能表示单个路径,补充上一个参数用 ...