基于Apache和tomcat实现负载均衡
1、基于Apache和tomcat实现负载均衡
准备三个虚拟机一个安装Apache两个安装Tomcat
关闭防火墙
systemctl stop firewalld
Iptabled -F
Setenforce 0
安装Apache
一.通过 https://apr.apache.org/ 下载 APR 和 APR-util
通过 http://httpd.apache.org/download.cgi 下载 httpd
通过 https://ftp.pcre.org/pub/pcre/ 下载 pcre
二、配置安装环境
yum -y install gcc gcc-c++ make expat-devel
三、解压与编译安装
mkdir /data
(1)编译安装 APR
tar xf apr-1.7.0.tar.gz -C /data
cd /data
mv apr-1.7.0/ apr
cd apr/
./configure --prefix=/data/apr && make && make install
(2)编译安装 APR-util
tar xf apr-util-1.6.1.tar.gz -C /data
cd /data
mv apr-util-1.6.1/ apr-util
cd apr-util/
./configure --prefix=/data/apr-util --with-apr=/data/apr && make && make install
(3)编译安装 pcre
tar xf pcre-8.43.tar.gz -C /data
cd /data
mv pcre-8.43/ pcre
cd pcre/
./configure --prefix=/data/pcre && make && make install
(4)编译安装 httpd
tar xf httpd-2.4.41.tar.gz -C /data
cd /data
mv httpd-2.4.41/ apache
cd apache/
./configure --prefix=/data/apache --with-apr=/data/apr --with-apr-util=/data/apr-util && make && make install
四、启动与关闭
/data/apache/bin/apachectl start //启动
/data/apache/bin/apachectl stop //关闭
开放80端口
firewall-cmd --permanent --and-port=80/tcp
firewall-cmd -reload
配置开机自启
(1)将 apachectl 命令拷贝到 /etc/init.d 目录下,改名为httpd
cp /data/apache/bin/apachectl /etc/init.d/httpd
(2)编辑 /etc/init.d/httpd 文件,在第一行 #!/bin/bash 的后面添加如下两行
chkconfig: 2345 70 40
说明:2345 表示脚本运行的级别,即在2、3、4、5这4种模式下都可以运行,70 表示脚本启动的顺序号,40 表示系统关闭时,脚本的停止顺序号
description:apache
(3)将 Apache 服务加入到系统服务
chkconfig --add httpd
chkconfig --list httpd
(4)通过使用 systemctl 命令控制 Apache 的启动和停止
启动 Apache 服务
systemctl start httpd.service
查看 Apache 服务运行状态
systemctl status httpd.service
关闭 Apache 服务
systemctl stop httpd.service
五、安装中遇到的问题以及解决办法
错误:configure:error:no acceptable C compiler found in $PATH
解决:需要安装 gcc
错误:rm:cannot remove ‘libtoolT’:No such file or directory
解决:编辑 /data/apr/configure , 找到 $RM '$cfgfile' 进行注释
错误:configure:error:APR not found. Please read the documentation.
解决:需要安装 APR 和 APR-util
错误:xml/apr_xml.c:35:19: 致命错误:expat.h:没有那个文件或目录
解决:需要安装 expat-devel 包
错误:configure:error:pcre-config for libpcre not found. PCRE is required and availab le from
解决:需要安装 pcre
错误:如果报多个 .so:undefined reference to 'XXX'
解决:有可能是下载的 APR-util 包 有问题。换一个下载就好了。
安装完apache后直接安装httpd服务
yum -y install httpd
源码安装Tomcat
(1)查看是否安装jdk
(2)卸载jdk的方式
方法一:which java
rm -rf /usr/bin/java
方法二:rpm -qa | grep -i openjdk
rpm -e java-1.7.0-openjdk
rpm -e java-1.7.0-openjdk-headless
rpm -e java-1.7.0-openjdk --nodeps
rpm -e java-1.7.0-openjdk-headless
rpm -qa | grep -i openjdk
(3)jdk安装
软件包jdk-8u191-linux-x64.tar.gz
解压当前目录下
用mv 移动到/usr/local/取名
定义环境变量 vim /etc/profile

设置java 根目录
在PATH 环境变量中添加Java 根目录的bin 子目录
用 source执行生效
安装tomcat
apache-tomcat-8.5.40.tar.gz
解压软件包当地

用ls 查看
解压后生成文件夹apache-tomcat-8.5.40
将文件夹移动到/usr/local/下,并改名为tomcat8

启动tomcat
查看8080端口

用谷歌查看本地的ip 地址:8080

安装完apache以及tomcat后
修改/etc/httpd/conf/httpd.conf
把下面的内容写到最后文件的最后,打开文件的80端口
#添加以下内容
<Proxy balancer://tomcat/>
# 定义集群成员,有多少个Tomcat,就加多少行,注意IP、端口
BalancerMember ajp://192.168.200.11:8009/ loadfactor=1 #权重为1
BalancerMember ajp://192.168.200.12:8009/ loadfactor=1
proxyset lbmethod=byrequests #均衡分配
</Proxy>
proxyrequests off #取消正向代理
ProxyPass / balancer://tomcat/ # 定义一个代理服务 语法:ProxyPass 路径 协议://名称/
proxypassreverse / balancer://tomcats/
# 不要代理/server-status路径,注意最后的感叹号
# /server-status路径是Apache里面用来统计、跟踪它本身的运行情况的
ProxyPass /server-status !
# 不要代理集群管理器的路径
ProxyPass /balancer-manager !

通过浏览器访问自己主机的ip


基于Apache和tomcat实现负载均衡的更多相关文章
- Apache和Tomcat 配置负载均衡(mod-proxy方式)-无session共享、无粘性session
转:https://blog.csdn.net/wangjunjun2008/article/details/38268483 mod-proxy方式实现负载均衡是利用了Apache 2.x版本自带的 ...
- Apache和Tomcat 配置负载均衡(mod-proxy方式)-粘性session
Tomcat集群配置后端Tomcat Server为支持AJP的独立服务,前端Apache配置为粘性会话(sticky-session),Tomcat不配置Cluster配置和Session复制. 配 ...
- 基于nginx与Tomcat实现负载均衡
server1:192.168.200.113(nginx服务端) server2:192.168.200.111(Tomcat服务端) server1中nginx的配置文件 nginx.conf h ...
- 基于Apache+Tomcat实现负载均衡
1.基于Apache和tomcat实现负载均衡 准备三个虚拟机一个安装Apache两个安装Tomcat 关闭防火墙 systemctl stop firewalld Iptabled -F Seten ...
- Apache+Tomcat部署负载均衡(或集群)
本来只打算写Tomcat集群部署,简化Apache和Tomcat整合过程的.后来想了想,这样不便于没有用过Apache的朋友来学习本文内容.于是干脆加大篇幅,让对Apache不了解的朋友能对Apach ...
- apache+tomcat配置负载均衡,实现http与websocket接口分压
一.应用场景 在生产环境中,应用服务器(此文以tomcat为例)不免面临高访问量的压力,相比而言web服务器(此文以apache为例)能够承担更大的并发量.Apache本身带有一些模块,可以完成对应用 ...
- Nginx 服务器 之Nginx与tomcat实现负载均衡
本文讲解我们如何使用Nginx做反向带服务器,实现nginx与tomcat服务器集群做负载均衡. 一.nginx与tomcat实现负载均衡 1.在/usr/local/ngnix/conf 创建 ...
- 利用httpd对tomcat进行负载均衡配置
实验系统:CentOS 6.6_x86_64 实验前提:提前准备好编译环境,防火墙和selinux都关闭 实验说明:本实验共有2台主机,IP分配如拓扑 实验软件:jdk-8u60-linux-x64 ...
- Tomcat(五):nginx/httpd + tomcat及负载均衡tomcat
*/ .hljs { display: block; overflow-x: auto; padding: 0.5em; color: #333; background: #f8f8f8; } .hl ...
随机推荐
- CF620C Pearls in a Row
CF620C Pearls in a Row 洛谷评测传送门 题目描述 There are nn pearls in a row. Let's enumerate them with integers ...
- css3中calc、vw、vh、vmin、vmax 属性的应用及兼容性详解
一. calc()的使用什么是calc()? calc()从字面我们可以把他理解为一个函数function.其实calc是英文单词calculate(计算)的缩写,是css3的一个新增的功能,用来指定 ...
- Linux 学习记录一(安装、基本文件操作).
Linux 名字的由来,是当时作者将初版的 Linux 发布在网上,供别人下载完善,而那个核心文件夹就叫 Linux,就这么叫着了.而为什么 Linux 的吉祥物是一只企鹅呢?是因为当时大家要发行稳定 ...
- Zookeeper分布式锁实战
场景描述: 在线程高并发场景下,生成唯一的订单编号,如: 2017-10-14-20-52-33-01 年-月-日-时-分-秒-序号 (1)Lock锁接口 package com.zookeeper. ...
- Mybatis关联查询之三
MyBatis的关联查询之自关联 自关联 一.entity实体类 public class City { private Integer cid; private String cname; priv ...
- 拎壶学python3-----(2)python之if语句用法
在生活中我们经常遇到各种选择,比如玩色子,猜大小,再比如选择未来另一半.python也经常会遇到这样的选择,这时候if语句显得尤为重要. 下边我们看一个简单的例子 如果是二选一怎么做呢?如下 如果多个 ...
- Hive_hdfs导入csv文件
转自:Hive_hdfs csv导入hive demo 1 create csv file.student.csv 4,Rose,M,78,77,76 5,Mike,F,99,98,98 2 pu ...
- 刷抖音太累,教你用Python把高颜值的小姐姐都爬下来慢慢看
前言 文的文字及图片来源于网络,仅供学习.交流使用,不具有任何商业用途,版权归原作者所有,如有问题请及时联系我们以作处理. 作者: 星安果.AirPython 目 标 场 景 相信大家平时刷抖音短视频 ...
- 敏捷软件开发_UML<一>
敏捷软件开发_UML 所看书籍是:敏捷软件开发_原则.模式与实践_C#版(美)马丁著,这本书写的非常棒,感谢作者.该归纳总结的过程按照我读的顺序写. UML 在建造桥梁,零件,自动化设备之前需要建 ...
- 进度更新---Responsive Web Design Certification (300 hours)
进度更新---Responsive Web Design Certification (300 hours) 已经完成: basic html and html5 basic css applied ...