mount: /dev/sdxx already mounted or /xxxx busy解决方法
异常现象:

解决方法:
1. 輸入root的密碼,進入單用戶
2. 重新掛載/目錄,使其變為可讀可寫
# mount –o rw,remount /
3. 修改/etc/fstab文件,注釋掉sdb
這個sdb是存儲直連服務器的
# vi /etc/fstab
-----------------------------------------------------------------------------------------------------------
#/dev/sdb1 /D37data01 ext4 defaults 1 2
#/dev/sdb2 /D37data02 ext4 defaults 1 2
-----------------------------------------------------------------------------------------------------------
4. 重啟服務器
# reboot
5. 進入系統,掛載文件
# mount /dev/sdb1 / D37data01
此時,報錯如下
-----------------------------------------------------------------------------------------------------------
mount: /dev/sdb1 already mounted or /D37data01 busy
-----------------------------------------------------------------------------------------------------------
6. 執行第5步報錯是因為sdb1被其他程式佔用
# dmsetup status
-----------------------------------------------------------------------------------------------------------
執行后,顯示類似下邊的輸出。此次異常輸出沒有保存,但是顯示的是multipath程式佔用
ResultFromHadoop-ResultFromHadoop: 0 3907026944 linear
ResultFromHadoop-ResultFromHadoop: 3907026944 3907026944 linear
ResultFromHadoop-ResultFromHadoop: 7814053888 3907026944 linea
-----------------------------------------------------------------------------------------------------------
# dmsetup remove_all(此命令解除佔用)
# dmsetup status(再次查看,沒有輸出,說明已經沒有佔用)
7. 再次掛載
# mount /dev/sdb1 / D37data01
# mount /dev/sdb2 /D37data02
8. 打開數據庫
9. 卸載multipath
配置好yum
# yum remove device-mapper-multipath
# yum remove device-mapper-multipath-libs
10. 修改/etc/fatab,取消sdb的注釋
mount: /dev/sdxx already mounted or /xxxx busy解决方法的更多相关文章
- mount: /dev/sdb already mounted or /sheepdog1 busy(multipath,wwid,uuid,udev)
正常处理逻辑: 先umount /dev/sdb或是umount /backup如果还是显示的busy,你试试下面的方法fuser -m /dev/sdb查看一下是否sdb1正在被使用,或是有进程正在 ...
- 【ubuntu】开机一直“/dev/sda3:clean, XXX files, XXXX blocks”解决方法
由于该电脑是实验室公用跑模型的机子,在解决过程中,发现是 cuda 导致一直进不了系统.原因是装了两个不同版本的cuda,一个9.2,另一个10.0,因为是公用的,目前尚不清楚,怎么同时装上两个的,也 ...
- mount: /dev/sdb1 already mounted or /mnt/hdb busy 导致NameNode无法启动
最近,公司由于断电导致的服务器关机,等到来电了,重启集群发现Namenode无法启动,查看原因是由于无法加在faimage文件,在查看一下Namenode的磁盘挂在情况(df -h命令查看),发现磁盘 ...
- centos7执行umount提示:device is busy或者target is busy解决方法
问题描述: 因为挂载错了,想取消挂载,但是umount报告如下错误: [root@zabbix /]# umount /dev/sdc1 umount: /data1: target is busy. ...
- 【亲测可行】Dev c++调试、运行报错解决方法总结
一.编译后 0错误 0警告,但是开始出现‘‘停止运行’’或者进行输入时出现‘‘停止运行’’ 可能的原因: 结构体指针为空,但调用了其成员. 有些scanf语句中忘记添加取址符. 无法跳出递归. 二. ...
- Linux umount设备时出现device is busy解决方法
在Linux中,有时使用umount命令去卸载LV或文件时,可能出现umount: xxx: device is busy的情况,如下案例所示 [root@DB-Server u06]# vgdisp ...
- IIS Server is too busy 解决方法(IIS6)
Server is too busy意思是服务器繁忙,资源不够用 为什么会出现这个问题呢? 因为服务器的配置不同,所能承受的压力不同. 而服务器默认对链接数,线程数等有设置,但这个设置太小,基本不够用 ...
- XAMPP安装后启动Apache的Busy解决方法
启动apache后,一直提示80 busy 使用netstat -ano查看,并无端口占用,真是奇怪. 百度之后发现有可能是启动后,ssl端口占用导致. XAMPP默认会加载一个SSL模块,它要占用一 ...
- mysql碰到unknown variable 'xxxx' 的解决方法
在使用mysqlbinlog查看日志的时候碰到了一个问题, 错误提示如下: /usr/local/mysql/bin/mysqlbinlog: unknown variable 'default-ch ...
随机推荐
- druid数据源yml配置
application.yml配置 spring: datasource: username: root password: 123456 url: jdbc:mysql://localhost:33 ...
- Unity GameObject
GameObject 游戏对象 GameObject是unity所有实体的基类 gameObject 获取当前脚本所挂载的游戏对象 一般来说,在属性视图中能看到或修改的属性,我们同样可以在脚本中获取并 ...
- scala安装遇到的问题:[ERROR] Failed to construct terminal; falling back to unsupported java.lang.NumberFormatException: For input string: "0x100"
安装scala时遇到的问题 lion@king:/opt$ scala Welcome to Scala 2.11.12 (Java HotSpot(TM) 64-Bit Server VM, Jav ...
- Jmeter二次开发——基于Java请求
简述 这近几年,越来越多非http的协议需要进行性能测试,包括不仅限于各类rpc.mq.缓存等.对于这些协议,市面上可能没有现成的工具可以直接使用,这个时候,我们可以自己动手,通过编写相应的JavaS ...
- Ubuntu16.04网卡配置
新安装的Ubuntu16.04系统容易出现无法连接有线网络的问题,主要是因为网卡配置不完善,下面通过实操讲解如何解决该问题. 1. 查看网络设备 ifconfig 发现只有enp2s0和lo,没有et ...
- 泡面不好吃,我用了这篇k8s调度器,征服了他
1.1 调度器简介 来个小刘一起 装逼吧 ,今天我们来学习 K8的调度器 Scheduler是 Kubernetes的调度器,主要的任务是把定义的 pod分配到集群的节点上,需要考虑以下问题: 公平: ...
- [从源码学设计]蚂蚁金服SOFARegistry 之 如何与Meta Server交互
[从源码学设计]蚂蚁金服SOFARegistry 之 如何与Meta Server交互 目录 [从源码学设计]蚂蚁金服SOFARegistry 之 如何与Meta Server交互 0x00 摘要 0 ...
- iOS 自定义tabBarController(中间弧形)
效果图 1.在继承自UITabBarController的自定义controller中调用以下方法(LZCustomTabbar为自定义的tabbar) - (void)viewDidAppear:( ...
- sqlserver 汉字转全拼函数
create function fn_Getquanpin (@str varchar(100)) returns varchar(8000) as begin declare @re varchar ...
- list转long[]数组
//list转long数组List<Long> list = new ArrayList<>(); Long[] skuIds = list.toArray(new Long[ ...