1.背景

虽然阅读了各大牛的博客或文章,但并没有找到特别全面的关于JVM内存分配方法的文章,很多都是复制黏贴

为了严谨,本文特别备注只介绍基于HotSpot VM虚拟机,并且基于JDK1.7的内存分配情况,有关GC的说法也是基于CMS的concurrent collection(而非G1),防止大牛拍砖.

目前主流的JVM就是HotSpot VM(其次还有J9 VM,Zing VM),目前各类博客文章也大多基于JDK1.7以前的版本进行阐述的.

(注:因为不同的虚拟机实现,不同的JDK,内存的分布都不一样,也就是说下面文章中提到的内存结构都只是逻辑结构,并不是内存的物理结构)

本文只介绍内存分配的方法,有关于具体的垃圾回收机制,内存结构的原理不作为本文重点,也希望通过本文让大家对JVM有一点点的认知,小编对JVM理解并不透彻,不想误人子弟。

2.内存总体结构

如果只是为了解决问题,不想了解其中缘由的请跳过本章节

本文介绍的是垃圾回收的内存区域的结构(简称GC堆,不包括程序计数器,栈,本地方法栈),引用一个大牛的说法《一个java对象的这一辈子》

我是一个普通的Java对象,我出生在Eden区,在Eden区我还看到和我长的很像的小兄弟(其他java对象),我们在Eden区中玩了挺长时间。有一天Eden区中的人实在是太多了(会触发Young GC,每次GC加一岁)),我就被迫去了Survivor区的“From”区,自从去了Survivor区,我就开始漂了,有时候在Survivor的“From”区,有时候在Survivor的“To”区,居无定所(每次Young GC都需要Survivor区中的from区和to区"对调")。直到我18岁的时候(进行了18次Young GC),爸爸说我成人了,该去社会上闯闯了。于是我就去了年老代那边,年老代里,人很多,并且年龄都挺大的,我在这里也认识了很多人。在年老代里,我生活了20年,然后被回收(Old GC)。

解释一下,首先内存总体分为年轻代(young),老年代(old),永久代(permanent),如下图

年轻代:(针对年轻代的垃圾回收我们简称Young GC)

年轻代分为eden区,survivor区

1.eden区,是new Object(),对象诞生的地方

2.survivor区是经过垃圾回收后的仍存活的对象存储区域,survivor区中又分为from区和to区

2.1.from区: 经过GC回收,eden区和to区仍存活的对象会存放在from区

2.2.to区: 经过GC回收,eden区和from区仍存活的对象会转移到to区

2.3.正因为2.1和2.2的操作,所以from区和to区中的存活对象来回转移,并且始终有一个区是空的

老年代:(针对老年代的垃圾回收简称Old GC)

经过18次Young GC后年轻代中仍存活的对象,会从年轻代中转移到老年代

老年代满了之后,会触发Old GC,仍存活的对象继续保留在老年代中,直到经过20次Old GC进行回收

永久代:(针对年轻代+老年代+永久代的回收简称Full GC)

是HotSpot VM针对Java方法区的一个实现,通常存储类信息、常量池、静态变量、JIT编译后的代码等数据(简单理解成编译代码的存储区域,即可以理解成:我们的java项目运行时,加载的类文件越多,则需要的永久代内存空间越大)

(注:据说永久代是Hotspot虚拟机特有的概念,别的JVM都没有这个东西,在Java 8中,永久代被彻底移除,取而代之的是另一块与堆不相连的本地内存——元空间)

3.通常内存问题解释

常见问题一 java.lang.OutOfMemoryError: Java heap space ----JVM Heap(堆)溢出

原因:项目运行阶段,new的对象过多,撑满了配置的最大内存,会出现该错误

解决方法:手动设置Xms ,Xmx 的大小.

常见问题二 java.lang.OutOfMemoryError: PermGen space ----PermGen space (永久代) 溢出

原因:开发的项目Java文件比较多的时候,会出现该错误(即项目很大,被JVM加载的文件很多)

解决方法:手动设置MaxPermSize大小.

常见问题三 java.lang.StackOverflowError ---- 栈溢出

原因:通常都是某个代码逻辑递归层次太多导致的,

解决方法:修改递归代码,控制递归层数

4.内存分配方法(建议,非药到病除)

本文只介绍常用的一些配置参数,通常情况下永久代不算堆内存(单独占用另一块内存),新生代占年老代的1/2,即占整个堆内存的1/3,按照这个原则我们给出一个配置例子。

比如服务器可以提供1G的内存以供项目使用,依据上图我们给出如下配置。

运行模式:

-server 服务器模式,多CPU时,性能更佳

新生代与老年代:(通常不单独配置新生代与老年代,所以直接配置整个内存堆大小即可)

-Xms384m 内存堆初始的内存空间

-Xmx768m 内存堆最大内存空间

永久代:(新生代,老年代配置剩余的内存留给永久代)---注意jdk1.8已移除

-XX:PermSize=128m 永久代初始化大小

-XX:MaxPermSize=256m 永久代最大的内存空间(默认为64m)

4.不同环境下的Tomcat内存配置方法

前面已经进行各类内存问题的详解以及配置参数的简要介绍,下面我们介绍一下各种环境下的具体配置方法.

1. 使用命令行启动的tomcat:

修改TOMCAT_HOME/bin/catalina.sh(windows中是catalina.bat), 在文件上方添加如下语句

JAVA_OPTS="-server -Xms384m -Xmx768m -XX:PermSize=128m -XX:MaxPermSize=256m"

2.如果tomcat注册成了windows服务,使用tomcat目录中的/bin/tomcat8w.exe修改就可以了.如下图

3.如果是使用myeclipse开发中,启动tomcat,上述的修改就不起作用了,可进行如下设置:

Myeclipse->preferences->myeclipse->servers->tomcat->tomcat×.×->JDK面板中的Optional Java VM arguments中添加如下内容:

-server -Xms384m -Xmx768m -XX:PermSize=128m -XX:MaxPermSize=256m

最后说两句:

不管配置什么,以及配置的参数值是多少,都需要根据实际项目不断的调试,不要轻易放弃.

比如tomcat的内存配置,也不是越大越好,适合项目/适合服务器配置才是最好的

这才是Tomcat内存配置的正确姿势的更多相关文章

  1. 这才是使用ps命令的正确姿势

    这才是使用ps命令的正确姿势 前言 在linux系统当中我们通常会使用命令去查看一些系统的进程信息,我们最常使用的就是 ps (process status).ps 命令主要是用于查看当前正在运行的程 ...

  2. Spring Boot 2实现分布式锁——这才是实现分布式锁的正确姿势!

    参考资料 网址 Spring Boot 2实现分布式锁--这才是实现分布式锁的正确姿势! http://www.spring4all.com/article/6892

  3. tomcat内存配置(二)

    Tomcat本身不能直接在计算机上运行,需要依赖于硬件基础之上的操作系统和一个Java虚拟机.Tomcat的内存溢出本质就是JVM内存溢出,所以在本文开始时,应该先对JavaJVM有关内存方面的知识进 ...

  4. tomcat内存配置及配置参数详解

    1.jvm内存管理机制: 1)堆(Heap)和非堆(Non-heap)内存 按照官方的说法:“Java 虚拟机具有一个堆,堆是运行时数据区域,所有类实例和数组的内存均从此处分配.堆是在 Java 虚拟 ...

  5. 【收藏】Linux下tomcat内存配置

    常见的内存溢出有以下两种: java.lang.OutOfMemoryError: PermGen space java.lang.OutOfMemoryError: Java heap space ...

  6. 内存溢出之Tomcat内存配置

    设置Tomcat启动的初始内存其初始空间(即-Xms)是物理内存的1/64,最大空间(-Xmx)是物理内存的1/4. 可以利用JVM提供的-Xmn -Xms -Xmx等选项可进行设置 三.实例,以下给 ...

  7. 【Tomcat】tomcat内存配置登记册

    20141202: 环境:windows2003 tomcat6.x jdk1.6 启动方式:windows服务方式启动 启动异常:java.lang.OutOfMemoryError: PermGe ...

  8. 在Eclipse中tomcat 内存配置

    修改1: 在Eclipse中下面Servers双击Tomcat Server... 然后点击General InformAtion 下的Open launch configuration: 会弹出Ed ...

  9. tomcat 内存配置

    在bin目录下的catalina.bat里添加如下代码: rem ----- Execute The Requested Command ------------------------------- ...

随机推荐

  1. TensorFlow学习笔记13-循环、递归神经网络

    循环神经网络(RNN) 卷积网络专门处理网格化的数据,而循环网络专门处理序列化的数据. 一般的神经网络结构为: 一般的神经网络结构的前提假设是:元素之间是相互独立的,输入.输出都是独立的. 现实世界中 ...

  2. Oracle的substr函数简单用法(转)

    转:http://www.cnblogs.com/nicholas_f/articles/1526063.html substr(字符串,截取开始位置,截取长度) //返回截取的字 substr('H ...

  3. Echats

    网址:https://www.echartsjs.com 1.特性 ECharts,一个使用 JavaScript 实现的开源可视化库,可以流畅的运行在 PC 和移动设备上,兼容当前绝大部分浏览器(I ...

  4. node.js多版本管理 nvm

    安装nvm 1.nvm压缩包下载地址 https://github.com/coreybutler/nvm-windows/releases 注意:Windows用户下载nvm-setup.zip 2 ...

  5. MySQL 中 limit 的使用

    需要注意的是,在Oracle中不使用limit,Oracle 使用rownum select no,name from emp limit 5 取前5条记录, select no,name from ...

  6. HDU 1069 Monkey and Banana dp 题解

    HDU 1069 Monkey and Banana 纵有疾风起 题目大意 一堆科学家研究猩猩的智商,给他M种长方体,每种N个.然后,将一个香蕉挂在屋顶,让猩猩通过 叠长方体来够到香蕉. 现在给你M种 ...

  7. VBA中Let与Set的区别

    Let与Set的区别 1.在“类模块”中 Property Let 语句 在Class块中,是给普通变量进行赋值操作的Property,该种Property将不能在其前面使用Set,因而将不能用户对对 ...

  8. C# asp.net XML格式的字符串显示不全

    前台显示XML字符串显示不全 后台XML字符串使用<xmp></xmp>将XML格式字符串括起来

  9. SQL SERVER 数据库跨服务器备份

    原文:https://www.cnblogs.com/jaday/p/6088200.html 需求介绍:每天备份线上正式库并且把备份文件复制到测试服务器,测试服务器自动把数据库备份文件还原. 方案介 ...

  10. 20191115PHP cookie登入实例

    首先是登入页面 <form action="" method="post"> <input type="text" nam ...