配置Ambari远程maridb 报错:

ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'ambari'

在环境搭建的过程中,在

#用Ambari用户(上面设置的用户)登录mysql ,(没有密码)

mysql -u ambari -p

use ambari;

source /var/lib/ambari-server/resources/Ambari-DDL-MySQL-CREATE.sql

遇到了:

ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'ambari';

背景:因为之前安装过Mysql,又把mysql卸载了,然后又安装的mariadb。

初步判断,可能是没有创建databases,或者密码错了,或者没有配置mariadb 远程连接的等配置信息(my.cnf)

按照思路逻辑,来验证第一个问题:

换成root用户,尝试登陆,查看是否有ambari database:

[root@n1 ~]# mysql -uroot –proot

MariaDB [(none)]> show databases;

+--------------------+

| Database           |

+--------------------+

| activity           |

| ambari             |

| amon               |

| cm                 |

| hive               |

| hueDEFAULT         |

| information_schema |

| mysql              |

| oozie              |

| oozieDEFAULT       |

| performance_schema |

| python             |

+--------------------+

如上述所示,是有ambari数据库的。

面对第二个问题,我的解决方案是:

mysql -uambari –p

直接敲回车,没有密码:

显示:

MariaDB [(none)]> show databases;

+--------------------+

| Database           |

+--------------------+

| information_schema |

+--------------------+

1 row in set (0.00 sec)

如上都不是解决问题的答案:

最终解决方案:花了1个小时48分钟,解决如上的BUG.

正确的思路:是权限问题。

用root权限登陆mariadb。

MariaDB [(none)]>  SELECT host,user,password,Grant_priv,Super_priv FROM mysql.user;

+-----------+--------+-------------------------------------------+------------+------------+

| host      | user   | password                                  | Grant_priv | Super_priv |

+-----------+--------+-------------------------------------------+------------+------------+

| localhost | root   | *81F5E21E35407D884A6CD4A731AEBFB6AF209E1B | Y          | Y          |

| 127.0.0.1 | root   | *81F5E21E35407D884A6CD4A731AEBFB6AF209E1B | Y          | Y          |

| ::1       | root   | *81F5E21E35407D884A6CD4A731AEBFB6AF209E1B | Y          | Y          |

| %         | ambari | *81F5E21E35407D884A6CD4A731AEBFB6AF209E1B | Y          | Y          |

| %         | hive   | *6B992DD2D480F43212F044AB3ECAF17E1EA056B9 | N          | Y          |

| %         | oozie  | *2F2E0D3AD70093DDB3F8964E3984EA04B40A6D3C | N          | Y          |

+-----------+--------+-------------------------------------------+------------+------------+

6 rows in set (0.00 sec)

此时ambari用户的Grant_priv的权限为N(图上是Y是因为修改后的解决方案)

输入sql:

UPDATE mysql.user SET Grant_priv='Y', Super_priv='Y' WHERE User='ambari';

然后用ambari用户登陆,输入密码成功。

ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'ambari'的更多相关文章

  1. ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'db'

    1.问题 在刚刚安装MySQL之后,进入到mysql环境下,创建数据库,出现下面的提示信息: ERROR 1044 (42000): Access denied for user ''@'localh ...

  2. ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'

    提示:ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'.前两天也出现过这个问题,网上找了一个比 ...

  3. MySQL:ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'

    ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'. 原因是:mysql数据库的user表里,存 ...

  4. 基于mysql创建库的报错解决小记mysql ERROR 1044 (42000): Access denied for user ''@'localhost' to database

    mysql ERROR 1044 (42000): Access denied for user ''@'localhost' to database异常处理 1.找到find / -name my. ...

  5. error 1044 (42000):access denied for user ''@'localhost' to database 'quickapp' 解决方法

    在虚拟机上重新创建一个数据库时,一直出现这个报错:error 1044 (42000):access denied for user ''@'localhost' to database 'quick ...

  6. mysql忘记root密码或报错:ERROR 1044 (42000): Access denied for user ”@’localhost’ to database ‘xx‘

    有的时候忘记了root密码或其他用户的密码,登录的时候报错:ERROR 1044 (42000): Access denied for user ”@’localhost’ to database ' ...

  7. 一秒 解决 ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql 问题

    提示:ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'.前两天也出现过这个问题,网上找了一个比 ...

  8. centos mysql数据库问题:ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'(转)

    问题描述: 安装好数据库MySQL,进入mysql,设置号密码后,退出的时候,利用密码无法进入,直接回车后可进入,无法看到数据库mysql,use mysql返回错误:ERROR 1044 (4200 ...

  9. 解决 ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'mysql'

    原文链接:https://blog.csdn.net/sea_snow/article/details/82498791 感谢原作者大大  提示:ERROR 1044 (42000): Access ...

随机推荐

  1. element-ui select 下拉框位置错乱--解决

    element-ui select 下拉框位置错乱 由于使用 element-ui 的 select 组件时,下拉框的位置错乱了. 开始查找问题 通过各种问题查找,发现是 css 问题 css bod ...

  2. CentOS下配置Apache HTTPS

    一.安装Apache支持SSL/TLS yum install mod_ssl openssl 二.创建证书 证书(Cerificate)的基本作用是将一个公钥和安全个体(个人.公司.组织等)的名字绑 ...

  3. Git小结---So far.......

    基本的: 1. 在配置了SSH Key的情况下,clone项目时使用:git clone git@github.com/用户名/仓库名.git  使用这种方式而不使用https的方式的好处在于,在pu ...

  4. webpack3 打包

    1. 基于 webpack 3.0 2.步骤.说明 2.1 webpack 本地初始化.安装基本包 npm init         >  package.json npm i  webpack ...

  5. 为了实现动态加载而编写的自己的ClassLoader

    Copy备用 之前客户要求在不重启应用的前提下实现动态增加服务及交易,在网上查了很长时间也没发现类似的技术,最后研究了一下ClassLoader.因为项目是与Spring,一开始我和同事尝试替换源码的 ...

  6. python-ssh-远程服务器+远程docker执行命令

    在python语言中实现远程服务器执行命令+远程dcoker执行命令 def ssh_exec_command(ip, username, password, cmd=None): "&qu ...

  7. Linux学习--第十三天--日志、系统运行级别、grub加密

    日志 rsyslogd取代了syslogd. /var/log/cron #定时任务相关日志 /var/log/cups #打印信息相关日志 /var/log/dmesg #开机内核自检相关日志,dm ...

  8. Qualcomm_Mobile_OpenCL.pdf 翻译-5-性能优化的概述

    这章提供了一个OpenCL应用程序优化的总体概述.更多的细节将会在接下来的章节中找到. 注意:OpenCL程序的优化是具有挑战性的.相比初始的程序开发工作,经常需要做更多的工作. 5.1 性能移植性 ...

  9. Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion' has value '1.8', but '1.7'

    第一种方法:安装1.8之前安装了1.7,将1.7卸载就好了. 第二种方法:删掉Windows\System32下的java.exe, javaw.exe 就行了,但是安装的1.8的jdk会回到1.7的 ...

  10. Nginx 502 Bad Gateway 的错误的解决方案

    我用的是nginx反向代理Apache,直接用Apache不会有任何问题,加上nginx就会有部分ajax请求502的错误,下面是我收集到的解决方案. 一.fastcgi缓冲区设置过小 出现错误,首先 ...