今天我开始做主从复制的集群模式的测试,所以需要再装一个Linux操作系统,我在虚拟机里已经安装了一个Linux操作系统,Redis也已经配置好了。今天打算再安装一个Linux操作系统,Linux系统的安装过程很简单,就不多说了,如果大家想看,请查看我的另一篇文章《Redis进阶实践之一VMWare Pro虚拟机安装和Linux系统的安装》。

Linux操作系统安装完成,然后我继续下载和安装Linux版本的Redis。由于第一次安装Redis是按着教程来的,所以每个步骤都是按着教程一步一步来操作的,最后安装成功,命令执行也很顺利。虽然执行完成了,但是对其中的操作有些了解不透,今天安装Redis的时候就出现问题,截图如下:
              

我在说说我的安装步骤:

             第一步:新建目录,并进入到这个目录下。

               [root@linux ~]# mkdir -p software/download/redis

               [root@linux ~]# cd software/download/redis

               [root@linux redis]#

             第二步:在当前目录下,执行wget命令,开始下载Redis软件包。

             [root@linux redis]# pwd
/root/software/download/redis [root@linux redis]# wget http://redis.io/download/redis-4.0.tar.gz
//.....
//开始下载
//...
//下载完成

             第三步:在当前目录解压Redis文件

             [root@linux redis]# pwd
/root/software/download/redis [root@linux redis]# tar zxvf redis-4.0..tar.gz
OK [root@linux redis]# ls
redis-4.0. redis-4.0.6.tar.gz

             第四步:进入Redis根目录,执行make命令开始编译

             [root@linux redis]# cd redis-4.0.
[root@linux redis-4.0.]# make
//开始编译
//。。。
//编译完成

             第五步:把相关的文件拷贝指定目录,目录地址:/root/application/program/redis,完成操作。

             [root@linux redis]# pwd
/root/software/download/redis [root@linux redis]# cp redis.conf /root/application/program/redis/
[root@linux redis]# cd src [root@linux src]# cp redis-cli /root/application/program/redis/
OK [root@linux src]# cp redis-server /root/application/program/redis/
OK [root@linux src]# cp redis-benchmark /root/application/program/redis/
OK

以上五步执行完之后,并且redis.conf 配置文件已经修改完成了,我以为可以启动Redis-server了,当执行如下命令提示错误。

          [root@linux~]# cd application/program/redis

          [root@linux redis]# redis-server redis.conf
-bash:redis-server:command not found //也就是上面的截图

经过调试发现,我原来省略了第六步,我以为执行到Make命令,编译就可以了,不需要执行Make install命令,我以为Make install命令的作用就是拷贝redis的相关文件到/usr/local/bin这个目录下,原来不是,如果不执行,redis-server redis.conf 这个命令是不会执行的。

下面是第六步,经过这个过程,理解的就更加深刻了。

             第六步:回到/root/software/download/redis/redis-4.0.6/src目录下,执行Make Install命令,完成所有的安装。

          [root@linux~]# cd software/download/redis/resis-4.0./src
[root@linux src]# make install
//开始安装
//。。。。
//安装完成

好了,问题解决了,我发现一个真理,“失败是成功之母”,通过不停的操作,不停调试,理解也会不一样,对软件开发尤其一样。开始测试两个Linux版本Redis的主从复制的集群模式。

Redis服务启动失败,提示:redis-server:command not found的更多相关文章

  1. windows下redis启动失败提示maxheap flag

    windows下redis启动失败 D:\redis>redis-server.exe redis.conf [] Oct ::39.789 # The Windows version of R ...

  2. SQL SERVER 服务启动失败

    好久没用SQL SERVER了.今天启动SQL,发现服务启动失败.报错例如以下:--错误发生 1069-(因为登录失败而无法启动服务.) .百度一下,解决方式例如以下: 请按下列步骤操作: 1.右键单 ...

  3. ipv6禁用导致rpcbind服务启动失败实例

    ipv6禁用导致rpcbind服务启动失败实例     昨天在做服务器磁盘分区扩容的时候出现过一个服务启动的问题,在此记录.情景再现:前天晚上申请做磁盘扩容,得到批准后,昨天早上5点开始做停机调整维护 ...

  4. 三十九.NoSQL概述 部署Redis服务 、 部署LNMP+Redis

    1. 搭建Redis服务器 在主机 192.168.4.50 上安装并启用 redis 服务 设置变量test,值为123 查看变量test的值   1.1 搭建redis服务器 1.1.1 安装re ...

  5. CentOS 7下MySQL服务启动失败的解决思路

    今天,启动MySQL服务器失败,如下所示: [root@spark01 ~]# /etc/init.d/mysqld start Starting mysqld (via systemctl): Jo ...

  6. Linux Redis自动启动,Redis开机启动,Linux Redis设置开机启动

    Linux Redis自动启动,Redis开机启动,Linux Redis设置开机启动 >>>>>>>>>>>>>> ...

  7. proftpd启动失败提示unable to determine IP address of “xxx.com”

    proftpd启动失败提示unable to determine IP address of “xxx.com”这种proftpd启动失败的原因是无法解析后面主机的IP地址,解决方法是在DNS列表中增 ...

  8. Docker安装、命令详情、层级架构、docker服务启动失败解决方法

    容器背景: 层级架构:  容器对比传统化虚拟机: 可以把docker理解成是一款自带软件(比如:nignx.tomcat.....)的镜像操作系统(首先是要下载镜像) 以下是Windows环境安装Do ...

  9. 玩转Windows服务系列——无COM接口Windows服务启动失败原因及解决方案

    将VS创建的Windows服务项目编译生成的程序,通过命令行 “服务.exe -Service”注册为Windows服务后,就可以通过服务管理器进行管理了. 问题 通过服务管理器进行启动的时候,发现服 ...

随机推荐

  1. Replacement(思维题)

    题目链接:http://codeforces.com/problemset/problem/570/C C. Replacement time limit per test 2 seconds mem ...

  2. c++2(循环和递归)

    其实编程的朋友知道,不管学什么语言,循环和递归是两个必须学习的内容.当然,如果循环还好理解一点,那么递归却没有那么简单.我们曾经对递归讳莫如深,但是我想告诉大家的是,递归其实没有那么可怕.所谓的递归就 ...

  3. YUI 阻止动态css加载

    skinnable动态加载 在YUI Module中,经常采用skinnable参数来动态加载css,如: YUI().use('w-paginator', function(Y) { }, requ ...

  4. GBK,UTF8是什么?有什么区别,做网站选择哪种好?

    GBK包含全部中文字符: UTF-8则包含全世界所有国家需要用到的字符. GBK是在国家标准GB2312基础上扩容后兼容GB2312的标准(好像还不是国家标准) UTF-8编码的文字可以在各国各种支持 ...

  5. 利用PHPExcel导出Excel并设置Excel格式以及数据源

    浏览:23969 发布日期:2013/07/24 分类:技术分享 代码有点长,读起来有点累.先来个截图 导出的Excel太宽了,所以将后面的列宽重新调整了再截的图 功能包括: 1.设置单元格格式,包括 ...

  6. 如何查看dede版本信息

    dedecms版本信息 更新日期 it 分类: dedecms 打开 /include/common.inc.php 查找 $cfg_version 可以看到版本号 /打开 data/admin/ve ...

  7. Objective-C基础教程学习笔记(附录)从Java转向Objective-C

    Java接口与Objective- C正式协议类似,因为它们都需要实现一组方法.Java具有抽象类,但Objective-C没有.Java具有类变量,但在Objective-C中, 可以使用文件范围内 ...

  8. 智能家居esp8266对接机智云

    依然存在稳定性问题 机智云官网--机智云 一个比较详细的教程--esp8266 一开始采用的是esp12f   可是他太不稳定,总是掉线,机智云的固件我也是刷了无数遍,哎太难了. 我比较懒,走过了太多 ...

  9. Effective Java 第三版——29. 优先考虑泛型

    Tips <Effective Java, Third Edition>一书英文版已经出版,这本书的第二版想必很多人都读过,号称Java四大名著之一,不过第二版2009年出版,到现在已经将 ...

  10. linux_链接文件

    链接概念: 分为软链接和硬链接,文件类型为 l 硬链接: ln 源文件 目标文件 软链接: ln -s 源文件 目标文件(目标文件不能事先存在) ln -s /root/ /tmp/root # 给 ...