一、Openvpn 用户注销

  每个公司都会用员工离职,因此注销vpn用户也就成了运维人员日常工作的一部分。 其实Openvpn在设计的时候也想到了这点,我们可以使用 revoke-full shell脚本来注销用户。

  命令如下:

    1.#source ./vars (不执行此命令,有时会报错,提示先执行此命令)

    2.#./revoke-full 用户证书名 (如:./revoke-full client1)      

      Using configuration from /usr/local/src/openvpn-2.2.1/easy-rsa/2.0/openssl-1.0.0.cnf
      ERROR:Already revoked, serial number 03
      Using configuration from /usr/local/src/openvpn-2.2.1/easy-rsa/2.0/openssl-1.0.0.cnf
      client1.crt: C = CN, ST = BJ, L = Beijing, O = openvpn, CN = client1, emailAddress = client1@openvpn.com
      error 23 at 0 depth lookup:certificate revoked

    如果有 error 23字样,表示client1 用户注销成功。  注意:生成的证书并没有删除,只是在 keys 目录下生成了一个 crl.pem  文件。里面就是注销掉的证书。

    3.vim /etc/openvpn/server.conf    :

      crl-verify /usr/local/src/openvpn-2.2.1/easy-rsa/2.0/keys/crl.pem  (添加一行)

    4.添加后需要重启Openvpn服务。 之后你会发现client1 用户,已经无法登陆。

二、openvpn服务器的key文件设置

    1、自动生成key文件存放路径设置  

       vim /usr/local/src/openvpn-2.2.1/easy-rsa/2.0/vars

         export EASY_RSA="`pwd`"     修改EASY_RSA的变量值来修改路径

    2、key 文件的有效期

      系统默认client 用户key值得有效期为10年,即3650天。

      vim /usr/local/src/openvpn-2.2.1/easy-rsa/2.0/vars

        # In how many days should the root CA key expire?

        export CA_EXPIRE=

        # In how many days should certificates expire?

        export KEY_EXPIRE=3650    (修改为自己期望的有效时长。单位:天)

三、防火墙配置

  如果需要开启防火墙,需要对防火前进行配置。

iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -s  -j ACCEPT     (IP:VPN虚拟隧道IP)
iptables -A FORWARD -j REJECT
iptables -t nat -A POSTROUTING -s  -o eth0 -j MASQUERADE   (接口:服务器物理接口)

四、Openvpn服务器的负载均衡

    保证多台Openvpn服务器上的配置和生成的证书 实时同步。

    使用LVS、F5等功能实现负载。

OpenVPN 2.2.1 之后期维护的更多相关文章

  1. QT在ui文件上建立信号操机制会不会对后期维护产生影响 - love4Mario的专栏 - 博客频道 - CSDN.NETQT在ui文件上建立信号操机制会不会对后期维护产生影响 - love4Mario的专栏 - 博客频道 - CSDN.NET

    QT在ui文件上建立信号操机制会不会对后期维护产生影响 - love4Mario的专栏 - 博客频道 - CSDN.NET QT在ui文件上建立信号操机制会不会对后期维护产生影响 分类: 学习心得 2 ...

  2. 关于CentOS 7.1后期维护的问题

    1.问题描述:在使用ssh服务远程登录的时候,当显示输入密码,特别特别的慢,刚刚搭建 服务器的时候还很正常,经过一个假期我实在忍不了它了,故决定解决此问题.服务器系统:CentOS 7.1 解决方式: ...

  3. racktables 后期维护

    一.网站与数据库分离 vim secret.php #$pdo_dsn = 'mysql:host=localhost;dbname=racktables'; #$db_username = 'roo ...

  4. 分离vue文件,方便后期维护

    参考: https://www.cnblogs.com/wy120/p/10179901.html https://blog.csdn.net/sinat_36146776/article/detai ...

  5. openstack 后期维护(四)--- 删除僵尸卷

    前言: 在长时间使用openstack之后,删除虚机后,经常会有因这样那样的问题,导致卷处于僵尸状态,无法删除! 状态一: 虚机已近删除,然而卷却挂在到了 None上无法删除 解决办法: 1.# ci ...

  6. centos openvpn 安装

    安装环境: 系统:centos 6.5 openvpn:openvpn-2.2.1 lzo:lzo-2.09    下载地址:http://www.oberhumer.com/opensource/l ...

  7. CentOS 部署openVPN

    一.openVPN工作原理 VPN技术通过密钥交换.封装.认证.加密手段在公共网络上建立起私密的隧道,保障传输数据的完整性.私密性和有效性.OpenVPN是近年来新出现的开放源码项目,实现了SSLVP ...

  8. 可爱的豆子——使用Beans思想让Python代码更易维护

    title: 可爱的豆子--使用Beans思想让Python代码更易维护 toc: false comments: true date: 2016-06-19 21:43:33 tags: [Pyth ...

  9. yiStack平台维护

    <一.> yiStack 二次封装 Iso通用发行版相关配置属性值替换1.1.yiStack AIO一体机环境根据部署子网替换修改示例如下:主要修改替换isolinux/ks-aio.cf ...

随机推荐

  1. pig简介

    Apache Pig是MapReduce的一个抽象.它是一个工具/平台,用于分析较大的数据集,并将它们表示为数据流.Pig通常与 Hadoop 一起使用:我们可以使用Apache Pig在Hadoop ...

  2. c# word操作

    合并单元格  http://www.360doc.com/content/11/0729/21/2097544_136620405.shtml

  3. 构建最小JDK Docker镜像

    参考: https://my.oschina.net/shyloveliyi/blog/1627020 1.首先下载jre,下载地址是https://www.java.com/en/download/ ...

  4. JsonConvert

    ///"{'jsonParam' : " + jsonText + "}" /* Dictionary<string, object> tmp = ...

  5. J2SE 8的流库 --- 基本类型流的使用

    展现流的方法 public static <T> void show(String title, Stream<T> stream){ System.out.println(& ...

  6. 解决jsfl 弹出警告

    fl.showIdleMessage(false);

  7. hadoop-2

    AsyncDispatcher,直接看代码 @Override protected void serviceStart() throws Exception { //start all the com ...

  8. Turn the Rectangles 1008B

    output standard output There are nn rectangles in a row. You can either turn each rectangle by 9090  ...

  9. maven中scope标签详解

    前言 最近在做itoo的pom优化工作,发现对于maven依赖管理中的scope标签还是有不明白的地方,所以今天就来总结一下这方面的知识,scope在maven的依赖管理中主要负责项目的部署 mave ...

  10. 今天折腾phantomjs+selenium的笔记

    1.debian8里安装phantomjs的方法: 参照:http://www.cnblogs.com/lgh344902118/p/6369054.html a.去https://bitbucket ...