前言

使用Transparent Gateway(透明网关),建立ORACLE与SQLServer的连接。

实现功能:在ORACLE中查询SQLServer数据库的内容。

注:网上有ORACLE和SQLServer不在同一服务器中的安装步骤。本文是ORACLE、SQLServer、透明网关都在同一服务器的场景。

一、环境信息

SQLServer2008(Window server 2008 R2)

标题 内容
IP地址 162.16.161.98

Oracle11g(Window server 2008 R2)

标题 内容
IP地址 162.16.161.98
Oracle端口 1521

Oracle gateway (Window server 2008 R2)

标题 内容
IP地址 162.16.161.98
Gateway根目录 E:\app\Administrator\product\11.1.0\tg_2
Gateway端口 1522(默认是1521,因为本机Oracle数据库已使用此端口,所以需要改一下)
SID Demo0707

二、Transparent Gateway安装

启动安装程序:

指定安装目录:

选择组件:

填写SQL Server数据库详细信息:

主机名填写SQL Server数据库IP地址,若SQL Server数据库和透明网关安装在同一台服务器上,可以填【.】。

数据库名称填写需要连接的SQL Server数据库名称。

注:【本页可以不填,之后在配置文件进行配置】

点击安装:



安装完Gateway后,会自动弹出配置监听界面。我们不配置监听,点击取消后安装完毕。

三、修改配置文件

指明要访问的MSSQL数据库(修改initdg4msql.ora)

在网关安装目录(E:\app\Administrator\product\11.1.0\tg_2\dg4msql\admin)

找到initdg4msql.ora文件。

该文件是Gateway的初始参数文件,描述的是连接哪个SQL Server数据库。该文件的格式是init【SID】.ora,SID可以根据需要自定义。

系统默认的SID为dg4msql(Oracle Database Gateway for MS SQL Server)。

这里我们将SID改为Demo0707,则修改后的文件名为initDemo0707.ora。

我们将文件内容修改为:

HS_FDS_CONNECT_INFO=[162.16.161.98]//Demo0707
HS_FDS_TRACE_LEVEL=OFF
HS_FDS_RECOVERY_ACCOUNT=RECOVER
HS_FDS_RECOVERY_PWD=RECOVER

注意:HS_FDS_CONNECT_INFO为之前安装网关时配置的SQL Server数据库信息,若之前没有填写配置信息,此时需要手动配置。

格式为:

HS_FDS_CONNECT_INFO =

[数据库IP地址,端口号(默认1433)]/实例名称(可空)/ 数据库名称

配置监听器,处理oracle的查询请求(修改listener.ora)

配置监听器,处理oracle的查询请求(修改listener.ora)

在网关安装目录下(E:\app\Administrator\product\11.1.0\tg_2\NETWORK\ADMIN)

找到listener.ora文件。

该文件是监听器配置文件。修改为:

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(GLOBAL_DBNAME = Demo0707)
(PROGRAM = dg4msql)
(SID_NAME = Demo0707)
(ORACLE_HOME = E:\app\Administrator\product\11.1.0\tg_2)
)
)
LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = 162.16.161.98)(PORT = 1522))
)
)

参数说明

1.PROGRAM:

因为实例配置文件在E:\app\Administrator\product\11.1.0\tg_2\dg4msql\admin\initdg4msql.ora,所以PROGRAM不能改变。

2.SID_NAME:

就是我们前面init.ora文件名里指定的SID。

3.GLOBAL_DBNAME:

和SID_NAME保持一致即可。

4.ORACLE_HOME:

透明网关安装路径。

5.LISTENER段:

(ADDRESS = (PROTOCOL = TCP)(HOST = 162.16.161.98)(PORT = 1522))

此处配置安装网关时未配置的监听端口和协议。

这里使用TCP协议,1522端口。(默认是1521,因为本机Oracle数据库已使用此端口,所以需要改一下)。

Oracle服务器配置tns文件

打开Oracle的tnsnames.ora文件

E:\app\Administrator\product\11.2.0\dbhome_2\NETWORK\ADMIN\tnsnames.ora

增加:

Demo0707=(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST = 162.16.161.98)(PORT =1522)))(CONNECT_DATA =(SID=Demo0707))(HS=OK))

四、启动监听器

通过命令行启动

开始菜单>运行>cmd,输入

C:\Users\Administrator>lsnrctl start

通过可执行文件启动

透明网关根目录BIN文件夹内,执行LSNRCTL.exe。



执行start命令,出现如下界面,说明成功启动:

五、在ORACLE数据库中建立连接

打开PL/SQL或其他工具,连接ORACLE数据库后,执行:

create public database link dbkink connect to "SQL用户名" identified by "密码" using 'Demo0707';

参数说明:

1.dbkink:我们建立的与SQL Server数据库的连接名称。

2.Demo0707:我们之前配置的SID。

测试连接是否建立:

执行select 1 from dual@dbkink

若执行成功则说明连接已经建立。

六、出现的问题及解决方法

监听器启动失败

可能的原因是listener.ora配置文件格式有问题。查看是否有多余的空格,或左右括号数量。

最稳妥的方法是取消换行,分别把LISTENER段和SID_LIST_LISTENER段写在一行里,去除多余的空格。

监听器启动了但测试连接时报错

ORACLE数据库和透明网关配置在一台机器上时可能出现这个问题。

原因是命令行启动监听器时,lsnrctl命令的系统路径为ORACLE安装目录下的。导致我们配置的网关监听器设置没有生效。

解决方法是:使用4.2中的方法,执行网关目录下的LSNRCTL.exe文件,启动监听器。

Transparent Gateway的使用方法的更多相关文章

  1. Activity透明/半透明效果的设置transparent(两种实现方法)

    两种方法实现Activity透明/半透明效果的设置,代码思路很有调理,感兴趣的朋友可以参考下,希望本文可以帮助到你   方法一:res/values文件夹下建立styles.xml: 复制代码代码如下 ...

  2. discuz用户登录不响应,提示nginx gateway timeout解决方法

    在使用nginx+php-cgi搭建discuz论坛过程中,出现论坛登录不响应,一直提示nginx gateway timeout504网关超时,单单采用php方式登录无问题.但因需要使用nginx把 ...

  3. Linux的Transparent Hugepage与关闭方法

    Transparent HugePages是在运行时动态分配内存的,而标准的HugePages是在系统启动时预先分配内存,并在系统运行时不再改变. 因为Transparent HugePages是在运 ...

  4. Nginx错误提示:504 Gateway Time-out解决方法

    朋友说504 Gateway Time-out的错误提示与nginx本身是没有任何关系的我们可以通过fastcgi配置参数的调整进行解 决. 修改 php-fpm 配置文件: 1.把 max_chil ...

  5. nginx+php测试时显示 502 bad gateway的解决方法

    http://www.apelearn.com/study_v2/chapter18.html 由于阿铭老师的PHP版本是 5.3的   我装了 5.5 测试出现了 502  错误 查看日志   借助 ...

  6. Nginx 502 Bad Gateway 错误的解决方法

    502 bad gateway 的解决方法 通用配置 proxy_buffer_size 4k; #设置代理服务器(nginx)保存用户头信息的缓冲区大小 proxy_buffers 4 32k; # ...

  7. paho_c_pub 使用方法

    Latest Paho Status (2) 摘自:http://modelbasedtesting.co.uk/ I last wrote about the state of Paho in Oc ...

  8. 解决 504 Gateway Time-out和502 Bad Gateway(nginx)

    504 Gateway Time-out 问题所在: 所请求的网关没有请求到,简单来说就是没有请求到可以执行的PHP-CGI. 一般看来, 这种情况可能是由于nginx默认的fastcgi进程响应的缓 ...

  9. 【AS3】Flash与后台数据交换四种方法整理

    随着Flash Player 9的普及,AS3编程也越来越多了,所以这次重新整理AS3下几种与后台数据交换方法.1.URLLoader(URLStream)2.FlashRemoting3.XMLSo ...

随机推荐

  1. Wordpress Polylang 翻译自定义格式

    WordPress 多语言插件 Polylang 主题函数参考 重要:使用一个函数之前,你必须检查函数是否存在,否则,你的网站可能会在 Polylang 更新之前遇到致命错误(因为 WordPress ...

  2. Redis缓存穿透和缓存雪崩的面试题解析

    前段时间去摩拜面试,然后,做笔试的时候,遇到了几道Redis面试题目,今天来做个总结.捋一下思路,顺便温习一下之前的知识,如果对您有帮助,左上角点下关注 ! 谢谢 文章目录 缓存穿透 缓存雪崩 大家都 ...

  3. windows Server 2016安装Sqlserver远程连接的坑

    如果要连接远程服务器 首先打开防火墙端口1433  新建入站规则 然后 如果没启用 就启用  然后重启服务就行 如果还是不行 进去属性  修改三处 然后重启服务

  4. LINQ to Entities 不识别方法“System.String ToString(“yyyy-MM-dd”)”

    将Queryable转化为IEnumerable或者直接Tolist()

  5. JavaEE在职加薪课好客租房项目实战视频教程

    JavaEE在职加薪课好客租房项目实战视频教程课程介绍:       本课程采用SOA架构思想进行设计,基于目前主流后端技术框架SpringBoot.SpringMVC.Mybaits.Dubbo等来 ...

  6. 【目标检测】基于传统算法的目标检测方法总结概述 Viola-Jones | HOG+SVM | DPM | NMS

    "目标检测"是当前计算机视觉和机器学习领域的研究热点.从Viola-Jones Detector.DPM等冷兵器时代的智慧到当今RCNN.YOLO等深度学习土壤孕育下的GPU暴力美 ...

  7. Qt学习笔记-设计简易的截图工具软件

    现在利用Qt来实现一个截图软件. 首先,设计一个界面出来. 最上面有一个label用来显示图片. 然后使用QPixmap中的静态函数grabWindow来获取图片.这里需要一个winID.可以使用 Q ...

  8. JavaSwing 船只停靠管理可视化(四)

    JavaSwing 船只停靠管理可视化(一) JavaSwing 船只停靠管理可视化(二) JavaSwing 船只停靠管理可视化(三) JavaSwing 船只停靠管理可视化(四) JavaSwin ...

  9. Spring Cloud Hystrix原理篇(十一)

    一.Hystrix处理流程 Hystrix流程图如下: Hystrix整个工作流如下: 构造一个 HystrixCommand或HystrixObservableCommand对象,用于封装请求,并在 ...

  10. el-input限制只能输入数字(开发小记)

    输入框中限制通常有三种处理方法 第一种:设置type属性(不推荐) 设置type属性为number,text等等,此方法输入框的后面会有不必要样式出现 <el-input type=" ...