centos6.8下redis的安装和配置
centos6.8下redis的安装和配置
下载、安装
在redis官网可以获取到最新版本的redis
进入/usr/local/目录,执行如下命令
wget http://download.redis.io/releases/redis-4.0.2.tar.gz
tar xzf redis-4.0.2.tar.gz
cd redis-4.0.2
make
执行make构建redis时报如下错误,这是因为没有安装gcc,执行如下命令即可解决
错误: make[3]: gcc:命令未找到解决: yum install -y wget gcc make tcl //安装gcc
错误: make[3]: gcc:命令未找到
解决: yum install -y wget gcc make tcl //安装gcc
继续执行make又报错,这是因为构建redis的默认内存分配器是jemalloc,如果系统中没有jemalloc,就会报错,可以在构建时将内存分配器设置成libc
错误: zmalloc.h:50:31: 错误:jemalloc/jemalloc.h:没有那个文件或目录
解决: make MALLOC=libc //构建时指定内存分配器
启动redis服务
使用默认配置文件启动redis服务
执行完make命令后,redis就安装完毕了,在安装目录/usr/local/redis-4.0.2目录下执行下面的命令,如果成功启动redis服务,说明redis安装成功
redis-server
指定配置文件启动redis服务
创建如下目录,存放配置文件、日志文件、进程文件、工作文件(如数据备份)
mkdir /etc/redis
mkdir /var/redis
mkdir /var/redis/log
mkdir /var/redis/run
mkdir /var/redis/6379
复制一份配置文件到/etc/redis目录
cp redis.conf /etc/redis/6379.conf
修改配置文件6379.conf
daemonize yes //将redis服务设成守护进程
requirepass 123456 //设置认证密码
bind 0.0.0.0 //设置监听所有ip,默认为bind 127.0.0.1,只监听本机ip,其他主机无法访问此redis,因为我要远程操作redis,所以暂时改成0.0.0.0
protected-mode no //关闭保护模式,默认启用保护模式,同样要想远程访问redis,必须设成no pidfile /var/redis/run/redis_6379.pid
logfile /var/redis/log/redis_6379.log
dir /var/redis/6379
使用6379.conf启动redis服务
redis-server /etc/redis/6379.conf
关闭redis服务
直接杀死redis服务进程
#查看运行的redis服务,得到redis服务的进程号,假设是1000
ps -ef|grep redis
#杀死redis进程
kill -9 1000
使用redis客户端关闭
redis-cli –h localhost –p 6379 –a 123456 shutdown
注意
远程访问redis服务,redis主机需要对外开放6379端口号或者直接关闭防火墙,否则会连接失败
开放6379端口号
centos6.8下redis的安装和配置的更多相关文章
- centos6.5下redis的安装与配置
参照官网描述(https://redis.io/download),linux下redis安装步骤如下: $ wget http://download.redis.io/releases/redis- ...
- CentOS-6.6下Tomcat-7.0安装与配置(Linux)
CentOS-6.6下Tomcat-7.0安装与配置(Linux) 一.认识tomcat Tomcat是一个免费的开源的Serlvet容器,它是Apache基金会的Jakarta项目中的一个核心项目, ...
- mac与centos下redis的安装与配置
前言 最近在用redis,下面简单写一下mac和centos下redis的安装与配置方法. 安装 mac下面 安装命令:brew intall redis 运行命令:brew services sta ...
- linux下redis的安装及配置启动
linux下redis的安装及配置启动 标签: redisnosql 2014-10-24 14:04 19732人阅读 评论(0) 收藏 举报 分类: 数据与性能(41) wget http:/ ...
- 莫小安 Linux下Redis的安装与配置
转载自--Linux下Redis的安装与配置 redis是当前比较热门的NOSQL系统之一,它是一个key-value存储系统.和Memcached类似,但很大程度补偿了 memcached的不足,它 ...
- [Linux]Linux下redis的安装及配置.
在上一篇[Linux] linux下安装配置 zookeeper/redis/solr/tomcat/IK分词器 详细实例. 我们已经将redis所需tar包拷贝到了linux下的root 根目录下, ...
- Linux下Redis的安装与配置
redis是当前比较热门的NOSQL系统之一,它是一个key-value存储系统.和Memcached类似,但很大程度补偿了 memcached的不足,它支持存储的value类型相对更多,包括stri ...
- Linux下Redis的安装、配置操作说明
Redis 是一个高性能的key-value数据库. redis的出现,很大程度补偿了memcached这类keyvalue存储的不足,在部分场合可以对关系数据库起到很好的补充作用.它提供了Pytho ...
- redis学习笔记(一)——windows下redis的安装与配置
前言 很久没有写东西了(.......我的水平就是记个笔记),北漂实习的我,每天晚上回来都不想动,但是做为社会主义接班人的我,还是要时刻给自己充充电,趁着年轻,趁着日渐脱发的脑袋还没有成为" ...
随机推荐
- mysql开启查询日志功能
1.开启查询日志 https://www.cnblogs.com/kerrycode/p/7130403.html MYsql 查询日志配置 mysql> show variables ...
- 1.JSONObject与JSONArray的使用
参考文献: http://blog.csdn.net/huangwuyi/article/details/5412500 1.JAR包简介 要使程序可以运行必须引入JSON-lib包,JSON-lib ...
- nodejs 获取文件夹中所有文件、图片 名
//获取项目工程里的图片 var fs = require('fs');//引用文件系统模块 var image = require("imageinfo"); //引用image ...
- Activity服务类-6 ManagementService服务类
一共含有17个方法 // 获取包含了Activiti数据库模式的{表名.行计数}项的映射.Map<String, Long> getTableCount();//获取诸如任务.执行之类的A ...
- android中拷贝assets下的资源文件到SD卡中(可以超过1M)
很多手机游戏,在安装APK之后都得需要下载相应的资源包,然后才能进入游戏. 有这样一个需求:就是游戏中需要的资源包打在APK内,随apk一起进行安装到手机中. 这样就不需要,在安装APK之后,去下载资 ...
- something about facebook token
There are two method origin token , you can use any one of them, first one may be easier. Origin fro ...
- Erlang/OTP:基于Behaviour的回调函数
原始链接:https://blog.zhustec.me/posts/erlang-otp-1-callback-based-on-behaviour OTP 是什么 OTP 的全称是开源电信平台 ( ...
- twitter 等网站console.log不能使用,可用alert或者
function setConsole() { var iframe = document.createElement('iframe'); iframe.style.display = 'none' ...
- windows服务启动的进程无窗口
勾选允许服务与桌面交互 指服务是否在桌面上提供用户界面,当服务启动后不论是谁登录都能使用.只有作为 LocalSystem 帐户(由“此帐户”指定)运行时,该选项才能使用. 如果一个服务需要界面(比如 ...
- 43. Multiply Strings (String)
Given two numbers represented as strings, return multiplication of the numbers as a string. Note: Th ...