xampp-apache配置
我安装的软件是xampp-win32-1.8.2-0-VC9-installer
需要配置的文件有
httpd.conf
httpd-default.conf
httpd-info.conf
httpd-xampp.conf
xampp安装后,以下文件夹内的内容需要配置修改
xamp\apache\bin
xamp\apache\conf
xamp\apache\conf\extra
xamp\apache\modules
---以下是我自己遇到的问题
---windows server 2008的系统
1.安装后启动不了,总提示libsasl.dll缺失
解决方法:将xampp/php/libsasl.dll文件复制到xampp\apache\bin文件下
2.apache中设置端口 (xampp\apache\conf\httpd.conf)
默认是80端口,可以修改,如下,
#Listen 12.34.56.78:80
#Listen 80
Listen 8081
这样设置后,本地启动网址为http://localhost:8081/
如果需要多个端口可以再添加
例如:
Listen 8082
NameVirtualHost *:8082
<VirtualHost *:8082>
ServerName localhost:8082
DocumentRoot "D:/xampp/htdocs/projectname"
</VirtualHost>
其中servername和documentroot要根据实际情况改变
如IP为10.1.12.3 则 ServerName 10.1.12.3:8082
DocumentRoot 则是你程序的位置
3.网站启动后可能会存在slow http post、slowloris的安全性问题(xampp\apache\conf\httpd.conf)
解决slow http post的方法
解决方法:LoadModule reqtimeout_module modules/mod_reqtimeout.so前的'#'去掉 并添加如下内容
//其实以下内容在xampp\apache\conf\extra\httpd-default.conf文件中已设置,保证httpd.conf文件中保证Include "conf/extra/httpd-default.conf"此句话存在且未被注释即可
<IfModule reqtimeout_module>
RequestReadTimeout header=20-40,MinRate=500 body=20,MinRate=500
</IfModule>
以下的内容也可能是需要配置的,但是我未验证
<IfModule mod_qos.c>
# handle connections from up to 100000 different IPs
QS_ClientEntries 100000
# allow only 50 connections per IP
QS_SrvMaxConnPerIP 50
# limit maximum number of active TCP connections limited to 256
MaxClients 256
# disables keep-alive when 180 (70%) TCP connections are occupied
QS_SrvMaxConnClose 180
# minimum request/response speed (deny slow clients blocking the server, keeping connections open without requesting anything
QS_SrvMinDataRate 150 1200
</IfModule>
解决slowloris的方法:
下载适合你电脑的mod_antiloris.so,我的是x86_2.4_vc10,将mod_antiloris.so放到xampp\apache\modules位置下
LoadModule antiloris_module modules/mod_antiloris.so
<IfModule antiloris_module>
IPReadLimit 50
</IfModule>
4.网站启动后,网站会泄露apache,php的版本信息问题(xampp\apache\conf\extra\httpd-default.conf)
解决方法,将此文件中的ServerTokens,ServerSignature值修改
#ServerTokens Full
ServerTokens Prod
#ServerSignature On
ServerSignature Off
5.网站启动后,网站会泄露apache状态信息即server-status、server-info(xampp\apache\conf\extra\httpd-info.conf)
解决方法:将SetHandler server-status和SetHandler server-info注释掉
<Location /server-status>
#SetHandler server-status
</Location>
<Location /server-info>
#SetHandler server-info
</Location>
6.关于New XAMPP security concept问题,(xampp中关于登录的一些问题)(xampp\apache\conf\extra\httpd-xampp.conf)
个人理解:让xampp的登录页面只能本地访问,其他位置都不可以访问xampp、mysql等的登录页面
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow
Deny from all
#Allow from ::1 127.0.0.0/8 \
# fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
# fe80::/10 169.254.0.0/16
Allow from 127.0.0.1
ErrorDocument 403 /error#/XAMPP_FORBIDDEN.html.var
</LocationMatch>
7.配置完后,需要重启apache才能生效
8.xampp安装好后,apache不是系统的服务
xampp\apache\apache_installservice.bat
右击此文件以管理员身份运行,apache服务就是出现服务内了,如果没出现,重启电脑应该可以出现
xampp\apache\apache_uninstallservice.bat
右击此文件以管理员身份运行,apache服务可以从电脑服务中卸载掉
9.php简写模式打开
php中有些代码用简写即<? ?>编辑的所以php.ini中
short_open_tag = On
10.error_log="D:\tools\xampp\php\logs\php_error_log"
将php.ini文件中此句话注释掉,防止产生大量的日志文件
11.extension=php_ldap.dll
php.ini文件中此句话,表示使用域账号,如果程序不适用域账号,此句话需注释
12.http://boxbaby123.blog.163.com/blog/static/23542244201412610412746/
此链接中还有一些优化设置
xampp-apache配置的更多相关文章
- XAMPP Apache 配置多端口和多域名方法
我们在工作中经常遇到同时调试多个网站的情况,那么如何配置呢?就像平时访问网站一样,网站 a.com 与网站 b.com 截然不同.这都是常见现象,如果在局域网中要访问另外一台电脑上的多个网站,就需要使 ...
- 【图文教程】Eclipse for PHP+XAMPP调试配置
一.下载安装XAMPP 下载地址:https://www.apachefriends.org/download.html, 一路“Next”,安装完毕. 二.下载Eclipse for PHP 下载地 ...
- 【转】XAMPP中配置多个网站
XAMPP虚拟主机配置,多域名绑定访问本地站点 XAMPP有时候你需要一些顶级域名访问方式来访问你本地的项目也就是虚拟主机配置,这时候就需要配置虚拟主机,给你的目录绑定一个域名,实现多域名绑定访问. ...
- PHP学习笔记:APACHE配置虚拟目录、一个站点使用多域名配置方式
我用的是xmapp lite2016的集成包,配置虚拟目录教程如下: 找到httpd-vhosts.conf这个文件,这个文件一般是在xampp\apache\conf\extra这个路径下面,找不到 ...
- XAMPP的配置与使用
XAMPP的配置与使用 一.起因 一开始,我在本地手动DIY安装了WAMPP环境,其中经历了很长时间的折腾,原因是独立安装Apache和MySQL,以及PHP的时候,屡次遇到版本兼容问题,我主要的时间 ...
- windows系统dokuwiki安装部署设置 xampp环境配置
简单记录一次安装dokuwiki的过程 dokuwiki下载 dokuwiki下载地址 https://download.dokuwiki.org/ 下载前有一些可选项目,版本.语言.插件,可以按照需 ...
- xampp Apache Access forbidden! Error 403解决方法
今天下载了最新的xampp,配置了一个虚拟主机,一直在报错,Access forbidden! Error 403 这很明显是服务器不允许访问文件,但是我的虚拟主机配置如下: DocumentRoot ...
- xampp默认配置拿shell
xampp默认配置拿shell 首先我们先来科普一下xampp(Apache+MySQL+PHP+PERL)是一个功能强大的建 XAMPP 软件站集成软件包 是一个易于安装且包含 MySQL.PHP ...
- 备忘-VSCODE、apache配置
一个像素点的光标:https://files.cnblogs.com/files/zjfree/mouse.zip VSCODE配置备忘: { "editor.fontLigatures&q ...
- apache配置 php中没有php5apache2_4.dll
apache配置 php中没有php5apache2_4.dll 今天,在win7系统下安装Apache+PHP+MySQL时,终于体会到了版本多也不一定是好事,各种不兼容,主要是因为动态包的多少问题 ...
随机推荐
- apt 安装 版本
1. 通过apt-get安装指定版本软件 apt-get install package=version 2. 查询指定软件有多少个版本 2.1 通过网站搜索https://packages.ubun ...
- Logon Trigger Example (C++)
This C++ example shows how to create a task that is scheduled to execute Notepad when a user logs on ...
- Python 基础教程(第二版)笔记 (2) 字典
P59 字典方法 1. clear 2. copy, deepcopy 3. fromkeys 4. get 比下标安全 5. has_key 6. items, iteritems 7. keys, ...
- Maven Wrapper简介
文章目录 简介 Maven Wrapper的结构 下载Maven Wrapper 使用 Maven Wrapper简介 简介 开发java项目少不了要用到maven或者gradle,对比gradle而 ...
- HDU 5954 Do Not Pour Out
#include<bits/stdc++.h> using namespace std; #define rep(i,a,b) for(int i=a;i<=b;++i) #defi ...
- HDU 5451 Best Solver
没有意识到循环节最大是M^2,用域Z_M下二阶可逆矩阵群的最大循环节(M^2-1)*(M^2-M)来做,考虑大数乘法,矩阵乘法,做到吐血.将代码贴在下方留作纪念. #include<bits/s ...
- 【Linux常见命令】split命令
split - split a file into pieces 按照指定的行数或大小分割文件 语法: split [OPTION]... [INPUT [PREFIX]] Output fixed- ...
- mac OS 搭建PHP项目开发环境
系统 macOS Mojave 版本10.14.6 mac OS 自带Apache和PHP 非常便利 sudo apachectl -v //查看apache版本 php -v //查看php版本 启 ...
- Linux监听磁盘使用情况
前阵子服务器磁盘写满了,导致项目出了很多奇怪的问题,比如文件上传不了(这个很好理解),还有登录时验证码无法加载(现在依旧不知道原因,项目的验证码图片是只在内存中生成的BufferedImage对象,不 ...
- 关于:Express会被Koa2取代吗?
知会上看到有个问题<Express会被Koa2取代吗?>.刚好对Express.koa有点小研究,于是简单回答了一下. 1.先说结论 目前没有看到Express会被koa2取代的迹象. 目 ...