好久没写什么新文章了,这里有关Office Web Apps 的部署我就省略了,只是在创建web场我一般 会创建2个url, 如:

New-OfficeWebAppsFarm -InternalUrl "https://owas.contoso.com" -ExternalUrl "https://owas.contoso.com" –CertificateName "owas.contoso.com" -EditingEnabled

(注:owas.contoso.com为证书的友好名称,这个需要我们像根证书颁发机构申请,证书必须具有可导出的私钥,并且“友好名称”字段在受信任根证书颁发机构存储中必须是唯一的。)

验证是否成功创建了 Office Web Apps Server 服务器场打开网页https://owas.contoso.com/hosting/discovery,和http://owas/hosting/discovery

我们打开exchange 2013 powershell,配置office web apps server URL

Set-OrganizationConfig -WACDiscoveryEndPoint https://owas.contoso.com/hosting/discovery

检查指令:Get-OrganizationConfig | Format-List WACDiscoveryEndPoint

启用或禁用office web apps server的呈现:

这里分为2种,一种为共用计算机启用附件呈现,一种为专用计算机启用附件呈现:
首先是专用:

在server01的默认outlook web app虚拟目录上启用owa呈现:

Set-OwaVirtualDirectory "exchange\owa (Default Web Site)" -WacViewingOnPrivateComputersEnabled $true

然后是共用:

在server01的默认outlook web app虚拟目录上启用owa呈现:

Set-OwaVirtualDirectory "exchange\owa (Default Web Site)" -WacViewingOnPublicComputersEnabled $true

要验证是否正确配置了owa的服务器渲染,运行以下命令行:

Get-OwaVirtualDirectory "exchange\owa (Default Web Site)" | Format-List Name,WacViewing*

验证 WacViewingOnPrivateComputersEnabled 属性是否设置为 True 并且 WacViewingOnPublicComputersEnabled 是否设置为 False。

强制执行owa呈现:

强制用户首先使用Owa呈现附件,再直接打开附件。无论用户在登陆outlook web app时选择的选项是什么。

Set-OwaVirtualDirectory "exchange\owa (Default Web Site)"
-ForceWacViewingFirstOnPublicComputers $true
-ForceWacViewingFirstOnPrivateComputers $true

验证是否成功,运行如下命令:

Get-OwaVirtualDirectory "exchange\owa (Default Web Site)" | Format-List Name,ForceWacViewing*

验证 ForceWacViewingFirstOnPrivateComputers 和 ForceWacViewingFirstOnPublicComputers 属性是否都设置为 True。

具体的截图可以参考:

http://tech.ddvip.com/2013-07/1374872785199804.html

http://1183839.blog.51cto.com/1173839/1140198/

Exchange 2013与 Office Web Apps 整合的更多相关文章

  1. SharePoint 2013中Office Web Apps的一次排错

    转自http://www.cnblogs.com/awpatp/archive/2013/06/06/3121420.html, 仅供自己查看 笔者尝试在自己的测试环境中为SharePoint 201 ...

  2. office web apps 整合Java web项目

    之前两篇文章将服务器安装好了,项目主要的就是这么讲其整合到我们的项目中,网上大部分都是asp.net的,很少有介绍Java如何整合的,经过百度,终于将其整合到了我的项目中. 首先建个servlet拦截 ...

  3. sharepoint 2013 和 office web apps server 2013集成

    环境: 三台服务器  系统:window 2008 R2server01: 192.168.10.162(office web app)server02: 192.168.10.163(AD)serv ...

  4. office web apps 整合到自己项目中(wopi实现在线预览编辑)

    借助office web apps实现在线预览和在线编辑 我所有的代码都是用go语言编写,你可以直接编译后使用,不用再有其他的操作. 最近项目实在太忙,这几天才有时间,这次是重头戏,要好好琢磨一下怎么 ...

  5. [转载]部署Office Web Apps Server并配置其与SharePoint 2013的集成

    Office Web Apps Server 是新的 Office 服务器产品,它提供 Word.PowerPoint.Excel 和 OneNote 的基于浏览器的版本.单个 Office Web ...

  6. 部署Office Web Apps Server并配置其与SharePoint 2013的集成

    部署Office Web Apps Server并配置其与SharePoint 2013的集成   Office Web Apps Server 是新的 Office 服务器产品,它提供 Word.P ...

  7. 如何整合Office Web Apps至自己开发的系统(一)

    在前面我的一篇博客中 Office Web Apps安装部署(一),有一张介绍Office Web Apps与其他系统的关系图,   从上述图中,可知实际上Office Web Apps也是可以接入自 ...

  8. 整合Office Web Apps至自己的开发系统

    原文出处:http://www.cnblogs.com/poissonnotes/p/3267190.html 还可参考:https://www.cnblogs.com/majiang/p/36729 ...

  9. Office Web Apps Server 2013与PDF(一)

    好吧--这个消息有点旧,迟了将近4个月. Office Web Apps是微软各大服务产品系列中的一个基础服务,可以为SharePoint 2013.Exchange 2013.Lync 2013提供 ...

随机推荐

  1. Android- SharedPreferences 使用详解

    Android-SharedPreferences 使用详解 参考 https://developer.android.google.cn/reference/android/content/Shar ...

  2. Jindent——让intellij idea 像eclipse一样生成模版化的javadoc注释

    插件地址 http://plugins.jetbrains.com/plugin/2170?pr=idea 安装方法参考 http://www.cnblogs.com/nova-/p/3535636. ...

  3. Windows 7硬盘安装CentOS 6.4 双系统 (WIN7下硬盘安装Linux(Fedora 16,CentOS 6.2,Ubuntu 12.04))

     WIN7下硬盘安装Linux(Fedora 16,CentOS 6.2,Ubuntu 12.04) 最近在看<鸟哥私房菜:基础学习篇>,觉得很不错,想要用U盘装个windows 7 和 ...

  4. [Java]Get与Post,客户端跳转与服务器端跳转

    http://www.thinksaas.cn/group/topic/133101/ 虽然说get 与post 问题很老套了,但是作为web 开发人员来说对于这个的理解确实很有必要,其实说到get  ...

  5. CentOS 7下的KVM网卡配置为千兆网卡

    在KVM下可以生成两种型号的网卡,RTL8139和E1000,其实应该是底层生成不同芯片的网卡,而不是附带宿主机网卡是什么型号就是什么型号的,其中默认为100兆网卡,即RTL8319的螃蟹卡,另一种是 ...

  6. spring cloud 学习(7) - 生产环境如何不停机热发布?

    业务繁忙的系统,原则上是不允许停机的,那么问题来了,如果真有严重的bug要修复,不得不发布,怎么做到不停机发布,对业务无感知呢? eureka 提供了一系列rest url,可以对注册实例进行操作,比 ...

  7. 让Win2008+IIS7+ASP.NET支持10万并发请求

    今天下午17点左右,博客园博客站点出现这样的错误信息: Error Summary: HTTP Error 503.2 - Service Unavailable The serverRuntime@ ...

  8. VirtualBox 在WIN7 X64 安装报错 获取VirtualBox COM对象失败,Unable to start the virtual device

    Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\CLSID\{---C000-}\InprocServer32] @="C:\ ...

  9. java之jvm学习笔记十三(jvm基本结构) 通俗易懂的JVM 文件,没有之一

    http://blog.csdn.net/yfqnihao/article/details/8289363

  10. Revit Family API 添加类型

    FamilyManager.NewType("");添加新类型,然后设置参数,就是为新类型设置参数. [TransactionAttribute(Autodesk.Revit.At ...