Centos 6.5(64bit)上安装Vertica single node
在Win8上使用虚拟机Virtualbox安装Centos6.5,想在上面安装vertica.
以下记录了我在安装的过程中遇到的问题与一些解决方案。
1.安装Centos的时候遇到了一个恼人的问题,即安装成功后第一次启动时会需要你配置一些用户信息,时区信息和Kdump信息。
我当时选择安装的类型是software development,因为我是准备把这个机器做为开发机来使用的。
此时会遇到一些问题,Kdump是最后一步,如果我的内存设置少于1G,则弹出内存过小无法设置kdump,
我给到2048m时,可以选择enabled or not,但是virtuabox会停止响应,然后重启虚拟机又出跳出这个步骤来。
我一直没有找到合适的解决方案,不过可以在进入这个设置步骤的时候,可以按ctrl,alt,backsapce 键,然后就可以重新载入
xwindows.这个时候可以正常地进入桌面系统。但是第二次重启进入的时候还会进入这个向导页面。
我正常进入桌面后,就安装了virtuabox的添加件,然后第二次进来的进修再做kdump这一步骤时,没有让它重启,居然没有停止响应。
安装Vertica的时候,也有一些问题,首先是下载安装包,
然后是解压安装包:rpm -Uvh packagename
然后就是进入安装,安装会检查是否符合安装条件,譬如disk ioscheduler的一些检查等,我们可以也不管。
但是这个时候可以配置一下ssh无密码访问(建数据库的时候需要)
build passwordless ssh connection:
ssh-keygen -t rsa
ssh-keygen -t dsa
cd .ssh
cat id_rsa.pub >>authorized_keys
cat id_dsa.pub >>authorized_keys
chmod .ssh
然后就执行
sudo ./install_vertica --hosts node1 --rpm /home/dbadmin/vertica/vertica-7.0.1-0.x86_64.RHEL5.rpm --failure-threshold NONE
一开始不要加后面的--failure--threshold的flag
根据提示把Fail的那些一个一个都解决,它会提供链接,其中有解决方案。
如果WArn的那些你不想解决,就可以使用这个方法来譬如检查不通过。这样检查通过后,基本上就完成安装了。
你还可以安装MC,下载对应的包就可以了。安装比较检查,一般不会出问题,然后通过url来配置一些集群的基本信息。
然后可以进入/bin/admintools, 接受EUML,liscense可以置空。
我在建数据库的时候遇到这么一个问题,
Unable to SSH as dbadmin to 220.250.64.228: UNEXPECTED EOF:
solution:
cd /opt/vertica/config/admintools.conf
replace the ip address to 127.0.0.1. then rerun the admintools it will be ok.
Centos 6.5(64bit)上安装Vertica single node的更多相关文章
- CentOS 6.5系统上安装SVN服务器端的方法及步骤
VN其实就是Subversion,分为服务器端和客户端.之前在网上搜了很多方法,都有各种问题,经过自己搜集整理以及实际尝试,总算有个比较靠谱的方法.本文主要介绍CentOS 6.5系统上安装SVN服务 ...
- CentOS 7 / RHEL 7 上安装 LAMP + phpMyAdmin
原文 CentOS 7 / RHEL 7 上安装 LAMP + phpMyAdmin 发表于 2014-11-02 作者 Haoxian Zeng 更新于 2014-12-12 之前根据在 Lin ...
- CentOS 6.5系统上安装SVN服务器端的方法及目录访问权限配置(转总结)
SVN其实就是Subversion,分为服务器端和客户端.之前在网上搜了很多方法,都有各种问题,经过自己搜集整理以及实际尝试,总算有个比较靠谱的方法.本文主要介绍CentOS 6.5系统上安装SVN服 ...
- 在Linux(CentOS 6.6)服务器上安装并配置基于Apache的SVN服务器
#!/bin/bash # # 在Linux(CentOS 6.6)服务器上安装并配置基于Apache的SVN服务器: # # .安装服务 # .创建svn版本库 # .创建svn用户 # .配置sv ...
- Windows 7 64bit上安装Oracle Database 12c [INS-30131] 错误的解决方法
Windows 7 64bit上安装Oracle Database 12c,出现以下错误: 解决方法: 第一步:控制面板>所有控制面板项>管理工具>服务>SERVER 启动 ...
- 在 CentOS 8/RHEL 8 上安装和使用 Cockpit
Cockpit 是一个基于 Web 的服务器管理工具,可用于 CentOS 和 RHEL 系统.最近发布的 CentOS 8 和 RHEL 8,其中 cockpit 是默认的服务器管理工具.它的软件包 ...
- 在Ubuntu 14.04 64bit上安装numpy和matplotlib库
原文:http://blog.csdn.net/tao_627/article/details/44004541 按照这个成功安装! 机器学习是数据挖掘的一种实现形式,在学习<机器学习实战> ...
- 在Linux CentOS 6.5 (Final)上安装git-1.9.0
CentOS 6.5 (Final)默认安装的git版本为1.7.1.3,而我们希望安装1.9.0版本.由于rpm安装库里没有1.9.0版本,因此我们需要找其它方法来安装. 网上有很多文章介绍了如何从 ...
- CentOS 6.5系统上安装SVN服务器
有效地管理源代码的方式是使用工具去帮助我们管理 , SVN(Subversion)就是目前主流的源代码管理工具 , 也称为版本控制工具. 本文主要介绍CentOS6.5上安装SVN服务器,配置SVN服 ...
随机推荐
- 轻松解决MYSQL数据库连接过多的错误
1.数据库系统允许的最大可连接数max_connections.这个参数是可以设置的.如果不设置,默认是100.最大是16384. 2.数据库当前的连接线程数threads_connected.这是动 ...
- html+css—two
1.滚动字幕(不常用) 默认状态:<marquee>向左移动</marquee> //-- hspasc滚动区域height滚动字幕高度 <marquee height= ...
- 互联网产品团队中Web前端工程师的重要性
国内外各大互联网公司,都有UEx/d|UCD|CDC(Customer Research & User Experience Design Center)团队. 在很多公司会认为,合格的产品经 ...
- 【Effective Java】2、构造参数过多的时候
package cn.xf.cp.ch02.item2; /** * * 功能:当我们的构造参数有很多,超出可控范围的时候,用build模式 时间:下午8:25:05 文件:NutritionFact ...
- ahjesus mongodb指定到数据盘连接不上的解决方案
关于配置路径指定到数据盘会出现连接不上的情况 我发现是因为数据盘权限不足引起的,目前没找到治本的方法 有个治标的方法就是设置数据盘的权限和用户 sudo chmod 777 * -R /path/d ...
- ADO.NET 实体类和数据访问类
SQL数据库字符串注入攻击:需要使用cmd.Parameters这个集合占位符: @key 代表这个位置用这个占位符占住了 Parameters这个集合中将此占位符所代表的数据补全 cmd.Param ...
- 帝吧出征FB:这李毅吧的“爆吧”文化是如何形成的
声明:本文不对爆吧行为及其涉及的事件进行是非判断,只探讨帝吧文化本身,欢迎拍砖.更正和补充. 一.“帝吧FB出征”事件梳理 继上次全网集体骂 “薯片”事件后,昨日(1月20日)晚7点,又发生了一次互联 ...
- ASP.NET MVC 微信公共平台开发之 微信接入
ASP.NET MVC 接入微信公共平台 申请微信公共账号 既然要接入微信公共平台,微信公共号是必须的(当然如果只是测试的话也可以申请微信公共平台接口测试账号),来这里微信公共平台 申请微信公共号(注 ...
- Setting up your App domain for SharePoint 2013
from:http://sharepointchick.com/archive/2012/07/29/setting-up-your-app-domain-for-sharepoint-2013.as ...
- iOS 编译报错
Undefined symbols for architecture i386: “_OBJC_CLASS_$_XXX”, referenced from: objc-class-ref in XXX ...