Centos 6.x 部署pptp VPN
安装
系统检测不到PPTP的时候 使用一下方法安装PPTP
下载地址:http://poptop.sourceforge.net/yum/stable/packages
rpm -ivh http://poptop.sourceforge.net/yum/stable/packages/pptpd-1.4.0-1.el6.x86_64.rpm
yum install -y ppp pptpd

配置 pptpd
1. 编辑配置文件 vi /etc/pptpd.conf,将如下配置:
#localip 192.168.0.1#remoteip 192.168.0.234-238
修改为:
localip 192.168.0.1remoteip 192.168.0.234-238,192.168.0.245# 以上设置的 IP 地址: localip 192.168.0.1 和 remoteip 192.168.0.2-200 分别是 vpn 的网关地址和 vpn 拨号获取地址段。可以根据需要进行调整
即将这两行第一个字符 # 去掉,取消注释,保存退出。

2.编辑 vi /etc/ppp/options.pptpd,将如下配置:
#ms-dns 10.0.0.1#ms-dns 10.0.0.2
修改为
ms-dns 223.5.5.5ms-dns 223.6.6.6# 223.5.5.5 和 223.6.6.6阿里云公共 DNS 服务地址,也可以按需配置为其它公共 DNS。
即将这两行第一个字符“#”去掉,而后修改 DNS 服务器的 IP 地址。

3. 设置使用 pptp 的用户名和密码命令:
vi /etc/ppp/chap-secrets
打开后只有两行,而且一个账号都没有,如下所示:
# Secrets for authentication using CHAP# client server secret IP addresses
根据需要添加账号,每行一个。按照:“用户名 pptpd 密码 ip地址” 的格式输入,每一项之间用空格分开,例如:test pptpd 123456 (表示所有IP),保存并退出。

4. 设置 MTU 大小
$ vi /etc/ppp/ip-up.....[ -x /etc/ppp/ip-up.local ] && /etc/ppp/ip-up.local "$@"# 这行后面增加如下内容:ifconfig ppp0 mtu 1472

修改内核设置以支持数据转发
1. 编辑配置文件 vi /etc/sysctl.conf
将 net.ipv4.ip_forward=0 改成 net.ipv4.ip_forward=1
保存并退出。然后执行以下命令使修改后的参数生效
sysctl -p

2. 添加 iptables 转发规则
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -j MASQUERADE
添加好转发规则后,使用如下命令保存设置并重启防火墙
/etc/init.d/iptables save/etc/init.d/iptables restart

服务配置
1. 重启 pptp 服务
/etc/init.d/pptpd restart
注意:其实此时 pptp 还没运行起来,所以使用 restart 重启,会显示 Shutting down pptp [FAILED]。还会有一个警告,可以忽略。如不放心可以再用以上命令重启 pptp 服务,相关告警信息就会消失。

2. 设置 pptp 和 iptables 自启动:
chkconfig pptpd onchkconfig iptables on
至此,PPTP VPN 服务端安装结束。在本地计算机"网络和共享中心",设置新的连接或网络,即可访问 VPN。
CentOS PPTP VPN客户端配置
1. 安装软件包
yum install -y ppp pptp pptp-setup


2. 连接 VPN 服务端
pptpsetup --create test --server IP--username 用户名 --password 密码 --encrypt --start# IP、用户名、密码替换为VPN服务端实际配置的值

连接成功后,提示已经被分配了 192.168.0.234 的客户端地址,执行 ifconfig 可以看到一块 ppp0 的网卡:

3. 增加默认路由
ip route replace default dev ppp0

增加路由后查看已经可以访问外网。
常见问题:
链接后出现感叹号 ,能够链接VPN 但不能上网
解决:没有做路由策略 防火墙中增加转发规则
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -j MASQUERADE
问题二: 防火墙提示
本人一开始按照网上教程安装,最后发现出现以下问题,折腾了很久,最后发现教程的防火墙策略有问题, 所以搭建的时候要根据自己的实际需求来配置策略。

防火墙配置

检查防火墙策略 是否被限制
Centos 6.x 部署pptp VPN的更多相关文章
- CentOS 6.3配置PPTP VPN的方法
1.验证ppp 用cat命令检查是否开启ppp,一般服务器都是开启的,除了特殊的VPS主机之外. [root@localhost1 /]# cat /dev/ppp cat: /dev/ppp: No ...
- CentOS 6.5搭建PPTP VPN服务器
VPN是虚拟专用网络(Virtual Private Network)的缩写,VPN有多种分类方式,包括PPTP.L2TP.IPSec等,本文配置的VPN服务器是采用PPTP协议的,PPTP是在PPP ...
- CentOS 6、7下pptp vpn一键安装脚本
之前有折腾过<CentOS 6.7下IPSEC/L2TP VPN一键安装脚本>,不稳定.不支持IOS,因此换成pptp,并已经添加到<lnmp一键安装包>.这个脚本可以单独使用 ...
- CentOS 6.x 一键安装PPTP VPN脚本
环境 CentOS 6.x 32位/64位XEN/KVM/OpenVZ 步骤 依次运行下列命令 #wget http://www.hi-vps.com/shell/vpn_centos6.sh #ch ...
- CentOS 6.3上搭建PPTP VPN
系统版本:CentOS 6.3_x86_64 eth0:172.16.10.72(实验环境当公网IP使用) eth1:192.168.100.50 1.检测是否支持ppp模块 # cat /dev/p ...
- 转载 - Vultr VPS注册开通且一键快速安装PPTP VPN和电脑连接使用
本文转载来自:https://www.vultrclub.com/139.html 从2014年Vultr VPS进入市场之后,作为有背景.实力的搅局者,是的最近两年VPS.服务器的用户成本降低.配置 ...
- 搬瓦工VPS搭建PPTP VPN
之前一直在用神器Lantern和Nydus(20元一个月),感觉还不错,但是各有各的不足! 于是开始自己动手折腾用VPS搭建VPN... 上网逛了一圈,最后选择了搬瓦工的VPS:512RAM,10G ...
- CentOS Mono Nginx 部署 MVC4+WebApi
CentOS Mono Nginx 部署 MVC4+WebApi 经过几天的折磨,终于在CentOS上成功部署了MVC4+WebApi.Mono上的服务器推荐两种:Jexus(国产高人写的一款很牛的服 ...
- Juniper SSG5 PPTP VPN 619错误解决
公司分部的客户端需要使用PPTP VPN连接总部,将网关更换为Juniper SSG5后,客户端出现了每几个小时自动断开的现象,错误619. 解决:Security —— ALG —— 开启PPTP协 ...
随机推荐
- Natas Wargame Level 2 Writeup 与目录泄露(强制访问)
- (Unsupported class version number [52.0] (maximum 51.0, Java 1.7))
遇到类似问题,主要原因是proguard版本只支持到java7,而我使用的是java8. 解决方法是下载最新proguard(支持java 8的版本),然后将下载的文件解压,将libs下jar与and ...
- 关于win10和sqlserver的兼容性
本人主要是用.NET开发一些MIS(信息管理系统)系统,如酒店管理系统,医院管理系统,以及其附属的如餐饮管理系统,洗浴管理系统,以及医保管理系统,合疗管理系统,前期开发的产品主要是VS2008+sql ...
- 热部署环境下,dubbo序列化的bug和优化
一.问题的发现与解决 (1) 在热部署下,使用dubbo的序列化一个pojo对象,反序列化时报错:ClassNotFoundException. 最后发现原因是我们的框架选择使用了java序列 ...
- Java中的系统时间
System.currentTimeMillis()产生一个当前的毫秒,这个毫秒其实就是自1970年1月1日0时起的毫秒数,Date()其实就是相当于Date(System.currentTimeMi ...
- Eclipse中常用的快捷键,敏捷开发必备.
1. ctrl+shift+r:打开资源 这可能是所有快捷键组合中最省时间的了.这组快捷键可以让你打开你的工作区中任何一个文件,而你只需要按下文件名或mask名中的前几个字母,比如applic*.xm ...
- TreeMap集合特点、排序原理
TreeMap特点(类似于TreeSet): 1.无序,不允许重复(无序指元素顺序与添加顺序不一致) 2.TreeMap集合默认会对键进行排序,所以键必须实现自然排序和定制排序中的一种 3..底层使用 ...
- mysql安装报错
一: -- MySQL 5.5.22Warning: Bison executable not found in PATH-- Configuring done-- Generating done-- ...
- Hadoop SSH+IP、SSH+别名 免密登录配置
1.为什么要进行 SSH 无密码验证配置? Hadoop运行过程中需要管理远端Hadoop守护进程,在Hadoop启动以后,NameNode是通过SSH(Secure Shell)来启动和停止各个Da ...
- File字节流
1. File f = new File("文件路径") 注意:相对路径:非web项目的相对都是以项目为起点.(src/a/txt(建议) 绝对路径:f: ...