oracle启动 init.ora spfile pfile[转]
>cmd
>sqlplus sys/**** as sysdba
SQL>startup
ORA-00093:_shared_pool_reserved_min_alloc must be between 4000 and 0
SQL>
然后我找了一个其中有
pga_aggregate_taarget=200M
.....
db_cache_size=200M
....
shared_pool_size=200M
..
的一个init什么w.ora的文件,不知道在哪里找的,把其中这3个参数改过去,改回来,启动还是报上面那个错,还有的错误是:
SQL>startup
ORA-00821:Specified value of sga_target 280M is too small,needs to be at least 692M
SQL>
D:\oracle\product\10.2.0\db_1\admin\orclyxkj\pfile\init.ora.4142011856
##############################################################################
# Copyright (c) 1991, 2001, 2002 by Oracle Corporation
##############################################################################
###########################################
# SGA Memory
###########################################
sga_target=890455552
这个错误,我找到了下面这个文件,改了其中的sga_target=890455552(之前是sga_target=290455552),也就是增加了4倍,但奇怪的是,包括上面那个问题,不管你把参数改成多少,他每次报的错还是一样,上面说至少4000,我改了5000,6000都还是报那个错,现在这个,从原来的参数增加了4倍,还是报同样的错,于是我认为,这些文件不起作用。然后问了群里的高人,问题解决了:
1.自建一个init.ora的oracle配置文件(随便放在哪里,我放在C盘根目录下面):
orclyxkj.__db_cache_size=192937984
orclyxkj.__java_pool_size=4194304
orclyxkj.__large_pool_size=4194304
orclyxkj.__shared_pool_size=83886080
orclyxkj.__streams_pool_size=0
*.audit_file_dest='D:\oracle\product\10.2.0\db_1/admin/orclyxkj/adump'
*.background_dump_dest='D:\oracle\product\10.2.0\db_1/admin/orclyxkj/bdump'
*.compatible='10.2.0.1.0'
*.control_files='D:\oracle\product\10.2.0\oradata\orclyxkj\control01.ctl','D:\oracle\product\10.2.0\oradata\orclyxkj\control02.ctl','D:\oracle\product\10.2.0\oradata\orclyxkj\control03.ctl'
*.core_dump_dest='D:\oracle\product\10.2.0\db_1/admin/orclyxkj/cdump'
*.db_block_size=8192
*.db_cache_size=188743680
*.db_domain=''
*.db_file_multiblock_read_count=16
*.db_name='orclyxkj'
*.db_recovery_file_dest='D:\oracle\product\10.2.0\db_1/flash_recovery_area'
*.db_recovery_file_dest_size=2147483648
*.dispatchers='(PROTOCOL=TCP) (SERVICE=orclyxkjXDB)'
*.job_queue_processes=10
*.open_cursors=300
*.pga_aggregate_target=96468992 #这个是pga的大小,96M。oracle 一共 使用内存 1.7 g。1.7g 的话 80% 给 sga(1.36M) ,20% 给 pga(0.34M)
*.processes=150
*.remote_login_passwordfile='EXCLUSIVE'
*.sga_target=1073741824 #这个之前很小,启动还是报错,于是把这个参数调大,内存2G,调的1G
*.shared_pool_size=0 #然后把share_pool都改为0(这个我不知道为什么,回头研究)
*.undo_management='AUTO'
*.undo_tablespace='UNDOTBS1'
*.user_dump_dest='D:\oracle\product\10.2.0\db_1/admin/orclyxkj/udump'
2。启动的时候:
SQL>startup pfile=c:\init.ora
然后就发现,oracle可以开起来了!可以在SQL>下面进行查询了。但是,这并不代表着就可以通过pl/sql访问oracle了。
另外还要执行一句非常重要的话,之前没执行这句话,pl/sql一直不能访问oracle,执行完后,终于可以访问:
SQL>create spfile from pfile='c:\init.ora'
注意,pfile=后面的路径一定要加单引号,要不然报“invalied file name”错误。
3。配置监听。
打开oracle的Net Configration Assistent,可以删除曾经的监听,再新建一个监听,或者直接配置之前已经有的监听。
若新建监听:
Oracle Net Configration Assistent--》本地Net服务名配置--》添加--》服务名(自己写,一般和数据库名一样orclyxkj)--》TCP--》主机名:(127.0.0.1)--》不进行测试--》网络服务名(默认和前面设置的服务名一样)--》后面要指定路径的,指定到db_1这一层(D:\oracle\product\10.2.0\db_1)
若更改旧监听:
在Oracle Net Manager页面:
本地--》服务命名--》orclyxkj(自己的服务器名)--》
--》服务标识:
服务名:orclyxkj
SID:(灰的,无法填)
连接类型:数据库默认设置
--》地址配置:
地址1:
协议:TCP/IP
主机名:192.168.1.X(我认为,这里一定要写本机IP,之前试过写本机名或者127.0.0.1,到后来开监听服务的时候,都会报错)
端口号:XXXX(默认是1521)
-------》监听程序
LISTENER:
地址1,和上面配一样,然后保存,监听就配好了。
4。开启服务:
我的电脑--》管理--》服务和应用程序--》服务(需要启动2个oracle服务):
OracleOraDb10g_home1TNSListener (启动这个的时候如果报“进程以外终止”错误,就到上面把监听配置正确)
OracleServiceORCLYXKJ
到这2个服务都正常开启,好了,可以通过pl/sql正常访问oracle了!
精华啊,弄到晚上4点半啊!其中sga_target为什么那么写,我要进一步了解!
oracle启动 init.ora spfile pfile[转]的更多相关文章
- Oracle启动中,spfile.ora、init<SID>.ora、spfile<SID>.ora 这三个文件正确的先后顺序是什么?
Oracle启动中,spfile.ora.init<SID>.ora.spfile<SID>.ora 这三个文件正确的先后顺序是什么? 解答:启动数据库,使用startup命令 ...
- 判断ORACLE启动时使用spfile还是pfile
自Oracle 9i以后启动的时候默认使用的初始化文件是spfile,我们可以通过如下三种方式来判断是SPFILE还是PFILE方式启动数据库.1.show parameter spfile2.sho ...
- ORACLE的init.ora配置文件中参数详解
db_name = "orcl" 一个数据库标识符,应与CREATE DATABASE 语句中指定的名称相对应. instance_name = orcl在多个例程使用相同服务 ...
- oracle三个重要参数文件:pfile和spfile和init.ora
Oracle中的参数文件是一个包含一系列参数以及参数对应值的操作系统文件.它们是在数据库实例启动第一个阶段时候加载的, 决定了数据库的物理 结构.内存.数据库的限制及系统大量的默认值.数据库的各种物理 ...
- init.ora, pfile, spfile
实例启动时,查找初始化参数文件的顺序为: spfile<sid>.oraspfile.orainit<sid>.ora 如果以上3个文件都不存在,则实例无法启动. init.o ...
- oracle的参数文件:pfile和spfile
1.pfile和spfile Oracle中的参数文件是一个包含一系列参数以及参数对应值的操作系统文件.它们是在数据库实例启动时候加载的,决定了数据库的物理 结构.内存.数据库的限制及系统大量的默认值 ...
- oracle spfile pfile
1.如果不指定的話 先后順序: spfileSID.ora spfile.ora initSID.ora init.ora. 2.这样startup spfile='*.oar',不允许的. 3.不过 ...
- oracle基础知识(六)----spfile与pfile
一, 认识参数文件 Oracle中的参数文件是一个包含一系列参数以及参数对应值的操作系统文件.它们是在数据库实例启动时候加载的,决定了数据库的物理 结构.内存.数据库的限制及系统大量的默认值 ...
- Linux 启动数据库报错:could not open parameter file init**.ora
sqlplus /nolog.conn /as sysdba.startup命令后显示 SQL> startupORA-01078: failure in processing system p ...
随机推荐
- 由于IPv6导致的iOS应用发布失败,是否该怪Azure?
IPv6已经被越来越广泛的支持了,尤其是苹果强制要求iOS (确切的说是iOS 9以及后续版本)应用必须支持IPv6之后(官方宣布),更将进一步推动IPv6的使用. 不过苹果应用作为客户端强制要求IP ...
- Django开发的基于markdown的博客开源
PiperMarkdown Blog for Django1.11,Python 3.6,based on Markdown,网址,希望大家能给个star,谢谢! 什么是PiperMarkdown 这 ...
- tomcat 修改为自己项目界面
修改Tomcat欢迎界面为自己项目界面 Posted on 2011-04-16 13:10 IceWee 阅读(1062) 评论(0) 编辑 收藏 所属分类: Tomcat 由于项目要发布到互 ...
- JS运动框架的封装过程(一)
给大家出一道题,从起点A走到目的地B,一共用了1000毫秒,每一次是30毫秒,请问你在这里面得到了哪些信息? 信息有哪些呢? 第一个,总时长是:1000毫秒 第二个,多久时间走一次?30毫秒 第三个, ...
- 利用libcurl进行post
逛百度知道看到有个人提问:http://zhidao.baidu.com/question/1447092283140740700 C写HTTP应用只有疯子才会老老实实的SOCKET编程吧?我后来还是 ...
- wget访问SOAP接口
SOAP协议主要是XML交互,所以其访问过程类似于这样: wget --header='Content-Type: text/xml;charset=utf-8' --post-data='<s ...
- gulp实用配置(2)——中小项目
上一篇的gulp配置很简单,主要就是为了demo的查看和调试,这一篇则会相对详细一些,包括压缩合并打时间戳等. 在互联网环境比较好的城市,需要多人协作的,大一点的项目应该都用上了模块化(这里主要指co ...
- WM_COPYDATA传送指针数据类型的问题
WM_COPYDATA传送指针数据的问题 var cdds:TcopyDataStruct; strAnsi:string;begin cdds:=PCopyDataSt ...
- ansible的安装
安装 ansible-server的安装 client需要有python2.5以上 的python server和client都关闭了selinux server端: 网址: http://www.a ...
- Apple使用Apache Mesos重建Siri后端服务
苹果公司宣布,将使用开源的集群管理软件Apache Mesos,作为该公司广受欢迎的.基于iOS的智能个人助理软件Siri的后端服务.Mesosphere的博客指出,苹果已经创建了一个命名为J.A.R ...