一. yum 安装mysql5.6
1. 安装仓库
要使用yum 安装mysql,需要使用mysql的yum 仓库,先从官网下载适合你的系统仓库
然后安装一下这个仓库列表
wget http://repo.mysql.com//mysql57-community-release-el6-8.noarch.rpm
rpm -ivh mysql57-community-release-el6-5.noarch.rpm
2.选择版本
查看可安装的mysql版本
[root@www ~]# yum repolist enabled | grep "mysql.*-community.*"
如果我们要选择版本,可以先执行下面命令查看一下有哪些版本
[root@www ~]# yum repolist all | grep mysql
选择版本启动5.6版本的,禁用5.7版本仓库
[root@www ~]# yum-config-manager --enable mysql56-community
[root@www ~]# yum-config-manager --disable mysql57-community
或者直接在yum 仓库中禁用mysql5.7的
编辑/etc/yum.repos.d/mysql-community.repo文件
enabled=0 表示禁用
比如要安装5.7版本的mysql,要确定5.6的enabled=0,5.7的enabled=1,一次保证只启用一个子仓库
[root@www yum.repos.d]# vim mysql-community.repo
###mysql5.5 全部禁用
15 # Enable to use MySQL 5.5
16 [mysql55-community]
17 name=MySQL 5.5 Community Server
18 baseurl=http://repo.mysql.com/yum/mysql-5.5-community/el/6/$basearch/
19 enabled=0
20 gpgcheck=1
21 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
###开启mysql5.6
23 # Enable to use MySQL 5.6
24 [mysql56-community]
25 name=MySQL 5.6 Community Server
26 baseurl=http://repo.mysql.com/yum/mysql-5.6-community/el/6/$basearch/
27 enabled=1
28 gpgcheck=0
29 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
###mysql5.7 禁用
31 [mysql57-community]
32 name=MySQL 5.7 Community Server
33 baseurl=http://repo.mysql.com/yum/mysql-5.7-community/el/6/$basearch/
34 enabled=0
35 gpgcheck=1
36 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-mysql
这时在查看可安装mysql版本,只剩下mysql5.6
[root@www yum.repos.d]# yum repolist enabled | grep "mysql.*-community.*"
mysql-connectors-community MySQL Connectors Community 42
mysql-tools-community MySQL Tools Community 51
mysql56-community MySQL 5.6 Community Server 396
安装mysql5.6
[root@www yum.repos.d]# yum install mysql-community-server
启动mysql数据库
[root@www yum.repos.d]# service mysqld start
MySQL Daemon failed to start.
启动报错,mysql Daemon 进程启动失败,查看错误日志: /var/log/mysqld.log
[ERROR] InnoDB: auto-extending data file ./ibdata1 is of a different size 640 pages (rounded down to MB) than specified in the .cnf file: initial 768 pages, max 0 (relevant if non-zero) pages!
2017-11-20 00:00:20 5464 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
2017-11-20 00:00:20 5464 [ERROR] Plugin 'InnoDB' init function returned error.
2017-11-20 00:00:20 5464 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2017-11-20 00:00:20 5464 [ERROR] Unknown/unsupported storage engine: InnoDB
2017-11-20 00:00:20 5464 [ERROR] Aborting
解决方法: yum安装mysql5.6 数据目录位置:/var/lib/mysql
在此目录下删除: ibdata1 ib_logfile1 ib_logfile0 这三个目录,重启动mysql成功
更改mysql root 密码:
[root@www mysql]# mysqladmin -u root password '123123'
Warning: Using a password on the command line interface can be insecure.
mysqladmin: unable to change password; error: 'Column count of mysql.user is wrong. Expected 43, found 39. Created with MySQL 50171, now running 50638. Please use mysql_upgrade to fix this error.'
报错信息:依据提示 执行。
[root@www mysql]# mysql_upgrade
再次更改mysql密码成功
[root@www mysql]# mysqladmin -uroot password '123123'
Warning: Using a password on the command line interface can be insecure.
- yum安装 lnmp (linux+nginx+php7.1+mysql5.7)
1.第一步先更新yum update 2.yum安装nginx安装nginx最新源:yum localinstall http://nginx.org/packages/centos/7/noarch ...
- Yum 安装并设置 MySQL
本质上都是设置一个yum源,然后yum安装即可. 不过添加yum源有两个方法,一种是自己新建一个 /etc/yum.repos.d/mysql-community.repo :另一种是使用MySQ ...
- linux下使用yum安装Apache+php+Mysql+phpMyAdmin
适用redhat于32位及64位,前提架设好本地源.在这里不再赘述. 1 安装Apache+php+Mysql a.安装Apahce, PHP, Mysql, 以及php连接mysql库组件 yum ...
- CentOS yum安装和配置MySQL(转载)
From:http://www.cnblogs.com/xiaoluo501395377/archive/2013/04/07/3003278.html] 一.MySQL简介 说到数据库,我们大多想到 ...
- 转载:centos上yum安装apache+php+mysql等
1. 更新系统内核到最新. [root@linuxfei ~]#yum -y update 系统更新后,如果yum安装时提示错误信息,请执行以下命令修复. [root@linuxfei ~]#rpm ...
- InputFormat,OutputFormat,InputSplit,RecordRead(一些常见面试题),使用yum安装64位Mysql
列举出hadoop常用的一些InputFormat InputFormat是用来对我们的输入数据进行格式化的.TextInputFormat是默认的. InputFormat有哪些类型? DBInpu ...
- CentOS 5.6服务器配置YUM安装Apache+php+Mysql+phpmyadmin
1. 更新系统内核到最新. [root@linuxfei ~]#yum -y update 系统更新后,如果yum安装时提示错误信息,请执行以下命令修复. [root@linuxfei ~]#rpm ...
- linux下yum安装指定的mysql版本
因为直接使用yum安装的mysql会是默认版本5.1的版本 但是有的同学不满足又想要其他版本的怎么办呢? 曾时候我来提供一种方案(仅供参考): 我们可以使用rpm包来进行指定mysql版本的安装, ...
- CentOS 6.5通过yum安装和配置MySQL
0x00 说明 Linux安装MySQL一共有两种方式,一种是下载安装包离线安装,另一种就是通过yum在线安装,这里先介绍在线安装的方式,此方法简单方便,出错最少,但是无法控制安装的MySQL版本,如 ...
随机推荐
- LeetCode OJ--4Sum *
https://oj.leetcode.com/problems/4sum/ 在一个数列中,找出所有的4个数,它们的和是target. class Solution { public: vector& ...
- CCCC L1-039. 古风排版【图形输出/循环控制行列/模拟/细节】
L1-039. 古风排版 时间限制 400 ms 内存限制 65536 kB 代码长度限制 8000 B 判题程序 Standard 作者 陈越 中国的古人写文字,是从右向左竖向排版的.本题就请你编写 ...
- CRB and Candies LCM 性质
题目 CRB and Candies 题意 \[ \text{给定正整数N,求} LCM \lbrace C \left(N , 0 \right),C\left(N , 1 \right),..., ...
- Linux笔记:crond
crontab中列出需要执行的命令及执行时间.由于指定的日期Day与星期Week不是相互包含的关系,而是有相交也有不相交的时间.当日期数与星期数均指定为确定值的时候,指令的执行时间到底是什么样的,之前 ...
- 洛谷——P2040 打开所有的灯
P2040 打开所有的灯 题目背景 pmshz在玩一个益(ruo)智(zhi)的小游戏,目的是打开九盏灯所有的灯,这样的游戏难倒了pmshz... 题目描述 这个灯很奇(fan)怪(ren),点一下就 ...
- 使用log4net无法将日志记录插入mysql数据库解决办法
写在前面 今天没事研究了下,将日志文件写入mysql数据库,因为新公司用的数据库也是mysql,项目中需要将日志信息写入数据库,没办法,就研究了下.在使用过程中遇到一个很蛋疼的问题.最后解决了,郁闷了 ...
- ArcGIS 开发时,解决__类型“XX”同时存在于“”和“”中__的错误
错误提示:类型“ESRI.ArcGIS.ADF.BaseClasses.BaseCommand”同时存在于“e:\Program Files\ArcGIS\DeveloperKit10.2\DotNe ...
- IOS7开发~UIKit Dynamics
UIKit Dynamics的中文名称:有叫UIKit动力,也有叫UIKit动力模型和UIKit动态或者动态UI,叫什么名不要紧,理解就含义就可以了. 什么是UIKit Dynamics ? UIKi ...
- 跟着实例学习设计模式(9)-桥接模式bridge(结构型)
桥接模式属于结构型设计模式. 设计意图:将抽象部分与实现部分分离.使它们都能够独立的变化. 一看到设计意图,大家可能有些发懵,我们看到的继承和接口不都是抽象和实现分离的吗?尤其是接口和抽象类都是这种实 ...
- CSS环绕球体的旋转文字-3D效果
代码地址如下:http://www.demodashi.com/demo/12482.html 项目文件结构截图 只需要一个html文件既可: 项目截图: 代码实现原理: 该示例的实现过程很简单,主要 ...