Supervisor 介绍

Supervisor是用Python开发的一套通用的进程管理程序,能将一个普通的命令行进程变为后台daemon,并监控进程状态,异常退出时能自动重启。它是通过fork/exec的方式把这些被管理的进程当作supervisor的子进程来启动,这样只要在supervisor的配置文件中,把要管理的进程的可执行文件的路径写进去即可。也实现当子进程挂掉的时候,父进程可以准确获取子进程挂掉的信息的,可以选择是否自己启动和报警。

官网

http://supervisord.org/installing.html

终于在Python3下可以正常使用pip安装了。

由于Supervisor是用Python开发的程序,在安装前,请确保系统已安装Python

pip install supervisor
upervisor安装完成后,会生成三个执行程序:supervisortd、supervisorctl、echo_supervisord_conf,分别是supervisor的守护进程服务(用于接收进程管理命令)、客户端(用于和守护进程通信,发送管理进程的指令)、生成初始配置文件程序。

生成配置文件:

mkdir Supervisor

cd Supervisor/
echo_supervisord_conf > supervisord.conf

配置文件:

[unix_http_server]
file=/tmp/supervisor.sock ;UNIX socket 文件,supervisorctl会使用其与supervisord通信
;chmod=0700 ;socket文件的mode,默认是0700
;chown=nobody:nogroup ;socket文件的owner,格式:uid:gid ;[inet_http_server] ;HTTP服务器,提供web管理界面
;port=127.0.0.1:9001 ;Web管理后台运行的IP和端口,如果开放到公网,需要注意安全性
;username=user ;登录管理后台的用户名
;password=123 ;登录管理后台的密码 [supervisord]
logfile=/tmp/supervisord.log ;日志文件,默认是 $CWD/supervisord.log
logfile_maxbytes=50MB ;日志文件大小,超出会rotate,默认 50MB。如果设成0,表示不限制大小
logfile_backups=10 ;日志文件保留备份数量默认10,设为0表示不备份
loglevel=info ;日志级别,默认info,其它: debug,warn,trace
pidfile=/tmp/supervisord.pid ;pid 文件
nodaemon=false ;是否在前台启动,默认是false,即以 daemon 的方式启动
minfds=1024 ;可以打开的文件描述符的最小值,默认 1024
minprocs=200 ;可以打开的进程数的最小值,默认 200 [supervisorctl]
serverurl=unix:///tmp/supervisor.sock ;通过UNIX socket连接supervisord,路径与unix_http_server部分的file一致
;serverurl=http://127.0.0.1:9001 ; 通过HTTP的方式连接supervisord ; [program:xx]是被管理的进程配置参数,xx是进程的名称
[program:xx]
command=/opt/apache-tomcat-8.0.35/bin/catalina.sh run ; 程序启动命令
autostart=true ; 在supervisord启动的时候也自动启动
startsecs=10 ; 启动10秒后没有异常退出,就表示进程正常启动了,默认为1秒
autorestart=true ; 程序退出后自动重启,可选值:[unexpected,true,false],默认为unexpected,表示进程意外杀死后才重启
startretries=3 ; 启动失败自动重试次数,默认是3
user=tomcat ; 用哪个用户启动进程,默认是root
priority=999 ; 进程启动优先级,默认999,值小的优先启动
redirect_stderr=true ; 把stderr重定向到stdout,默认false
stdout_logfile_maxbytes=20MB ; stdout 日志文件大小,默认50MB
stdout_logfile_backups = 20 ; stdout 日志文件备份数,默认是10
; stdout 日志文件,需要注意当指定目录不存在时无法正常启动,所以需要手动创建目录(supervisord 会自动创建日志文件)
stdout_logfile=/opt/apache-tomcat-8.0.35/logs/catalina.out
stopasgroup=false ;默认为false,进程被杀死时,是否向这个进程组发送stop信号,包括子进程
killasgroup=false ;默认为false,向进程组发送kill信号,包括子进程 ;包含其它配置文件
;[include]
;files = relative/directory/*.ini ;可以指定一个或多个以.ini结束的配置文件

配置示例:

[program:flower]
command=/root/python_envs/celery_project/bin/celery -A celery_task.celery flower --address=0.0.0.0 --port=5555 --basic_auth=admin:Zxing.112233 ; the program (relative uses PATH, can take args)
process_name=%(program_name)s ; process_name expr (default %(program_name)s)
numprocs=1 ; number of processes copies to start (def 1)
directory=/root/python-projects/test-project/celery_project ; directory to cwd to before exec (def no cwd)
priority=999 ; the relative start priority (default 999)
autostart=true ; start at supervisord start (default: true)
startsecs=1 ; # of secs prog must stay up to be running (def. 1)
startretries=3 ; max # of serial start failures when starting (default 3)
autorestart=unexpected ; when to restart if exited after running (def: unexpected)
exitcodes=0 ; 'expected' exit codes used with autorestart (default 0)
redirect_stderr=false ; redirect proc stderr to stdout (default false)
stdout_logfile=/etc/supervisor/logs/flower_stdout.log ; stdout log path, NONE for none; default AUTO
stdout_logfile_maxbytes=10MB ; max # logfile bytes b4 rotation (default 50MB)
stdout_logfile_backups=10 ; # of stdout logfile backups (0 means none, default 10)
stdout_capture_maxbytes=1MB ; number of bytes in 'capturemode' (default 0)
stdout_events_enabled=false ; emit events on stdout writes (default false)
stdout_syslog=false ; send stdout to syslog with process name (default false)
stderr_logfile=/etc/supervisor/logs/flower_stderr.log ; stderr log path, NONE for none; default AUTO
stderr_logfile_maxbytes=10MB ; max # logfile bytes b4 rotation (default 50MB)
stderr_logfile_backups=10 ; # of stderr logfile backups (0 means none, default 10)
stderr_capture_maxbytes=1MB ; number of bytes in 'capturemode' (default 0)
stderr_syslog=false ; send stderr to syslog with process name (default false)
user=root

配置管理进程

进程管理配置参数,不建议全都写在s upervisord.conf 文件中,建议每个进程写一个配置文件,并放在include配置块中files指定的目录下,通过include包含进 supervisord.conf 文件中。

修改配置文件:

(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# vim supervisord.conf 

# 最后加上
[include]
;files = relative/directory/*.ini
files = /home/user/ITNest/Supervisor/*.ini

# 注意点:一定开启include

启动Supervisor服务

(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisord -c supervisord.conf 

(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# tail /tmp/websocket.log 

管理用户进程

交互终端

supervisord启动成功后,通过supervisorctl客户端来管理用户进程:启动、停止、重启。运行supervisorctl命令,会进入supervisor客户端的交互终端,并会列出当前所管理的所有进程。

输入help,可以查看命令列表。如果想看某个命令的作用,运行“help 命令名称”,如:help stop。stop daphne 表示停止daphne进程,stop all 表示停止所有进程

 
 
supervisorctl管理:
命令 说明
help 打印可用操作的列表
help <action> 打印帮助<action>
add <name> [...] 激活进程/组配置中的任何更新
remove <name> [...] 从活动配置中删除进程/组
update 重新加载配置和添加/删除必要的,并将重新启动受影响的程序
update all 重新加载配置和添加/删除必要的,并将重新启动受影响的程序
update <gname> [...] 更新特定的组,并将重新启动受影响的程序
clear <name> 清除进程的日志文件
clear <name> <name> 清除多个进程的日志文件
clear all 清除所有进程的日志文件
fg <process> 连接到前台模式下的进程,按Ctrl+C退出前台
pid 得到主控制器的PID
pid <name> 按名称获取单个子进程的PID
pid all 获取每个子进程的PID,每行一个
reload 重新启动远程监控程序
reread 重新加载守护进程的配置文件,无需添加/删除(无需重新启动)
restart <name> 重启进程,注意:Restart不会重新读取配置文件。对此,请参阅reread和update
restart <gname>:* 重启组内所有进程,注意:Restart不会重新读取配置文件。对此,请参阅reread和update
restart <name> <name> 重新启动多个进程或组,注意:Restart不会重新读取配置文件。对此,请参阅reread和update
restart all 重启所有进程,注意:Restart不会重新读取配置文件。对此,请参阅reread和update
signal  
start <name> 启动进程
start <gname>:* 在一个组中启动所有进程
start <name> <name> 启动多个进程或组
start all 开始所有进程
status 获取所有进程状态信息
status <name> 按名称获取单个进程的状态
status <name> <name> 获取多个已命名进程的状态
stop <name> 停止一个进程
stop <gname>:* 停止组中的所有进程
stop <name> <name> 停止多个进程或组
stop all 停止所有进程
`tail [-f] <name> [stdout stderr] (default stdout)` 输出进程日志的最后一部分,例如: tail -f <name>按 Ctrl-C退出。tail -100 <name> 最后100个字节的进程

非交互命令操作:
(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisorctl -c supervisord.conf restart
Error: restart requires a process name
restart <name> Restart a process
restart <gname>:* Restart all processes in a group
restart <name> <name> Restart multiple processes or groups
restart all Restart all processes
Note: restart does not reread config files. For that, see reread and update.
(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisorctl -c Supervisor/supervisord.conf restart all
daphne: stopped
daphne: started (ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisorctl -c supervisord.conf stop
(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisorctl -c supervisord.conf start

重启supervisord服务:

supervisorctl  reload

Web管理界面

出于安全考虑,默认配置没有开启web管理界面,需要修改 supervisord.conf 配置文件,以打开http访权限。

修改配置

将下面的配置

;[inet_http_server]         ; inet (TCP) server disabled by default
;port=127.0.0.1:9001 ; ip_address:port specifier, *:port for all iface
;username=user ; default is no username (open server)
;password=123 ; default is no password (open server)

修改为:

[inet_http_server]         ; inet (TCP) server disabled by default
port=0.0.0.0:9001 ; ip_address:port specifier, *:port for all iface
username=user ; default is no username (open server)
password=user@user.com ; default is no password (open server)

浏览器访问 IP:9001

重启supervisor服务

(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisorctl shutdown
Shut down
(ITNest) root@PxeCtrlSys:/home/user/ITNest/Supervisor# supervisord -c supervisord.conf

一键搞定:supervisorctl reload

设置开机启动

systemctl daemon-reload       # 重新加载 systemctl配置
systemctl enable supervisord.service # 设置开机启动
systemctl disable supervisord.service # 禁止开机启动
systemctl is-active supervisord.service #(仅显示是否Active)
systemctl list-units --type=service # 显示所有已启动的服务
systemctl is-enabled supervisord.service 验证一下是否为开机启动

问题:

1.

Server requires authentication
error: <class 'xmlrpc.client.ProtocolError'>, <ProtocolError for 127.0.0.1/RPC2: 401 Unauthorized>: file: /data/python_envs/es-service/lib/python3.7/site-packages/supervisor/xmlr
pc.py line: 545

场景:执行命令:supervisorctl shutdown 之后

这是因为开启了权限验证导致,可以通过执行supervisorctl 回车输入用户名+密码 进入之后进行shutdown操作

2.

http://localhost:9001 refused connection

启动方式:

supervisorctl -c supervisord.conf

服务加入系统:

添加服务配置 vim /lib/systemd/system/supervisor.service

[Unit]
Description=supervisor
After=network.target [Service]
Type=forking
ExecStart=/data/python_envs/es-service/bin/supervisord -c /data/Supervisor/supervisord.conf
ExecStop=/data/python_envs/es-service/bin/supervisorctl $OPTIONS shutdown
ExecReload=/data/python_envs/es-service/bin/supervisorctl $OPTIONS reload
KillMode=process
Restart=on-failure
RestartSec=42s [Install]
WantedBy=multi-user.target

设置文件权限: chmod 766 supservisor.service

 
3. unknown error making dispatchers for
解决:
  原因是日志文件权限问题, 指定具体输出文件并设置对应的日志权限即可
 
 
 4. unix:///tmp/supervisor.sock no such file的问题
    今天使用supervisorctl命令,报出以上的错误信息, 这是由于linux会定期清理/tmp目录下的文件导致
    解决:
  1)修改配置文件
    

vim /etc/supervisord.conf

这里把所有的/tmp路径改掉,
/tmp/supervisor.sock 改成/var/run/supervisor.sock,
/tmp/supervisord.log 改成 /var/log/supervisor.log,
/tmp/supervisord.pid 改成 /var/run/supervisor.pid

  2)修改权限

chmod  777 /run
chmod 777 /var/log

  3) 创建supervisor.sock

touch /var/run/supervisor.sock
chmod 777 /var/run/supervisor.sock

  4)启动supervisord,注意停止之前的实例或杀死进程

supervisord -c /etc/supervisord.conf
 5.

Error: Cannot open an HTTP server: socket.error reported errno.ENOENT (2)

启动supervisord服务的时候出现的错误

原因:这是因为默认配置中的目录不存在(我的之前配置的是var/run下的一个supervisord目录下的文件, 由于服务重启 目录被删除,所以需要首先创建该目录),配置【unix_http_server】> file配置项

mkdir -p /var/run/supervisord

然后执行启动服务启动命令即可
supervisord -c /etc/supervisord/supervisord.conf
 
 
 
 
 
 
 
 
 

进程管理工具之supervisor(完整版)*的更多相关文章

  1. 进程管理工具之supervisor[详解]

    原文链接:https://blog.csdn.net/weixin_42390791/article/details/88866237 一.问题背景1.背景​   如何才能让一个进程摆脱终端,获得相对 ...

  2. Python—守护进程管理工具(Supervisor)

    一.前言简介 1.Supervisor 是一个 Python 开发的 client/server 系统,可以管理和监控类 UNIX 操作系统上面的进程.可以很方便的用来启动.重启.关闭进程(不仅仅是 ...

  3. 进程管理工具之supervisor[安装并使用]

    在Linux服务器中,有时候我们需要一个进程需要可靠的在后台运行,并且能够监控进程状态,在意外结束时能够自动重启等.此时就可以使用supervisor. supervisor 是使用Python开发的 ...

  4. supervisor python开发的进程管理工具

    Supervisor (http://supervisord.org) 是一个用 Python 写的进程管理工具,可以很方便的用来启动.重启.关闭进程(不仅仅是 Python 进程).除了对单个进程的 ...

  5. Linux进程管理工具——supervisor

    介绍 Supervisord是用Python实现的一款非常实用的进程管理工具 安装 这里用源码 supervisor-.tar.gz .tar.gz cd supervisor- sudo pytho ...

  6. supervisor进程管理工具的使用

    supervisor是一款进程管理工具,当想让应用随着开机启动,或者在应用崩溃之后自启动的时候,supervisor就派上了用场. 广泛应用于服务器中,用于引导控制程序的启动 安装好superviso ...

  7. Python 进程管理工具 Supervisor 使用教程

    Supervisor 是基于 Python 的进程管理工具,只能运行在 Unix-Like 的系统上,也就是无法运行在 Windows 上.Supervisor 官方版目前只能运行在 Python 2 ...

  8. linux 使用进程管理工具 supervisor

    1.supervisor是使用python进行开发的运行在linux服务器上的进程管理工具 老版本的supervisor需要运行在python2环境,如果需要使用supervisor管理python3 ...

  9. Supervisor安装与配置(Linux/Unix进程管理工具)

    原文链接:http://blog.csdn.net/xyang81/article/details/51555473 Supervisor(http://supervisord.org/)是用Pyth ...

  10. Supervisor(Linux/Unix进程管理工具)安装与配置

    参考链接:https://blog.csdn.net/xyang81/article/details/51555473 Supervisor(http://supervisord.org/)是用Pyt ...

随机推荐

  1. C#自定义控件—指示灯

    C#用户控件之指示灯 在体现通讯状态.运行状态等用一个靓眼的指示灯如何做? 思路(GDI) 外环用笔绘制(Pen),内圆用画刷(SolidBrush); 两个方法(用笔画圆,用画刷填充圆的内部): 绘 ...

  2. c程序设计语言 by K&R(三)结构

    一.类型定义 typedef typedef int Length; typedef char* String; typedef struct tnode* Treeptr; typedef int ...

  3. 携手华为云WeLink,合合信息旗下名片全能王推动人脉管理数智化升级

    名片是商务场景中信息传递的重要载体.在无纸化办公日益兴盛的当下,数字名片逐渐被广大职场人士接受,成为商务交流的新方式.近期,合合信息旗下名片全能王与华为云WeLink联合研发,升级数字名片" ...

  4. Angular Material 18+ 高级教程 – Material Form Field

    介绍 Form Field 或 Text Field 是 Material Design 独有的设计风格 .它长这样 注:Material Design 管它叫 Text Field,Angular ...

  5. 工具 – Cypress

    介绍 Cypress 是一款 e2e 测试工具.每当我们写好一个组件或者一个页面之后,我们会想对整体做一个测试. 在不使用工具的情况下,我们会开启 browser,然后做一系列点击.滚动.填 form ...

  6. Nuxt Kit 中的上下文处理

    title: Nuxt Kit 中的上下文处理 date: 2024/9/16 updated: 2024/9/16 author: cmdragon excerpt: Nuxt Kit 提供的上下文 ...

  7. 暑假集训CSP提高模拟5

    听好了: 7 月 22 日,比样的学长就此陷落.每个陷落的学长都将迎来一场模拟赛,为这些模拟赛带来全新的题面. 你所熟知的一切都将改变,你所熟悉的算法都将加诸比样的考验. 至此,一锤定音. 尘埃,已然 ...

  8. Outlook无法接收发送邮件,报错超出最大空间 的解决办法

    事件起因: 某客户的outlook邮箱无法接收/发送邮件,报错为:存储区已达到最大大小     解决办法: 解决思路:新建一个数据文件来接收发送邮件   具体操作: 文件-账户配置-数据文件-新建(更 ...

  9. Python之py9-py9博客情况获取

    #!/usr/bin/env python # -*- coding:utf-8 -*- import os import re import datetime import requests url ...

  10. spring cloud openfeign源码分析

    大体流程鱼骨图 1.读取配置 启动类上添加注解@EnableFeignClients,工程启动后会自动读取注解上的配置 1 @Retention(RetentionPolicy.RUNTIME) 2 ...