这篇文章主要介绍了Windows服务器下出现ZendOptimizer.MemoryBase@NETWORK SERVICE问题解决方法,需要的朋友可以参考下

日志提示

事件 ID ( 2 )的描述(在资源( Zend Optimizer )中)无法找到。本地计算机可能没有必要的注册信息或消息 DLL 文件来从远程计算机显示消息。您可能可以使用 /AUXSOURCE= 标识来检索词描述;查看帮助和支持以了解详细信息。下列信息是事件的一部分: C:\WINDOWS\TEMP\ZendOptimizer.MemoryBase@NETWORK SERVICE@262916123, 系统找不到指定的文件。

.

事件 ID ( 487 )的描述(在资源( Zend Optimizer )中)无法找到。本地计算机可能没有必要的注册信息或消息 DLL 文件来从远程计算机显示消息。您可能可以使用 /AUXSOURCE= 标识来检索词描述;查看帮助和支持以了解详细信息。下列信息是事件的一部分: Unable to view file mapping, 试图访问无效的地址。

从网上搜索到的N种可能及解决方法

解决办法一:

1.修改C:\WINDOWS\Temp\目录的访问权限,使Zend可以对目录进行修改

一般添加IIS_WPG和Network Service的写入权限就够了

2.有可能在C:\WINDOWS\temp\目录下找不到该文件,方法是新建文件名为ZendOptimizer.MemoryBase@SYSTEM和ZendOptimizer.MemoryBase@NETWORK SERVICE(如果没有)空文件即可

3.php.ini文件中设置upload_tmp_dir = “c:\windows\temp”(注意=两边的空格)

4.还有可能就是IIS没有读取ZEND目录的权限,为C:\Program Files\ZendOptimizer-2.6.2\lib\Optimizer-2.6.2目录和C:\Program Files\ZendOptimizer-2.6.2\lib\ZendExtensionManager.dll文件添加IIS_WPG读取权限(注意版本不同可能路径也有所不同)

解决有三种方法:

一种是在php.ini中去掉eAccelerator,然后重启IIS和Mysql服务;

第二种是在php.ini中加入一个"extension=php_yaz.dll"扩展,必须启用他,然后重启IIS和Mysql服务,OK问题解决。。。

第三种就是修改c:\WINDOWS\temp\目录的访问权限,使Zend可以对目录进行修改,第三种情况一般很少出现。

解决办法:

1.修改C:\WINDOWS\Temp\目录的访问权限,使Zend可以对目录进行修改

一般添加IIS_WPG和Network Service的写入权限就够了

2.有可能在C:\WINDOWS\temp\目录下找不到该文件,方法是新建文件名为ZendOptimizer.MemoryBase@SYSTEM和ZendOptimizer.MemoryBase@NETWORK SERVICE(如果没有)空文件即可

3.php.ini文件中设置upload_tmp_dir = “c:\windows\temp”(注意=两边的空格)

4.还有可能就是IIS没有读取ZEND目录的权限,为C:\Program Files\ZendOptimizer-2.6.2\lib\Optimizer-2.6.2目录和C:\Program Files\ZendOptimizer-2.6.2\lib\ZendExtensionManager.dll文件添加IIS_WPG读取权限(注意版本不同可能路径也有所不同)

复制代码 代码如下:

c:\Program Files\zend

administrators 完控

system 完控

service 完控

users 读取和运行,列出文件夹目录,读取

c:\windows\temp

Administrator 全部权限

System 全部权限

users 全部权限

extension=php_yaz.dll

extension=php_zip.dll

extension=php_sockets.dll

另外一种说法

跟扩展无关。这个错误表示 ZendOptimizer 不能设置共享内存,通常是由于权限问题造成的。建议你先注释掉 ZendOptimizer 部分,看看 phpinfo() 中输出 Environment 的 TEMP 和 TMP 都是哪些路径,确认两个目录对 everyone 可写(尤其是 TMP 目录,因为 ZendOptimizer 用的是 TMP 目录而不是 TEMP 目录)。

另外不妨用个 PHP 脚本往 TMP 目录里新建个 ZendOptimizer.SharedMemoryArea@UserName 文件来测试一下 TMP 目录确实可写。

文章来源:站群软件http://www.iis7.com/a/lm/zhanqun/

SERVICE问题解决方法的更多相关文章

  1. CentOS7下安装NVIDIA独立显卡驱动出现X service error问题解决方法

    问题症状: 最近在CentOS7下安装NVIDIA独立显卡驱动的过程中出现X service error问题,如下图所示: 解决方法: 0.到NVIDIA 官网上下载驱动文件(.run 格式) : N ...

  2. OpenStack安装部署管理中常见问题解决方法

    一.网络问题-network 更多网络原理机制可以参考<OpenStack云平台的网络模式及其工作机制>. 1.1.控制节点与网络控制器区别 OpenStack平台中有两种类型的物理节点, ...

  3. #2006 - MySQL server has gone away 问题解决方法 (全) (转)

    #2006 - MySQL server has gone away 问题解决方法 原文地址:http://www.cnblogs.com/bisonjob/archive/2009/08/18/15 ...

  4. Docker 下载镜像慢的问题解决方法

    让你火箭般的速度下载docker镜像! 的冷漠度 百家号17-11-1713:09 因为有墙的原因所以在国内下载docker镜像的速度非常慢,有时候是几kb每秒,那个蛋疼的等待,真是谁等谁知道!下面我 ...

  5. soapUI参数中文乱码问题解决方法&soap UI工具进行web接口测试

    soapUI参数中文乱码问题解决方法 可能方案1: 字体不支持中文,将字体修改即可: file-preferences-editor settings-select font 修改字体,改成能显示中文 ...

  6. cloudemanager安装时出现failed to receive heartbeat from agent问题解决方法(图文详解)

    不多说,直接上干货! 安装cdh5到最后报如下错误: 安装失败,无法接受agent发出的检测信号. 确保主机名称正确 确保端口7182可在cloudera manager server上访问(检查防火 ...

  7. cloudemanager安装时出现8475 MainThread agent ERROR Heartbeating to 192.168.30.1:7182 failed问题解决方法(图文详解)

    不多说,直接上干货!   问题详情 解决这个问题简单的,是因为有进程占用了.比如 # ps aux | grep super root ? Ss : : /opt/cm-/lib64/cmf/agen ...

  8. win7中VS2010中安装CSS3.0问题解决方法

    win7中VS2010中安装CSS3.0问题解决方法   在安装Standards Update for VS2010 SP1后,VS2010中没有CSS3.0问题,以下是我的解决方法 1.首先去官网 ...

  9. win8安装SQL Server 2005问题解决方法

    win8安装SQL Server 2005问题解决方法 1.正常安装任一版本的SQL Server 2005(最好安装企业版). 2.安装到SqlServer服务的时候提示启动服务失败(提示重试的时候 ...

随机推荐

  1. YII 用gii生成modules模块下的mvc

    1.生成model ModelPath设置为: application.modules.[moduleName].models 2.生成CURD ModelClass设置为: application. ...

  2. PHP 抽象类实现接口注意事项(含PHP与.Net的区别)

    最近在学习Drupal8,看到源码里面一个抽象类BlockBase实现了一个接口BlockPluginInterface,但是并没有实现该接口的所有方法.然后我就不淡定了,因为之前是做.NET的,记忆 ...

  3. SSRS 报表开发小技巧

    说明: 开发工具为: SQL Server Data Tools (英文版)     开发环境为: SQL Server 2012 (英文版) 一. 饼图数据外部显示 首先我们来看3张效果图:  内部 ...

  4. 重要BLOG

    Cloud http://www.cnblogs.com/CloudMan6/tag/OpenStack/ 算法基础 http://www.cnblogs.com/ECJTUACM-873284962 ...

  5. 那些年vue踩过的坑

    1.前言 学习Vue前端框架已经一个月了,作为一个web刚入门的菜鸟,在学习的过程中,网上有些技术博客往往没有什么可以借鉴的地方,在这里 我特意将我从开始一直到登录的过程记录下来.希望看到我的文章的朋 ...

  6. Pig sample用法举例

    some = sample data 0.1   遍历整个数据集,获取指定比例的行数的数据,获取的数据不确定,条数也不准确.   内部重写为filter data by random() <= ...

  7. java基础(九) 可变参数列表介绍

    一.可变参数简介 在不确定参数的个数时,可以使用可变的参数列表. 1. 语法: 参数类型...(三个点) 例如: void printArray(Object...) 注意: 每个方法最多只有一个可变 ...

  8. VisualSVN server搭建装配和指定IP或域名

    在主机商边绑定A记录即可

  9. 如何使用CSS进行网页布局(HTML/CSS)

    什么叫做布局? 又称为版式布局,是网页UI设计师将有限的视觉元素进行有机的排列组合. 题目:假设高度已知,请写出三栏布局,其中左栏和右栏宽度各为300px,中间自适应 1.浮动布局 <!DOCT ...

  10. Linux服务器安装redis数据库教程

    前面小Alan给大家说了jdk的安装,这篇跟大家聊聊redis非关系型数据库在Linux服务器的安装. redis简单介绍 REmote DIctionary Server(Redis) 是一个由Sa ...