1、属性名:appBase、使用对象:all、含义:这一Host的Web应用程序目录的路径(Web应用程序和/或WAR文件驻留的目录)。可以是CATALINA_HOME的相对路径,或者是绝对路径、默认值:无;必要的元素

2、属性名:autoDeploy、 使用对象:all、含义:Boolean型表值,在Tomcat正运行时,决定Tomcat是否自动部署最佳到Host的appBase目录中的新Web 应用程序。如果该属性被设置为true,则在Tomcat正运行时,在appBase目录中追加Web应用程序的解包目录或WAR文件,则Tomcat将 立即对其实现部署。、默认值:ture

3、属性名:className、使用对象:all、含义:Host容器实现的完全限定类名。该类必须实现org.apache.catalina.Host、默认值:org.apache.catalina.core.standardHost

4、属性名:deployOnstartup、使用对象:all、含义:Boolean型标记,决定Tomcat在启动时是否自动部署在Host的appBase目录下找到的Web应用程序。、默认值:true

5、属性名:deployXML、使用对象:S、含义:Boolean型标记,决定Tomcat是否在CATALINA_HOME/conf/[engine-name]/[host-name]目录下自动部署拥有context XML片段文件的Web应用程序、默认值:true

6、属性名:errorReportValVeClass、使用对象:S、含义:允许由Java开发者定制错误网页,必须实现org.apache.catalina.Valve、默认值:org.apache.catalina.valves.Error-ReportValve

7、属性名:name、使用对象:all、含义:Host名。在所有Engine的Host名中,必须惟一、默认值:无;必要的属性

8、属性名:unpackHars、使用对象:S、含义:决定在Tomcat启动Web应用程序之前是否解包WAR文件的标志。如果为true,则Tomcat在解压目录之外提供Web应用程序的资源。如果为false,则在压缩的的WAR文件之外提供Web应用程序的资源、默认值:true

9、属性名:workDir、使用对象:S、含义:除了在Contexts指定不同的workDir之外,在该Host中所有Web应用程序使用的临时文件路径名、默认值:\${catalina.base}/work

10、属性名:xmlNamespaceAware、使用对象:、含义:该标志知道启用或禁用XML命名空间。设置该值与xmlValidation为true,表示对web.xml文件执行有效性检验、默认值:false

11、属性名:xmlValidation、使用对象:、含义:决定Tomcat是否对Web.xml文件执行有效性检验的标志。在大部分Tomcat版本中,该功能不是很有用,因为XML分析器与一直到Sun JDK 1.6.0(包括1.6.0)的JVM中的XML分析器不兼容、默认值:false

Tomcat配置文件Host元素属性介绍的更多相关文章

  1. Tomcat配置文件Executor元素属性介绍

    该元素可用于Tomcat 6.0.11以及更高版本. 允许您为一个Service的所有Connector配置一个共享线程池.在运行多个Connector的状况下,这样处理非常有用,而且每个Connec ...

  2. tomcat 配置文件server.xml 详解 Connector Engine Host Context

    目录 一 server.xml 1.1 server 配置 1.2 service 配置 1.3 Executor 1.4 Connector 配置 1.5 Engine 其他tocmat 文章 一 ...

  3. Tomcat配置文件server.xml

    Tomcat目录中的server.xml配置文件 server.xml称为主配置文件或全局配置文件 它完成以下两个目标: 1,提供Tomcat组件的初始化配置 2,说明Tomcat的结构和含义,使得T ...

  4. tomcat配置文件之Server.xml

    Server.xml包含的元素有<Server>.<Service>.<Connector>.<Engine>.<Host>.<Con ...

  5. 【转】Tomcat配置文件入门

    Tomcat 基本配置 tomcat读取配置文件 首先简单说一下tomcat是如何读取配置文件的.tomcat在启动时,首先找系统变量CATALINA_BASE,如果没有,则找CATALINA_HOM ...

  6. 详解Tomcat 配置文件server.xml

    前言 Tomcat隶属于Apache基金会,是开源的轻量级Web应用服务器,使用非常广泛.server.xml是Tomcat中最重要的配置文件,server.xml的每一个元素都对应了Tomcat中的 ...

  7. Tomcat配置(二):tomcat配置文件server.xml详解和部署简介

    */ .hljs { display: block; overflow-x: auto; padding: 0.5em; color: #333; background: #f8f8f8; } .hl ...

  8. 3.3.4 配置Tomcat的<Context>元素 (转)

    本章3.3.2节已经介绍了在Tomcat中发布JavaWeb应用的最快捷的方式,即只需把JavaWeb应用的所有文件复制到<CATALINA_HOME>/webapps目录下即可,Tomc ...

  9. Tomcat 配置文件 server.xml

    Tomcat隶属于Apache基金会,是开源的轻量级Web应用服务器,使用非常广泛.server.xml是Tomcat中最重要的配置文件,server.xml的每一个元素都对应了Tomcat中的一个组 ...

随机推荐

  1. Theos tweak MSHookFunction

    #import "substrate.h" static FILE * (*s_orig_fopen) ( const char * filename, const char * ...

  2. IE6 下 输入类型表单控件背景问题

    .box input{background:url(img/1.jpg) fixed} <body> <div class="box"> <input ...

  3. 在TTF字体中提取想要的文字

    工具地址:https://yunpan.cn/cSLhX5jXnxFZg  访问密码 8000 1. 确保你的电脑已经安装了Java环境(能运行Java命令),这是必须的. 2.复制要提取的源字体(j ...

  4. hadoop yarn

    简介: 本文介绍了 Hadoop 自 0.23.0 版本后新的 map-reduce 框架(Yarn) 原理,优势,运作机制和配置方法等:着重介绍新的 yarn 框架相对于原框架的差异及改进:并通过 ...

  5. 转:Jmeter 用户思考时间(User think time),定时器,和代理服务器(proxy server)

    在负载测试中需要考虑的的一个重要要素是思考时间(think time), 也就是在两次成功的访问请求之间的暂停时间. 有多种情形挥发导致延迟的发生: 用户需要时间阅读文字内容,或者填表,或者查找正确的 ...

  6. Chapter 1 First Sight——14

    I parked in front of the first building, which had a small sign over the door reading front office. ...

  7. Apache无法启动提示the requested operation has failed

    主要参考这篇 http://apps.hi.baidu.com/share/detail/15868128 但还是遇到一些问题,记录如下: 1. 配置完成后,restart apache,出现 the ...

  8. Nginx反向代理使用【转载】

    最近工作中经常使用nginx,为了能够更好的使用nginx,我搜罗了很多nginx相关的技术文章来读,所以才有了下面以下内容.在此,为文中引用到和参考到的文章提供者表示感谢.如文中相关内容有错误,也欢 ...

  9. 使用JAVA NIO实现的UDP client和server

    //////////////////////////////////////////////////////////////////////////////////////////////////// ...

  10. Android学习之Service(1)--->Started方式

    界面退出后进程程序还在运行,不会被杀死,如音乐播发器.后台下载等 注:本文只讨论Started方式 main.xml代码分析 <?xml version="1.0" enco ...