mysql 5.7.20 在线安装与卸载(yum卸载与rpm卸载方式)
mysql5.7.20和之前的5.7.16版本不同,解压后没有data文件,需要自己建立
1.把下载的mysql5.7.20放到目录:/usr/local/
2.卸载cenos上预装的mysql
查看已安装:
rpm -qa|grep -i mysql mysql-libs-5.1.71-1.el6.x86_64
卸载预安装:
rpm -e --nodeps mysql-libs-5.1.71-1.el6.x86_64
再次查看查不出来说明没有预装:
rpm -qa|grep-i mysql
3.在linux /usr/local/中解压mysql压缩包改名为mysql,并在解压后的文件里面创建文件夹data
切换到目标路径:
cd /usr/local/ 解压mysql包: tar -zxvf mysql-5.7.20-linux-glibc2.12-x86_64.tar.gz 重命名: mv mysql-5.7.20-linux-glibc2.12-x86_64.tar.gz mysql cd /usr/local/mysql 创建数据库文件夹data: mkdir data
4.创建用户组mysql,创建用户mysql并将其添加到用户组mysql中,并赋予读写权限
groupadd mysql --创建mysql用户组组 useradd -r -g mysql mysql --创建mysql用户并添加到mysql用户组中 chown -R mysql mysql/ --将mysql目录访问权限赋为myql用户 chgrp -R mysql mysql/ --改变mysql目录的用户组属于mysql组
5.创建配置文件 保存并退出
创建配置文件: vim /etc/my.cnf
在mysql文件夹下创建配置文件夹data(很重要):
mkdir data [client] port = 3306 socket = /tmp/mysql.sock [mysqld] character_set_server=utf8 init_connect='SET NAMES utf8' basedir=/usr/local/mysql datadir=/usr/local/mysql/data socket=/tmp/mysql.sock log-error=/var/log/mysqld.log pid-file=/var/run/mysqld/mysqld.pid
#不区分大小写
lower_case_table_names = 1 sql_mode=STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION max_connections=5000 default-time_zone = '+8:00'
保存内容,按esc输入如下命令:wq!
6.初始化数据库并查看初始密码
#先安装一下这个,要不然初始化有可能会报错
yum install libaio
#手动编辑一下日志文件,什么也不用写,直接保存退出
cd /var/log/ vim mysqld.log :wq
chmod 命令:用于改变文件或目录的访问权限。用户用它控制文件或目录的访问权限。
chmod 777 mysqld.log chown mysql:mysql mysqld.log
#这是一行的文本,不要换行
/usr/local/mysql/bin/mysqld --initialize --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --lc_messages_dir=/usr/local/mysql/share --lc_messages=en_US
#查看初始密码
cat /var/log/mysqld.log
执行后关注最后一点:root@localhost: 这里就是初始密码
7.启动服务,进入mysql,修改初始密码
#一些必须的基本操作
cd /var/run/ mkdir mysqld chmod 777 mysqld cd mysqld vim mysqld.pid chmod 777 mysqld.pid chown mysql:mysql mysqld.pid
#在mysql的support-files文件夹下执行
cd /usr/local/mysql/support-files
#启动服务
systemctl start mysqld.service
登录服务
cd /usr/local/mysql/bin ./mysql -u root -p 注意:在此处直接回车,然后输入临时密码
修改密码:set password=password("root");
登录授权:grant all privileges on *.* to'root' @'%' identified by 'root';
授权生效:flush privileges;
注意:退出时,用exit命令就可以退出sql命令模式
8.开机自启
cd /usr/local/mysql/support-files/ cp mysql.server /etc/init.d/mysql #将mysql目录填上: vi /etc/init.d/mysql basedir=/usr/local/mysql/ datadir=/usr/local/mysql/data/授权: chmod +x /etc/init.d/mysql 设为开机启动:chkconfig --add mysqld(或者chkconfig --add mysql)
9.service启动
重启服务: service mysql restart 停止服务: service mysql stop 启动服务: service mysql start 查看服务: service mysql status 注意:以上命令也可以用mysqld来代替mysql
彻底卸载mysql5.7.20
1.使用yum安装的mysql,使用如下命令进行卸载(不能确定使用何种方式安装的mysql情况下,按后续步骤一一进行处理即可):
yum remove mysql mysql-server mysql-libs compat-mysql51 rm -rf /var/lib/mysq rm /etc/my.cnf
使用rpm -qa|grep mysql命令来查看rpm方式安装的mysql,如果查询结果不为空,需要将这些rpm卸载掉。
2.使用rpm方式安装的mysql,按如下步骤进行处理:
查看系统中是否以rpm包安装的mysql:
rpm -qa | grep -i mysql
使用rpm -e 命令将上个命令中包列表一一进行卸载。
3.删除mysql相关的服务。
chkconfig --list | grep -i mysql chkconfig --del mysql
4.找出OS中分散的mysql文件夹,并删除。
find / -name mysql
最后清空mysql相关的的所有目录以及文件
rm -rf
mysql 5.7.20 在线安装与卸载(yum卸载与rpm卸载方式)的更多相关文章
- mysql 5.6.20的安装、配置服务、设置编码格式
一.安装 安装环境 系统:Window 32 版本:Mysql 5.6.20 1. 首先从官网上http://dev.mysql.com/downloads/mysql/ ...
- 新版MySql 5.6.20,安装后无法登陆的解决办法
1.按照提示安装好mysql 2.运行cmd 进入mysql的安装目录,我的安装目录C:\Program Files\MySQL\MySQL Server 5.6\bin 输入 cd C:\Progr ...
- rpm 命令|rpm 安装|rpm 卸载|rpm 使用|rpm 删除
在Linux操作系统中,有一个系统软件包,它的功能类似于Windows里面的“添加/删除程序”,但是功能又比“添加/删除程序”强很多,它就是Red Hat Package Manager(简称RPM) ...
- [转]Linux下RPM软件包的安装及卸载 yum操作
在 Linux 操作系统下,几乎所有的软件均通过RPM 进行安装.卸载及管理等操作.RPM 的全称为Redhat Package Manager ,是由Redhat 公司提出的,用于管理Linux 下 ...
- redhat 7安装CentOS 7 yum源
http://www.bubuko.com/infodetail-2004218.html http://www.bubuko.com/infodetail-2004218.html ******** ...
- redhat下安装mysql 5.6.20,解压zip包,查看已经安装过的mysql,卸载rpm安装包,安装mysqlserver端和client,改动mysqlusername,登陆mysql,启动关闭mysql
1 将相关的mysql rpm包上传到redhat上 2 我的电脑是Redhat 6.*版本号.所以这里使用上面一个 3 解压zip包 4 安装下面几个rpm MySQL-client-a ...
- centos7环境下在线安装mysql
卸载mariadb centos默认安装了mariadb,因此,在安装mysql之前,需要卸载系统中安装的mariadb. 查看系统中所有已安装的mariadb包.命令:rpm -qa | grep ...
- win 2012 安装mysql 5.7.20 及报错 This application requires Visual Studio 2013 Redistributable. Please install the Redistributable then run this installer again 的解决办法
本文地址:http://www.cnblogs.com/jying/p/7764147.html 转载请注明出处. 安装过程其实挺简单,基本上下一步下一步,可以参考我的另一篇mysql安装文章: ...
- Windows 下 MySql 5.7.20安装及data和my.ini文件的配置(转)
Windows 下 MySql 5.7.20安装及data和my.ini文件的配置 本文通过图文并茂的形式给大家介绍了MySql 5.7.20安装及data和my.ini文件的配置方法. my ...
随机推荐
- linux 命令2
who who am i ssh scott@192.168.1.105 ps aux | grep pts/8 pwd // where are you? Page 205 mkdir -p dir ...
- 《Java多线程编程核心技术》读后感(十四)
单例模式与多线程 立即加载/饿汉模式 立即加载就是使用类的时候已经将对象创建完毕,常见的实现办法就是直接new实例化. 立即加载/饿汉模式实在调用方法前,实例已经被创建了 package Six; p ...
- VNC协议分析
VNC协议分析 摘自: http://blog.csdn.net/forever_feng/article/details/4703088 简介 VNC(Virtual Network Computi ...
- centos6.5安装filezilla
下载filezilla https://filezilla-project.org/download.php?show_all=1 tar jxf _FileZilla_3.9.0.1_x86_64- ...
- vc++图像显示
显示资源中的图片 (1)从资源中装入位图 ● 定义位图对象数据成员CBitmap m_Bitmap; ● 调用CBitmap成员函数LoadBitmap(),如m_Bitmap.LoadBitmap( ...
- Jsoncpp写“鱘”的json数据,报错。
最近在用Json::FastWriter生成json数据时,发现一个问题.含有“鱘”字的json字段会多出一个斜杠,不知道是不是编码的问题. C++要使用JSON来解析数据,一般采用jsoncpp. ...
- poj1837 Balance
Balance POJ - 1837 题目大意: 有一个天平,天平左右两边各有若干个钩子,总共有C个钩子,有G个钩码,求将钩码全部挂到钩子上使天平平衡的方法的总数. 其中可以把天枰看做一个以x轴0点 ...
- Glassfish DeploymentException: Error in linking security policy for
http://stackoverflow.com/questions/7322476/glassfish-deploymentexception-error-in-linking-security-p ...
- JS高级学习历程-12
冒充继承 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/T ...
- 将RegEx(正则表达式提取器)与JMeter一起使用
JMeter的,最流行的开源性能测试工具,可以工作正则表达式,用正则表达式提取.正则表达式是一种用于通过使用高级操作提取文本的必需部分的工具.正则表达式在测试Web应用程序时很流行,因为它们可用于验证 ...