业务迁移---redis
以前也没怎么搞过redis 只知道他是一个nosql数据库很强大,这次迁移用到了~ 正好熟练一下并记录过程,还挺繁琐。。
记录一下在学习中的几个问题,总结加深一下印象,有可能会漏掉或者有误差的地方~~~
#############################################
Redis 是一个Nosql数据库
redis.cn 中文官网
redis 编译安装依赖gcc C程序与原的编译器,redis是c语言编写的。
make 报错缺少gcc的话安装gcc, yum install gcc
make 报错jemalloc/jemalloc.h:没有那个文件或者目录,运行make distclean 之后在make
redis 5大数据类型 string字符串 HASH 哈希 LIST 列表 SET 集合 ZSET有序集合
##############################################
Redis持久化是什么?
是RDB和AOF的两种备份方式
Redis备份方法?区别在哪?
两种备份方法:
1.rdb文件备份
2.aof文件备份
区别:
RDB文件是系统默认开启的,
优点:以文件的形式存储到硬盘,根据写入的次数和和时间策略来触发备份,适合大文件的备份迁移较快的恢复大量的数据;
缺点:紧急断电或故障时有丢少量数据风险,完整性要求较高的文件备份不建议使用rdb方式。
Aof文件备份默认不开启,
优点:时时备份,AOF持久化以日志的形式记录服务器所处理的每一个写、删除操作,查询操作不会记录,以文本的方式记录,可以打开文件看到详细的操作记录。
缺点:因为是时时备份,会对磁盘时时写入,影响磁盘IO性能。
几种工作模式?
1.单机
2.分片
3.集群
主从复制的几种模式:
4中模式
1.一主二从
2.薪火相连
3.反客为主
4.哨兵模式 (目前比较流行)
迁移流程:
拷贝备份文件到新的redis服务器上
我用的rdb备份模式,scp dump.rdb到新的redis的服务器
安装Redis服务
yum install redis php-pecl-redis.x86_64 php-phpiredis.x86_64 php-nrk-Predis.noarch #yum 安装
配置redis.conf
里面配置太多了,我只更改了几个地方:
1.Redis默认不是以守护进程的方式运行,可以通过该配置项修改,使用yes启用守护进程
daemonize no #如果不想起服务的时候卡死在那最好先改为yes。。
2.rdb备份是系统默认开启的,但是他的备份文件的路径需要改一下找个大点的磁盘存储。。
dir /test/redis
3.访问权限,默认是127.0.0.1本机访问,我这边给他放开所有主机的权限,因为连的web有点多。。bind 0.0.0.0
################################## NETWORK ##################################### # By default, if no "bind" configuration directive is specified, Redis listens
# for connections from all the network interfaces available on the server.
# It is possible to listen to just one or multiple selected interfaces using
# the "bind" configuration directive, followed by one or more IP addresses.
#
# Examples:
#
# bind 192.168.1.100 10.0.0.1
# bind 127.0.0.1 ::1
bind 0.0.0.0
4.生产模式下需要配置redis密码,否则很危险,默认不配置
requirepass "myPasswOrd"
启动Redis
redis-server /etc/redis.conf
############
还有一个参数我目前没设置,因为可能性能要求还没那么高,但是非常重要,记录一下!
maxmemory 值的设置限制redis使用的内存大小一般都设置总内存的4/3,
maxmemory在64位操作系统中默认不限制,也就是=0,在32位系统默认是3G,这个根据自己情况更改吧。。
提这个的主要目的就是一旦开启了maxmemory的大小限制,就一定要给一个缓存策略,帮他来消化限制之外的set怎么处理,是抛弃?是腾空间?怎么腾?所以就有了这几个选项
noeviction就不建议选了,allkeys-lru可以在迷茫的时候选择试试~ 就理解这么多。。。
noeviction:当内存使用达到阈值的时候,所有引起申请内存的命令会报错
allkeys-lru:在主键空间中,优先移除最近未使用的key。
volatile-lru:在设置了过期时间的键空间中,优先移除最近未使用的key。
allkeys-random:在主键空间中,随机移除某个key。
volatile-random:在设置了过期时间的键空间中,随机移除某个key。
volatile-ttl:在设置了过期时间的键空间中,具有更早过期时间的key优先移除。
############
__NOLAYOUT__}
:(
Class 'Redis' not found
错误位置
FILE: /letv/www/hotel/Hoteltest/Think
错误摘记:
启动后页面打开报错,因为我使用的时SLB负载均衡,登陆网站时输入验证码时好时坏,因为时轮询的那肯定有一台有问题。
【排查思路】
1.tail -f /var/log/nginx/access.log 看一下Nginx日志,抓到了原来其中一台报错500.。。。
2.为什么会报错500呢,我测试了一下redis的连接性,没有问题应该不是权限问题。。
3.页面F12查看错误详情"Class 'Redis' not found",浏览器很友好的告诉我错误提示了。
4.通过博客查看结果时: 有的说没安装redis扩展导致的,还有一种可能就是你php和web 没有加载正确。。
【解决】
1.先将报错机器的php全部卸载。。
2.看一下正常机器安装的扩展包
[root@iz8vbilqy0q9v8tds55bqyz Hoteltest]# yum list installed|grep php|awk -F ' ' '{print $1}'|xargs
php-channel-nrk.noarch php-cli.x86_64 php-common.x86_64 php-fpm.x86_64 php-gd.x86_64 php-mysql.x86_64 php-nrk-Predis.noarch \
php-pdo.x86_64 php-pear.noarch php-pecl-igbinary.x86_64 php-pecl-redis.x86_64 php-phpiredis.x86_64 php-process.x86_64 php-xml.x86_64
yum install php-channel-nrk.noarch php-cli.x86_64 php-common.x86_64 php-fpm.x86_64 php-gd.x86_64 php-mysql.x86_64 \
php-nrk-Predis.noarch php-pdo.x86_64 php-pear.noarch php-pecl-igbinary.x86_64 php-pecl-redis.x86_64 php-phpiredis.x86_64 php-process.x86_64 php-xml.x86_64
安装重启,解决。。
错误摘记:
在一次迁移中,更换了redis.conf 中的密码,导致了主战登录页面验证码无法通过验证,一直报错~~ 将密码改回即解决,目前还不知道什么原因!!!
业务迁移---redis的更多相关文章
- 搭建备份到业务迁移---mysql
mysql安装启动以及配置 使用到阿里云主机直接yum安装以及配置 [root@yunwei-169 mysql]# yum install mysql mysql-server [root@yunw ...
- 使用redis-dump与redis-load方式迁移redis数据库
实际生产场景中,有可能会因为迁移机房或者更换物理机等原因需要在生产环境迁移redis数据.本文就来为大家介绍一下迁移redis数据的方法. 迁移redis数据一般有如下3种方式: 1.第三方工具red ...
- 华为云计算IE面试笔记-华为云计算解决方案业务迁移支持哪些迁移?有哪些特点?请描述基本的业务交付流程、业务迁移流程和原则。
1. 迁移场景:华为云计算解决方案按照源端环境来说,支持P2V.V2V(P2V:物理设备(操作系统及其上的应用软件和数据)迁移到华为虚拟化平台.V2V:其他厂商的虚拟化平台迁移到华为虚拟化平台.)以及 ...
- 新浪计数业务之Redis
今天听一个同事说新浪使用的是Redis,于是自己将研究的过程整理出来以备后用. 我们都知道微博这玩意儿现在很火,新浪作为国内最早使用redis,并且是国内最大的redis使用者,当然备受人们关注.新浪 ...
- Redis-port安装使用实现redis迁移codis,以及简单redis pipe实现将mysql迁移redis
(0)Redis-port原理: 首先是看到下面这篇文档开始研究的redis-port http://www.itnpc.com/news/web/146085373656602.html 简要截图 ...
- 业务迁移---web
#本文是做记录使用,不做为任何参考文档# 迁移代码 将源代码scp至新的server上 搭建服务 yum安装nginx服务 yum install nginx #yum安装 service nginx ...
- redis跨实例迁移 & redis上云
1)redis跨实例迁移--源实例db11迁移至目标实例db30 root@fe2e836e4470:/data# redis-cli -a pwd1 -n 11 keys \* |while rea ...
- zabbix通过php脚本模拟业务访问redis验证nosql的可用性
背景: redis通过shell脚本进行监控,没有问题,应用报警连不上redis,此时需要通过php模拟web环境进行redis的操作来确认web服务器是否能正常和redis通信 .配置nginx,让 ...
- redis集群数据迁移txt版
./redis-trib.rb create --replicas 1 192.168.112.33:8001 192.168.112.33:8002 192.168.112.33:8003 192. ...
随机推荐
- WebGL学习笔记(1)
基本的WebGL图形操作(详细参考教程:https://www.yiibai.com/webgl,需要1周左右熟悉webgl的对象方法以及着色器代码):绘制三角形 drawElements gl.TR ...
- 实现一个shell程序
实现一个自己的shell程序,这个程序有这些功能:解释执行命令,支持输入输出重定向,支持管道,后台运行 程序.当运行该程序后,它支持以下的命令格式: 1.单个命令,如:ls.2.带l到多个参数的命令, ...
- python字符编码转换说明及深浅copy介绍
编码说明: 常用编码介绍: ascii 数字,字母 特殊字符. 字节:8位表示一个字节. 字符:是你看到的内容的最小组成单位. abc : a 一个字符. 中国:中 一个字符. a : 0000 10 ...
- 使用js实现单向绑定
详细解释单向绑定 参考资料 MDN addEventListener()定义与用法 <!DOCTYPE html> <html lang="en"> < ...
- go加密算法:非对称加密(三)--Elliptic
看了2星期的区块链原理与运行机制,加密这里开始变得有些生疏,花了一天时间复习了一些;看到了之前忽略的,也学会了椭圆曲线加密. //基础板:浅显易懂package main import ( " ...
- WIN10远程连接winserver2012 r2,连接失败
背景:2012开启远程的时候,默认是勾选“仅允许运行使用网络级别身份验证的远程桌面的计算机连接”,这个选项据说比较安全,但是用win10远程的时候就报错,函数不受支持,最后通过修改win10的配置得以 ...
- 典型的 ajax 异步请求及错误处理
$.ajax({ url: path + '/emergency/saveEmergency.do', async: false,//同步,会阻塞操作 type: 'POST',//PUT DELET ...
- telent connection refused
1.问题场景 Centos7 做flume案例时,telnet hadoop-senior03.itguigu.com 44444 总是Connection redused, Trying 192.1 ...
- 爬虫-爬虫介绍及Scrapy简介
在编写案例之前首先理解几个问题,1:什么是爬虫2:为什么说python是门友好的爬虫语言?3:选用哪种框架编写爬虫程序 一:什么是爬虫? 爬虫 webSpider 也称之为网络蜘蛛,是使用一段编写好的 ...
- 单片机,struct ,union定义标志,节约RAM
单片机的RAM是非常少的,像新唐,STC,合泰等一些国产的51单片机,RAM 512 byte,1k,2k,非常常见, 有时候我们的串口接收一串数据,或AD连续采集,这些数据是不能放到 flash 里 ...