报错如下,原因是存放传过来的归档的目录+HWAREDODG满了,MRP进程无法应用归档,我在手动传了几个归档之后发现不是GAP,select * from V$ARCHIVE_GAP 显示没有GAP。于是就把HWAREDODG下已经应用的归档删掉,

rman target /

rman>select 'run{' from dual

union all

select 'delete noprompt archivelog until sequence '||max(sequence#)||' thread '||thread#||';' from v$archived_log where applied='YES' and name is not null GROUP BY thread#

union all

select '}' from dual;

删除后归档顺利生成,MRP进程正常应用

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

FAL[client]: Failed to request gap sequence

GAP - thread 1 sequence 19387-19387

DBID 3365933973 branch 982424855

FAL[client]: All defined FAL servers have been attempted.

------------------------------------------------------------

Check that the CONTROL_FILE_RECORD_KEEP_TIME initialization

parameter is defined to a value that's sufficiently large

enough to maintain adequate log switch information to resolve

archivelog gaps.

------------------------------------------------------------

Mon Feb 18 22:22:06 2019

Archived Log entry 10638 added for thread 2 sequence 16410 ID 0xc935a096 dest 1:

Mon Feb 18 22:22:06 2019

Unable to create archive log file '+HWAREDODG'

Mon Feb 18 22:22:06 2019

Errors in file /oracle/app/oracle/diag/rdbms/wlwzz/wlwcdb/trace/wlwcdb_arc3_10142.trc:

ORA-19504: failed to create file "+HWAREDODG"

ORA-17502: ksfdcre:4 Failed to create file +HWAREDODG

ORA-15041: diskgroup "HWAREDODG" space exhausted

ARC3: Error 19504 Creating archive log file to '+HWAREDODG'

Mon Feb 18 22:29:06 2019

Unable to create archive log file '+HWAREDODG'

Mon Feb 18 22:29:06 2019

Errors in file /oracle/app/oracle/diag/rdbms/wlwzz/wlwcdb/trace/wlwcdb_arc1_10138.trc:

ORA-19504: failed to create file "+HWAREDODG"

ORA-17502: ksfdcre:4 Failed to create file +HWAREDODG

ORA-15041: diskgroup "HWAREDODG" space exhausted

ARC1: Error 19504 Creating archive log file to '+HWAREDODG'

Mon Feb 18 22:36:06 2019

Unable to create archive log file '+HWAREDODG'

Mon Feb 18 22:36:06 2019

Errors in file /oracle/app/oracle/diag/rdbms/wlwzz/wlwcdb/trace/wlwcdb_arc0_10136.trc:

ORA-19504: failed to create file "+HWAREDODG"

ORA-17502: ksfdcre:4 Failed to create file +HWAREDODG

ORA-15041: diskgroup "HWAREDODG" space exhausted

ARC0: Error 19504 Creating archive log file to '+HWAREDODG'

Mon Feb 18 22:44:07 2019

Unable to create archive log file '+HWAREDODG'

Mon Feb 18 22:44:07 2019

Errors in file /oracle/app/oracle/diag/rdbms/wlwzz/wlwcdb/trace/wlwcdb_arc3_10142.trc:

ORA-19504: failed to create file "+HWAREDODG"

ORA-17502: ksfdcre:4 Failed to create file +HWAREDODG

ORA-15041: diskgroup "HWAREDODG" space exhausted

ARC3: Error 19504 Creating archive log file to '+HWAREDODG'

Mon Feb 18 22:51:07 2019

Unable to create archive log file '+HWAREDODG'

Mon Feb 18 22:51:07 2019

Errors in file /oracle/app/oracle/diag/rdbms/wlwzz/wlwcdb/trace/wlwcdb_arc1_10138.trc:

ORA-19504: failed to create file "+HWAREDODG"

ORA-17502: ksfdcre:4 Failed to create file +HWAREDODG

ORA-15041: diskgroup "HWAREDODG" space exhausted

ARC1: Error 19504 Creating archive log file to '+HWAREDODG'

记一次ADG备库归档目录满导致的延时处理的更多相关文章

  1. DG备库磁盘空间满导致无法创建归档

    上周五去某客户那里做数据库巡检.是window 2008系统上10g的一套NC系统的库,已经配置了DG,可是巡检时发现数据库报错: Tue Nov 11 10:13:57 2014 LNS: Stan ...

  2. DB2 HADR备库归档问题

    --DB2 HADR备库归档问题 --------------------------------2013/10/29 我们注意到在Oracle DataGuard中,备机中依然会设置LOG_ARCH ...

  3. oracle--DG模式备库归档缺失问题(1)

    01.问题描述 备库的归档日志没有增加,一直等待一个 查询问题: SQL> SELECT * FROM V$ARCHIVE_GAP; THREAD# LOW_SEQUENCE# HIGH_SEQ ...

  4. Oracle 19c Data Guard DML Redirection ADG备库上执行DML重定向(未来更好的进行读写分离)

    资料来自官方网站: https://docs.oracle.com/en/database/oracle/oracle-database/19/sbydb/managing-oracle-data-g ...

  5. dataguard 归档丢失(主库中无此丢失归档处理),备库基于SCN恢复

    dataguard 归档丢失(主库中无此丢失归档处理),备库基于SCN恢复 环境: OS: CentOS 6.5 DB: Oracle 10.2.0.5 1.主备库环境 主库: SQL> sel ...

  6. KingbaseES R3集群备库执行sys_backup.sh物理备份案例

    案例说明: KingbaseES R3的后期版本支持通过sys_backup.sh执行sys_rman的物理备份,实际上是调用了sys_rman_v6的工具做物理备份.本案例是在备库上执行集群的备份, ...

  7. Oracle主库归档丢失,备库日志有gap,在不重建备库的情况下,恢复备库

    本文主要描述Oracle备库日志与主库日志之间有gap,切主库这部分gap的归档日志已经删除或丢失,如何在不重建备库的情况下,恢复备库. 欢迎转载,请注明作者.出处. 作者:张正 blog:http: ...

  8. DG备库,实时应用如何判断,MR进程,及MRP应用归档,三种情况的查询及验证

    本篇文档学习,DG备库,实时应用如何判断,MR进程,及MRP应用归档,三种情况的查询及验证 1.取消MRP进程 备库查询进程状态select process,client_process,sequen ...

  9. DG备库无法接受主库归档日志之密码文件

    DG备库无法接受主库归档日志之密码文件 实验目的:还原某个客户案例,客户审计需要,对主库sys用户进行锁定,一小时后对sys用户进行解锁后,发现备库无法接受主库的归档日志 本篇文章,测试sys用户与D ...

随机推荐

  1. ComputeShader中Counter类型的使用

    接上一篇:https://www.cnblogs.com/hont/p/10122129.html 除了Append类型对应的Consume/AppendStructuredBuffer还有一个Cou ...

  2. C#中,重新排列panel中的按钮

    https://www.cnblogs.com/hfzsjz/archive/2010/08/13/1799068.html void ArrangeButtons(Panel pn) { , y = ...

  3. Golang进程权限调度包runtime三大函数Gosched、Goexit、GOMAXPROCS

    转自:https://www.cnblogs.com/wt645631686/p/9656046.html runtime.Gosched(),用于让出CPU时间片,让出当前goroutine的执行权 ...

  4. Asp.Net WebApi 跨域设置

    跨越问题主要发生在客户端ajax请求时,为了安全设置,默认webapi是不允许ajax跨越请求的,不过有方法设置让支持跨越,我说说最常见的两种方法 一.jquery jsonp 缺点:JSONP也有局 ...

  5. virtualbox安装android6.0并设置分辨率为1920x1080x32

    下载安装:https://www.cnblogs.com/wynn0123/p/6288344.html 这里我做的是下载android6.0-64bit,然后文件系统只支持ext4 安装完成之后我的 ...

  6. FastDFS特性及问题思考

    FastDFS是国人开发的一款分布式文件系统,目前社区比较活跃.系统中存在三种节点:Client.Tracker.Storage,在底层存储上通过逻辑的分组概念,使得通过在同组内配置多个Storage ...

  7. 【nodejs】exports 和 module.exports 的区别

    require 用来加载代码,而 exports 和 module.exports 则用来导出代码.但很多新手可能会迷惑于 exports 和 module.exports 的区别,为了更好的理解 e ...

  8. C# 3个延时函数

    ) { int time = Environment.TickCount; while (true) { if (Environment.TickCount - time >= DelayTim ...

  9. 推荐一本写给IT项目经理的好书

    原文地址:http://www.cnblogs.com/cbook/archive/2011/01/19/1939060.html (防止原文作者删除.只能拷贝一份了) 推荐一本写给IT项目经理的好书 ...

  10. linux可执行文件添加到PATH环境变量的方法

    linux命令行下面执行某个命令的时候,首先保证该命令是否存在,若存在,但输入命令的时候若仍提示:command not found 这个时候就的查看PATH环境变量的设置了,当前命令是否存在于PAT ...