Bug 14143011 : ORA-19606: CANNOT COPY OR RESTORE TO SNAPSHOT CONTROL FILE

[oracle@test]$ tail -f rman_delete.log   Backup Piece       3687   2018:06:08 01:05:13 /home/oracle/nfs/arch_TRANDB_20180608_3789_1 RMAN-00571: =========================================================== RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-00571: =========================================================== RMAN-03009: failure of delete command on ORA_MAINT_DISK_1 channel at 06/08/2018 01:05:36 ORA-19606: Cannot copy or restore to snapshot control file

RMAN>

Recovery Manager complete. [oracle@trandb1 nfs]$ cd ..

[oracle@test]$ rman target /

Recovery Manager: Release 11.2.0.4.0 - Production on Fri Jun 8 11:42:56 2018

Copyright (c) 1982, 2011, Oracle and/or its affiliates.  All rights reserved.

connected to target database: TRANDB (DBID=28069)

RMAN> show all;

using target database control file instead of recovery catalog

RMAN configuration parameters for database with db_unique_name TRANDB are:

CONFIGURE RETENTION POLICY TO REDUNDANCY 1; # default CONFIGURE BACKUP OPTIMIZATION OFF; # default

CONFIGURE DEFAULT DEVICE TYPE TO DISK; # default CONFIGURE CONTROLFILE AUTOBACKUP OFF; # default

CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default

CONFIGURE DEVICE TYPE DISK PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default

CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default

CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default

CONFIGURE MAXSETSIZE TO UNLIMITED; # default CONFIGURE ENCRYPTION FOR DATABASE OFF; # default

CONFIGURE ENCRYPTION ALGORITHM 'AES128'; # default

CONFIGURE COMPRESSION ALGORITHM 'BASIC' AS OF RELEASE 'DEFAULT' OPTIMIZE FOR LOAD TRUE ; # default

CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default

CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f'; # default

RMAN> show SNAPSHOT CONTROLFILE NAME;

RMAN configuration parameters for database with db_unique_name TRANDB are:

CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f'; # default

RMAN> CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f';

old RMAN configuration parameters: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f'; new RMAN configuration parameters: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f'; new RMAN configuration parameters are successfully stored

RMAN>

RMAN> CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f';

old RMAN configuration parameters: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f'; new RMAN configuration parameters: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f'; new RMAN configuration parameters are successfully stored

[oracle@test dbs ]$ cd /u01/app/oracle/11.2.0/db_1/dbs/
[oracle@test ]$ mv snapcf_trandb1.f snapcf_trandb1.f.bak

RMAN> crosscheck controlfilecopy '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f';

allocated channel: ORA_DISK_1 channel ORA_DISK_1: SID=4921 instance=trandb1 device type=DISK validation failed for control file copy control file copy file name=/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f RECID=4 STAMP=975839353 Crosschecked 1 objects

RMAN> delete expired controlfilecopy '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f';

released channel: ORA_DISK_1 allocated channel: ORA_DISK_1 channel ORA_DISK_1: SID=4921 instance=trandb1 device type=DISK List of Control File Copies ===========================

Key     S Completion Time     Ckp SCN    Ckp Time           ------- - ------------------- ---------- ------------------- 4       X 2018:05:11 10:29:13 105054602912 2018:05:11 10:29:13         Name: /u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f         Tag: TAG20180511T102912

Do you really want to delete the above objects (enter YES or NO)? yes deleted control file copy control file copy file name=/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f RECID=4 STAMP=975839353 Deleted 1 EXPIRED objects

RMAN> CONFIGURE SNAPSHOT CONTROLFILE NAME clear;

old RMAN configuration parameters: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1_temp.f'; RMAN configuration parameters are successfully reset to default value

RMAN> show SNAPSHOT CONTROLFILE NAME;

RMAN configuration parameters for database with db_unique_name TRANDB are: CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/app/oracle/11.2.0/db_1/dbs/snapcf_trandb1.f'; # default

-----再次执行RMAN 删除操作;不报错
rman target / nocatalog log /home/oracle/nfs/rman_delete.log append << EOF
  allocate channel for maintenance type disk; 
  crosscheck backupset; 
  crosscheck archivelog all; 
  delete noprompt expired backup; 
  crosscheck copy;
  report obsolete;
  delete noprompt  obsolete;

Bug 14143011 : ORA-19606: CANNOT COPY OR RESTORE TO SNAPSHOT CONTROL FILE的更多相关文章

  1. ORA-19606: Cannot copy or restore to snapshot control file

    delete obsolete; 发现出现报错 ORA-19606: Cannot copy or restore to snapshot control file 解决办法:CONFIGURE SN ...

  2. 【12c】12c RMAN新特性之通过网络远程恢复数据库(RESTORE/Recover from Service)

    [12c]12c RMAN新特性之通过网络远程恢复数据库(RESTORE/Recover from Service) 通过网络远程恢复数据库(Restore/Recover from Service) ...

  3. ocp 1Z0-043 1-60题解析

    1.You observe that a database performance has degraded overa period of time. While investigating the ...

  4. RAC异机恢复

    RAC异机恢复PDCL到PFCL: PNCL:RAC+ASM ,product env   db name:PNCL   instance:PDCL1 PDCL2 PFCL:RAC+ASM ,perf ...

  5. OCP读书笔记(27) - 题库(ExamG)

    601.You need to perform a block media recovery on the tools01.dbf data file in the SALES database by ...

  6. 【RMAN】Oracle中如何备份控制文件?备份控制文件的方式有哪几种?

    真题1. 如何备份控制文件?备份控制文件的方式有哪几种? 答案:备份控制文件的方式有多种. ① 备份控制文件可以在线进行: SQL> ALTER DATABASE BACKUP CONTROLF ...

  7. 如何通过rman的增量备份恢复dataguard中standby端的数据

    很多正在使用dataguard的客户,都会遇到一个棘手的问题: 在备份端与主库同步的过程中由于网络原因或磁盘问题导致一个或多个归档日志丢失,进而dataguard同步无法继续.很多客户都选择了重新全库 ...

  8. 官方文档 恢复备份指南六 Configuring the RMAN Environment: Advanced Topics

    RMAN高级设置. 本章内容: Configuring Advanced Channel Options  高级通道选项 Configuring Advanced Backup Options 高级备 ...

  9. TNS-01201: Listener cannot find executablen 错误

    近期在启动监听器的时候收到了TNS-01201: Listener cannot find executable...的错误提示.这个错误还真是一个一直没有碰到过的错误.咋一看还真不明确是怎么一回事呢 ...

随机推荐

  1. c# 后台拼接分页Html

    public static string ReplaceStr(string originalStr, string oldStr, string newStr) { if (string.IsNul ...

  2. Java学习笔记之——switch-case条件结构

    语法: switch(变量){ case 常量1: 执行语句: break: case 常量2: 执行语句: break: case 常量3: 执行语句: break: ………… default: 语 ...

  3. 关于git的一个错误提示

    一般clone仓库后如果,remote -v或者add出现如下的错误的话: Not a git repository (or any of the parent directories): .git需 ...

  4. sql server:查詢系統表

    ---查看所有存储过程或视图的位置 select a.name,a.[type],b.[definition] from sys.all_objects a,sys.sql_modules b whe ...

  5. VUE组件 之 Toast (Vue.extend 方式)

    一.效果图 二.说明 这类提示框组件我们通常都会直接在 JS 代码中进行调用.像下面这样: this.$toast('别点啦,到头啦!') 但看到网上大多数还是通过 component  方式实现的, ...

  6. Related concepts of testing

    根据是否知道源代码测试可以分为黑盒和白盒. 黑盒:功能测试. 白盒:知道源代码,要写测试代码. 根据测试的粒度. 方法测试: 单元测试: 集成测试: 系统测试: 根据测试的暴力程度. 压力测试:谷歌工 ...

  7. sql server 数据导出(入)方法总结

    我们都知道日常在面对数据需求时需要导出数据,比较少量的数据导出我们一般是通过查询后另存即可,当面对数据量比较大的时候我们应该怎么处理?我搜索总结一些几个方法:1.bcp 导出.2.数据库本身自带的导入 ...

  8. mysql常用赋权命令

    GRANT 所需权限 ON 库名.表名 TO '账号'@'允许访问的IP地址'; 把中文按需替换掉 所需权限:select.insert.delete.update按需要来. 上面那个允许访问IP ' ...

  9. 【PAT】B1032 挖掘机技术哪家强(20 分)

    #include<cstdio> const int maxx= 100010; int school[maxx]={0}; int main() { int n,schid,schsco ...

  10. git 创建本地仓库、远程仓库,上传项目

    1.在本地想创建git仓库的地方创建本地仓库 首先右键打开 Git Bash Here,如果没有,请先安装git,下载地址:https://git-scm.com/downloads git init ...