思路:在网络上准备一个主机,在其中安装一个web服务器软件(比如apache),然后创建一个目录,在这个目录中准备上yum仓库的全部资源,如果用户可以通过网络访问到该主机的这个目录,那么这个目录就成为网络yum仓库

实现过程
第一步:配置yum源主机

1)安装配置apache

[root@ ~]# yum install httpd -y

2)配置yum仓库相关资源

1. 创建一个目录,作为存储yum资源的目录,此次目录为mysource

(此目录需要创建在apache的根目录下,由于安装方式不相同,根目录位置也不相同

采用编译安装的apache根目录在/usr/local/apache/htdocs下,yum安装的apache根目录在/var/www/html下)

在apache根目录中创建yum资源的目录

[root@~]# mkdir /var/www/html/mysource
[root@66 ~]# cd /var/www/html/
[root@66 html]# ls
mysource

3). 挂载光盘(本次使用系统自带的光盘中的源,自己也可以到国内镜像网站下载源)

[root@67 ~]# mount /dev/sr0 /mnt
mount: /dev/sr0 is write-protected, mounting read-only

4). 将光盘中的资源复制到前面所创建的目录下

[root@ ~]# cp /mnt/* /var/www/html/mysource/ -rvf

5).查看

[root@~]# ls /var/www/html/mysource/
CentOS_BuildTag EULA images LiveOS repodata RPM-GPG-KEY-CentOS-Testing-
EFI GPL isolinux Packages RPM-GPG-KEY-CentOS- TRANS.TBL

6). 用浏览器访问一下yum仓库,检查是否可以看到相关文件

此次实验主机ip10.220.5.67,在浏览器输入10.220.5.67.mysource

说明部署成功

第二步:配置客户端主机 用于测试(10.220.5.63)

修改yum配置文件

1)备份原有的配置文件

[root@ ~]# mkdir bak
[root@ ~]# mv /etc/yum.repos.d/*.repo bak
[root@ ~]# cd /etc/yum.repos.d/
[root@ yum.repos.d]#
[root@ yum.repos.d]# vim mysource.repo
[mysource]
name=mysource
enabled=
gpgcheck=
baseurl=http://10.220.5.66/mysource <<<所指定的位置为repodata所的路径

清除缓存

[root@ yum.repos.d]# yum clean all

查看yum仓库的信息

[root@ yum.repos.d]# yum repolist
Loaded plugins: fastestmirror
Determining fastest mirrors
mysource | 3.6 kB ::
(/): mysource/group_gz | kB ::
(/): mysource/primary_db | 3.1 MB ::
repo id repo name status
mysource mysource ,
repolist: ,971 <<<有3791个包说明网络yum可用

安装ipvsadm (lvs)

[root@ yum.repos.d]# yum install ipvsadm -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package ipvsadm.x86_64 :1.27-.el7 will be installed
--> Finished Dependency Resolution Dependencies Resolved ===============================================================================================================
Package Arch Version Repository Size
===============================================================================================================
Installing:
ipvsadm x86_64 1.27-.el7 mysource k Transaction Summary
===============================================================================================================
Install Package Total download size: k
Installed size: k
Downloading packages:
ipvsadm-1.27-.el7.x86_64.rpm | kB ::
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : ipvsadm-1.27-.el7.x86_64 /
Verifying : ipvsadm-1.27-.el7.x86_64 / Installed:
ipvsadm.x86_64 :1.27-.el7 Complete!

测试成功

网络yum源制作的更多相关文章

  1. linux:网络yum源和制作本地光盘yum源

    linux:存放yum源的位置:/etc/yum.repos.d/,该目录下全是一些yum源 一.网络yum源: 如图:下面全部都是yum源,后缀是".repo"都是合法的yum源 ...

  2. Centos----本地yum源制作

    本地YUM源制作 1.   YUM相关概念 1.1.  什么是YUM YUM(全称为 Yellow dog Updater, Modified)是一个在Fedora和RedHat以及CentOS中的S ...

  3. Linux配置网络YUM源

    配置网络yum源 RHEL6.5 [root@xuegod163 ~]# wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun ...

  4. CentOS 配置网络yum源

    配置网络yum源(需要保证外网开通,使用网易163提供开源镜像站) 1.下载repo文件 方法一:下载到本地windows再上传到linux服务器上: 下载地址 : http://mirrors.16 ...

  5. Linux 本地yum源搭建和网络yum源搭建

    一.本地yum源搭建 首先挂载上光盘 [root@www /]# mount /dev/cdrom /media/cdrom/ 系统默认已经安装了可使用yum的软件包,所以可以直接配置: [root@ ...

  6. 搭建网络yum源

    #!/bin/bash #Linux搭建163网络yum源 cd /etc/yum.repos.d/ echo "-------------------下载163-repo--------- ...

  7. Linux:网络yum源设置

    网络yum源,最大的网易(163)算是一个,无论是速度还是软件版本,都非常的不错,将yum源设置为163yum,可以提升软件包安装和更新的速度,同时避免一些常见软件版本无法找到.具体设置方法如下: 1 ...

  8. 配置网络yum源

    有的时候服务器需要下载一些软件,是本地yum源没有的,这时候需要配置网络yum源 #cd  /etc/yum.repos.d/ 把这个目录下的配置文件备份,改名:或者是把文件里边的enabled=1的 ...

  9. CentOS7下配置网络yum源(附带下载地址)

    一.查看外网是否通畅 配置网络yum源(需要保证外网开通,我这里是使用网易163提供开源镜像站) 二.下载repo文件 cd /etc/yum.repos.dwget http://mirrors.1 ...

随机推荐

  1. DevExpress Grid使用checkBox选中的方法

    到官网得到消息自13.2版本后的Dev Grid中均内置了CheckBox列多选功能.在寻找答案的过程的成果进行记录. 一.13.2版本以后用法 启用多选列 对Gird中的View进行以下属性设置: ...

  2. MySQL报错ERROR 1558 (HY000): Column count of mysql.user is wrong.

    MySQL报错ERROR 1558 (HY000): Column count of mysql.user is wrong. 1.今天在使用MySQL创建数据库时出现如下报错: mysql> ...

  3. 常用java的正则表达式

    package everyDayPratise; import java.util.regex.Pattern; public class RegexExample { public static v ...

  4. Oracle查看表空间

    知道表空间名,显示该表空间包括的所有表. select * from all_tables where tablespace_name='表空间名' 知道表名,查看该表属于那个表空间 select t ...

  5. Linux简单线程池实现(带源码)

    这里给个线程池的实现代码,里面带有个应用小例子,方便学习使用,代码 GCC 编译可用.参照代码看下面介绍的线程池原理跟容易接受,百度云下载链接: http://pan.baidu.com/s/1i3z ...

  6. webRTC中音频相关的netEQ(一):概述

    上篇文章(语音通信中终端上的时延(latency)及减小方法)说从本篇开始会切入webRTC中的netEQ主题,netEQ是webRTC中音频技术方面的两大核心技术之一(另一核心技术是音频的前后处理, ...

  7. HTTP请求的502、504、499错误

    1.名词解释 502 Bad Gateway:作为网关或者代理工作的服务器尝试执行请求时,从上游服务器接收到无效的响应(伪响应). 504 Gateway Time-out:作为网关或者代理工作的服务 ...

  8. jenkins疑惑

    本地仓库,脚本 os.getcwd() 获取当前脚本目录 正常 把脚本放到了工作区,os.getcwd()获取的却是 项目的主目录 打算: 思路: 兼容一波,给jenkins的写个配置文件在 项目的主 ...

  9. VUE开发

    待完善... Node.js    参考文档:http://nodejs.cn/ Node.js 是一个基于 Chrome V8 引擎的 JavaScript 运行环境.  Node.js 使用了一个 ...

  10. [转]Win2012的 IIS 503 错误

    下载并安装 https://www.microsoft.com/zh-CN/download/details.aspx?id=48145 因为安装了 dotnet-hosting-2.2.3-win. ...