在启动TDS LDAP服务器时遇到一些问题,由于习惯使用Oracle数据库,而对DB2数据库比较陌生,在遇到这些问题时也是摸不到头脑,好在现在解决了,并把所遇到的问题罗列如下:

使用命令启动TDS LDAP 服务器:./ibmslapd -I ldapdb2 ,执行结果如下:

从上面的执行结果,很明显可以看到两个错误:

1、SQL1032N 未发出启动数据库管理器的命令。 SQLSTATE=57019

2、GLPRDB001E Error code -l from function:" SQLConnect  " ldapdb2b

问题1解决:

问题1参考原文链接:http://blog.csdn.net/pursue168/article/details/6536386

在晚上查找发现问题1是因为db2没有启动,需要执行:db2start命令,在执行db2start命令时遇到如下错误:

SQL6048N  A communication error occurred during START or STOP DATABASE MANAGER processing. 
SQL1032N  No start database manager command was issued.  SQLSTATE=57019

我们需要修改db2下的db2nodes.cfg文件或者hosts文件

先看下db2nodes.cfg 和hosts文件的内容是什么? 
vi db2nodes.cfg 
 
vi /etc/hosts 

明显可以看到db2nodes.cfg内的localhost在hosts文件没有定义 
所以我们需要把db2nodes.cfg内的localhost修改为hosts文件中的linux-vm23.localdomain 

接下来启动db2 正常的启动了! 

再次使用命令启动TDS LDAP 服务器:./ibmslapd -I ldapdb2 ,执行结果如下:

我们发现问题1已经得到了解决,现在来全力解决问题2:

问题2解决参考链接:http://www-01.ibm.com/support/docview.wss?tcss=Newsletter&uid=swg21377253

执行命令:[idsadm@ibmecm bin]$ db2 list db directory,结果如下:

然而UAT环境中执行[idsadm@ibmecm bin]$ db2 list db directory,执行命令结果如下所示:

注:(UAT环境启动正常)

参照UAT环境,对其做更改如下所示:

再次执行命令:[idsadm@ibmecm bin]$ db2 list db directory,结果如下:

重新启动数据库:

db2 force applications all ;
db2stop force ;
ipclean ;

db2start ;

再次使用命令启动TDS LDAP 服务器:./ibmslapd -I ldapdb2 ,执行结果如下:

从打印的日志可以看到TDS LDAP服务已经启动成功!

启动TDS LDAP 服务器遇到的问题总结的更多相关文章

  1. 启动受管服务器出现:unable to get file lock, will retry...

    启动受管服务器出现:unable to get file lock, will retry... 解决方法:一.删掉Domain下的*.lok文件1. 删除edit.lok进入到domain_home ...

  2. Windows 下搭建LDAP服务器

    五一闲来没事,加上项目正在进行UAT.抽空研究了一下LDAP相关知识.随手做一个记录. 为了方便阅读还是先介绍一下什么是LDAP? 前言.Lightweight Directory Access Pr ...

  3. 《LDAP服务器和客户端的加密认证》RHEL6——第二篇 运维工程师必考

    服务端的配置: (基于原先配好的ldap服务器)打开加密认证: Iptables –F  setenforce 0 1.编辑ldap的配置文件:slapd.conf 2.启动ldap服务器: 3.切换 ...

  4. 《LDAP服务器的配置与客户端的测试》RHEL6——第一篇 运维工程师必考

    ldap这种原始的服务器搭建起来比较复杂,同时它也是CE必考的(客户端的搭建). 服务器端的配置: 1.安装openldap-servers软件包 2.查看ldap模板文件的存放位置: 3.拷贝lda ...

  5. 04_Weblogic之受管服务器:配置受管服务器,启动受管服务器,解决因为强制关闭Weblogic之后导致启动有问题的问题,配置boot.properties

     配置受管服务器, 先启动WebLogic服务器,启动方式如下: 在WebLogic控制台中的"开发模式"---"锁定并编辑"模式下,点击"Ser ...

  6. centos7安装Jenkins更改默认端口并配置Ldap服务器进行用户认证

    应用环境:Jenkins是一个开源软件项目,是基于Java开发的一种持续集成工具,用于监控持续重复的工作.   Jenkins官网:https://jenkins.io/ 测试环境:一台Centos ...

  7. ldap服务器OpenLDAP安装使用

    OpenLDAP 是 LDAP 协议的一个开源实现.LDAP 服务器本质上是一个为只读访问而优化的非关系型数据库.它主要用做地址簿查询(如 email 客户端)或对各种服务访问做后台认证以及用户数据权 ...

  8. 【JMeter4.0学习(二)】之搭建openLDAP在windows8.1上的安装配置以及JMeter对LDAP服务器的性能测试脚本开发

    目录: 概述 安装测试环境 安装过程 配置启动 配置搭建OpenLDAP 给数据库添加数据 测试查询刚刚插入的数据 客户端介绍 JMeter建立一个扩展LDAP服务器的性能测试脚本开发 附:LDAP学 ...

  9. 2020年,手把手教你如何在CentOS7上一步一步搭建LDAP服务器的最新教程

    同步滚动:关 什么是LDAP 什么是LDAP? 要想知道一个概念,最简单的办法就是wikipedia,当然也可以百科. LDAP全称是轻型目录访问协议(Lightweight Directory Ac ...

随机推荐

  1. UltraISO制作U盘启动盘安装Win7系统攻略

    reference win 7 iso name: cn_windows_7_ultimate_x86_dvd_x15-65907.iso URL FOR download: http://jingy ...

  2. UVA.12230.Crossing Rivers(期望)

    题目链接 /* 到达一条河时,船在河中的位置是随机的,所以船到达岸边需要的时间在 0~2l/v 均匀分布,所以船到岸的期望为 (0+2l/v)/2 过河需要 l/v 的时间,所以过一条河总的期望为 ( ...

  3. PHP中的字符串 — 表示方法

    Strings 的字符集,因此本质上不支持Unicode编码,关于Unicode阅读 utf8_encode() 和 utf8_decode() . 注意: 一个字符串的大小决定与计算机内存的大小,理 ...

  4. NOIP 2006 作业调度方案

    [问题描述] 我们现在要利用m台机器加工n个工件,每个工件都有m道工序,每道工序都在不同的指定的机器上完成.每个工件的每道工序都有指定的加工时间. 每个工件的每个工序称为一个操作,我们用记号j-k表示 ...

  5. Ping监控脚本

    需求 内网服务器之间高频率检验延时信息, 脚本特点 多进程,可同时异步监控多个地址,不会互相影响. 使用方式 创建文件夹(可以替换为你自己的,我这里就用我们生产环境的标准目录了) mkdir /dat ...

  6. JNI编程实现(Linux)

    JNI是Java Native Interface的缩写,是Java平台的本地调用,从Java1.1就成为了Java标准的一部分,它允许Java代码和其它语言的代码进行互相调用,只要调用约定支持即可, ...

  7. webpack总结

    1.webpack默认只能引用js文件,通过loader可以引入别的文件(css.image.font等) 2.webpack-dev-server提供了一个web server,通过配置将dist目 ...

  8. git存储用户名与密码

    git config credential.helper store git config --global credential.helper cache ... which tells git t ...

  9. Unity Shader-后处理:Bloom全屏泛光

    一.简介   今天来学习一下全屏Bloom效果,有时候也叫Glow效果,中文一般叫做“全屏泛光”,这是一种可以模拟出HDR的全屏后处理效果,但是实现原理与HDR相差很远,效果比HDR差一些,但是比HD ...

  10. [Android Pro] Android P版本 新功能介绍和兼容性处理(三)Android Studio 3.0 ~ 3.2 其他特性

    cp : https://blog.csdn.net/yi_master/article/details/80067198 1:JAVA8特性支持 1)Base64.java 在升级到as3.0之后, ...