Starting sendmail:

Starting sm-client:

刚才发了修改主机名那篇文章后,我意外发现重新启动CentOS的时候系统会卡在sendmail和sm-client那里将近3分钟才继续,找了一下sendmail和sm-client的文档发现自己犯了一个错误。

我简单说一下原因,就是sendmail和sm-client都是MTA,只认网络主机名,如admin.slyar.com这样的,而我之前那篇文章直接把localhost.localdomain改成了Slyar,不符合网络主机名规范,所以启动速度慢。解决办法如下:

1.修改 /etc/sysconfig/network 下的主机名为网络主机名 Slyar.localdomain

# vim /etc/sysconfig/network

2.修改 /etc/hosts 下的主机名为网络主机名 Slyar.localdomain

# vim /etc/hosts

3.重新启动系统,以后就不会出现速度慢的情况了。

# reboot

关掉Starting sendmail:,用chkconfig sendmail off 关掉就可以了

http://blog.sina.com.cn/s/blog_6631bc8d01014pi2.html

一、前提
  首先你要安装sendmail,如果你在安装Linux时选择全部安装的话,sendmail就已经在你的系统里了。如果不是的话就要安装了。
  其次就是你的DNS一定要配置正确,完整,否则sendmail服务可能运行不正常。
  如果你的系统是按照上面所述的安装好的话,那么sendmail服务的配置可以说是非常简单了,想知道有关DNS的详细配置请看本站的有关DNS的文章。
二、配置过程
 1、修改/etc/mail/access 文件
 象下面这样: domain.com    RELAY    //“domain.com”是你的域的名字
        192.168.0    RELAY    //允许 192.168.0.*的机器通过你的机器发信
 然后输入下面这个命令进行转化:
    makemap hash access.db < access
 2、修改或创建文件:/etc/mail/relay-domains 内容如下:
   192.168.0
 这样就可以了。可能你这配置时要许多的问题。以上是我经过十几次的安装和配置linux总结出来的最简单的方法了,希望对你有帮助。注意了,你的DNS一定要是没有问题的,否则sendmail是不会好用的。
 3、sendmail常用命令及测试和相关文件
   A、相关文件
     /etc/sendmail.cf
     /etc/sendmil.cw
     /etc/inetd.conf
   在/etc/mail目录下有以下文件
     access.db    access
     mailertable.db   mailertable
     aliases.db     aliases
   B、命令
     1。重新启动sendmail服务
       有这个目录下 /etc/rc.d/init.d 有文件sendmail,输入如下命令:
        ./sendmail restart
     2。检查POP3端口是否打开
       命令: netstat -a |grep pop
      如有下面的信息,则POP3端口就打开了:
      tcp 0 0 *: pop3 *.* LISTEN
     3。确定sendmail服务是否启动
       ps -axuw | grep sendmail
       如启动了,则会有一些提示信息。

http://www.linuxidc.com/Linux/2006-12/1333.htm

开机启动的时候,发现进度条一直卡在sendmail那里,想办法把这个服务停止掉。直接停掉服务,可以在终端输入 service sendmail stop 。

取消开机启动的方法:

1、终端输入ntsysv,把sendmail服务取消掉。

2、chkconfig 命令也可以用来激活和停运服务。
       执行命令:chkconfig --list sendmail
        sendmail        0:off   1:off   2:on    3:on    4:on    5:on    6:off
        表明sendmail在level在2.3.4.5时是自动开启的。而一般系统设置为中间level(3),因此每次机器重启,sendmail会自动重启。
        chkconfig --level 2345 sendmail off
        这样以来,sendmail在2、3、4、5级别也关闭了。这样,机器重启之后,sendmail也不会重启了。

http://blog.csdn.net/fedorayang/article/details/7633074

ntsysv工具为启动或停止服务提供了简单的界面。你可以使用ntsysv来启动或关闭由xinetd管理的服务。你还可以使用ntsysv来配置运行级别。按照默认设置,只有当前运行级别会被配置。要配置不同的运行级别,使用"--level"选项来指定一个或多个运行级别。例如,命令"ntsysv --level 345"配置运行级别3、4和5。ntsysv的工作界面如图4-7所示。

使用上下箭头来查看列表。使用空格键来选择或取消选择服务,或用"确定"和"取消"按钮。要在服务列表和"确定"、"取消"按钮中切换,可以使用"Tab"键。"*"表明某服务被设为启动。

http://www.linuxso.com/command/ntsysv.html

netstat可用查看目前已经启动的服务,
service可以用来立即启动某个服务。
chkconfig用来设置服务在开机的时候自动启动。

--查看nfs服务是否开机自动启动。可以看见6个开机级别都不会启动nfs服务。
[root@db ~]# chkconfig  --list nfs
nfs             0:off   1:off   2:off   3:off   4:off   5:off   6:off

--设置开机自动启动nfs服务。
[root@db ~]# chkconfig  nfs on

--再次查看,可以看见2、3、4、5级别开机会自动启动nfs服务。
[root@db ~]# chkconfig  --list nfs
nfs             0:off   1:off   2:on    3:on    4:on    5:on    6:off

--取消开机自动启动nfs服务。
[root@db ~]# chkconfig nfs off

--再次查看,6个级别开机又都不会启动nfs服务了。
[root@db ~]# chkconfig  --list nfs
nfs             0:off   1:off   2:off   3:off   4:off   5:off   6:off

--设置3级别开机自动启动nfs服务。
[root@db ~]# chkconfig --level 3 nfs on

--再次查看,可以看见在级别开机会自动启动nfs服务。
[root@db ~]# chkconfig --list nfs
nfs             0:off   1:off   2:off   3:on    4:off   5:off   6:off

-------------------------------------------------------------------------------------------------------------------------

ntsysv:类图形界面管理模式来设置开机启动。(RedHat特有的,基本上chkconfig就很好用了。)

总结一下功能按钮:
上下键:可以在中间的方框当中,在各个服务之间移动;
空格键:可以用来选择你所需要的服务,[*]表示开起启动;
tab键:可以在方框、OK、Cancel之间移动;
[F1]键:可以显示该服务的说明。       
例如:

[root@linux ~]# ntsysv
ntsysv 1.3.30.1 - (C) 2000-2001 Red Hat, Inc.

http://www.linuxidc.com/Linux/2011-12/48396.htm

解决CentOS(RedHat)中sendmail和sm-client启动慢故障(转)的更多相关文章

  1. 解决CentOS 7安装zabbix 3.0 无法启动zabbix-server的问题[segfault at 18 ip 00007f78842b4bd0 sp 00007fff1995a818 error 4 in libpthread-2.17.so[7f78842ab000+16000]]

    解决CentOS 7安装zabbix 3.0 无法启动zabbix-server的问题 [root@localhost sbin]# service zabbix-server start Redir ...

  2. 解决CentOS 7中php-fpm进程数过多导致服务器内存资源消耗较大的问题

    本文由荒原之梦原创,原文链接:http://zhaokaifeng.com/?p=653 什么是php-fpm: php-fpm即FastCGI进程管理器,用于控制php的内存和进程等. 操作环境: ...

  3. 解决Centos/Redhat,命令不存在

    [root@26 ~]# lsb_release                    #不存在-bash: lsb_release: command not found    [root@26 ~] ...

  4. Docker: 解决Centos 7中Permission Denied的问题

    当用docker -v挂载volume后,会出现Permission Denied的问题,这有时是因为SeLinux导致的.解决方法如下: chcon -Rt svirt_sandbox_file_t ...

  5. Spring中使用集成MongoDB Client启动时报错:rc: 48

    一定是所在的服务器也装了MongoDB导致端口冲突,解决方法:kill掉全部MongoDB的进程. ps aux | grep mongod PID 参考: http://blog.csdn.net/ ...

  6. CentOS 7 中配置通过 daemon 模式启动的 Tomcat 8 服务

    距离上次折腾已经有很长一段时间了... 不说这个,刚好有空闲,把这两天折腾的 Tomcat 8 的服务配置整理出来收录一下. 1.JDK安装 1)检查服务器是否预装了 openJdk,如果有就删除,在 ...

  7. vsftp在REDHAT,CENTOS 5中登录慢的解决办法

    vsftp在REDHAT,CENTOS 5中登录慢的解决办法 vsftp在REDHAT,CENTOS 5中不仅登录慢,至少花30秒左右,而且上传文件的速度也受影响, 经过摸索,根本原因在DNS解析上花 ...

  8. Redhat中网络启动错误解决办法( Failed to start LSB: Bring up/down networking RTNETLINK answers: File exists)

    关于Redhat系列中网络启动失败的解决办法 报错: Failed to start LSB: Bring up/down networking.             RTNETLINK answ ...

  9. Nginx安装与使用 及在redhat 中的简单安装方式

    首先说下在redhat中的安装方法, 正常安装nginx 需要安装很多的依赖,最后再安装nginx,而且很容易出错. 在nginx官方上有这么一段描述: Pre-Built Packages for ...

随机推荐

  1. cf478B Random Teams

    B. Random Teams time limit per test 1 second memory limit per test 256 megabytes input standard inpu ...

  2. 使用ASIHttoRequest需要导入的framework

    需要导入如下framework libxml2.2.dylib libz.1.2.5.dylib MobileCoreServices.framework SystemConfiguration.fr ...

  3. Windows Message Queue(优先队列)

    欢迎参加——BestCoder周年纪念赛(高质量题目+多重奖励) Windows Message Queue Time Limit: 2000/1000 MS (Java/Others)    Mem ...

  4. hdu 4750 Count The Pairs (2013南京网络赛)

    n个点m条无向边的图,对于q个询问,每次查询点对间最小瓶颈路 >=f 的点对有多少. 最小瓶颈路显然在kruskal求得的MST上.而输入保证所有边权唯一,也就是说f[i][j]肯定唯一了. 拿 ...

  5. iOS8使用Core Graphics实现渐变效果-Swift基础教程

    Core Graphics是一个强大的底层API,在这篇教程中我们主要使用Core Graphics来实现渐变效果,为了简单起见,我们采用线性渐变.线性渐变是从起点到终点颜色进行顺序渐变.教程在iOS ...

  6. 追加addclass和removeclass

    //addclass             Base.prototype.addclass=function(classname){                 for(var i=0;i< ...

  7. videojs 视频开发API

    videojs就提供了这样一套解决方案,他是一个兼容html5的视频播放工具,早期版本兼容所有浏览器,方法是:提供三个后缀名的视频,并在不支持html5的浏览器下生成一个flash的版本. 最新的3. ...

  8. iOS 生成.a文件

    一.新建一个工程,选择Cocoa Touch Static Library. 二. 三. 四. 五. 六. 七. 八. 九. 十. 十一. 十二. 十三.打开终端,输入以下命令将真机和模拟器中的.a合 ...

  9. RTMP流媒体播放过程(转)

    http://blog.csdn.net/leixiaohua1020/article/details/11704355 本文描述了从打开一个RTMP流媒体到视音频数据开始播放的全过程. 注意:RTM ...

  10. list集合接口

    import java.util.ArrayList; import java.util.List; class Phone { private String brand; private doubl ...