Net6 Core Api(.net6)发布到IIS注意事项及显示HTTP 错误500.19解决方法
Net6 Core Api发布到IIS不同于webapi,依赖框架不同,配置也移至项目内Program.cs
一、发布到指定文件夹,和IIS,不过注意IIS应用程序池选择的是 “无托管代码“

访问接口路径报500.19,原因是所依赖的框架不同,需要下载安装指定的依赖环境(查看第二点)

二、查看项目框架和下载,
下载地址
https://dotnet.microsoft.com/download/dotnet
我这里使用的是.Net6.0,要下载高于此版本的环境

点击你要下载的版本

下载了对应位数的安装


下载完成后可以在控制面板-程序和功能看到

此时运行可能还会报404

需要到发布文件下修改web.config文件(这步有时候需要有时候不需要)

<aspNetCore processPath="dotnet" arguments=".\Signin.dll" stdoutLogEnabled="false" stdoutLogFile=".\logs\stdout" hostingModel="inprocess">
<environmentVariables>
<environmentVariable name="ASPNETCORE_ENVIRONMENT" value="Development" />
</environmentVariables>
</aspNetCore>
成功访问

执行点击登录后可能会出现下面错误
如果出现下面这个错误就是因为没有执行上步修改webconfig文件(修改后这个错误就没了)
出现错误2
原因:其实就是说明我们这个网站需要认证了才能访问

解决:
查看该网页使用的是什么身份认证(默认是匿名身份验证)

发现是启用的是匿名身份验证
匿名身份验证表示不需要登录都可以访问

右键编辑发现他选择的特定用户是IUSR

查看IUSR是否有权限(右击这个网页编辑权限)

查看并没有这个用户

解决一: 我们可以让他和应用程序池使用同一个用户
点击发布网页=》打开身份验证=》右键匿名身份验证编辑

选择应用池标志按钮

查看应用程序池使用的用户是哪个

标识其实就是用户

再次浏览发现还是不行

那么修改一下程序池的用户,改一个级别高的

选择localsystem,这个权限很高的

再次刷新网页进行浏览
此时本地又报一个新错

错误信息
An unhandled exception occurred while processing the request.
SqlException: 无法打开登录所请求的数据库 "ProgramTest"。登录失败。
用户 'NT AUTHORITY\SYSTEM' 登录失败。
InvalidOperationException: An exception has been raised that is likely due to a transient failure. Consider enabling transient error resiliency by adding 'EnableRetryOnFailure' to the 'UseSqlServer' call.
问题出现原因:
无法打开登录所请求的数据库 “xxxxxx”。登录失败。
用户 'IIS APPPOOL\xxxxxxxxxxxx 登录失败。
或者这样的错误信息:
异常详细信息: System.Data.SqlClient.SqlException: 用户 ‘IIS APPPOOL\xxxxxxxx’ 登录失败。
在Visual Studio 2010调试模式下,没有问题,配置到IIS就出错.原因是权限问题.
在IIS中默认是不允许window集成登录的,改为帐号密码登录就没有问题了,服务器名最好填写ip地址/实例名这样的格式,以免报错.
1.若应用程序的连接字符串是windows集成登录 ,将其改成用户名密码登录
所以将连接字符串改为使用用户名登录即可

//"SystemCenterProject": "Data Source=.;Initial Catalog=ProgramTest;Integrated Security=True;TrustServerCertificate=true",
"SystemCenterProject": "Data Source=.;Initial Catalog=ProgramTest;User ID=sa;Pwd=123456;TrustServerCertificate=true"
连接字符串并且必须加‘TrustServerCertificate=true’,否则会报错
Microsoft.Data.SqlClient.SqlException 证书链是由不受信任的颁发机构颁发的 - 知乎 (zhihu.com)

发布网页运行成功,并且登录成功

解决二: 使用特定用户账号 (不做参考-不正确可能)
不使用应用程序池的用户。


选择特定用户

编辑用户名为IUSR

将相应程序池设置成原先默认的

程序池标识改为原先默认

确定后,点击相应应用程序池回收

网站重新启动,然后浏览

Net6 Core Api(.net6)发布到IIS注意事项及显示HTTP 错误500.19解决方法的更多相关文章
- Asp.Net Core子应用由于配置中重复添加模块会引起IIS错误500.19
ASP.NET Core已经从IIS中解耦,可以作为自宿主程序运行,不再依赖IIS. 但我们还是需要强大的IIS作为前置服务器,IIS利用httpPlatformHandler模块来对后台的一些web ...
- Net Core子应用由于配置引起IIS错误500.19
Asp.Net Core子应用由于配置中重复添加模块会引起IIS错误500.19 ASP.NET Core已经从IIS中解耦,可以作为自宿主程序运行,不再依赖IIS. 但我们还是需要强大的IIS作为前 ...
- IIS发布网站浏览之后看到的是文件目录 & Internal Server Error 处理程序“ExtensionlessUrlHandler-ISAPI-4.0_64bit”在其模块列表中有一个错误模块“IsapiModule” 解决方法 & App_global.asax.pduxejp_.dll”--“拒绝访问。 ”
Q:IIS发布网站浏览之后看到的是文件目录 A:它出现了一个说到.NET4.0 更高框架什么的错误,所以我将 .NTE CRL版本由4.0改为2.0了,改为2.0后就出现了只能浏览文件目录了.改为4. ...
- asp.net mvc项目使用spring.net发布到IIS后,在访问提示错误 Could not load type from string value 'DALMsSql.DBSessionFactory,DALMsSql'.
asp.net mvc项目使用spring.net发布到IIS后,在访问提示错误 Could not load type from string value 'DALMsSql.DBSessionFa ...
- [代码]--IIS发布网站浏览之后看到的是文件目录 & Internal Server Error 处理程序“ExtensionlessUrlHandler-ISAPI-4.0_64bit”在其模块列表中有一个错误模块“IsapiModule” 解决方法 & App_global.asax.pduxejp_.dll”--“拒绝访问。 ”
Q:IIS发布网站浏览之后看到的是文件目录 A:它出现了一个说到.NET4.0 更高框架什么的错误,所以我将 .NTE CRL版本由4.0改为2.0了,改为2.0后就出现了只能浏览文件目录了.改为4. ...
- 关于 IIS 上运行 ASP.NET Core 站点的“HTTP 错误 500.19”错误
昨天回答了博问中的一个问题 —— “HTTP 错误 500.19 - Internal Server Error dotnetcore”,今天在这篇随笔中时候事后诸葛亮地小结一下. 服务器是 Wind ...
- 针对windowsserver 创建iis站点访问出错的解决方案(HTTP 错误 500.19 - Internal Server Error)
错误如下: 服务器错误 Internet信息服务 7.0 错误摘要HTTP 错误 500.19 - Internal Server Error 无法访问请求的页面,因为该页的相关配置数据无效. 详 ...
- win server2012r2上发布网站常见错误 "HTTP 错误 500.19 请求的页面的相关配置数据无效" 解决办法
HTTP 错误 500.19 - Internal Server Error无法访问请求的页面,因为该页的相关配置数据无效. 问题“详细错误信息模块 IIS Web Core通知 BeginReque ...
- win10 iis部署后 浏览目录报错 500.19
错误摘要HTTP 错误 500.19 - Internal Server Error无法访问请求的页面,因为该页的相关配置数据无效.详细错误信息模块 IIS Web Core 通知 BeginReq ...
- 部署到IIS报错:HTTP错误500.19,错误代码0x800700d
title=部署到IIS报错:HTTP错误500.19,错误代码0x800700d. 用vs直接运行网站没问题,部署到IIS就报错,由此可知应该是IIS中不支持网站相关配置. 查找发现在web.c ...
随机推荐
- 动态SQL遇到的问题
看图 查不出来任何数据 因为判断有问题 修改方法如下:
- 错误:Required request parameter 'XXX' for method parameter type String is not present
错误信息:Required request parameter 'XXX' for method parameter type String is not present 这种都是前端请求方式不同,后 ...
- Django连接数据库(mysql)与Django ORM实操(增删改查) 前端页面
目录 一:pycharm链接数据库(MySQL) 1.pycharm右侧Database工具栏 2.下载对应的驱动,填写MySQL数据库信息连接(当前为客户端) 3.pycharm连接MySQL数据库 ...
- Python:界面开发,wx入门篇
以下内容为本人的学习笔记,如需要转载,请声明原文链接微信公众号「englyf」https://mp.weixin.qq.com/s/3Yb_YAKiMte_f5HanetXiA 本文大概 3617 个 ...
- python 之异常捕获及处理(try--except)
在python中,至少有两类错误,一种是程序语法错误,一种是程序异常. 所谓的语法错误是指你未按规定格式书写导致的错误,如:定义函数时,括号后面要紧跟英文冒号,若缺失则不能识别与运行,并抛出 Synt ...
- 前端使用工具规范commit信息
前言 通过工具规范git提交信息也是工程化的一部分,在前端领域有一些工具为我们提供了相关功能,在这里做一下使用总结. commitlint commitlint是什么? 就像eslint用来检查js代 ...
- 【运维笔录】局域网实现项目的CI/CD,Docker+Gitea+Drone搭建轻量级自动化部署平台
一.安装Docker 1.1 安装excpet $ apt-get -f install expect 1.2 编写执行Docker安装脚本 编写docker_dep.exp脚本 #!/usr/bin ...
- [编程基础] C++多线程入门4-数据共享和资源竞争
原始C++标准仅支持单线程编程.新的C++标准(称为C++11或C++0x)于2011年发布.在C++11中,引入了新的线程库.因此运行本文程序需要C++至少符合C++ 11标准. 4 数据共享和资源 ...
- 使用Lighthouse更好推动项目性能优化,性能指标详解,优化方法,需要关注指标分析
Lighthouse是什么---一种工具 Lighthouse 是一个开源的自动化工具,用来测试页面性能. 为什么要用Lighthouse----提升用户体验 Web性能可以直接影响业务指标,例如转化 ...
- java入门与进阶 P-2.7+P-3.1
判断语句常见错误 忘了大括号 永远在if和else后面加上大括号,即使当时后面只有一条语句 if后面的分号 错误使用== 和= if只要求()里面的值是零或者非零 = 是赋值 == 是判断是否相同 代 ...