1.yum 安装出错

[root@iz25m0z7ik3z ~]#yum install mysql

  1. [root@iZ25m0z7ik3Z ~]#yum install mysql
  2. Loaded plugins: security
  3. http://mirrors.aliyun.com/centos/6/os/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyun.com'"
  4. Trying other mirror.
  5. http://mirrors.aliyuncs.com/centos/6/os/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyuncs.com'"
  6. Trying other mirror.
  7. http://mirrors.aliyun.com/epel/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyun.com'"
  8. Trying other mirror.
  9. http://mirrors.aliyuncs.com/epel/6/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyuncs.com'"
  10. Trying other mirror.
  11. http://mirrors.aliyun.com/centos/6/extras/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyun.com'"
  12. Trying other mirror.
  13. http://mirrors.aliyuncs.com/centos/6/extras/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyuncs.com'"
  14. Trying other mirror.
  15. http://mirrors.aliyun.com/centos/6/updates/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyun.com'"
  16. Trying other mirror.
  17. http://mirrors.aliyuncs.com/centos/6/updates/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.aliyuncs.com'"
  18. Trying other mirror.
  19. Setting up Install Process
  20. Package mysql-5.1.73-5.el6_6.x86_64 already installed and latest version
  21. Nothing to do

2. 修改dns

[root@iz25m0z7ik3z ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth0

文末添加

DNS1=8.8.8.8
DNS2=8.8.4.4

3. 重启network 服务

[root@iz25m0z7ik3z ~]# service network restart

  1. Shutting down interface eth0:  Device state: 3 (disconnected)
  2. [  OK  ]
  3. Shutting down interface eth1:                              [  OK  ]
  4. Shutting down loopback interface:                          [  OK  ]
  5. FATAL: Module off not found.
  6. Bringing up loopback interface:                            [  OK  ]
  7. Bringing up interface eth0:  Active connection state: activated
  8. Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/2
  9. [  OK  ]
  10. Bringing up interface eth1:  RTNETLINK answers: File exists
  11. RTNETLINK answers: File exists
  12. [  OK  ]
  13. FATAL: Module off not found.

4. 如下提示表示network  服务 与 NetworkManager服务冲突

  1. Bringing up interface eth0:  Active connection state: activated
  2. Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/2
  3. [  OK  ]

应该是之前安装了图形界面“X Window System”导致。

5. 停止NetworkManager

[root@iz25m0z7ik3z ~]#  service NetworkManager stop

  1. Stopping NetworkManager daemon:                            [  OK  ]

6. 再次重启 network 服务

[root@iz25m0z7ik3z ~]#  service network restart

  1. Shutting down interface eth0:                              [  OK  ]
  2. Shutting down interface eth1:                              [  OK  ]
  3. Shutting down loopback interface:                          [  OK  ]
  4. FATAL: Module off not found.
  5. Bringing up loopback interface:                            [  OK  ]
  6. Bringing up interface eth0:  Determining if ip address 10.44.153.37 is already in use for device eth0...
  7. [  OK  ]
  8. Bringing up interface eth1:  Determining if ip address 101.200.188.182 is already in use for device eth1...
  9. RTNETLINK answers: File exists
  10. [  OK  ]
  11. FATAL: Module off not found.

7. 该警告一般是由于网卡解析arp协议导致的,可在网卡的配置文件中加入ARPCHECK=NO参数来屏蔽该检查

[root@iz25m0z7ik3z ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth0

文末添加

ARPCHECK=no

再次启动网卡

  1. Shutting down interface eth0:                              [  OK  ]
  2. Shutting down interface eth1:                              [  OK  ]
  3. Shutting down loopback interface:                          [  OK  ]
  4. FATAL: Module off not found.
  5. Bringing up loopback interface:                            [  OK  ]
  6. Bringing up interface eth0:                                [  OK  ]
  7. Bringing up interface eth1:  RTNETLINK answers: File exists
  8. [  OK  ]
  9. FATAL: Module off not found.

至此yum update 一切正常。

来源:http://blog.csdn.net/zhugq_1988/article/details/47784031

yum 安装出错--"Couldn't resolve host 'mirrors.aliyun.com'"的更多相关文章

  1. CentOs 6 或 7 yum安装JDK1.8 (内含报 PYCURL ERROR 6 - "Couldn't resolve host 'mirrors.163.com'"错误解决方案)并分析为什么不能yum安装

    查看JDK的安装路径 # java -version============================查看Linux系统版本信息# cat /etc/redhat-releaseCentOS r ...

  2. yum安装出错

    [root@lxh yum.repos.d]# yum install -y samba Loaded plugins: fastestmirror, refresh-packagekit, secu ...

  3. 云服务器镜像问题("Couldn't resolve host 'mirrors.tencentyun.com')

    云服务器镜像问题("Couldn't resolve host 'mirrors.tencentyun.com') 原因: 腾讯云服务器内网yum源的域名 mirrors.tencentyu ...

  4. yum-config-manager YUM安装遭遇: [Errno 256] No more mirrors to try CentOS yum之$releasever和$basearch

    YUM安装遭遇: [Errno 256] No more mirrors to try createrepo 有问题. CentOS yum之$releasever和$basearch分类: 操作系统 ...

  5. YUM安装软件提示[Errno 14] curl#6 - "Could not resolve host: mirrors.cloud.aliyuncs.com; 未知的错误"

    报错如下: 翻译过来就是 所以问题很简单: 第一种情况:本地DNS服务错误 第二种情况:远程主机挂了 第三种情况:远程主机地址配置错误 第一种解决方法:换DNS 首先验证一下是不是本地DNS错误 从上 ...

  6. 内核升级在线安装报错:Could not retrieve mirrorlist http://mirrors.elrepo.org/mirrors-elrepo-kernel.el7 error was14: curl#6 - "Could not resolve host: mirrors.elrepo.org; 未知的错误"

    修改网卡配置 [root@localhost ~]# vim /etc/sysconfig/network-scripts/ifcfg-ens32 BOOTPROTO="none" ...

  7. 安装时遇到:正在尝试其它镜像。 http://mirrors.btte.net/centos/7.2.1511/extras/x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: mirrors.btte.net; 未知的错误"

    我出现这种错误是因为网络链接问题,因为我设置虚拟机网络链接为VmNET8,设置了nat模式,使得我本地机可以访问虚拟机的linux服务器.但是打开虚拟机的浏览器却不能上网了.所以现在我用xshell装 ...

  8. yum 安装 出错 Error: Protected multilib versions:

    例如:安装zlib出错 yum install zlib-1.2.3-29.el6.i686 Error: Protected multilib versions: zlib-1.2.3-29.el6 ...

  9. curl: (6) Could not resolve host: mirrors.163.com; Unknown error 服务器上解析不了域名,换成ip可以

    原因是DNS域名解析问题: 添加nameserver即可解决 echo nameserver 8.8.8.8 > /etc/resolv.conf 解释一下DNS服务 DNS(Domain Na ...

随机推荐

  1. 十招让Ubuntu 16.04用起来更得心应手

    Ubuntu 16.04是一种长期支持版本(LTS),是Canonical承诺发布五年的更新版.也就是说,你可以让这个版本在电脑上运行五年!这样一来,一开始就设置好显得特别重要.你应该确保你的软件是最 ...

  2. web页面实时更新页面的原理--WebSocket

    原文:https://www.jianshu.com/p/8f956cd4d42b angular-cli启动的项目也可以自动刷新,底下应该也是应用的websocket的原理. ----------- ...

  3. [HTML5] Track First Contentful Paint with PerformanceObserver and Google Analytics

    "If you can't measure it, you can't improve it." The first step when doing performance wor ...

  4. SQLServer:探讨EXEC与sp_executesql的区别详解

    摘要 MSSQL为我们提供了两种动态执行SQL语句的命令,分别是EXEC和sp_executesql;通常,sp_executesql则更具有优势,它提供了输入输出接口,而EXEC没有.还有一个最大的 ...

  5. C# 5 in a Nutshell - Delegate

    1. What is delegate in C#? A delegate is an object that knows how to call a method.A delegate type d ...

  6. .NET Framwork 之 托管代码的执行过程

    源代码代码第一次编译形成IL中间语言的托管代码,在运行时被Class Loader装载后进行JIT第二次编译形成托管的本地代码.在执行过程中,它会不断地检查当前我们执行的代码的安全性和规范性. Cla ...

  7. Apatche httpd + Django + Mysql web server 搭建

    Required: httpd: 2.4.18 django : 1.8.7 mysql: 5.7.10 MySQL-python: 1.2.3 mod_wsgi: 4.4.21 Offical Do ...

  8. ajax同步和异步

    // 方案2: 回调函数 // function getFile( callback ){ // // 1: 创建ajax对象 XMLHttpRequest // var xhr = new XMLH ...

  9. sqlserver远程备份到其他服务器

    直接将数据库备份到其他机器上 --如果xp_cmdshell没有启用,请先启用 sp_configure reconfigure go sp_configure reconfigure go --1. ...

  10. CodeForces 390E Inna and Large Sweet Matrix(树状数组改段求段)

    树状数组仅仅能实现线段树区间改动和区间查询的功能,能够取代不须要lazy tag的线段树.且代码量和常数较小 首先定义一个数组 int c[N]; 并清空 memset(c, 0, sizeof c) ...